- New port: emulators/mupen64plus-gln64

A graphics plugin for Mupen64Plus emulator
This commit is contained in:
Jose Alonso Cardenas Marquez 2008-05-20 18:49:25 +00:00
parent ffef66e776
commit 1ebe0c8e83
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=213408
3 changed files with 63 additions and 0 deletions

View file

@ -110,6 +110,7 @@
SUBDIR += mupen64plus-base
SUBDIR += mupen64plus-dummyaudio
SUBDIR += mupen64plus-glide
SUBDIR += mupen64plus-gln64
SUBDIR += nonpareil
SUBDIR += o2em
SUBDIR += ods2reader

View file

@ -0,0 +1,23 @@
# New ports collection makefile for: mupen64plus-gln64
# Date created: 2008-05-16
# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
#
# $FreeBSD$
#
PKGNAMESUFFIX= -gln64
COMMENT= The glN64 graphics plugin for Mupen64plus
USE_GL= yes
USE_SDL= sdl
FIXFILES= glN64/DepthBuffer.cpp
PLUGIN_NAME= glN64
MASTERDIR= ${.CURDIR}/../mupen64plus-base
OPTIONS= #
.include "${MASTERDIR}/Makefile"

View file

@ -0,0 +1,39 @@
--- glN64/Config_linux.cpp 2008-05-16 17:58:34.000000000 -0500
+++ glN64/Config_linux.cpp 2008-05-16 18:00:13.000000000 -0500
@@ -1,4 +1,3 @@
-#include <features.h>
#include <dlfcn.h>
#include <unistd.h>
#include "../main/winlnxdefs.h"
@@ -44,29 +43,8 @@
}
else
{
-#ifdef __USE_GNU
- Dl_info info;
- void *addr = (void*)GetPluginDir;
- if(dladdr(addr, &info) != 0)
- {
- strncpy(path, info.dli_fname, PATH_MAX);
- *(strrchr(path, '/')) = '\0';
- }
- else
- {
- fprintf(stderr, "(WW) Couldn't get path of .so, trying to get emulator's path\n");
-#endif // __USE_GNU
- if(readlink("/proc/self/exe", path, PATH_MAX) == -1)
- {
- fprintf(stderr, "(WW) readlink() /proc/self/exe failed: %s\n", strerror(errno));
- path[0] = '.';
- path[1] = '\0';
- }
- *(strrchr(path, '/')) = '\0';
- strncat(path, "/plugins", PATH_MAX);
-#ifdef __USE_GNU
- }
-#endif
+ strcpy(path, getenv("HOME"));
+ strncat(path, "/.mupen64plus/plugins", PATH_MAX);
}
return path;
}