Update to 0.7.3

This commit is contained in:
Romain Tartière 2020-01-12 19:57:05 +00:00
parent 44ee2ed6f0
commit 1ebe516a6b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=522833
4 changed files with 4 additions and 36 deletions

View file

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= postfix-mta-sts-resolver
PORTVERSION= 0.7.2
PORTVERSION= 0.7.3
DISTVERSIONPREFIX=v
CATEGORIES= mail python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1578764689
SHA256 (Snawoot-postfix-mta-sts-resolver-v0.7.2_GH0.tar.gz) = e5934c0ef39060e10be43d113bb81b830dd8ca02aff16022025c39993bda9526
SIZE (Snawoot-postfix-mta-sts-resolver-v0.7.2_GH0.tar.gz) = 43533
TIMESTAMP = 1578858389
SHA256 (Snawoot-postfix-mta-sts-resolver-v0.7.3_GH0.tar.gz) = 3b929fc7da60547dbe34f8c07aa5b9c3dd6c195052db160b71ca74d820536ba2
SIZE (Snawoot-postfix-mta-sts-resolver-v0.7.3_GH0.tar.gz) = 43866

View file

@ -1,22 +0,0 @@
--- postfix_mta_sts_resolver/daemon.py.orig 2020-01-11 21:18:26 UTC
+++ postfix_mta_sts_resolver/daemon.py
@@ -7,7 +7,6 @@ import logging
import signal
from functools import partial
-from sdnotify import SystemdNotifier
from . import utils
from . import defaults
from .responder import STSSocketmapResponder
@@ -72,11 +71,8 @@ async def amain(cfg, loop): # pragma: no cover
sig_handler = partial(exit_handler, exit_event)
signal.signal(signal.SIGTERM, sig_handler)
signal.signal(signal.SIGINT, sig_handler)
- notifier = await loop.run_in_executor(None, SystemdNotifier)
- await loop.run_in_executor(None, notifier.notify, "READY=1")
await exit_event.wait()
logger.debug("Eventloop interrupted. Shutting down server...")
- await loop.run_in_executor(None, notifier.notify, "STOPPING=1")
beat.cancel()
await responder.stop()

View file

@ -1,10 +0,0 @@
--- setup.py.orig 2020-01-11 21:21:32 UTC
+++ setup.py
@@ -23,7 +23,6 @@ setup(name='postfix_mta_sts_resolver',
'aiodns>=1.1.1',
'aiohttp>=3.4.4',
'PyYAML>=3.12',
- 'sdnotify>=0.3.2',
],
extras_require={
'sqlite': 'aiosqlite>=0.10.0',