Digital Audio Processor.

PR:		ports/7719
Submitted by:	Yoshiaki Uchikawa <yoshiaki@kt.rim.or.jp>
This commit is contained in:
Vanilla I. Shu 1998-09-16 12:54:00 +00:00
parent 611db2c04c
commit 1ec5a23dde
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=13174
8 changed files with 483 additions and 0 deletions

31
audio/dap/Makefile Normal file
View file

@ -0,0 +1,31 @@
# ports collection makefile for: dap
# Version required: 1.3b
# Date created: 23 August 1998
# Whom: yoshiaki Uchikawa
#
# $Id$
#
DISTNAME= DAPSource
PKGNAME= dap-1.3b
CATEGORIES= audio
MASTER_SITES= http://www.cee.hw.ac.uk/~richardk/
MAINTAINER= yoshiaki@kt.rim.or.jp
LIB_DEPENDS= xforms\\.0\\.88:${PORTSDIR}/x11-toolkits/xforms
WRKSRC= ${WRKDIR}/dap
USE_X_PREFIX= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/main/DAP ${PREFIX}/bin/
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/DAP/
${INSTALL_MAN} ${WRKSRC}/COPYING ${WRKSRC}/README \
${WRKSRC}/THANKS ${WRKSRC}/TODO ${PREFIX}/share/doc/DAP/
.endif
post-install:
strip ${PREFIX}/bin/DAP
.include <bsd.port.mk>

1
audio/dap/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (DAPSource.tar.gz) = ff0cad20e504f7f7b7e670cd1651650e

84
audio/dap/files/patch-aa Normal file
View file

@ -0,0 +1,84 @@
--- Makefile.orig Wed Sep 16 09:26:41 1998
+++ Makefile Wed Sep 16 09:26:41 1998
@@ -0,0 +1,81 @@
+BACKDIR = ./bak
+HOMEDIR = $(HOME)
+
+all: DAP
+
+DAP:
+ (cd tooltips; make -f Makefile);
+ (cd spkit/spkit; make -f Makefile.freebsd);
+ (cd main; make -f Makefile.freebsd);
+
+release: DAP
+ strip main/DAP
+ (cd ..; tar -cf $(HOMEDIR)/LinuxDAP.tar dap/main/DAP dap/main/effects \
+ dap/README dap/INSTALL dap/COPYING dap/CHANGES dap/TODO dap/THANKS);
+ gzip $(HOMEDIR)/LinuxDAP.tar
+
+source:
+ (cd ..; tar -cf $(HOMEDIR)/DAPSource.tar \
+ dap/README dap/INSTALL dap/COPYING dap/CHANGES dap/TODO dap/THANKS \
+ dap/Makefile.* dap/main/*.c dap/main/*.cc dap/main/*.h dap/main/*.fd \
+ dap/main/icons/*.gif dap/main/icons/*.xpm dap/main/Makefile.* \
+ dap/main/effects dap/sound/*.h dap/sound/*.cc dap/sound/*.inl \
+ dap/sound/Makefile.* dap/spkit/spkit/*.cc dap/spkit/spkit/*.h \
+ dap/spkit/spkit/Makefile.* dap/tooltips/CHANGES dap/tooltips/COPYING \
+ dap/tooltips/Makefile dap/tooltips/README dap/tooltips/THANKS \
+ dap/tooltips/TODO dap/tooltips/*.c dap/tooltips/*.h dap/tooltips/*.fd \
+ dap/tooltips/examples/menu/Makefile dap/tooltips/examples/menu/*.c \
+ dap/tooltips/examples/menu/*.h dap/tooltips/examples/menu/*.fd);
+ gzip $(HOMEDIR)/DAPSource.tar
+
+cleanall:
+ (cd tooltips; make -f Makefile clean);
+ (cd main; make -f Makefile.freebsd clean);
+ (cd sound; make -f Makefile.freebsd clean);
+ (cd spkit/spkit; make -f Makefile.freebsd clean);
+
+emptyall:
+ (cd tooltips; make -f Makefile clean);
+ (cd main; make -f Makefile.freebsd empty);
+ (cd sound; make -f Makefile.freebsd empty);
+ (cd spkit/spkit; make -f Makefile.freebsd empty);
+
+backall: back
+ (cd main; make -f Makefile.freebsd back);
+ (cd sound; make -f Makefile.freebsd back);
+ (cd spkit/spkit; make -f Makefile.freebsd back);
+
+back:
+ "cp" README $(BACKDIR)
+ "cp" INSTALL $(BACKDIR)
+ "cp" COPYING $(BACKDIR)
+ "cp" CHANGES $(BACKDIR)
+ "cp" TODO $(BACKDIR)
+ "cp" THANKS $(BACKDIR)
+ "cp" Makefile.* $(BACKDIR)
+ lha a $(HOMEDIR)/tich4.lzh \
+ README INSTALL COPYING CHANGES TODO THANKS Makefile.*
+
+restoreall: restore
+ (cd main; make -f Makefile.freebsd restore);
+ (cd sound; make -f Makefile.freebsd restore);
+ (cd spkit/spkit; make -f Makefile.freebsd restore);
+
+restore:
+ lha x $(HOMEDIR)/tich4.lzh
+
+printall: print
+ (cd main; make -f Makefile.linux print);
+ (cd sound; make -f Makefile.linux print);
+ (cd spkit/spkit; make -f Makefile.linux print);
+
+print:
+ a2ps \
+ README \
+ INSTALL \
+ COPYING \
+ CHANGES \
+ TODO \
+ THANKS \
+ Makefile.* \
+ >$(HOMEDIR)/tich4.ps

112
audio/dap/files/patch-ab Normal file
View file

@ -0,0 +1,112 @@
--- main/Makefile.freebsd.orig Wed Sep 16 09:26:42 1998
+++ main/Makefile.freebsd Wed Sep 16 18:34:39 1998
@@ -0,0 +1,83 @@
+CC = gcc
+CXX = g++
+FORMS = /usr/X11R6/include
+SOUND = ../sound
+SPKIT = ../spkit
+TOOLTIP = ../tooltips
+BACKDIR = ../mainbak
+HOMEDIR = $(HOME)
+INCDIR = -I. -I$(SOUND) -I$(SPKIT) -I$(FORMS) -I$(TOOLTIP) -I/usr/include
+LIBDIR = -L$(SPKIT)/spkit -L$(FORMS) -L$(TOOLTIP) -L/usr/lib -L/usr/X11R6/lib
+CCFLAGS = $(CFLAGS) $(INCDIR) -DLINUX -DUSINGGCC
+LDFLAGS = $(LIBDIR) -ldsp -ltooltips -lxforms -lXpm -lX11 -lm
+
+PROGS = DAP
+OBJS = DPTich.o DPTich_cb.o DPTich_DSP.o DPTich_edit_cb.o DPTich_macros.o \
+ DPTich_effect_cb.o DPTich_main.o DPSampleXforms.o DPTich_prefs.o \
+ DPTich_linux_audio.o DPTich_linux_audiofile.o \
+ DPTich_linux_macros.o DPTich_linux_ieee.o \
+ $(SOUND)/DPSample.o $(SOUND)/DPResample.o $(SOUND)/DPMixPlay.o \
+ DPCrossButton.o
+
+.c.o:
+ $(CC) $(CCFLAGS) -c $*.c -o $*.o
+
+.cc.o:
+ $(CXX) $(CCFLAGS) -c $*.cc -o $*.o
+
+all: $(PROGS)
+
+DAP: $(OBJS)
+ $(CXX) $(OBJS) -o DAP $(LDFLAGS)
+
+clean:
+ -rm -f $(OBJS) core
+
+empty:
+ -rm -f $(OBJS) $(PROGS) core
+
+back:
+ "cp" *.c $(BACKDIR)
+ "cp" *.cc $(BACKDIR)
+ "cp" *.h $(BACKDIR)
+ "cp" *.fd $(BACKDIR)
+ "cp" icons/*.gif $(BACKDIR)/icons
+ "cp" icons/*.xpm $(BACKDIR)/icons
+ "cp" Makefile.* $(BACKDIR)
+ lha a $(HOMEDIR)/tich3.lzh *.c *.cc *.h *.fd icons/*.gif icons/*.xpm \
+ Makefile.*
+
+restore:
+ lha x $(HOMEDIR)/tich3.lzh
+
+print:
+ a2ps \
+ DPTich_main.h \
+ DPTich_main.cc \
+ DPTich_prefs.h \
+ DPTich_prefs.cc \
+ DPTich_macros.h \
+ DPTich_macros.cc \
+ DPTich_cb.h \
+ DPTich_cb.cc \
+ DPTich_edit_cb.cc \
+ DPTich_effect_cb.cc \
+ DPTich_effect.h \
+ DPTich_DSP.h \
+ DPTich_DSP.cc \
+ DPTich_linux_macros.h \
+ DPTich_linux_macros.c \
+ DPTich_linux_audio.h \
+ DPTich_linux_audio.c \
+ DPTich_linux_audiofile.h \
+ DPTich_linux_audiofile.c \
+ DPTich_linux_ieee.h \
+ DPTich_linux_ieee.c \
+ DPSampleXforms.h \
+ DPSampleXforms.cc \
+ DPCrossButton.h \
+ DPCrossButton.c \
+ DPTich.h \
+ DPTich.c \
+ Makefile.* \
+ >$(HOMEDIR)/tich3.ps
--- main/DPTich_linux_audio.h.orig Wed Sep 16 18:40:00 1998
+++ main/DPTich_linux_audio.h Wed Sep 16 18:43:04 1998
@@ -23,7 +23,11 @@
#define _DPTich_linux_audio_h
#include <stdio.h>
+#ifdef __FreeBSD__
+#include <stdio.h>
+#else
#include <malloc.h>
+#endif
#include <unistd.h>
#include <fcntl.h>
#include <limits.h>
@@ -31,7 +35,11 @@
#include <sys/types.h>
#include <sys/stat.h>
#include <sys/ioctl.h>
+#ifdef __FreeBSD__
+#include <machine/soundcard.h>
+#else
#include <sys/soundcard.h>
+#endif
#ifdef __cplusplus
extern "C"

239
audio/dap/files/patch-ac Normal file
View file

@ -0,0 +1,239 @@
--- spkit/spkit/Makefile.freebsd.orig Wed Sep 16 09:26:42 1998
+++ spkit/spkit/Makefile.freebsd Wed Sep 16 18:34:14 1998
@@ -0,0 +1,164 @@
+CC = gcc
+CXX = g++
+FORMS = /usr/X11R6/include
+SOUND = ../../sound
+TOOLTIP = ../../tooltips
+BACKDIR = ../spkitbak
+MAINDIR = ../../main
+HOMEDIR = $(HOME)
+INCDIR = -I. -I.. -I$(SOUND) -I$(FORMS) -I$(MAINDIR) -I$(TOOLTIP)
+CCFLAGS = $(CFLAGS) $(INCDIR) -DLINUX -DUSINGGCC
+
+.c.o:
+ $(CC) $(CCFLAGS) -c $*.c -o $*.o
+
+.cc.o:
+ $(CXX) $(CCFLAGS) -c $*.cc -o $*.o
+
+LIBNAME = libdsp.a
+
+OBJS = \
+ allpassi.o \
+ allpassn.o \
+ amp.o \
+ butterwo.o \
+ bwbandpa.o \
+ bwbandre.o \
+ bwhighpa.o \
+ bwlowpas.o \
+ comb.o \
+ combint.o \
+ comblowp.o \
+ complim.o \
+ compress.o \
+ delay.o \
+ delayint.o \
+ dist.o \
+ dpreader.o \
+ dpwriter.o \
+ dynamics.o \
+ fbdelay.o \
+ feedback.o \
+ gate.o \
+ inverter.o \
+ jamrever.o \
+ lfo.o \
+ limiter.o \
+ mult.o \
+ mux.o \
+ pan.o \
+ processo.o \
+ rectifie.o \
+ resonato.o \
+ schroede.o \
+ stdrever.o \
+ sum.o \
+ sumavg.o \
+ waveshap.o \
+ z1lpf.o
+
+all: libdsp.a
+
+libdsp.a: $(OBJS)
+ rm -f $(LIBNAME)
+ ar -ruv $(LIBNAME) $(OBJS)
+ ranlib $(LIBNAME)
+
+clean:
+ rm -f $(OBJS)
+
+empty:
+ rm -f $(OBJS) $(LIBNAME)
+
+back:
+ "cp" *.cc $(BACKDIR)
+ "cp" *.h $(BACKDIR)
+ "cp" Makefile.* $(BACKDIR)
+ lha a $(HOMEDIR)/tich1.lzh *.cc *.h Makefile.*
+
+restore:
+ lha x $(HOMEDIR)/tich1.lzh
+
+print:
+ a2ps \
+ allpassi.h \
+ allpassi.cc \
+ allpassn.h \
+ allpassn.cc \
+ amp.h \
+ amp.cc \
+ butterwo.h \
+ butterwo.cc \
+ bwbandpa.h \
+ bwbandpa.cc \
+ bwbandre.h \
+ bwbandre.cc \
+ bwhighpa.h \
+ bwhighpa.cc \
+ bwlowpas.h \
+ bwlowpas.cc \
+ comb.h \
+ comb.cc \
+ combint.h \
+ combint.cc \
+ comblowp.h \
+ comblowp.cc \
+ complim.h \
+ complim.cc \
+ compress.h \
+ compress.cc \
+ delay.h \
+ delay.cc \
+ delayint.h \
+ delayint.cc \
+ dist.h \
+ dist.cc \
+ dpreader.h \
+ dpreader.cc \
+ dpwriter.h \
+ dpwriter.cc \
+ dynamics.h \
+ dynamics.cc \
+ fbdelay.h \
+ fbdelay.cc \
+ feedback.h \
+ feedback.cc \
+ gate.h \
+ gate.cc \
+ inverter.h \
+ inverter.cc \
+ jamrever.h \
+ jamrever.cc \
+ lfo.h \
+ lfo.cc \
+ limiter.h \
+ limiter.cc \
+ mult.h \
+ mult.cc \
+ mux.h \
+ mux.cc \
+ pan.h \
+ pan.cc \
+ processo.h \
+ processo.cc \
+ rectifie.h \
+ rectifie.cc \
+ resonato.h \
+ resonato.cc \
+ schroede.h \
+ schroede.cc \
+ spkit.h \
+ stdrever.h \
+ stdrever.cc \
+ sum.h \
+ sum.cc \
+ sumavg.h \
+ sumavg.cc \
+ tube.h \
+ valve.h \
+ waveshap.h \
+ waveshap.cc \
+ z1lpf.h \
+ z1lpf.cc \
+ Makefile.* \
+ >$(HOMEDIR)/tich1.ps
--- sound/Makefile.freebsd.orig Wed Sep 16 18:45:52 1998
+++ sound/Makefile.freebsd Wed Sep 16 18:46:18 1998
@@ -0,0 +1,53 @@
+CC = gcc
+CXX = g++
+FORMS = /usr/X11R6/include
+SPKIT = ../spkit
+TOOLTIP = ../tooltips
+BACKDIR = ../soundbak
+MAINDIR = ../main
+HOMEDIR = $(HOME)
+INCDIR = -I. -I$(SPKIT) -I$(FORMS) -I$(MAINDIR) -I$(TOOLTIP) -I/usr/include -I/usr/local/include
+LIBDIR = -L$(SPKIT)/spkit -L$(FORMS) -L/usr/lib -L/usr/X11R6/lib
+CCFLAGS = $(CFLAGS) -DNOFORMS -DLINUX -DUSINGGCC
+LDFLAGS = $(LIBDIR) -ldsp -lforms -lXpm -lX11 -lm
+
+PROGS = SampleTest
+OBJS = DPSample.o DPResample.o DPMixPlay.o SampleTest.o
+LINUX = $(MAINDIR)/DPTich_linux_audio.o \
+ $(MAINDIR)/DPTich_linux_audiofile.o \
+ $(MAINDIR)/DPTich_linux_macros.o \
+ $(MAINDIR)/DPTich_linux_ieee.o
+
+.c.o:
+ $(CC) $(CCFLAGS) $(INCDIR) -c $*.c -o $*.o
+
+.cc.o:
+ $(CXX) $(CCFLAGS) $(INCDIR) -c $*.cc -o $*.o
+
+normal: DPSample.o DPResample.o DPMixPlay.o
+
+all: $(PROGS)
+
+SampleTest: $(OBJS)
+ $(CXX) $(CCFLAGS) $(OBJS) $(LINUX) -o SampleTest $(LDFLAGS)
+
+clean:
+ -rm -f $(OBJS) core
+
+empty:
+ -rm -f $(OBJS) $(PROGS) core
+
+back:
+ "cp" *.h $(BACKDIR)
+ "cp" *.cc $(BACKDIR)
+ "cp" *.inl $(BACKDIR)
+ "cp" Makefile.* $(BACKDIR)
+ lha a $(HOMEDIR)/tich2.lzh *.h *.cc *.inl Makefile.*
+
+restore:
+ lha x $(HOMEDIR)/tich2.lzh
+
+print:
+ a2ps DPDefs.h DPSample.h DPSample.inl DPSample.cc DPResample.h \
+ DPResample.cc DPMixPlay.h DPMixPlay.cc Makefile.* \
+ >$(HOMEDIR)/tich2.ps
--- tooltips/Makefile.orig Wed Sep 16 18:45:00 1998
+++ tooltips/Makefile Wed Sep 16 18:45:19 1998
@@ -36,11 +36,11 @@
# Uncomment out this line if you do not want debug information included.
# DEBUG = -g -Wall -ansi -pedantic
-DEBUG =
+#DEBUG =
# Define the utilities to use for compilation.
CC = gcc
-CCOPTS = $(DEBUG) -I$(XFORMS_INCLUDE_DIR) -I$(X11_INCLUDE_DIR) \
+CCOPTS = $(CFLAGS) -I$(XFORMS_INCLUDE_DIR) -I$(X11_INCLUDE_DIR) \
-I$(OTHER_INCLUDE_DIR)
AR = ar
AROPTS = rc

1
audio/dap/pkg-comment Normal file
View file

@ -0,0 +1 @@
Audio sample editing and processing suite.

9
audio/dap/pkg-descr Normal file
View file

@ -0,0 +1,9 @@
DAP is a comprehensive audio sample editing and processing suite. DAP
currently supports AIFF and AIFF-C audio files, 8 or 16 bit resolution
and 1, 2 or 4 channels of audio data. Note however that on Linux and
Solaris, compressed AIFF-C files are not currently supported, only
non-compressed AIFF and AIFF-C files.
The package itself offers comprehensive editing, playback and recording
facilities including full time stretch resampling, manual data editing
and a reasonably complete DSP processing suite.

6
audio/dap/pkg-plist Normal file
View file

@ -0,0 +1,6 @@
bin/DAP
share/doc/DAP/COPYING
share/doc/DAP/README
share/doc/DAP/THANKS
share/doc/DAP/TODO
@dirrm share/doc/DAP