- Fix build on CURRENT
Approved by: marck (maintainer)
This commit is contained in:
parent
e0cdb32d2b
commit
1f2bae50fc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=163355
2 changed files with 12 additions and 4 deletions
|
@ -49,10 +49,6 @@ OPTIONS= GIGABASE "GigaBase storage" on \
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700015
|
||||
BROKEN= Does not compile on FreeBSD >= 7.0
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_GIGABASE)
|
||||
.if defined (WITH_DB4)
|
||||
BROKEN= "Only one DB storage can be used (First)"
|
||||
|
|
12
www/oops/files/patch-src_lib.c
Normal file
12
www/oops/files/patch-src_lib.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/lib.c.orig Thu May 25 12:28:53 2006
|
||||
+++ src/lib.c Thu May 25 12:30:17 2006
|
||||
@@ -306,6 +306,9 @@
|
||||
rc = gethostbyname_r(val, &he_b, &he_d);
|
||||
if ( !rc ) he = &he_b;
|
||||
else he = NULL;
|
||||
+#elif defined(__FreeBSD__)
|
||||
+ gethostbyname_r(val, &he_b, he_strb, sizeof(he_strb), &he, &he_errno);
|
||||
+
|
||||
#else
|
||||
he = gethostbyname_r(val, &he_b, he_strb, sizeof(he_strb), &he_errno);
|
||||
#endif
|
Loading…
Reference in a new issue