- Add p5-ExtUtils-Helpers 0.016
ExtUtils::Helpers provides various portable helper functions for module building modules. WWW: http://search.cpan.org/dist/ExtUtils-Helpers/ Feature safe: yes
This commit is contained in:
parent
cd5ad1584f
commit
1f49d3db1b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315853
6 changed files with 55 additions and 0 deletions
|
@ -1924,6 +1924,7 @@
|
|||
SUBDIR += p5-ExtUtils-Config
|
||||
SUBDIR += p5-ExtUtils-Constant
|
||||
SUBDIR += p5-ExtUtils-Depends
|
||||
SUBDIR += p5-ExtUtils-Helpers
|
||||
SUBDIR += p5-ExtUtils-Install
|
||||
SUBDIR += p5-ExtUtils-InstallPaths
|
||||
SUBDIR += p5-ExtUtils-LibBuilder
|
||||
|
|
27
devel/p5-ExtUtils-Helpers/Makefile
Normal file
27
devel/p5-ExtUtils-Helpers/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ExtUtils-Helpers
|
||||
PORTVERSION= 0.016
|
||||
CATEGORIES= devel perl5
|
||||
MASTER_SITES= CPAN
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Various portability utilities for module builders
|
||||
|
||||
LICENSE= ART10 GPLv1
|
||||
LICENSE_COMB= dual
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN3= ExtUtils::Helpers.3 \
|
||||
ExtUtils::Helpers::Unix.3 \
|
||||
ExtUtils::Helpers::VMS.3 \
|
||||
ExtUtils::Helpers::Windows.3
|
||||
|
||||
post-patch:
|
||||
@${RM} ${WRKSRC}/lib/ExtUtils/Helpers.pm.orig
|
||||
@${REINPLACE_CMD} -e 's|3pm|3|' ${WRKSRC}/t/man_pagename.t
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/p5-ExtUtils-Helpers/distinfo
Normal file
2
devel/p5-ExtUtils-Helpers/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (ExtUtils-Helpers-0.016.tar.gz) = 78912c6e97eb01c3eafd9a95032f7bd79b64293ca687c358bf490cc2ab6b5f18
|
||||
SIZE (ExtUtils-Helpers-0.016.tar.gz) = 16785
|
|
@ -0,0 +1,12 @@
|
|||
--- lib/ExtUtils/Helpers.pm.orig 2013-04-12 22:39:09.000000000 +0800
|
||||
+++ lib/ExtUtils/Helpers.pm 2013-04-14 18:30:31.986773914 +0800
|
||||
@@ -39,7 +39,8 @@
|
||||
my ($vols, $dirs, $file) = splitpath(canonpath($filename));
|
||||
$file = basename($file, qw/.pm .pod/);
|
||||
$dirs = abs2rel($dirs, $base);
|
||||
- return join $separator, $dirs, "$file.3pm";
|
||||
+ $dirs =~ s|/|$separator|g;
|
||||
+ return join $separator, $dirs, "$file.3";
|
||||
}
|
||||
|
||||
1;
|
4
devel/p5-ExtUtils-Helpers/pkg-descr
Normal file
4
devel/p5-ExtUtils-Helpers/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
ExtUtils::Helpers provides various portable helper functions for module
|
||||
building modules.
|
||||
|
||||
WWW: http://search.cpan.org/dist/ExtUtils-Helpers/
|
9
devel/p5-ExtUtils-Helpers/pkg-plist
Normal file
9
devel/p5-ExtUtils-Helpers/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
%%SITE_PERL%%/ExtUtils/Helpers.pm
|
||||
%%SITE_PERL%%/ExtUtils/Helpers/Unix.pm
|
||||
%%SITE_PERL%%/ExtUtils/Helpers/VMS.pm
|
||||
%%SITE_PERL%%/ExtUtils/Helpers/Windows.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/Helpers/.packlist
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/Helpers
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils
|
||||
@dirrmtry %%SITE_PERL%%/ExtUtils/Helpers
|
||||
@dirrmtry %%SITE_PERL%%/ExtUtils
|
Loading…
Reference in a new issue