audio/audacity: Update to 2.4.2

- This should fix hangs on startup on FreeBSD 11.4
- Remove NYQUIST option since it is mandatory and disabling it does
  not work

Changes:	https://www.audacityteam.org/audacity-2-4-2-released/
PR:		247604
Submitted by:	maintainer
This commit is contained in:
Tobias Kortkamp 2020-07-03 02:58:48 +00:00
parent 48e4ad73db
commit 1f50082f53
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=541065
10 changed files with 31 additions and 31 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= audacity
PORTVERSION= 2.4.1
PORTVERSION= 2.4.2
DISTVERSIONPREFIX= Audacity-
CATEGORIES= audio
@ -35,18 +35,19 @@ CMAKE_ARGS= -Daudacity_lib_preference:STRING=system \
-Daudacity_use_portsmf:STRING=local \
-Daudacity_use_portmixer:STRING=local \
-Daudacity_use_portaudio:STRING=system
CMAKE_OFF= audacity_use_pch
OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME LV2 MAD \
MIDI NYQUIST OGG SBSMS SOUNDTOUCH TWOLAME VAMP \
MIDI OGG SBSMS SOUNDTOUCH TWOLAME VAMP \
VORBIS VST
OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD MIDI NYQUIST OGG SBSMS \
OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD MIDI OGG SBSMS \
SOUNDTOUCH TWOLAME VAMP VORBIS VST
OPTIONS_EXCLUDE_i386= SBSMS
LAME_DESC= Use lame for import and export support
LV2_DESC= Add LV2 plug-in support
MAD_DESC= Use libmad for mp2/3 decoding support
MIDI_DESC= MIDI support
NYQUIST_DESC= Nyquist synthesis and composition support
SBSMS_DESC= Use libsbsms for pitch and tempo changing
SOUNDTOUCH_DESC= Use libSoundTouch for pitch and tempo changing
TWOLAME_DESC= Use libtwolame for MP2 export support
@ -99,9 +100,6 @@ MIDI_CMAKE_OFF= -Daudacity_use_midi:STRING=off
# TODO: fix NLS support properly
PLIST_SUB+= NLS=""
NYQUIST_CMAKE_ON= -Daudacity_use_nyquist:STRING=local
NYQUIST_CMAKE_OFF= -Daudacity_use_nyquist:STRING=off
OGG_CMAKE_ON= -Daudacity_use_ogg:STRING=system
OGG_CMAKE_OFF= -Daudacity_use_ogg:STRING=local
OGG_LIB_DEPENDS= libogg.so:audio/libogg

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1589881433
SHA256 (audacity-audacity-Audacity-2.4.1_GH0.tar.gz) = 50240f07471373a7e5c2df65cc26eeeaaced9a0850ad1f95cb795f171ea3009f
SIZE (audacity-audacity-Audacity-2.4.1_GH0.tar.gz) = 63935461
TIMESTAMP = 1593304211
SHA256 (audacity-audacity-Audacity-2.4.2_GH0.tar.gz) = cdb4800c8e9d1d4ca19964caf8d24000f80286ebd8a4db566c2622449744c099
SIZE (audacity-audacity-Audacity-2.4.2_GH0.tar.gz) = 61248430

View file

@ -1,7 +1,7 @@
--- cmake-proxies/CMakeLists.txt.orig 2020-05-19 09:43:53 UTC
--- cmake-proxies/CMakeLists.txt.orig 2020-06-19 15:16:47 UTC
+++ cmake-proxies/CMakeLists.txt
@@ -150,7 +150,7 @@ addlib( lame lame LAME YES
addlib( lib-widget-extra libextra EXTRA YES YES "" )
@@ -132,7 +132,7 @@ addlib( expat expat EXPAT YES
addlib( lame lame LAME YES YES "lame >= 3.100" )
addlib( libsndfile sndfile SNDFILE YES YES "sndfile >= 1.0.28" )
addlib( libsoxr soxr SOXR YES YES "soxr >= 0.1.1" )
-addlib( portaudio-v19 portaudio PORTAUDIO YES YES "" )

View file

@ -1,10 +0,0 @@
--- cmake-proxies/sbsms/CMakeLists.txt.orig 2020-05-19 09:43:53 UTC
+++ cmake-proxies/sbsms/CMakeLists.txt
@@ -28,6 +28,7 @@ list( APPEND INCLUDES
list( APPEND OPTIONS
PRIVATE
$<$<C_COMPILER_ID:AppleClang,Clang,GNU>:-Wno-enum-compare>
+ ${SSE_FLAG}
)
find_package( Threads )

View file

@ -1,6 +1,6 @@
--- lib-src/libnyquist/nyquist/cmt/cext.h.orig 2018-10-01 14:07:33 UTC
+++ lib-src/libnyquist/nyquist/cmt/cext.h
@@ -58,7 +58,7 @@ EXIT(n) -- calls exit(n) after shutting down/dealloca
@@ -61,7 +61,7 @@ EXIT(n) -- calls exit(n) after shutting down/dealloca
#include <malloc.h>
#endif

View file

@ -1,6 +1,6 @@
--- lib-src/libnyquist/nyquist/xlisp/xlisp.h.orig 2016-07-26 13:34:06 UTC
+++ lib-src/libnyquist/nyquist/xlisp/xlisp.h
@@ -160,6 +160,15 @@ extern long ptrtoabs();
@@ -161,6 +161,15 @@ extern long ptrtoabs();
#endif
#endif

View file

@ -0,0 +1,11 @@
--- src/AboutDialog.cpp.orig 2020-06-28 06:25:54 UTC
+++ src/AboutDialog.cpp
@@ -63,7 +63,7 @@ hold information about one contributor to Audacity.
// RevisionIdent.h may contain #defines like these ones:
//#define REV_LONG "28864acb238cb3ca71dda190a2d93242591dd80e"
//#define REV_TIME "Sun Apr 12 12:40:22 2015 +0100"
-#include <RevisionIdent.h>
+//#include <RevisionIdent.h>
#ifndef REV_TIME
#define REV_TIME "unknown date and time"

View file

@ -1,6 +1,6 @@
--- src/AudioIO.cpp.orig 2018-10-01 14:07:33 UTC
--- src/AudioIO.cpp.orig 2020-06-19 15:16:47 UTC
+++ src/AudioIO.cpp
@@ -480,7 +480,6 @@ TimeTrack and AudioIOListener and whether the playback
@@ -491,7 +491,6 @@ time warp info and AudioIOListener and whether the pla
#define ROUND(x) (int) ((x)+0.5)
//#include <string.h>
// #include "../lib-src/portmidi/pm_common/portmidi.h"
@ -8,7 +8,7 @@
#include "NoteTrack.h"
#endif
@@ -793,13 +797,22 @@ struct AudioIO::ScrubState (private)
@@ -815,13 +814,22 @@ struct AudioIoCallback::ScrubState (private)
// return the system time as a double
static double streamStartTime = 0; // bias system time to small number

View file

@ -1,6 +1,6 @@
--- src/FFmpeg.h.orig 2018-10-01 14:07:33 UTC
+++ src/FFmpeg.h
@@ -667,7 +667,7 @@ extern "C" {
@@ -685,7 +685,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
AVOutputFormat*,
av_oformat_next,
@ -9,7 +9,7 @@
(f)
);
#endif
@@ -748,7 +748,7 @@ extern "C" {
@@ -766,7 +766,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
int,
av_fifo_size,
@ -18,7 +18,7 @@
(f)
);
#endif
@@ -810,7 +810,7 @@ extern "C" {
@@ -828,7 +828,7 @@ extern "C" {
FFMPEG_FUNCTION_WITH_RETURN(
AVDictionaryEntry *,
av_dict_get,

View file

@ -3,6 +3,7 @@ man/man1/audacity.1.gz
share/appdata/audacity.appdata.xml
share/applications/audacity.desktop
%%DATADIR%%/EQDefaultCurves.xml
%%DATADIR%%/modules/mod-script-pipe.so
%%DATADIR%%/nyquist/aud-do-support.lsp
%%DATADIR%%/nyquist/dspprims.lsp
%%DATADIR%%/nyquist/envelopes.lsp