- Remove irc/zircon and math/lensnns, both expired and abandoned
This commit is contained in:
parent
59ed0c6f94
commit
1f5202d990
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=311627
22 changed files with 2 additions and 828 deletions
2
MOVED
2
MOVED
|
@ -4039,3 +4039,5 @@ devel/kdebindings4-smoke-smokeqt|devel/smokeqt|2013-02-03|Renamed
|
|||
net/freeradius||2013-02-04|Has expired: no longer supported. Please use net/freeradius2 instead
|
||||
net/freeradius-mysql||2013-02-04|Has expired: no longer supported. Please use net/freeradius2 instead
|
||||
multimedia/despotify||2013-02-04|Has expired: API no longer supported
|
||||
irc/zircon||2013-02-04|Has expired: Project has been abandoned
|
||||
math/lensnns||2013-02-04|Has expired: Project has been abandoned
|
||||
|
|
|
@ -145,7 +145,6 @@
|
|||
SUBDIR += xchat-mircryption
|
||||
SUBDIR += xchat-ruby
|
||||
SUBDIR += xchat1
|
||||
SUBDIR += zircon
|
||||
SUBDIR += znc
|
||||
|
||||
.include <bsd.port.subdir.mk>
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
# Created by: jkh / pst
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= zircon
|
||||
PORTVERSION= 1.18.256
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= irc tk
|
||||
MASTER_SITES= ftp://catless.ncl.ac.uk/pub/ \
|
||||
${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= dinoex
|
||||
|
||||
DEPRECATED= Development has ceased 10 years ago
|
||||
EXPIRATION_DATE=2013-02-01
|
||||
|
||||
MAINTAINER= tcltk@FreeBSD.org
|
||||
COMMENT= An X11 interface to Internet Relay Chat
|
||||
|
||||
LICENSE= BSD
|
||||
LICENSE_FILE= ${WRKSRC}/doc/COPYRIGHT
|
||||
|
||||
# zircon will start with tk84, but a lot of functions won't work
|
||||
# a lot of variable names conflicts with new functions.
|
||||
.if defined(ZIRCON_WITH_TCL84) || defined(ZIRCON_WITH_TK84)
|
||||
USE_TK= 84
|
||||
USE_TCL= 84
|
||||
.else
|
||||
USE_TK= 83
|
||||
USE_TCL= 83
|
||||
.endif
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
do-configure:
|
||||
${REINPLACE_CMD} -e 's=%%WISH%%=wish${TCL_VER}=' \
|
||||
-e 's=%%TCLSH%%=tclsh${TCL_VER}=' \
|
||||
${WRKSRC}/installZircon
|
||||
${REINPLACE_CMD} -e 's=%%WISH%%=wish${TCL_VER}=' \
|
||||
-e 's=%%TCL_INCLUDE%%=${LOCALBASE}/include/tcl${TCL_VER}=' \
|
||||
-e 's=/usr/local=${PREFIX}=' \
|
||||
${WRKSRC}/installer/unix.tcl
|
||||
|
||||
do-install:
|
||||
${ECHO_CMD} "set go {Yes}" >>${WRKSRC}/install.in
|
||||
(cd ${WRKSRC} && ./installZircon NoGui)
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (zircon-1.18.256.tar.gz) = 687a5537883e1df3b4d096d57ac1fb56c0ad20d4a070e99ca5bbd7a463857d2b
|
||||
SIZE (zircon-1.18.256.tar.gz) = 315505
|
|
@ -1,18 +0,0 @@
|
|||
--- plugins/Dcc/dcc.tcl.orig Tue Jul 10 17:40:00 2001
|
||||
+++ plugins/Dcc/dcc.tcl Wed Mar 3 04:24:11 2004
|
||||
@@ -46,6 +46,15 @@
|
||||
return 0
|
||||
}
|
||||
switch $posn [set fp [file size $file]] {} default {
|
||||
+ foreach x [$net autoget] {
|
||||
+ if {[regexp -- $x $usr]} {
|
||||
+ $net CTCP DCC [$usr name] "RESUME [deSpace [file tail $file]] $port $fp"
|
||||
+ global Resume
|
||||
+ if {![info exists Resume($usr)]} {$usr ref}
|
||||
+ lappend Resume($usr) [list $file $addr $port $leng $fp]
|
||||
+ return 0
|
||||
+ }
|
||||
+ }
|
||||
switch [tk_dialog .@dg$net {DCC Get} \
|
||||
"File \"$file\" already exists. Select the action you want to take." \
|
||||
warning 0 Overwrite Resume {Rename incoming} \
|
|
@ -1,24 +0,0 @@
|
|||
--- installZircon.orig Wed Jun 7 11:16:06 2000
|
||||
+++ installZircon Fri Aug 15 20:29:58 2003
|
||||
@@ -2,19 +2,14 @@
|
||||
#
|
||||
# Thanks to Alain Nissen for this - I couldn't be fashed to do it!!
|
||||
#
|
||||
-if test -z "$DISPLAY"
|
||||
-then
|
||||
- echo You must run this program under the X-Window System
|
||||
- exit 1
|
||||
-fi
|
||||
IFS="${IFS= }"
|
||||
old_ifs="$IFS"
|
||||
IFS="${IFS}:"
|
||||
if test -z "$*"
|
||||
then
|
||||
- progs="wish8.4 wish8.3 wish8.2 wish8.1 wish8.0 wish4.2 wish4.1 wish wish"
|
||||
+ progs="%%WISH%%"
|
||||
else
|
||||
- progs="tclsh8.4 tclsh8.3 tclsh8.2 tclsh8.1 tclsh8.0 tclsh4.2 tclsh"
|
||||
+ progs="%%TCLSH%%"
|
||||
fi
|
||||
my_wish=
|
||||
for wish in $progs
|
|
@ -1,56 +0,0 @@
|
|||
--- installer/support.tcl.orig Wed Feb 2 11:09:16 2000
|
||||
+++ installer/support.tcl Sat Jul 26 18:54:54 2003
|
||||
@@ -45,7 +45,7 @@
|
||||
zinfo Done!!
|
||||
if {[catch {open install.in w} fd]} {
|
||||
} {
|
||||
- foreach x {Type Lib Bin CC SCflag SLDflag CFlags Wish TIDir} {
|
||||
+ foreach x {Type Lib Bin CC SCflag SLDflag CFlags WishCmd TIDir} {
|
||||
puts $fd "set $x {[uplevel #0 set $x]}"
|
||||
}
|
||||
close $fd
|
||||
@@ -110,7 +110,7 @@
|
||||
}
|
||||
#
|
||||
proc doGlobals {argv} {
|
||||
- global Type types Lib Bin CC LD Version Patchlevel Wish types cflags\
|
||||
+ global Type types Lib Bin CC LD Version Patchlevel WishCmd types cflags\
|
||||
libs share SCflag GCC SLDflag CFlags TIDir Prefix ExecPrefix SED go \
|
||||
pseudo
|
||||
#
|
||||
@@ -124,7 +124,7 @@
|
||||
set SCflag {}
|
||||
set SLDflag {}
|
||||
set CFlags {}
|
||||
- set Wish {}
|
||||
+ set WishCmd {}
|
||||
set TIDir {}
|
||||
set go 0
|
||||
set SED 0
|
||||
@@ -144,7 +144,7 @@
|
||||
-p {set pseudo $v}
|
||||
-s {set SCflag $v}
|
||||
-t {set Type $v }
|
||||
- -w {set Wish $v}
|
||||
+ -w {set WishCmd $v}
|
||||
-z {set SLDflag $v }
|
||||
}
|
||||
set argv [lrange $argv 2 end]
|
||||
@@ -273,7 +273,7 @@
|
||||
#
|
||||
proc makeBinary {} {
|
||||
zinfo "Making zircon..."
|
||||
- global Bin Lib Version Patchlevel Wish Xtn
|
||||
+ global Bin Lib Version Patchlevel WishCmd Xtn
|
||||
if {![file exists [pWrap [set Bin [fixPath $Bin]]]]} {
|
||||
if {[catch {dirmake [pWrap $Bin]} msg]} {
|
||||
fail "Cannot create directory \"$Bin\" - $msg"
|
||||
@@ -298,7 +298,7 @@
|
||||
}
|
||||
return 0
|
||||
}
|
||||
- puts $fd "#!$Wish
|
||||
+ puts $fd "#!$WishCmd
|
||||
set zircon(lib) [whereLib]
|
||||
#
|
||||
proc zVersion {} {
|
|
@ -1,63 +0,0 @@
|
|||
--- installer/unix.tcl.orig Wed Jun 13 09:20:29 2001
|
||||
+++ installer/unix.tcl Sat Jul 26 18:50:45 2003
|
||||
@@ -16,7 +16,7 @@
|
||||
package require support
|
||||
package require -exact unixfile 1.18.[info tclversion]
|
||||
#
|
||||
- global Type types Lib Bin CC LD Version Patchlevel Wish types cflags\
|
||||
+ global Type types Lib Bin CC LD Version Patchlevel WishCmd types cflags\
|
||||
libs share SCflag GCC SLDflag CFlags TIDir v7 SED go NoGUI Xtn
|
||||
#
|
||||
set types {AIX Alpha BSDI FreeBSD HP-UX IRIX Linux OSF1 {SunOS 4} {SunOS 5} UNIX_SV}
|
||||
@@ -81,7 +81,7 @@
|
||||
#
|
||||
# Wish
|
||||
#
|
||||
- makeEntry $w wish {Tcl/Tk Interpreter} Wish [incr i] getWish
|
||||
+ makeEntry $w wish {Tcl/Tk Interpreter} WishCmd [incr i] getWish
|
||||
#
|
||||
# Info
|
||||
#
|
||||
@@ -153,12 +153,12 @@
|
||||
}
|
||||
#
|
||||
proc getWish {} {
|
||||
- global Wish
|
||||
- switch {} $Wish {set Wish [findWish]}
|
||||
+ global WishCmd
|
||||
+ switch {} $WishCmd {set WishCmd [findWish]}
|
||||
}
|
||||
#
|
||||
proc getBin {} {
|
||||
- global Bin env Lib Wish
|
||||
+ global Bin env Lib WishCmd
|
||||
switch {} $Bin {} default return
|
||||
foreach x [split $env(PATH) :] {
|
||||
set z [file join $x zircon]
|
||||
@@ -167,7 +167,7 @@
|
||||
set Bin $x
|
||||
if {![catch {open $z r} fd]} {
|
||||
gets $fd wish
|
||||
- set Wish [string range $wish 2 end]
|
||||
+ set WishCmd [string range $wish 2 end]
|
||||
gets $fd lib
|
||||
close $fd
|
||||
set Lib [lindex $lib 2]
|
||||
@@ -181,7 +181,7 @@
|
||||
proc getCC {} {
|
||||
global CC GCC SCflag CFlags Type SLDflag share scflags
|
||||
switch {} $CC {} default return
|
||||
- set CFlags -O
|
||||
+ set CFlags {-O -I%%TCL_INCLUDE%%}
|
||||
catch {set CFlags $cflags($Type)}
|
||||
switch BSDI $Type {
|
||||
set CC gcc2
|
||||
@@ -220,7 +220,7 @@
|
||||
proc findWish {} {
|
||||
global env
|
||||
foreach x [split $env(PATH) :] {
|
||||
- foreach y {wish8.3 wish8.2 wish8.1 wish8.0 wish4.2 wish4.1 wish wishx} {
|
||||
+ foreach y {%%WISH%%} {
|
||||
if {[file exists [set f [file join $x $y]]]} {
|
||||
return $f
|
||||
}
|
|
@ -1,19 +0,0 @@
|
|||
Zircon is an X11 interface to Internet Relay Chat. The software
|
||||
is written in tcl/tk and uses its native features to provide network
|
||||
communications. Suggestions for improvements to Zircon are welcome.
|
||||
The author particularly interested in making the system useful for
|
||||
those users in groups where JIPS and other national character sets
|
||||
are used.
|
||||
|
||||
Zircon has more features than you could possibly imagine and
|
||||
implements nearly everything that the irc II clients support as
|
||||
well as many other useful and interesting features. This reflects
|
||||
the power of tcl/tk and not wonderful programming (the programming
|
||||
is wonderful of course, but that is an aside). The tcl/tk system
|
||||
is excellent, and you need it on your machine NOW!
|
||||
|
||||
LICENSE: BSD 4-clause
|
||||
This product includes software developed by Lindsay F. Marshall
|
||||
of the Department of Computing Science, University of Newcastle upon Tyne.
|
||||
|
||||
WWW: http://catless.ncl.ac.uk/Programs/Zircon/
|
|
@ -1,158 +0,0 @@
|
|||
bin/zircon
|
||||
lib/zircon/gifs/arc.gif
|
||||
lib/zircon/gifs/button.gif
|
||||
lib/zircon/gifs/ii.gif
|
||||
lib/zircon/gifs/key.gif
|
||||
lib/zircon/gifs/line.gif
|
||||
lib/zircon/gifs/lock.gif
|
||||
lib/zircon/gifs/log.gif
|
||||
lib/zircon/gifs/noii.gif
|
||||
lib/zircon/gifs/none.gif
|
||||
lib/zircon/gifs/nospeak.gif
|
||||
lib/zircon/gifs/off.gif
|
||||
lib/zircon/gifs/off1.gif
|
||||
lib/zircon/gifs/on.gif
|
||||
lib/zircon/gifs/on1.gif
|
||||
lib/zircon/gifs/oval.gif
|
||||
lib/zircon/gifs/polygon.gif
|
||||
lib/zircon/gifs/rectangle.gif
|
||||
lib/zircon/gifs/speak.gif
|
||||
lib/zircon/gifs/text.gif
|
||||
lib/zircon/gifs/unlock.gif
|
||||
lib/zircon/gifs/zircon.gif
|
||||
lib/zircon/gifs/zlogo.gif
|
||||
lib/zircon/help/Netspaces
|
||||
lib/zircon/help/Zircon/Bindings
|
||||
lib/zircon/help/Zircon/CommandLine
|
||||
lib/zircon/help/Zircon/Environment
|
||||
lib/zircon/help/Zircon/Ons
|
||||
lib/zircon/help/Zircon/Windows/Channel
|
||||
lib/zircon/help/Zircon/Windows/Control
|
||||
lib/zircon/help/Zircon/Windows/Info
|
||||
lib/zircon/help/Zircon/Windows/Message
|
||||
lib/zircon/installed
|
||||
lib/zircon/lang/bulgar.tcl
|
||||
lib/zircon/lang/catala.tcl
|
||||
lib/zircon/lang/deutsch.tcl
|
||||
lib/zircon/lang/english.tcl
|
||||
lib/zircon/lang/espanol.tcl
|
||||
lib/zircon/lang/esperanto.tcl
|
||||
lib/zircon/lang/francais.tcl
|
||||
lib/zircon/lang/italiano.tcl
|
||||
lib/zircon/lang/magyar.tcl
|
||||
lib/zircon/lang/nihongo.tcl
|
||||
lib/zircon/lang/norsk.tcl
|
||||
lib/zircon/lang/suomi.tcl
|
||||
lib/zircon/lib/Away.tcl
|
||||
lib/zircon/lib/Button.tcl
|
||||
lib/zircon/lib/Channel.tcl
|
||||
lib/zircon/lib/Chat.tcl
|
||||
lib/zircon/lib/Classes.tcl
|
||||
lib/zircon/lib/Consts.tcl
|
||||
lib/zircon/lib/Control.tcl
|
||||
lib/zircon/lib/DALnet.tcl
|
||||
lib/zircon/lib/Entry.tcl
|
||||
lib/zircon/lib/Frame.tcl
|
||||
lib/zircon/lib/Friend.tcl
|
||||
lib/zircon/lib/Friends.tcl
|
||||
lib/zircon/lib/Help.tcl
|
||||
lib/zircon/lib/IRC.tcl
|
||||
lib/zircon/lib/Ignore.tcl
|
||||
lib/zircon/lib/Info.tcl
|
||||
lib/zircon/lib/Interface.tcl
|
||||
lib/zircon/lib/List.tcl
|
||||
lib/zircon/lib/Log.tcl
|
||||
lib/zircon/lib/Look.tcl
|
||||
lib/zircon/lib/Mac.tcl
|
||||
lib/zircon/lib/Message.tcl
|
||||
lib/zircon/lib/Monitor.tcl
|
||||
lib/zircon/lib/Net.tcl
|
||||
lib/zircon/lib/Netspace.tcl
|
||||
lib/zircon/lib/Notice.tcl
|
||||
lib/zircon/lib/Notrace.tcl
|
||||
lib/zircon/lib/Object.tcl
|
||||
lib/zircon/lib/On.tcl
|
||||
lib/zircon/lib/Protect.tcl
|
||||
lib/zircon/lib/SOCKS.tcl
|
||||
lib/zircon/lib/Server.tcl
|
||||
lib/zircon/lib/Service.tcl
|
||||
lib/zircon/lib/Sound.tcl
|
||||
lib/zircon/lib/Split.tcl
|
||||
lib/zircon/lib/Tags.tcl
|
||||
lib/zircon/lib/Topic.tcl
|
||||
lib/zircon/lib/Tracing.tcl
|
||||
lib/zircon/lib/Undernet.tcl
|
||||
lib/zircon/lib/Unix.tcl
|
||||
lib/zircon/lib/User.tcl
|
||||
lib/zircon/lib/Util.tcl
|
||||
lib/zircon/lib/WBoard.tcl
|
||||
lib/zircon/lib/Window.tcl
|
||||
lib/zircon/lib/Windows.tcl
|
||||
lib/zircon/lib/bindings.tcl
|
||||
lib/zircon/lib/confChan.tcl
|
||||
lib/zircon/lib/confInfo.tcl
|
||||
lib/zircon/lib/confTab.tcl
|
||||
lib/zircon/lib/config.tcl
|
||||
lib/zircon/lib/ctcp.tcl
|
||||
lib/zircon/lib/dbgsrv.tcl
|
||||
lib/zircon/lib/debug.tcl
|
||||
lib/zircon/lib/dialog.tcl
|
||||
lib/zircon/lib/errors.tcl
|
||||
lib/zircon/lib/frivol.tcl
|
||||
lib/zircon/lib/initial.tcl
|
||||
lib/zircon/lib/main.tcl
|
||||
lib/zircon/lib/misc.tcl
|
||||
lib/zircon/lib/misc2.tcl
|
||||
lib/zircon/lib/pkgIndex.tcl
|
||||
lib/zircon/lib/plugin.tcl
|
||||
lib/zircon/lib/saverc.tcl
|
||||
lib/zircon/lib/servers.tcl
|
||||
lib/zircon/lib/tcl75.tcl
|
||||
lib/zircon/lib/tcl76.tcl
|
||||
lib/zircon/lib/tcl80.tcl
|
||||
lib/zircon/lib/tcl81.tcl
|
||||
lib/zircon/lib/tcl82.tcl
|
||||
lib/zircon/lib/tcl83.tcl
|
||||
lib/zircon/lib/tcl84.tcl
|
||||
lib/zircon/lib/upgrade.tcl
|
||||
lib/zircon/lib/userCmds.tcl
|
||||
lib/zircon/lib/zircon.tcl
|
||||
lib/zircon/look/standard.tcl
|
||||
lib/zircon/plugins/Dcc/auto.tcl
|
||||
lib/zircon/plugins/Dcc/chat.tcl
|
||||
lib/zircon/plugins/Dcc/dcc.tcl
|
||||
lib/zircon/plugins/Dcc/dccget.tcl
|
||||
lib/zircon/plugins/Dcc/dccsend.tcl
|
||||
lib/zircon/plugins/Dcc/pkgIndex.tcl
|
||||
lib/zircon/plugins/Dcc/send.tcl
|
||||
lib/zircon/plugins/MsgOps/setup.tcl
|
||||
lib/zircon/plugins/NoticeOps/setup.tcl
|
||||
lib/zircon/plugins/Sed/decrypt.tcl
|
||||
lib/zircon/plugins/Sed/pkgIndex.tcl
|
||||
lib/zircon/samples/zircon.ad
|
||||
@exec mkdir -p %D/lib/zircon/help/Channels
|
||||
@exec mkdir -p %D/lib/zircon/help/Servers
|
||||
@exec mkdir -p %D/lib/zircon/help/Services
|
||||
@exec mkdir -p %D/lib/zircon/help/Users
|
||||
@exec mkdir -p %D/lib/zircon/scripts
|
||||
@exec mkdir -p %D/lib/zircon/sounds
|
||||
@dirrm lib/zircon/help/Zircon/Windows
|
||||
@dirrm lib/zircon/help/Channels
|
||||
@dirrm lib/zircon/help/Servers
|
||||
@dirrm lib/zircon/help/Services
|
||||
@dirrm lib/zircon/help/Users
|
||||
@dirrm lib/zircon/help/Zircon
|
||||
@dirrm lib/zircon/help
|
||||
@dirrm lib/zircon/gifs
|
||||
@dirrm lib/zircon/lang
|
||||
@dirrm lib/zircon/lib
|
||||
@dirrm lib/zircon/look
|
||||
@dirrm lib/zircon/plugins/Dcc
|
||||
@dirrm lib/zircon/plugins/MsgOps
|
||||
@dirrm lib/zircon/plugins/NoticeOps
|
||||
@dirrm lib/zircon/plugins/Sed
|
||||
@dirrm lib/zircon/plugins
|
||||
@dirrm lib/zircon/samples
|
||||
@dirrm lib/zircon/scripts
|
||||
@dirrm lib/zircon/sounds
|
||||
@dirrm lib/zircon
|
|
@ -209,7 +209,6 @@
|
|||
SUBDIR += lapacke
|
||||
SUBDIR += laspack
|
||||
SUBDIR += ldouble
|
||||
SUBDIR += lensnns
|
||||
SUBDIR += levmar
|
||||
SUBDIR += libR
|
||||
SUBDIR += libRmath
|
||||
|
|
|
@ -1,64 +0,0 @@
|
|||
# New ports collection makefile for: lensnns
|
||||
# Date created: 9 jan 2007
|
||||
# Whom: Jason W. Bacon <jwbacon@tds.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= lensnns
|
||||
PORTVERSION= 2.63
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= math science
|
||||
MASTER_SITES= http://tedlab.mit.edu/~dr/Lens/Dist/ \
|
||||
http://www.neuro.mcw.edu/Ports/distfiles/
|
||||
DISTNAME= lens
|
||||
|
||||
MAINTAINER= tcltk@FreeBSD.org
|
||||
COMMENT= Light Efficient Neural Network Simulator
|
||||
|
||||
DEPRECATED= Project has been abandoned
|
||||
EXPIRATION_DATE=2013-02-01
|
||||
|
||||
LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83 \
|
||||
tk83.1:${PORTSDIR}/x11-toolkits/tk83
|
||||
RUN_DEPENDS= runsomebrowser:${PORTSDIR}/www/runsomebrowser
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAN1= lensnns.1
|
||||
|
||||
SUB_FILES= pkg-message lensnns.1 lensnns.cshrc lensnns.profile
|
||||
PKGMESSAGE= ${WRKDIR}/pkg-message
|
||||
WEB_BROWSER?= runsomebrowser
|
||||
MAKE_ENV+= HOSTTYPE="FreeBSD"
|
||||
|
||||
post-extract:
|
||||
${MKDIR} ${WRKDIR}/lens
|
||||
${MV} ${WRKDIR}/[A-Z]* ${WRKDIR}/lens
|
||||
${REINPLACE_CMD} 's|netscape|${WEB_BROWSER}|g' ${WRKSRC}/Src/lensrc.tcl
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/Bin/FreeBSD/alens-2.63 ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/Bin/FreeBSD/lens-2.63 ${PREFIX}/bin
|
||||
${LN} -s ${PREFIX}/bin/alens-2.63 ${PREFIX}/bin/alensnns
|
||||
${LN} -s ${PREFIX}/bin/lens-2.63 ${PREFIX}/bin/lensnns
|
||||
${INSTALL_MAN} ${WRKDIR}/lensnns.1 ${MAN1PREFIX}/man/man1
|
||||
${MKDIR} ${PREFIX}/share/${PORTNAME}/Src/Images
|
||||
${MKDIR} ${PREFIX}/share/${PORTNAME}/Examples
|
||||
${MKDIR} ${PREFIX}/share/${PORTNAME}/Commands
|
||||
${INSTALL_DATA} ${WRKSRC}/Src/*.tcl \
|
||||
${PREFIX}/share/${PORTNAME}/Src
|
||||
${INSTALL_DATA} ${WRKSRC}/Src/Images/* \
|
||||
${PREFIX}/share/${PORTNAME}/Src/Images
|
||||
${INSTALL_DATA} ${WRKSRC}/Examples/* \
|
||||
${PREFIX}/share/${PORTNAME}/Examples
|
||||
${INSTALL_DATA} ${WRKSRC}/Commands/* \
|
||||
${PREFIX}/share/${PORTNAME}/Commands
|
||||
${MKDIR} ${PREFIX}/etc/mri
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/lensnns.cshrc ${WRKDIR}/lensnns.profile \
|
||||
${PREFIX}/etc/mri
|
||||
|
||||
post-install:
|
||||
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (lens.tar.gz) = e884cf7e64fd1be7389b484cc899eb611d631149f68d3d185a32e855026b1933
|
||||
SIZE (lens.tar.gz) = 7678205
|
|
@ -1,21 +0,0 @@
|
|||
.TH LENS 1
|
||||
.SH NAME \" Section header
|
||||
.PP
|
||||
|
||||
LENS \- Light Efficient (Neural) Network Simulator
|
||||
|
||||
.SH "DESCRIPTION"
|
||||
|
||||
To use the default installation, set LENSDIR to %%DATADIR%%.
|
||||
|
||||
If you want to customize anything in this directory, make a personal
|
||||
copy of %%DATADIR%%, and set LENSDIR to the full pathname of your
|
||||
own copy.
|
||||
|
||||
For information on using LENS, please see the online documentation at
|
||||
http://tedlab.mit.edu/~dr/Lens/.
|
||||
|
||||
.SH "PORT MAINTAINER"
|
||||
.nf
|
||||
.na
|
||||
Jason W. Bacon
|
|
@ -1 +0,0 @@
|
|||
setenv LENSDIR %%DATADIR%%
|
|
@ -1,2 +0,0 @@
|
|||
LENSDIR=%%DATADIR%%
|
||||
export LENSDIR
|
|
@ -1,27 +0,0 @@
|
|||
--- Makefile.orig Tue Dec 9 13:13:54 2003
|
||||
+++ Makefile Thu May 10 11:19:20 2007
|
||||
@@ -6,7 +6,7 @@
|
||||
#CFLAGS = -w1 -O3 -march=pentiumiii -mcpu=pentiumpro -DAVOID_NAN_TEST
|
||||
#MACHINE = INTEL
|
||||
MAKE = /usr/bin/make
|
||||
-SYSLIB = -export-dynamic -ldl -L/usr/X11R6/lib
|
||||
+SYSLIB = -export-dynamic -ldl -L${LOCALBASE}/lib
|
||||
|
||||
# Windows 95/98/NT using Cygwin:
|
||||
ifeq ($(HOSTTYPE),i686)
|
||||
@@ -14,6 +14,15 @@
|
||||
CFLAGS = -Wall -O4 -march=i486
|
||||
MAKE = make
|
||||
EXT = .exe
|
||||
+ SYSLIB =
|
||||
+endif
|
||||
+# FreeBSD
|
||||
+ifeq ($(HOSTTYPE),FreeBSD)
|
||||
+ MACHINE = FREEBSD
|
||||
+ MAKE = gmake
|
||||
+ CC = cc
|
||||
+ CFLAGS = -pipe -O -DAVOID_NAN_TEST -DHAVE_LIMITS_H -DHAVE_UNISTD_H
|
||||
+ EXT =
|
||||
SYSLIB =
|
||||
endif
|
||||
# Macintosh X:
|
|
@ -1,25 +0,0 @@
|
|||
--- Src/Makefile.orig Tue Dec 9 13:13:53 2003
|
||||
+++ Src/Makefile Thu May 10 11:20:40 2007
|
||||
@@ -11,6 +11,14 @@
|
||||
INCL= -I$(TCLDIR)/include
|
||||
LIBS= -L$(TCLDIR)/lib -ltk83 -ltcl83 -lm $(SYSLIB)
|
||||
else
|
||||
+ifeq ($(MACHINE),FREEBSD)
|
||||
+ O= ../Obj/$(HOSTTYPE)
|
||||
+ TCLVER= 8.3
|
||||
+ TCLDIR= /usr/local/include
|
||||
+ BINDIR= $(TOP)/Bin/$(HOSTTYPE)
|
||||
+ INCL= -I$(TCLDIR)/tcl$(TCLVER)/generic -I$(TCLDIR)/tk$(TCLVER)/generic -I${LOCALBASE}/include
|
||||
+ LIBS= -L$(BINDIR) -L/usr/local/lib -L${LOCALBASE}/lib -ltk83 -ltcl83 -lm -lX11 $(SYSLIB)
|
||||
+else
|
||||
O= ../Obj/$(HOSTTYPE)
|
||||
TCLVER= 8.3.4
|
||||
TCLDIR= ../TclTk
|
||||
@@ -24,6 +32,7 @@
|
||||
INCL= -I$(TCLDIR)/tcl$(TCLVER)/generic -I$(TCLDIR)/tk$(TCLVER)/generic
|
||||
LIBS= -L$(BINDIR) -ltk8.3 -ltcl8.3 -lm -lX11 $(SYSLIB)
|
||||
endif
|
||||
+endif
|
||||
endif
|
||||
EXEC_OBJS= $(O)/main.o $(patsubst %,$(O)/%.o,$(SRCS))
|
||||
LIB_OBJS= $(O)/library.o $(patsubst %,$(O)/%.o,$(SRCS))
|
|
@ -1,16 +0,0 @@
|
|||
--- Src/sysext.h.orig Tue Dec 9 13:13:53 2003
|
||||
+++ Src/sysext.h Thu May 10 10:59:36 2007
|
||||
@@ -3,10 +3,8 @@
|
||||
#ifndef SYSEXT_H
|
||||
#define SYSEXT_H
|
||||
|
||||
-/*
|
||||
-#ifdef MACHINE_YOURMACHINE
|
||||
- include headers or define macros as necessary
|
||||
-#endif
|
||||
-*/
|
||||
+#if BYTE_ORDER == LITTLE_ENDIAN
|
||||
+# define LITTLE_END
|
||||
+#endif /* LITTLE_END */
|
||||
|
||||
#endif /* SYSEXT_H */
|
|
@ -1,40 +0,0 @@
|
|||
===========================================================================
|
||||
|
||||
For quick instructions, type
|
||||
|
||||
man lensnns
|
||||
|
||||
---
|
||||
|
||||
To use the default configuration, set the environment variable LENSDIR to
|
||||
|
||||
%%DATADIR%%
|
||||
|
||||
As an alternative to manual setup shown above, this port (and many other MRI
|
||||
ports) include configuration scripts to automaticaly perform this setup.
|
||||
Using these scripts, a single addition to your shell's startup script will
|
||||
automatically configure the environment for all MRI ports that include
|
||||
a configuration script.
|
||||
|
||||
To utilize these scripts in C-shell compatible shells, add the following
|
||||
to your .cshrc:
|
||||
|
||||
foreach script (%%PREFIX%%/etc/mri/*.cshrc)
|
||||
source ${script}
|
||||
end
|
||||
|
||||
For Bourne-shell compatibles, add the following to your .profile:
|
||||
|
||||
for script in %%PREFIX%%/etc/mri/*.profile; do
|
||||
. ${script}
|
||||
done
|
||||
|
||||
---
|
||||
|
||||
If you want to customize your environment, make a complete copy of
|
||||
|
||||
%%DATADIR%%
|
||||
|
||||
and set LENSDIR to the full pathname of your copy.
|
||||
|
||||
===========================================================================
|
|
@ -1,5 +0,0 @@
|
|||
Lens is an efficient, yet flexible, neural network simulator that runs on
|
||||
a variety of platforms, is able to handle large, complex simulations, but
|
||||
is also reasonably easy for novices to operate.
|
||||
|
||||
WWW: http://tedlab.mit.edu/~dr/Lens/
|
|
@ -1,237 +0,0 @@
|
|||
bin/alensnns
|
||||
bin/alens-2.63
|
||||
bin/lensnns
|
||||
bin/lens-2.63
|
||||
etc/mri/lensnns.cshrc
|
||||
etc/mri/lensnns.profile
|
||||
%%DATADIR%%/Commands/addGroup.txt
|
||||
%%DATADIR%%/Commands/addLinkType.txt
|
||||
%%DATADIR%%/Commands/addNet.txt
|
||||
%%DATADIR%%/Commands/alias.txt
|
||||
%%DATADIR%%/Commands/autoPlot.txt
|
||||
%%DATADIR%%/Commands/cd.txt
|
||||
%%DATADIR%%/Commands/changeGroupType.txt
|
||||
%%DATADIR%%/Commands/clientInfo.txt
|
||||
%%DATADIR%%/Commands/close.txt
|
||||
%%DATADIR%%/Commands/closeNetOutputFile.txt
|
||||
%%DATADIR%%/Commands/connectGroupToUnits.txt
|
||||
%%DATADIR%%/Commands/connectGroups.txt
|
||||
%%DATADIR%%/Commands/connectUnits.txt
|
||||
%%DATADIR%%/Commands/copyConnect.txt
|
||||
%%DATADIR%%/Commands/copyUnitValues.txt
|
||||
%%DATADIR%%/Commands/deleteExampleSets.txt
|
||||
%%DATADIR%%/Commands/deleteGroupInputs.txt
|
||||
%%DATADIR%%/Commands/deleteGroupOutputs.txt
|
||||
%%DATADIR%%/Commands/deleteGroups.txt
|
||||
%%DATADIR%%/Commands/deleteLinkType.txt
|
||||
%%DATADIR%%/Commands/deleteLinks.txt
|
||||
%%DATADIR%%/Commands/deleteNets.txt
|
||||
%%DATADIR%%/Commands/deleteUnitInputs.txt
|
||||
%%DATADIR%%/Commands/deleteUnitOutputs.txt
|
||||
%%DATADIR%%/Commands/deltaBarDelta.txt
|
||||
%%DATADIR%%/Commands/disconnectGroupUnit.txt
|
||||
%%DATADIR%%/Commands/disconnectGroups.txt
|
||||
%%DATADIR%%/Commands/disconnectUnits.txt
|
||||
%%DATADIR%%/Commands/doExample.txt
|
||||
%%DATADIR%%/Commands/dougsMomentum.txt
|
||||
%%DATADIR%%/Commands/drawUnits.txt
|
||||
%%DATADIR%%/Commands/elmanConnect.txt
|
||||
%%DATADIR%%/Commands/eval.txt
|
||||
%%DATADIR%%/Commands/exampleSetMode.txt
|
||||
%%DATADIR%%/Commands/exec.txt
|
||||
%%DATADIR%%/Commands/exit.txt
|
||||
%%DATADIR%%/Commands/exportGraph.txt
|
||||
%%DATADIR%%/Commands/expr.txt
|
||||
%%DATADIR%%/Commands/for.txt
|
||||
%%DATADIR%%/Commands/foreach.txt
|
||||
%%DATADIR%%/Commands/freezeWeights.txt
|
||||
%%DATADIR%%/Commands/getObject.txt
|
||||
%%DATADIR%%/Commands/getSeed.txt
|
||||
%%DATADIR%%/Commands/glob.txt
|
||||
%%DATADIR%%/Commands/graph.txt
|
||||
%%DATADIR%%/Commands/graphObject.txt
|
||||
%%DATADIR%%/Commands/groupType.txt
|
||||
%%DATADIR%%/Commands/healUnits.txt
|
||||
%%DATADIR%%/Commands/help.txt
|
||||
%%DATADIR%%/Commands/history.txt
|
||||
%%DATADIR%%/Commands/if.txt
|
||||
%%DATADIR%%/Commands/index.txt
|
||||
%%DATADIR%%/Commands/lesionLinks.txt
|
||||
%%DATADIR%%/Commands/lesionUnits.txt
|
||||
%%DATADIR%%/Commands/loadExamples.txt
|
||||
%%DATADIR%%/Commands/loadWeights.txt
|
||||
%%DATADIR%%/Commands/loadXerionWeights.txt
|
||||
%%DATADIR%%/Commands/ls.txt
|
||||
%%DATADIR%%/Commands/manual.txt
|
||||
%%DATADIR%%/Commands/momentum.txt
|
||||
%%DATADIR%%/Commands/moveExamples.txt
|
||||
%%DATADIR%%/Commands/nice.txt
|
||||
%%DATADIR%%/Commands/noiseType.txt
|
||||
%%DATADIR%%/Commands/open.txt
|
||||
%%DATADIR%%/Commands/openNetOutputFile.txt
|
||||
%%DATADIR%%/Commands/orderGroups.txt
|
||||
%%DATADIR%%/Commands/path.txt
|
||||
%%DATADIR%%/Commands/pid.txt
|
||||
%%DATADIR%%/Commands/plotAll.txt
|
||||
%%DATADIR%%/Commands/plotRow.txt
|
||||
%%DATADIR%%/Commands/polarity.txt
|
||||
%%DATADIR%%/Commands/printLinkValues.txt
|
||||
%%DATADIR%%/Commands/printUnitValues.txt
|
||||
%%DATADIR%%/Commands/puts.txt
|
||||
%%DATADIR%%/Commands/pwd.txt
|
||||
%%DATADIR%%/Commands/rand.txt
|
||||
%%DATADIR%%/Commands/randInt.txt
|
||||
%%DATADIR%%/Commands/randWeights.txt
|
||||
%%DATADIR%%/Commands/repeat.txt
|
||||
%%DATADIR%%/Commands/resetDerivs.txt
|
||||
%%DATADIR%%/Commands/resetExampleSets.txt
|
||||
%%DATADIR%%/Commands/resetNet.txt
|
||||
%%DATADIR%%/Commands/resetPlot.txt
|
||||
%%DATADIR%%/Commands/resetUnitValues.txt
|
||||
%%DATADIR%%/Commands/return.txt
|
||||
%%DATADIR%%/Commands/saveExamples.txt
|
||||
%%DATADIR%%/Commands/saveParameters.txt
|
||||
%%DATADIR%%/Commands/saveWeights.txt
|
||||
%%DATADIR%%/Commands/seed.txt
|
||||
%%DATADIR%%/Commands/sendEval.txt
|
||||
%%DATADIR%%/Commands/sendObject.txt
|
||||
%%DATADIR%%/Commands/set.txt
|
||||
%%DATADIR%%/Commands/setLinkValues.txt
|
||||
%%DATADIR%%/Commands/setObject.txt
|
||||
%%DATADIR%%/Commands/setTime.txt
|
||||
%%DATADIR%%/Commands/signal.txt
|
||||
%%DATADIR%%/Commands/source.txt
|
||||
%%DATADIR%%/Commands/startClient.txt
|
||||
%%DATADIR%%/Commands/startServer.txt
|
||||
%%DATADIR%%/Commands/steepest.txt
|
||||
%%DATADIR%%/Commands/stopClient.txt
|
||||
%%DATADIR%%/Commands/stopServer.txt
|
||||
%%DATADIR%%/Commands/switch.txt
|
||||
%%DATADIR%%/Commands/test.txt
|
||||
%%DATADIR%%/Commands/thawWeights.txt
|
||||
%%DATADIR%%/Commands/time.txt
|
||||
%%DATADIR%%/Commands/trace.txt
|
||||
%%DATADIR%%/Commands/train.txt
|
||||
%%DATADIR%%/Commands/trainParallel.txt
|
||||
%%DATADIR%%/Commands/unalias.txt
|
||||
%%DATADIR%%/Commands/unset.txt
|
||||
%%DATADIR%%/Commands/updateGraphs.txt
|
||||
%%DATADIR%%/Commands/updateWeights.txt
|
||||
%%DATADIR%%/Commands/useNet.txt
|
||||
%%DATADIR%%/Commands/useTestingSet.txt
|
||||
%%DATADIR%%/Commands/useTrainingSet.txt
|
||||
%%DATADIR%%/Commands/verbosity.txt
|
||||
%%DATADIR%%/Commands/view.txt
|
||||
%%DATADIR%%/Commands/viewConsole.txt
|
||||
%%DATADIR%%/Commands/viewLinks.txt
|
||||
%%DATADIR%%/Commands/viewObject.txt
|
||||
%%DATADIR%%/Commands/viewUnits.txt
|
||||
%%DATADIR%%/Commands/wait.txt
|
||||
%%DATADIR%%/Commands/waitForClients.txt
|
||||
%%DATADIR%%/Commands/while.txt
|
||||
%%DATADIR%%/Examples/adder10.ex.gz
|
||||
%%DATADIR%%/Examples/adder10.gen
|
||||
%%DATADIR%%/Examples/adder10.in
|
||||
%%DATADIR%%/Examples/adder2.ex.gz
|
||||
%%DATADIR%%/Examples/adder2.gen
|
||||
%%DATADIR%%/Examples/adder2.in
|
||||
%%DATADIR%%/Examples/bench.ex
|
||||
%%DATADIR%%/Examples/bench.in
|
||||
%%DATADIR%%/Examples/boltz-complete.in
|
||||
%%DATADIR%%/Examples/boltz.ex
|
||||
%%DATADIR%%/Examples/boltz.in
|
||||
%%DATADIR%%/Examples/client.tcl
|
||||
%%DATADIR%%/Examples/crazyxor.ex
|
||||
%%DATADIR%%/Examples/digits.ex
|
||||
%%DATADIR%%/Examples/digits.in
|
||||
%%DATADIR%%/Examples/digits2.ex
|
||||
%%DATADIR%%/Examples/encoder.dense.ex
|
||||
%%DATADIR%%/Examples/encoder.in
|
||||
%%DATADIR%%/Examples/encoder.sparse.ex
|
||||
%%DATADIR%%/Examples/filler-srbptt.in
|
||||
%%DATADIR%%/Examples/filler.ex.gz
|
||||
%%DATADIR%%/Examples/filler.gen
|
||||
%%DATADIR%%/Examples/filler.in
|
||||
%%DATADIR%%/Examples/formatSentence
|
||||
%%DATADIR%%/Examples/hand-digits.in
|
||||
%%DATADIR%%/Examples/hand-digits.trn.bex.gz
|
||||
%%DATADIR%%/Examples/hand-digits.tst.bex.gz
|
||||
%%DATADIR%%/Examples/integrate.in
|
||||
%%DATADIR%%/Examples/jets-n-sharks.ex
|
||||
%%DATADIR%%/Examples/jets-n-sharks.in
|
||||
%%DATADIR%%/Examples/kohonen.ex
|
||||
%%DATADIR%%/Examples/kohonen.in
|
||||
%%DATADIR%%/Examples/kohonen.tcl
|
||||
%%DATADIR%%/Examples/logic.ex.gz
|
||||
%%DATADIR%%/Examples/logic.gen
|
||||
%%DATADIR%%/Examples/logic.in
|
||||
%%DATADIR%%/Examples/logic2.gen
|
||||
%%DATADIR%%/Examples/logic2.in
|
||||
%%DATADIR%%/Examples/logic2.trn.ex.gz
|
||||
%%DATADIR%%/Examples/logic2.tst.ex.gz
|
||||
%%DATADIR%%/Examples/negation.ex
|
||||
%%DATADIR%%/Examples/negation.in
|
||||
%%DATADIR%%/Examples/on-off.ex
|
||||
%%DATADIR%%/Examples/on-off.in
|
||||
%%DATADIR%%/Examples/on-off2.ex
|
||||
%%DATADIR%%/Examples/output
|
||||
%%DATADIR%%/Examples/pick-one.ex.gz
|
||||
%%DATADIR%%/Examples/pick-one.in
|
||||
%%DATADIR%%/Examples/rand10x40.ex
|
||||
%%DATADIR%%/Examples/rand10x40.in
|
||||
%%DATADIR%%/Examples/rand10x40b.ex
|
||||
%%DATADIR%%/Examples/recoder.ex
|
||||
%%DATADIR%%/Examples/recoder.gen
|
||||
%%DATADIR%%/Examples/recoder.in
|
||||
%%DATADIR%%/Examples/rhw-sequence.gen
|
||||
%%DATADIR%%/Examples/rhw-sequence.in
|
||||
%%DATADIR%%/Examples/rhw-sequence.trn.ex
|
||||
%%DATADIR%%/Examples/rhw-sequence.tst.ex
|
||||
%%DATADIR%%/Examples/sequence
|
||||
%%DATADIR%%/Examples/sequence.ex
|
||||
%%DATADIR%%/Examples/sequence.gen
|
||||
%%DATADIR%%/Examples/sequence.in
|
||||
%%DATADIR%%/Examples/server.tcl
|
||||
%%DATADIR%%/Examples/t-c.ex.gz
|
||||
%%DATADIR%%/Examples/t-c.gen
|
||||
%%DATADIR%%/Examples/t-c.in
|
||||
%%DATADIR%%/Examples/task.ex
|
||||
%%DATADIR%%/Examples/task.gen
|
||||
%%DATADIR%%/Examples/task.in
|
||||
%%DATADIR%%/Examples/xor.chooseEx
|
||||
%%DATADIR%%/Examples/xor.ex
|
||||
%%DATADIR%%/Examples/xor.in
|
||||
%%DATADIR%%/Src/Images/down.xbm
|
||||
%%DATADIR%%/Src/Images/left.xbm
|
||||
%%DATADIR%%/Src/Images/left0.xbm
|
||||
%%DATADIR%%/Src/Images/left2.xbm
|
||||
%%DATADIR%%/Src/Images/left3.xbm
|
||||
%%DATADIR%%/Src/Images/lens.medium.gif
|
||||
%%DATADIR%%/Src/Images/lensIcon.gif
|
||||
%%DATADIR%%/Src/Images/reload.xbm
|
||||
%%DATADIR%%/Src/Images/right.xbm
|
||||
%%DATADIR%%/Src/Images/right0.xbm
|
||||
%%DATADIR%%/Src/Images/right2.xbm
|
||||
%%DATADIR%%/Src/Images/right2b.xbm
|
||||
%%DATADIR%%/Src/Images/right3.xbm
|
||||
%%DATADIR%%/Src/Images/right3b.xbm
|
||||
%%DATADIR%%/Src/Images/up.xbm
|
||||
%%DATADIR%%/Src/Images/up2.xbm
|
||||
%%DATADIR%%/Src/Images/up3.xbm
|
||||
%%DATADIR%%/Src/auto.tcl
|
||||
%%DATADIR%%/Src/console.tcl
|
||||
%%DATADIR%%/Src/display.tcl
|
||||
%%DATADIR%%/Src/file.tcl
|
||||
%%DATADIR%%/Src/fileselect.tcl
|
||||
%%DATADIR%%/Src/graph.tcl
|
||||
%%DATADIR%%/Src/init.tcl
|
||||
%%DATADIR%%/Src/interface.tcl
|
||||
%%DATADIR%%/Src/lensrc.tcl
|
||||
%%DATADIR%%/Src/object.tcl
|
||||
%%DATADIR%%/Src/shell.tcl
|
||||
@dirrm %%DATADIR%%/Src/Images
|
||||
@dirrm %%DATADIR%%/Src
|
||||
@dirrm %%DATADIR%%/Examples
|
||||
@dirrm %%DATADIR%%/Commands
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrmtry etc/mri
|
Loading…
Reference in a new issue