Fix orca so that it actually runs. While here, replace some hardcoded paths

with replaceable values.
This commit is contained in:
Joe Marcus Clarke 2007-03-25 05:12:50 +00:00
parent 78dee05804
commit 1f596f873d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=188239
5 changed files with 43 additions and 0 deletions

View file

@ -8,6 +8,7 @@
PORTNAME= orca
PORTVERSION= 2.18.0
PORTREVISION= 1
CATEGORIES= accessibility x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@ -17,6 +18,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Scriptable screen reader
LIB_DEPENDS= gnome-mag.2:${PORTSDIR}/accessibility/gnome-mag
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
LATEST_LINK= gnome-orca
@ -33,4 +35,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= orca.1
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
s|/usr/X11R6|${X11BASE}|g' \
${WRKSRC}/src/orca/orca.in
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/src/orca/orca_i18n.py
.include <bsd.port.mk>

View file

@ -0,0 +1,26 @@
--- src/orca/orca.in.orig Sun Mar 25 00:58:52 2007
+++ src/orca/orca.in Sun Mar 25 01:02:09 2007
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/local/bin/bash
#
# Orca
#
@@ -30,7 +30,7 @@
# Set the user's $PATH for this script.
#
-export PATH="/usr/ccs/bin:/usr/bin:/usr/sbin:/bin:/usr/sfw/bin:/usr/openwin/bin:/usr/X11R6/bin"
+export PATH="/usr/ccs/bin:/usr/bin:/usr/sbin:/bin:/usr/sfw/bin:/usr/openwin/bin:/usr/local/bin:/usr/X11R6/bin"
# If you set RUNONCE to "true", then this will just run Orca once and quit.
#
@@ -125,7 +125,7 @@ watchdog()
do
sleep 5
USERID=`id | cut -f2 -d= | cut -f1 -d\(`
- PID=`ps -eo pid,ruid,args | grep $USERID | egrep "orca[.]orca" | grep -v grep | awk '{ print $1 }'`
+ PID=`ps -exo pid,ruid,args | grep $USERID | egrep "orca[.]orca" | grep -v grep | awk '{ print $1 }'`
if [ "x$PID" = "x" ]
then

View file

@ -0,0 +1,8 @@
--- src/orca/platform.py.in.orig Sun Mar 25 01:07:40 2007
+++ src/orca/platform.py.in Sun Mar 25 01:07:56 2007
@@ -40,4 +40,4 @@ package = "@PACKAGE@"
# The name of the data directory (usually "share").
#
-datadirname = "@DATADIRNAME@"
+datadirname = "@datadir@"