- Unbreak

- Fix build with gcc 4.2

PR:		116822
		116823
		116824
		116828
Submitted by:	miwi
Approved by:	maintainer
This commit is contained in:
Martin Wilke 2007-10-09 23:09:55 +00:00
parent 736c5e2a1b
commit 1f71de60b9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=201228
8 changed files with 44 additions and 16 deletions

View file

@ -35,10 +35,6 @@ INSTALL_TARGET= install_lh001
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
pre-everything::
.if ${HAVE_SDL}
@${ECHO_MSG} "This port depends on SDL with OpenGL support."

View file

@ -0,0 +1,11 @@
--- noegnud/noegnud_gui.c.orig 2007-10-02 14:32:19.000000000 +0200
+++ noegnud/noegnud_gui.c 2007-10-02 14:32:30.000000000 +0200
@@ -627,7 +627,7 @@
//button=(noegnud_gui_tbutton *)noegnud_gui_create_window(parent,x,y,width,height,(sizeof(noegnud_gui_twindow)-sizeof(noegnud_gui_twidget))+datasize);
text=noegnud_gui_create_text(
- (noegnud_gui_twidget *)button=(noegnud_gui_tbutton *)noegnud_gui_create_window(
+ button=(noegnud_gui_tbutton *)noegnud_gui_create_window(
parent,
x,y,
width,height,

View file

@ -35,10 +35,6 @@ INSTALL_TARGET= install_nh342-dt
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
pre-everything::
.if ${HAVE_SDL}
@${ECHO_MSG} "This port depends on SDL with OpenGL support."

View file

@ -0,0 +1,11 @@
--- noegnud/noegnud_gui.c.orig 2007-10-02 14:32:19.000000000 +0200
+++ noegnud/noegnud_gui.c 2007-10-02 14:32:30.000000000 +0200
@@ -627,7 +627,7 @@
//button=(noegnud_gui_tbutton *)noegnud_gui_create_window(parent,x,y,width,height,(sizeof(noegnud_gui_twindow)-sizeof(noegnud_gui_twidget))+datasize);
text=noegnud_gui_create_text(
- (noegnud_gui_twidget *)button=(noegnud_gui_tbutton *)noegnud_gui_create_window(
+ button=(noegnud_gui_tbutton *)noegnud_gui_create_window(
parent,
x,y,
width,height,

View file

@ -35,10 +35,6 @@ INSTALL_TARGET= install_nh343
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
pre-everything::
.if ${HAVE_SDL}
@${ECHO_MSG} "This port depends on SDL with OpenGL support."

View file

@ -0,0 +1,11 @@
--- noegnud/noegnud_gui.c.orig 2007-10-02 14:32:19.000000000 +0200
+++ noegnud/noegnud_gui.c 2007-10-02 14:32:30.000000000 +0200
@@ -627,7 +627,7 @@
//button=(noegnud_gui_tbutton *)noegnud_gui_create_window(parent,x,y,width,height,(sizeof(noegnud_gui_twindow)-sizeof(noegnud_gui_twidget))+datasize);
text=noegnud_gui_create_text(
- (noegnud_gui_twidget *)button=(noegnud_gui_tbutton *)noegnud_gui_create_window(
+ button=(noegnud_gui_tbutton *)noegnud_gui_create_window(
parent,
x,y,
width,height,

View file

@ -35,10 +35,6 @@ INSTALL_TARGET= install_se006e4f8
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
pre-everything::
.if ${HAVE_SDL}
@${ECHO_MSG} "This port depends on SDL with OpenGL support."

View file

@ -0,0 +1,11 @@
--- noegnud/noegnud_gui.c.orig 2007-10-02 14:32:19.000000000 +0200
+++ noegnud/noegnud_gui.c 2007-10-02 14:32:30.000000000 +0200
@@ -627,7 +627,7 @@
//button=(noegnud_gui_tbutton *)noegnud_gui_create_window(parent,x,y,width,height,(sizeof(noegnud_gui_twindow)-sizeof(noegnud_gui_twidget))+datasize);
text=noegnud_gui_create_text(
- (noegnud_gui_twidget *)button=(noegnud_gui_tbutton *)noegnud_gui_create_window(
+ button=(noegnud_gui_tbutton *)noegnud_gui_create_window(
parent,
x,y,
width,height,