Remove expired port:

2019-09-04 net/py-tweepy: Broken for more than 6 months
This commit is contained in:
Rene Ladan 2019-12-31 21:49:11 +00:00
parent 3e6da11c00
commit 1fb9754eda
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=521661
7 changed files with 1 additions and 83 deletions

1
MOVED
View file

@ -13715,3 +13715,4 @@ x11-toolkits/linux-c6-pango|x11-toolkits/linux-c7-pango|2019-12-31|Has expired:
x11-toolkits/linux-c6-qt47-x11|x11-toolkits/linux-c7-qt-x11|2019-12-31|Has expired: Superseded by CentOS 7
x11-toolkits/linux-c6-tk85|x11-toolkits/linux-c7-tk85|2019-12-31|Has expired: Superseded by CentOS 7
lang/gnatdroid-x86||2019-12-31|Has expired: Unfetchable, unmaintained
net/py-tweepy||2019-12-31|Has expired: Broken for more than 6 months

View file

@ -1122,7 +1122,6 @@
SUBDIR += py-suds-jurko
SUBDIR += py-terminado
SUBDIR += py-tofu
SUBDIR += py-tweepy
SUBDIR += py-twitter-tools
SUBDIR += py-txamqp
SUBDIR += py-txrestapi

View file

@ -1,44 +0,0 @@
# Created by: Cheng-Lung Sung <clsung@FreeBSD.org>
# $FreeBSD$
PORTNAME= tweepy
PORTVERSION= 3.5.0
DISTVERSIONPREFIX= v
CATEGORIES= net python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
COMMENT= Twitter API library for Python
LICENSE= MIT
BROKEN= installs in examples namespace
DEPRECATED= Broken for more than 6 months
EXPIRATION_DATE= 2019-09-04
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.4.3:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0.4.1:www/py-requests-oauthlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.7.3:devel/py-six@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:devel/py-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}vcrpy>=1.1.2:devel/py-vcrpy@${PY_FLAVOR}
USES= python
USE_GITHUB= yes
USE_PYTHON= autoplist distutils
NO_ARCH= yes
TEST_ENV= USE_REPLAY=1
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3000
TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}unittest2>0:devel/py-unittest2@${PY_FLAVOR}
.endif
do-test:
@cd ${WRKSRC} && ${SETENV} ${TEST_ENV} nosetests-${PYTHON_VER} -v tests.test_cursors tests.test_api tests.test_utils
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
TIMESTAMP = 1500106920
SHA256 (tweepy-tweepy-v3.5.0_GH0.tar.gz) = 156748432e71e3f3258d109ef06638c32d2591aa98e480eb321a2c226f4ac47d
SIZE (tweepy-tweepy-v3.5.0_GH0.tar.gz) = 602727

View file

@ -1,22 +0,0 @@
--- setup.py.orig 2015-11-20 05:42:25 UTC
+++ setup.py
@@ -15,7 +15,10 @@ else:
raise RuntimeError("Unable to find version string in %s." % (VERSIONFILE,))
install_reqs = parse_requirements('requirements.txt', session=uuid.uuid1())
+test_reqs = parse_requirements('test_requirements.txt', session=uuid.uuid1())
+
reqs = [str(req.req) for req in install_reqs]
+treqs = [str(req.req) for req in test_reqs]
setup(name="tweepy",
version=version,
@@ -26,6 +29,8 @@ setup(name="tweepy",
url="http://github.com/tweepy/tweepy",
packages=find_packages(exclude=['tests']),
install_requires=reqs,
+ tests_require=treqs,
+ test_suite='nose.collector',
keywords="twitter library",
classifiers=[
'Development Status :: 4 - Beta',

View file

@ -1,9 +0,0 @@
--- test_requirements.txt.orig 2015-11-20 05:42:25 UTC
+++ test_requirements.txt
@@ -1,4 +1,2 @@
-tox>=1.7.2
-vcrpy==1.1.2
-mock==1.0.1
-unittest2 # Comment this line out if using Python 3.
+vcrpy>=1.1.2
+mock>=1.0.1

View file

@ -1,4 +0,0 @@
A Python library for accessing the Twitter.com API.
Supports OAuth, covers the entire API, and streaming API.
WWW: https://github.com/tweepy/tweepy