This is a GPL release of the Seven Kingdoms: Ancient Adversaries

thanks to Enlight Software which granted the ability to license the
game under a free and open source license in 2009. See the file
"COPYING" for the details of the license. We are indebted to Enlight
for making the 7kfans project possible and giving a new chance to
build a community for fans of the game.

WWW: http://7kfans.com/
This commit is contained in:
Dmitry Marakasov 2015-05-21 12:56:58 +00:00
parent cb18b0c1ee
commit 1fe3c71e87
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=386930
5 changed files with 71 additions and 0 deletions

35
games/7kaa/Makefile Normal file
View file

@ -0,0 +1,35 @@
# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
PORTNAME= 7kaa
PORTVERSION= 2.14.5
CATEGORIES= games
MASTER_SITES= SF/skfans/7KAA%20${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Seven Kingdoms: Ancient Adversaries
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libenet.so:${PORTSDIR}/net/enet
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules \
--disable-nls # no translations ATM
USES= gmake openal:al tar:xz
USE_SDL= sdl2
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= *
PORTDATA= *
OPTIONS_DEFINE= DOCS
post-install:
${RM} -f ${STAGEDIR}${DOCSDIR}/COPYING
.include <bsd.port.mk>

2
games/7kaa/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (7kaa-2.14.5.tar.xz) = c7f04fa640d324ed8f1523da49945acd0f1ee2a99e3ee82ee29b52d2f735e464
SIZE (7kaa-2.14.5.tar.xz) = 31223408

View file

@ -0,0 +1,25 @@
--- src/common/OMISC.cpp.orig 2015-05-19 01:00:20 UTC
+++ src/common/OMISC.cpp
@@ -37,6 +37,7 @@
#include <stdlib.h>
#include <time.h>
#include <ctype.h>
+#include <math.h>
#include <ALL.h>
#include <OSTR.h>
@@ -755,10 +756,13 @@ char* Misc::format(double inNum, int for
static char outBuf[35];
char *outPtr=outBuf;
+ char floatBuf[35];
char *floatStr;
int i, intDigit, sign; // intDigit = no. of integer digits
- floatStr = fcvt( inNum, MONEY_DEC_PLACE, &intDigit, &sign );
+ intDigit = snprintf(floatBuf, sizeof(floatBuf), "%.0lf", fabs(inNum) * 100.0);
+ intDigit -= 2;
+ floatStr = floatBuf;
#ifdef DEBUG
if( intDigit > 29 ) // integer digits can't exceed 29

8
games/7kaa/pkg-descr Normal file
View file

@ -0,0 +1,8 @@
This is a GPL release of the Seven Kingdoms: Ancient Adversaries
thanks to Enlight Software which granted the ability to license the
game under a free and open source license in 2009. See the file
"COPYING" for the details of the license. We are indebted to Enlight
for making the 7kfans project possible and giving a new chance to
build a community for fans of the game.
WWW: http://7kfans.com/

View file

@ -12,6 +12,7 @@
SUBDIR += 3omns
SUBDIR += 4stattack
SUBDIR += 54321
SUBDIR += 7kaa
SUBDIR += CaribbeanStud
SUBDIR += HeroesOfMightAndMagic
SUBDIR += KnightCap