- Fix build by using correct shell
- Fix build on 9.x by properly using c++11
This commit is contained in:
parent
224fbe6f4d
commit
1ff45cdd0a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=426117
3 changed files with 24 additions and 0 deletions
|
@ -14,8 +14,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
|||
USES= compiler:c++11-lib gettext gmake libarchive pkgconfig shebangfix
|
||||
USE_GNOME= gtkmm30 intltool libxslt
|
||||
USE_GSTREAMER= mm
|
||||
USE_CXXSTD= c++11
|
||||
INSTALLS_ICONS= yes
|
||||
GNU_CONFIGURE= yes
|
||||
SHEBANG_FILES= create-lw-file
|
||||
bash_CMD= /bin/sh
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
games/lordsawar/files/patch-src_MapRenderer.cpp
Normal file
11
games/lordsawar/files/patch-src_MapRenderer.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/MapRenderer.cpp.orig 2015-06-10 18:06:19 UTC
|
||||
+++ src/MapRenderer.cpp
|
||||
@@ -72,7 +72,7 @@ void MapRenderer::render_tile(Vector<int
|
||||
}
|
||||
else
|
||||
{
|
||||
- if (style->getImage() == false)
|
||||
+ if (!style->getImage())
|
||||
{
|
||||
printf ("pic for style %d for tile %d at %d,%d is null\n",
|
||||
style->getType(), mtile->getType(), tile.x, tile.y);
|
11
games/lordsawar/files/patch-src_gui_stack-army-button.cpp
Normal file
11
games/lordsawar/files/patch-src_gui_stack-army-button.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/gui/stack-army-button.cpp.orig 2015-06-20 22:48:43 UTC
|
||||
+++ src/gui/stack-army-button.cpp
|
||||
@@ -146,7 +146,7 @@ void StackArmyButton::fill_army_button()
|
||||
{
|
||||
bool greyed_out = false;
|
||||
Stack *active_stack = p->getActivestack();
|
||||
- if (active_stack->getArmyById(d_army->getId()) == false)
|
||||
+ if (!active_stack->getArmyById(d_army->getId()))
|
||||
greyed_out = true;
|
||||
army_image->property_pixbuf() =
|
||||
gc->getCircledArmyPic(p->getArmyset(), d_army->getTypeId(),
|
Loading…
Reference in a new issue