devel/libspice-server: Update version 0.15.0=>0.15.2

- Adopt port as maintainers domain has expired

Changelog: https://gitlab.freedesktop.org/spice/spice/-/tags/v0.15.2

Approved by:	portmgr (blanket)
This commit is contained in:
Muhammad Moinur Rahman 2024-01-10 13:12:32 +01:00
parent 22f29c4e8b
commit 200b1ecfd4
6 changed files with 34 additions and 89 deletions

View file

@ -1,57 +1,46 @@
PORTNAME= libspice-server
DISTVERSION= 0.15.0
PORTREVISION= 3
DISTVERSION= 0.15.2
CATEGORIES= devel
MASTER_SITES= https://www.spice-space.org/download/releases/spice-server/
DISTNAME= spice-${PORTVERSION}
MAINTAINER= portmaster@BSDforge.com
MAINTAINER= bofh@FreeBSD.org
COMMENT= Implements the server side of the SPICE protocol
WWW= https://spice-space.org/
LICENSE= GPLv2
LIB_DEPENDS= libopus.so:audio/opus
BUILD_DEPENDS= autoconf-archive>=0:devel/autoconf-archive \
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>0:devel/py-pyparsing@${PY_FLAVOR} \
spice-protocol>=0.12.10:devel/spice-protocol
LIB_DEPENDS= libopus.so:audio/opus
OPTIONS_DEFINE= GSTREAMER LZ4 SASL STATISTICS
OPTIONS_DEFAULT= GSTREAMER LZ4 SASL
STATISTICS_DESC= Statistic code
GSTREAMER_USES= gstreamer
GSTREAMER_CONFIGURE_ON= --enable-gstreamer=1.0
GSTREAMER_CONFIGURE_OFF= --enable-gstreamer=no
GSTREAMER_LIB_DEPENDS= liborc-0.4.so:devel/orc
LZ4_CONFIGURE_ENABLE= lz4
LZ4_LIB_DEPENDS+= liblz4.so:archivers/liblz4
SASL_CONFIGURE_WITH= sasl
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
STATISTICS_CONFIGURE_ENABLE= statistics
USES= autoreconf compiler:c++11-lang cpe gmake gnome jpeg \
libtool localbase:ldflag pkgconfig python ssl tar:bzip2 xorg
USE_GNOME= glib20
USE_XORG= pixman
USE_LDCONFIG= yes
USES= compiler:c++11-lang cpe gmake gnome jpeg libtool \
localbase:ldflag meson pkgconfig python ssl tar:bzip2 xorg
CPE_VENDOR= spice_project
CPE_PRODUCT= spice
USE_GNOME= glib20
USE_LDCONFIG= yes
USE_XORG= pixman
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-celt051 \
--enable-manual=no
SPICE_SSL_CFLAGS= -I${OPENSSLINC}
SPICE_SSL_LIBS= -L${OPENSSLLIB} -lcrypto -lssl
CONFIGURE_ENV+= SSL_CFLAGS="${SPICE_SSL_CFLAGS}" SSL_LIBS="${SPICE_SSL_LIBS}" \
OPENSSL_CFLAGS="${SPICE_SSL_CFLAGS}" OPENSSL_LIBS="${SPICE_SSL_LIBS}" \
PYTHON=${PYTHON_CMD}
MESON_ARGS+= -Dsmartcard=disabled
INSTALL_TARGET= install-strip
BINARY_ALIAS= python3=${PYTHON_CMD}
OPTIONS_DEFINE= GSTREAMER LZ4 SASL STATISTICS
OPTIONS_DEFAULT= GSTREAMER LZ4 SASL
STATISTICS_DESC= Statistic code
GSTREAMER_LIB_DEPENDS= liborc-0.4.so:devel/orc
GSTREAMER_USES= gstreamer
GSTREAMER_MESON_ON= -Dgstreamer=1.0
GSTREAMER_MESON_OFF= -Dgstreamer=no
LZ4_LIB_DEPENDS= liblz4.so:archivers/liblz4
LZ4_MESON_TRUE= lz4
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
SASL_MESON_TRUE= sasl
STATISTICS_MESON_ON= -Dstatistics=true
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1618969647
SHA256 (spice-0.15.0.tar.bz2) = b320cf8f4bd2852750acb703c15b72856027e5a8554f8217dfbb3cc09deba0f5
SIZE (spice-0.15.0.tar.bz2) = 1537970
TIMESTAMP = 1704885543
SHA256 (spice-0.15.2.tar.bz2) = 6d9eb6117f03917471c4bc10004abecff48a79fb85eb85a1c45f023377015b81
SIZE (spice-0.15.2.tar.bz2) = 1663326

View file

@ -1,6 +1,6 @@
--- configure.ac.orig 2021-04-17 06:49:29 UTC
--- configure.ac.orig 2023-05-12 08:37:06 UTC
+++ configure.ac
@@ -41,6 +41,7 @@ AC_PROG_CC_C99
@@ -42,6 +42,7 @@ fi
if test x"$ac_cv_prog_cc_c99" = xno; then
AC_MSG_ERROR([C99 compiler is required.])
fi
@ -8,7 +8,7 @@
AC_PROG_INSTALL
AC_CANONICAL_HOST
LT_INIT([disable-static])
@@ -204,7 +205,8 @@ AS_VAR_APPEND([SPICE_REQUIRES], [" pixman-1 >= $PIXMAN
@@ -205,7 +206,8 @@ AC_SUBST(SSL_LIBS)
PKG_CHECK_MODULES(SSL, openssl >= 1.0.0)
AC_SUBST(SSL_CFLAGS)
AC_SUBST(SSL_LIBS)
@ -18,26 +18,3 @@
save_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $SSL_CFLAGS"
@@ -217,15 +219,16 @@ CFLAGS="$save_CFLAGS"
AC_CHECK_LIB(jpeg, jpeg_destroy_decompress,
AC_MSG_CHECKING([for jpeglib.h])
- AC_TRY_CPP(
-[#include <stdio.h>
+ AC_PREPROC_IFELSE(
+[AC_LANG_SOURCE([[
+#include <stdio.h>
#undef PACKAGE
#undef VERSION
#undef HAVE_STDLIB_H
-#include <jpeglib.h>],
- JPEG_LIBS='-ljpeg'
- AC_MSG_RESULT($jpeg_ok),
- AC_MSG_ERROR([jpeglib.h not found])),
+#include <jpeglib.h>]])],
+ [JPEG_LIBS='-ljpeg'
+ AC_MSG_RESULT($jpeg_ok)],
+ [AC_MSG_ERROR([jpeglib.h not found])]),
AC_MSG_ERROR([libjpeg not found]))
AC_SUBST(JPEG_LIBS)

View file

@ -1,11 +0,0 @@
--- server/net-utils.c.orig 2021-04-21 06:31:14 UTC
+++ server/net-utils.c
@@ -48,7 +48,7 @@
static inline bool
darwin_einval_on_unix_socket(int fd, int err)
{
-#if defined(__APPLE__)
+#if defined(__APPLE__) || defined(__FreeBSD__)
if (err == EINVAL) {
union {
struct sockaddr sa;

View file

@ -1,10 +0,0 @@
--- server/red-stream.cpp.orig 2021-04-21 06:29:28 UTC
+++ server/red-stream.cpp
@@ -24,6 +24,7 @@
#include <netdb.h>
#include <sys/socket.h>
#include <netinet/tcp.h>
+#include <netinet/in.h>
#else
#include <ws2tcpip.h>
#endif

View file

@ -9,6 +9,6 @@ include/spice-server/spice.h
include/spice-server/spice-audio.h
include/spice-server/spice-version.h
include/spice-server/spice-qxl.h
lib/libspice-server.so.1.14.1
lib/libspice-server.so.1.14.3
lib/libspice-server.so
lib/libspice-server.so.1