new port of mcrypt 2.5.5, a replacement for crypt(1)

Obtained from:	OpenBSD
This commit is contained in:
Trevor Johnson 2001-03-23 05:16:45 +00:00
parent cea4828308
commit 201fdac8c9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40246
6 changed files with 73 additions and 0 deletions

View file

@ -62,6 +62,7 @@
SUBDIR += logcheck
SUBDIR += lsh
SUBDIR += lxnb
SUBDIR += mcrypt
SUBDIR += mhash
SUBDIR += mindterm-binary
SUBDIR += nbaudit

54
security/mcrypt/Makefile Normal file
View file

@ -0,0 +1,54 @@
# New ports collection makefile for: mcrypt
# Date created: 2000-12-31
# Whom: trevor
# based on the OpenBSD port
#
# $OpenBSD: Makefile,v 1.1.1.1 2000/11/27 15:56:03 avsm Exp $
# $FreeBSD$
#
PORTNAME= mcrypt
PORTVERSION= 2.5.5
CATEGORIES= security
MASTER_SITES= ftp://argeas.cs-net.gr/pub/unix/mcrypt/ \
ftp://ftp.ntua.gr/pub/security/mcrypt/
# http://mcrypt.hellug.gr/mcrypt/
MAINTAINER= Trevor Johnson <trevor@FreeBSD.org>
LIB_DEPENDS= mcrypt.4:${PORTSDIR}/security/libmcrypt/ \
mhash.2:${PORTSDIR}/security/mhash/ \
intl.1:${PORTSDIR}/devel/gettext/
post-patch:
${RM} -f ${WRKSRC}/configure
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= ${CONFIGURE_SHARED}
CONFIGURE_ARGS+= --enable-static --with-catgets
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl -lltdl"
MAN1= mcrypt.1
PLIST= ${WRKDIR}/pkg-plist
USE_AUTOCONF= yes
USE_LIBTOOL= yes
pre-install:
${ECHO} bin/${PORTNAME} > ${PLIST}
${ECHO} bin/mdecrypt >> ${PLIST}
.for i in cz el pl
${ECHO} share/locale/${i}/LC_MESSAGES/mcrypt.mo >> ${PLIST}
.endfor
.if !defined(NOPORTDOCS)
${ECHO} share/examples/${PORTNAME}/sample.mcryptrc >> ${PLIST}
${ECHO} @dirrm share/examples/${PORTNAME} >> ${PLIST}
.endif
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/doc/sample.mcryptrc \
${PREFIX}/share/examples/${PORTNAME}/
.endif
.include <bsd.port.mk>

1
security/mcrypt/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (mcrypt-2.5.5.tar.gz) = 2c7ce0050d897c09ec1f650671b66a3f

View file

@ -0,0 +1,11 @@
--- src/extra.c.orig Mon Oct 2 09:38:07 2000
+++ src/extra.c Thu Mar 22 20:14:15 2001
@@ -289,7 +289,7 @@
int i;
for (i = 0; i < size; i++) {
- str[i] = _tolower(str[i]);
+ str[i] = tolower(str[i]);
}
}

View file

@ -0,0 +1 @@
Replacement for crypt(1)

View file

@ -0,0 +1,5 @@
This program is intended to replace crypt(1), It supports all the
algorithms and modes in libmcrypt (BLOWFISH, TWOFISH, DES, TripleDES,
3-WAY, SAFER, LOKI97, GOST, RC2, RC6, MARS, IDEA, RIJNDAEL, SERPENT,
CAST, ARCFOUR and WAKE), and is compatibile with UNIX crypt(1) and
with des(1) from Solaris.