- Update to version 1.0.3

PR:		59751
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2003-12-04 10:12:01 +00:00
parent 27956856a5
commit 2044b063a8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94925
7 changed files with 17 additions and 115 deletions

View file

@ -6,24 +6,28 @@
#
PORTNAME= rubix
PORTVERSION= 1.0.2
PORTVERSION= 1.0.3
CATEGORIES= games
MASTER_SITES= http://sed.free.fr/rubix/
MAINTAINER= ports@FreeBSD.org
COMMENT= Another Rubik's cube game with a rather interesting interface
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
ALL_TARGET= ${PORTNAME}
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" XINC="-I${X11BASE}/include" \
XLIB="-L${X11BASE}/lib -lX11"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rubix ${PREFIX}/bin
@${MKDIR} ${PREFIX}/share/rubix
${INSTALL_DATA} ${WRKSRC}/module.xm ${PREFIX}/share/rubix
.if !defined(NOPORTDOCS)
.for file in AUTHORS BUGS INSTALL NOISE README TODO
@${MKDIR} ${PREFIX}/share/doc/rubix
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/rubix
.for file in AUTHORS BUGS INSTALL README TODO
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif

View file

@ -1 +1 @@
MD5 (rubix-1.0.2.tar.gz) = c59d6e4ad830aa37f6c559c587c15cd8
MD5 (rubix-1.0.3.tar.bz2) = 05a8721e409f7b7d18c994a6a86b2f25

View file

@ -1,50 +0,0 @@
--- Makefile.orig Tue Dec 7 00:19:16 1999
+++ Makefile Sat Dec 23 13:31:45 2000
@@ -11,35 +11,38 @@
#
#customize to fit your needs (it does not work for now).
-architecture=-DPC_ARCHI
+#architecture=-DPC_ARCHI
+module_path=-DMODULE_PATH=\"${PREFIX}/share/rubix\"
#SOLARIS=-lsocket
-CC=gcc
-CFLAGS=-Wall -O3 -fomit-frame-pointer -ffast-math -Iplayer \
- $(architecture)
+CC?=gcc
+CFLAGS+=-Iplayer \
+ $(architecture) $(module_path)
#CFLAGS=-Wall -g -ffast-math -Iplayer \
# $(architecture)
-XINC=-I/usr/X11R6/include
-XLIB=-L/usr/X11R6/lib -lX11
+XINC=-I${X11BASE}/include
+XLIB=-L${X11BASE}/lib -lX11
#the following should not be changed.
OBJ=cube.o event.o fillpoly.o line.o main.o screen.o sound.o player/player.a
+all: rubix
+
rubix : $(OBJ)
$(CC) $(CFLAGS) -o $@ $^ -lm $(XLIB) $(SOLARIS)
# strip rubix
clean :
rm -f *.o *~ core *.bak *.dat gmon.out
- (cd player; make clean)
+ (cd player; $(MAKE) clean)
dep :
- makedepend -Y *.c -s"#I like the GNU tools" -Iplayer
+# makedepend -Y *.c -s"#I like the GNU tools" -Iplayer
player/player.a : player/*.c player/*.h
- (cd player; make)
+ (cd player; $(MAKE))
%.o : %.c
$(CC) $(CFLAGS) $(XINC) -c -o $@ $<

View file

@ -1,10 +0,0 @@
--- event.c Thu Dec 2 12:50:06 1999
+++ event.c.new Mon Dec 6 16:44:01 1999
@@ -18,6 +18,7 @@
#include <errno.h>
#include <stdio.h>
#include <X11/Xlib.h>
+#include <string.h>
#include "sound.h"
#include "screen.h"

View file

@ -1,17 +0,0 @@
--- player/Makefile.orig Fri Dec 3 02:35:44 1999
+++ player/Makefile Sat Dec 23 13:35:18 2000
@@ -4,10 +4,11 @@
# * This is total free software.
# */
-WITH_ASM=1
+#WITH_ASM=1
-CC=gcc
-CFLAGS=-Wall -O3 -fomit-frame-pointer -ffast-math
+CC?=gcc
+INCS=-I${X11BASE}/include
+CFLAGS+=$(INCS)
OBJ=card.o mixer.o xm.o live_player.o wav.o

View file

@ -1,22 +0,0 @@
--- main.c.orig Fri Dec 10 01:59:09 1999
+++ main.c Sat Dec 23 13:37:46 2000
@@ -54,6 +54,10 @@
CUBE cube;
int i;
int rand=1;
+ char full_module_file[4096];
+ char *module_file = "module.xm";
+ strcpy(full_module_file, MODULE_PATH "/");
+ strcat(full_module_file, module_file);
the_screen=&screen.buffer[0];
d.buffer=screen.buffer;
@@ -81,7 +85,7 @@
}
if (do_init_sound)
- if (rubick_init_sound(&sound, "module.xm")==-1) {
+ if (rubick_init_sound(&sound, full_module_file)==-1) {
fprintf(stderr, "Error with initing the sound, sorry pal, no sound no game.\n(I fucked my head with"
" an xm player, this is not for nothing !)\n");
return 0;

View file

@ -1,10 +1,7 @@
bin/rubix
%%PORTDOCS%%share/doc/rubix/AUTHORS
%%PORTDOCS%%share/doc/rubix/BUGS
%%PORTDOCS%%share/doc/rubix/INSTALL
%%PORTDOCS%%share/doc/rubix/NOISE
%%PORTDOCS%%share/doc/rubix/README
%%PORTDOCS%%share/doc/rubix/TODO
share/rubix/module.xm
@dirrm share/rubix
%%PORTDOCS%%@dirrm share/doc/rubix
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%@dirrm %%DOCSDIR%%