Initial import of xg version 1.0.
Windows(tm) controls - like widget set for Motif(tm). PR: 8950 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
This commit is contained in:
parent
6b8e9c5547
commit
205a5d395b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=15500
8 changed files with 142 additions and 0 deletions
38
x11-toolkits/xg/Makefile
Normal file
38
x11-toolkits/xg/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
|||
# New ports collection makefile for: xg
|
||||
# Version required: 1.0
|
||||
# Date created: 3 December 1998
|
||||
# Whom: Andrey Zakhvatov
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= xg
|
||||
PKGNAME= xg-1.0
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= ftp://messners.com/code/ \
|
||||
http://www.messners.com/code/
|
||||
|
||||
MAINTAINER= andy@icc.surw.chel.su
|
||||
|
||||
REQUIRES_MOTIF= yes
|
||||
USE_X_PREFIX= yes
|
||||
MAKEFILE= makefile
|
||||
WRKSRC= ${WRKDIR}/Xg-1.0
|
||||
|
||||
do-install:
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/src/libxg.a ${PREFIX}/lib
|
||||
@ ${MKDIR} ${PREFIX}/include/xg
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/include/xg
|
||||
@ ${MKDIR} ${PREFIX}/share/examples/xg
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/testsrc/* ${PREFIX}/share/examples/xg
|
||||
@ ${MV} ${PREFIX}/share/examples/xg/makefile ${PREFIX}/share/examples/xg/Makefile
|
||||
@ ${RM} ${PREFIX}/share/examples/xg/makefile.orig
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@ ${MKDIR} ${PREFIX}/share/doc/xg
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${PREFIX}/share/doc/xg
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xg
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
x11-toolkits/xg/distinfo
Normal file
1
x11-toolkits/xg/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (xg.tar.gz) = c9b8045a2840ad1d317968b2e389836a
|
13
x11-toolkits/xg/files/patch-aa
Normal file
13
x11-toolkits/xg/files/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- makefile Sat Mar 15 00:36:20 1997
|
||||
+++ /home/andy/tmp/wrk/makefile Wed Dec 2 22:28:41 1998
|
||||
@@ -51,8 +51,8 @@
|
||||
# most systems don't need to do this, ie:. -I/usr/dt/include for
|
||||
# Solaris
|
||||
#
|
||||
-MOTIF_INC =
|
||||
-CFLAGS = "-DUSE_XM_MWMUTIL_H -DUSE_XGPM -I../include ${MOTIF_INC}"
|
||||
+MOTIF_INC = -I${X11BASE}/include -I${X11BASE}/include/X11
|
||||
+CFLAGS = "-DUSE_XM_MWMUTIL_H -DUSE_XGPM -DV_USE_TM_ZONE -I../include ${MOTIF_INC}"
|
||||
|
||||
#
|
||||
# If your OS doesn't use ranlib set RANLIB to true
|
22
x11-toolkits/xg/files/patch-ab
Normal file
22
x11-toolkits/xg/files/patch-ab
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- src/TimeEntry.c Fri Mar 14 21:50:04 1997
|
||||
+++ /home/andy/tmp/wrk/src/TimeEntry.c Wed Dec 2 22:29:36 1998
|
||||
@@ -1549,7 +1549,9 @@
|
||||
{
|
||||
struct tm ts;
|
||||
long time_value;
|
||||
+#ifndef __FreeBSD__
|
||||
extern long timezone;
|
||||
+#endif
|
||||
|
||||
ts.tm_mon = te->timeentry.month_value - 1;
|
||||
ts.tm_mday = te->timeentry.day_value;
|
||||
@@ -1574,7 +1576,9 @@
|
||||
*/
|
||||
if ( te->timeentry.use_timezone == False )
|
||||
{
|
||||
+#ifndef __FreeBSD__
|
||||
time_value -= timezone;
|
||||
+#endif
|
||||
|
||||
/*
|
||||
* Adjust for Daylight Savings Time
|
12
x11-toolkits/xg/files/patch-ac
Normal file
12
x11-toolkits/xg/files/patch-ac
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- testsrc/makefile Fri Mar 14 22:50:16 1997
|
||||
+++ /home/andy/tmp/wrk/testsrc/makefile Wed Dec 2 23:05:06 1998
|
||||
@@ -43,6 +43,9 @@
|
||||
testrow.c testtb.c testte.c testtabs.c
|
||||
TESTPROGS = ${TESTCSRC:.c=}
|
||||
|
||||
+CFLAGS = -I/usr/X11R6/include/xg -I/usr/X11R6/include
|
||||
+LDFLAGS = -L/usr/X11R6/lib -lXm -lXt -lXmu -lX11 -lxg
|
||||
+
|
||||
# ------------------------------------------------------------------------
|
||||
# miscellaneous macros
|
||||
#
|
1
x11-toolkits/xg/pkg-comment
Normal file
1
x11-toolkits/xg/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Windows(tm) controls - like widget set for Motif(tm).
|
10
x11-toolkits/xg/pkg-descr
Normal file
10
x11-toolkits/xg/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
In the many years that I have been developing GUIs for UNIX, I have
|
||||
always envied the controls that are commonly available for MS Windows
|
||||
applications. In attempt to rectify this situation I designed the
|
||||
"Xg Widget Set". This widget set is an extension of the Motif widget
|
||||
set and provides many of the controls found in MS Windows applications.
|
||||
|
||||
The widget set is self contained, as such it requires no additional
|
||||
libraries other than X, Xt, and Motif (1.1, 1.2.x or 2.0).
|
||||
|
||||
http://www.messners.com/xgwidgets/xgwidgets.html
|
45
x11-toolkits/xg/pkg-plist
Normal file
45
x11-toolkits/xg/pkg-plist
Normal file
|
@ -0,0 +1,45 @@
|
|||
include/xg/ClockLabel.h
|
||||
include/xg/ClockLabelP.h
|
||||
include/xg/ComboBox.h
|
||||
include/xg/ComboBoxP.h
|
||||
include/xg/ExtPushB.h
|
||||
include/xg/ExtPushBP.h
|
||||
include/xg/FastLabel.h
|
||||
include/xg/FastLabelP.h
|
||||
include/xg/NumEntry.h
|
||||
include/xg/NumEntryP.h
|
||||
include/xg/Row.h
|
||||
include/xg/RowP.h
|
||||
include/xg/Tabs.h
|
||||
include/xg/TabsP.h
|
||||
include/xg/TimeEntry.h
|
||||
include/xg/TimeEntryP.h
|
||||
include/xg/ToolBar.h
|
||||
include/xg/ToolBarP.h
|
||||
include/xg/ToolPushB.h
|
||||
include/xg/ToolPushBP.h
|
||||
include/xg/XgUtils.h
|
||||
include/xg/x_rotate.h
|
||||
include/xg/xgpm.h
|
||||
lib/libxg.a
|
||||
share/doc/xg/LICENSE
|
||||
share/doc/xg/README
|
||||
share/examples/xg/CancelPB.xpm
|
||||
share/examples/xg/HandSign.xpm
|
||||
share/examples/xg/HelpPB.xpm
|
||||
share/examples/xg/Makefile
|
||||
share/examples/xg/NoPB.xpm
|
||||
share/examples/xg/OkayPB.xpm
|
||||
share/examples/xg/YesPB.xpm
|
||||
share/examples/xg/testcb.c
|
||||
share/examples/xg/testcl.c
|
||||
share/examples/xg/testepb.c
|
||||
share/examples/xg/testfl.c
|
||||
share/examples/xg/testne.c
|
||||
share/examples/xg/testrow.c
|
||||
share/examples/xg/testtabs.c
|
||||
share/examples/xg/testtb.c
|
||||
share/examples/xg/testte.c
|
||||
@dirrm include/xg
|
||||
@dirrm share/doc/xg
|
||||
@dirrm share/examples/xg
|
Loading…
Reference in a new issue