graphics/jogl: fix build with OpenJDK8
PR: 203495 Approved by: peterj (maintainer)
This commit is contained in:
parent
b9f21ba8ce
commit
20f1a1f3cf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=399125
2 changed files with 21 additions and 2 deletions
|
@ -52,13 +52,22 @@ ALL_TARGET+= javadoc
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${JAVA_PORT_VERSION} == "1.6.0"
|
||||
.if ${JAVA_PORT_VERSION:M1.6.*}
|
||||
PLIST_SUB+= JDK6=""
|
||||
PLIST_SUB+= JDK7="@comment "
|
||||
.else
|
||||
.endif
|
||||
.if ${JAVA_PORT_VERSION:M1.7.*}
|
||||
PLIST_SUB+= JDK6="@comment "
|
||||
PLIST_SUB+= JDK7=""
|
||||
.endif
|
||||
.if ${JAVA_PORT_VERSION:M1.8.*}
|
||||
PLIST_SUB+= JDK6="@comment "
|
||||
PLIST_SUB+= JDK7="@comment "
|
||||
.endif
|
||||
|
||||
.if ${JAVA_PORT_VERSION:M1.8.*}
|
||||
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-build.xml
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%JAVALIBDIR%%|${JAVALIBDIR}|g' \
|
||||
|
|
10
graphics/jogl/files/extra-patch-build.xml
Normal file
10
graphics/jogl/files/extra-patch-build.xml
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- jogl/make/build.xml.orig 2015-10-01 22:40:34.563042000 +0000
|
||||
+++ jogl/make/build.xml 2015-10-01 22:40:53.793693000 +0000
|
||||
@@ -1058,6 +1058,7 @@
|
||||
sourcepath="${src.java};${src.generated.java}"
|
||||
destdir="${javadoc}" windowtitle="${javadoc.windowtitle}"
|
||||
overview="${javadoc.overview}"
|
||||
+ additionalparam="-Xdoclint:none"
|
||||
source="1.4"
|
||||
linkoffline="${javadoc.link} 142-packages"
|
||||
bottom="${javadoc.bottom}" >
|
Loading…
Reference in a new issue