- Update to 1.1-final.

- Fix master_sites.
- Fix gcc-4.2 related errors.
- Makefile and pkg build cleanup.

PR:		ports/120074
Submitted by:	Brett Johnson <brett@define.net.au>
Approved by:	linimon (mentor)
This commit is contained in:
Beech Rintoul 2008-01-28 22:55:50 +00:00
parent 4e20352c95
commit 20f531a072
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=206345
5 changed files with 55 additions and 10 deletions

View file

@ -7,10 +7,12 @@
PORTNAME= BitchX
PORTVERSION= 1.1.0.1
CATEGORIES+= irc
MASTER_SITES= ftp://ftp.bitchx.org/pub/BitchX/source/ \
PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://www.bitchx.com/ \
CENKES
DISTNAME= ircii-pana-1.1a-final
DISTNAME= ircii-pana-1.1-final
MAINTAINER?= beech@FreeBSD.org
COMMENT?= ircII color client with GTK/GNOME support
@ -80,7 +82,8 @@ CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}
.endif
.if defined(WITH_PLUGINS)
PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay
PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,\
fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay
PLIST_SUB+= PLUGINS=""
.else
CONFIGURE_ARGS+=--without-plugins
@ -94,7 +97,8 @@ PLIST_SUB+= XMMS=""
PLIST_SUB+= XMMS="@comment "
.endif
.if (defined(WITH_XMMS) && defined(WITH_PLUGINS))
PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay,xmms
PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,\
hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay,xmms
.endif
.if (defined(WITH_PLUGINS) || defined(WITH_XMMS))
@ -116,10 +120,12 @@ post-install:
${RMDIR} ${PREFIX}/share/bx/help
.endif
.if defined(WITH_GNOME)
${STRIP_CMD} ${PREFIX}/bin/gtkBitchX-${PORTVERSION}-final
${STRIP_CMD} ${PREFIX}/bin/gtkBitchX-1.1-final
.else
${STRIP_CMD} ${PREFIX}/bin/BitchX-${PORTVERSION}-final
${STRIP_CMD} ${PREFIX}/bin/BitchX-1.1-final
${STRIP_CMD} ${PREFIX}/bin/scr-bx
.endif
@cd ${FILESDIR} && ${CP} .placeholder ${PREFIX}/share/bx/plugins/
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (ircii-pana-1.1a-final.tar.gz) = cd77b52b2ba92cc9a082e4ddb631d05c
SHA256 (ircii-pana-1.1a-final.tar.gz) = 40cea400fa7592bed47071fec9d31e5ff69088d6cf78e5cdfe9cc7ee7198618e
SIZE (ircii-pana-1.1a-final.tar.gz) = 2599126
MD5 (ircii-pana-1.1-final.tar.gz) = 611d2dda222f00c10140236f4c331572
SHA256 (ircii-pana-1.1-final.tar.gz) = 7464cd75a10f2d117a10cf0184e5d4b9ece44de03a226402c17bdd3f2c7eca57
SIZE (ircii-pana-1.1-final.tar.gz) = 2532476

View file

@ -0,0 +1 @@
This file is a placeholder for pkg install.

View file

@ -0,0 +1,36 @@
diff -ru source.orig/ctcp.c source/ctcp.c
--- source.orig/ctcp.c 2003-05-26 23:00:22.000000000 -0800
+++ source/ctcp.c 2008-01-28 07:31:56.000000000 -0900
@@ -176,7 +176,7 @@
/* CDE do ops and unban logging */
-static char *ctcp_type[] =
+char *ctcp_type[] =
{
"PRIVMSG",
"NOTICE"
diff -ru source.orig/term.c source/term.c
--- source.orig/term.c 2003-04-10 17:09:07.000000000 -0800
+++ source/term.c 2008-01-28 07:58:45.000000000 -0900
@@ -92,7 +92,7 @@
#endif
extern char *getenv();
-extern char *tparm();
+
/*
* The old code assumed termcap. termcap is almost always present, but on
diff -ru source.orig/timer.c source/timer.c
--- source.orig/timer.c 2003-04-10 17:09:07.000000000 -0800
+++ source/timer.c 2008-01-28 08:00:29.000000000 -0900
@@ -148,7 +148,7 @@
* This is put here on purpose -- we dont want any of the above functions
* to have any knowledge of this struct.
*/
-static TimerList *PendingTimers;
+TimerList *PendingTimers;
static char *schedule_timer (TimerList *ntimer);
static char *current_exec_timer = empty_string;

View file

@ -1,3 +1,4 @@
@unexec if [ -f %D/share/bx/script/bxglobal.old ]; then rm -f %D/share/bx/script/bxglobal.old; fi
%%NOGNOME%%bin/BitchX
%%NOGNOME%%bin/BitchX-1.1-final
%%GNOME%%bin/gtkBitchX
@ -936,6 +937,7 @@ share/bx/BitchX.kick
%%PLUGINS%%share/bx/plugins/cavlink.so
%%PLUGINS%%share/bx/plugins/identd.so
%%XMMS%%share/bx/plugins/xmms.so
share/bx/plugins/.placeholder
share/bx/script/SCRIPTS
share/bx/script/actplug.gmz
share/bx/script/bxglobal