Update to 0.99.5.
PR: 46767 Submitted by: Dominic Marks <dom@cus.org.uk>
This commit is contained in:
parent
7051b94d09
commit
2128cafb49
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72977
10 changed files with 124 additions and 92 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= dovecot
|
||||
PORTVERSION= 0.98.4
|
||||
PORTVERSION= 0.99.5
|
||||
CATEGORIES= mail ipv6
|
||||
MASTER_SITES= http://dovecot.procontrol.fi/
|
||||
|
||||
|
@ -15,8 +15,10 @@ MAINTAINER= d.marks@student.umist.ac.uk
|
|||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --disable-shadow --enable-ipv6 \
|
||||
--localstatedir=/var/dovecot
|
||||
|
||||
--localstatedir=/var/dovecot --with-ssl=openssl \
|
||||
--with-vpopmail --with-pam --with-rawlog \
|
||||
--with-ssldir=/var/dovecot/ssl
|
||||
|
||||
pre-build:
|
||||
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
|
||||
${WRKSRC}/dovecot-example.conf
|
||||
|
@ -25,11 +27,22 @@ pre-install:
|
|||
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" \
|
||||
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${PREFIX}/lib/dovecot
|
||||
${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/src/imap/imap \
|
||||
${WRKSRC}/src/auth/imap-auth \
|
||||
${WRKSRC}/src/login/imap-login \
|
||||
${PREFIX}/lib/dovecot/
|
||||
${INSTALL_DATA} ${WRKSRC}/dovecot-example.conf ${PREFIX}/etc/
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/master/imap-master ${PREFIX}/sbin/
|
||||
|
||||
post-install:
|
||||
@${MKDIR} /var/dovecot
|
||||
@${MKDIR} /var/dovecot/ssl
|
||||
@${MKDIR} /var/dovecot/auth
|
||||
@${MKDIR} /var/dovecot/login
|
||||
@${CHOWN} imapd:imapd /var/dovecot
|
||||
@${CHOWN} -R imapd:imapd /var/dovecot
|
||||
@if [ ! -f ${PREFIX}/etc/rc.d/dovecot-imapd.sh ]; then \
|
||||
${ECHO} "Installing dovecot-imapd.sh startup file."; \
|
||||
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/dovecot-imapd.sh \
|
||||
|
@ -43,7 +56,9 @@ post-install:
|
|||
${WRKSRC}/doc/index.txt \
|
||||
${WRKSRC}/doc/multiaccess.txt \
|
||||
${WRKSRC}/doc/nfs.txt \
|
||||
${PREFIX}/share/doc/dovecot
|
||||
${WRKSRC}/doc/configuration.txt \
|
||||
${WRKSRC}/doc/mail-storages.txt \
|
||||
${PREFIX}/share/doc/dovecot
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (dovecot-0.98.4.tar.gz) = 2b8087867cbfc4a85183daee2fe49854
|
||||
MD5 (dovecot-0.99.5.tar.gz) = b9e592f23213be9db3603f8bda8235cd
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- src/auth/userinfo-pam.c Thu Aug 1 05:16:44 2002
|
||||
+++ src/auth/userinfo-pam.c Mon Aug 12 23:41:48 2002
|
||||
@@ -21,7 +21,6 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
-#include <shadow.h>
|
||||
|
||||
#include <security/pam_appl.h>
|
||||
|
|
@ -1,42 +1,51 @@
|
|||
--- dovecot-example.conf.orig Thu Aug 29 07:59:26 2002
|
||||
+++ dovecot-example.conf Sun Sep 1 22:07:55 2002
|
||||
@@ -38,7 +38,7 @@
|
||||
##
|
||||
|
||||
# Executable location
|
||||
-#login_executable = /usr/lib/dovecot/imap-login
|
||||
+#login_executable = %%PREFIX%%/lib/dovecot/imap-login
|
||||
|
||||
# User to use for imap-login process
|
||||
#login_user = imapd
|
||||
@@ -46,7 +46,7 @@
|
||||
# Directory where imap-auth places authentication UNIX sockets which login
|
||||
# needs to be able to connect to. The sockets are created when running as
|
||||
# root, so you don't need to give imap-auth any access for it.
|
||||
-#login_dir = /var/run/dovecot/login
|
||||
+#login_dir = /var/dovecot/login
|
||||
|
||||
# chroot() imap-login process to the login_dir. Only reason not to do this
|
||||
# is if you wish to run the whole imapd without roots.
|
||||
--- dovecot-example.conf Thu Jan 2 10:33:53 2003
|
||||
+++ dovecot-example.conf.new Sat Jan 4 21:40:34 2003
|
||||
@@ -64,7 +64,7 @@
|
||||
##
|
||||
|
||||
# Executable location
|
||||
-#imap_executable = /usr/lib/dovecot/imap
|
||||
+#imap_executable = %%PREFIX%%/lib/dovecot/imap
|
||||
-#login_executable = /usr/libexec/dovecot/imap-login
|
||||
+login_executable = %%PREFIX%%/dovecot/imap-login
|
||||
|
||||
# Maximum number of running imap processes. When this limit is reached,
|
||||
# new users aren't allowed to log in.
|
||||
@@ -139,7 +139,7 @@
|
||||
# User to use for imap-login process
|
||||
#login_user = imapd
|
||||
@@ -76,7 +76,7 @@
|
||||
# Directory where imap-auth places authentication UNIX sockets which login
|
||||
# needs to be able to connect to. The sockets are created when running as
|
||||
# root, so you don't need to give imap-auth any access for it.
|
||||
-#login_dir = /var/run/dovecot/login
|
||||
+login_dir = /var/dovecot/login
|
||||
|
||||
# chroot imap-login process to the login_dir. Only reason not to do this
|
||||
# is if you wish to run the whole imapd without roots.
|
||||
@@ -111,7 +111,7 @@
|
||||
##
|
||||
|
||||
# Executable location
|
||||
-#imap_executable = /usr/libexec/dovecot/imap
|
||||
+imap_executable = %%PREFIX%%/dovecot/imap
|
||||
|
||||
# Set max. process size in megabytes. Most of the memory goes to mmap()ing
|
||||
# files, so it shouldn't harm much even if this limit is set pretty high.
|
||||
@@ -292,7 +292,7 @@
|
||||
auth_userinfo = pam
|
||||
|
||||
# Executable location
|
||||
-#auth_executable = /var/lib/dovecot/imap-auth
|
||||
+#auth_executable = %%PREFIX%%/lib/dovecot/imap-auth
|
||||
-#auth_executable = /usr/libexec/dovecot/imap-auth
|
||||
+auth_executable = %%PREFIX%%/dovecot/imap-auth
|
||||
|
||||
# User to use for the process. Only shadow and pam authentication requires
|
||||
# roots, so use something else if possible.
|
||||
@@ -162,7 +162,7 @@
|
||||
# Set max. process size in megabytes.
|
||||
#auth_process_size = 256
|
||||
@@ -303,7 +303,7 @@
|
||||
|
||||
# Directory where to chroot the process. Most authentication backends don't
|
||||
# work if this is set, and there's no point chrooting if auth_user is root.
|
||||
-#auth_chroot =
|
||||
+auth_chroot = /var/dovecot/auth
|
||||
|
||||
# Number of authentication processes to create
|
||||
#auth_count = 1
|
||||
@@ -319,7 +319,7 @@
|
||||
#auth_realms =
|
||||
#auth_userinfo = passwd-file /etc/passwd.imap
|
||||
#auth_user = imapauth
|
||||
|
|
|
@ -9,5 +9,7 @@ sbin/imap-master
|
|||
%%PORTDOCS%%share/doc/dovecot/nfs.txt
|
||||
%%PORTDOCS%%share/doc/dovecot/index.txt
|
||||
%%PORTDOCS%%share/doc/dovecot/multiaccess.txt
|
||||
%%PORTDOCS%%share/doc/dovecot/configuration.txt
|
||||
%%PORTDOCS%%share/doc/dovecot/mail-storages.txt
|
||||
%%PORTDOCS%%@dirrm share/doc/dovecot
|
||||
@dirrm lib/dovecot
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= dovecot
|
||||
PORTVERSION= 0.98.4
|
||||
PORTVERSION= 0.99.5
|
||||
CATEGORIES= mail ipv6
|
||||
MASTER_SITES= http://dovecot.procontrol.fi/
|
||||
|
||||
|
@ -15,8 +15,10 @@ MAINTAINER= d.marks@student.umist.ac.uk
|
|||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --disable-shadow --enable-ipv6 \
|
||||
--localstatedir=/var/dovecot
|
||||
|
||||
--localstatedir=/var/dovecot --with-ssl=openssl \
|
||||
--with-vpopmail --with-pam --with-rawlog \
|
||||
--with-ssldir=/var/dovecot/ssl
|
||||
|
||||
pre-build:
|
||||
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
|
||||
${WRKSRC}/dovecot-example.conf
|
||||
|
@ -25,11 +27,22 @@ pre-install:
|
|||
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" \
|
||||
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${PREFIX}/lib/dovecot
|
||||
${INSTALL_PROGRAM} \
|
||||
${WRKSRC}/src/imap/imap \
|
||||
${WRKSRC}/src/auth/imap-auth \
|
||||
${WRKSRC}/src/login/imap-login \
|
||||
${PREFIX}/lib/dovecot/
|
||||
${INSTALL_DATA} ${WRKSRC}/dovecot-example.conf ${PREFIX}/etc/
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/master/imap-master ${PREFIX}/sbin/
|
||||
|
||||
post-install:
|
||||
@${MKDIR} /var/dovecot
|
||||
@${MKDIR} /var/dovecot/ssl
|
||||
@${MKDIR} /var/dovecot/auth
|
||||
@${MKDIR} /var/dovecot/login
|
||||
@${CHOWN} imapd:imapd /var/dovecot
|
||||
@${CHOWN} -R imapd:imapd /var/dovecot
|
||||
@if [ ! -f ${PREFIX}/etc/rc.d/dovecot-imapd.sh ]; then \
|
||||
${ECHO} "Installing dovecot-imapd.sh startup file."; \
|
||||
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/dovecot-imapd.sh \
|
||||
|
@ -43,7 +56,9 @@ post-install:
|
|||
${WRKSRC}/doc/index.txt \
|
||||
${WRKSRC}/doc/multiaccess.txt \
|
||||
${WRKSRC}/doc/nfs.txt \
|
||||
${PREFIX}/share/doc/dovecot
|
||||
${WRKSRC}/doc/configuration.txt \
|
||||
${WRKSRC}/doc/mail-storages.txt \
|
||||
${PREFIX}/share/doc/dovecot
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (dovecot-0.98.4.tar.gz) = 2b8087867cbfc4a85183daee2fe49854
|
||||
MD5 (dovecot-0.99.5.tar.gz) = b9e592f23213be9db3603f8bda8235cd
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- src/auth/userinfo-pam.c Thu Aug 1 05:16:44 2002
|
||||
+++ src/auth/userinfo-pam.c Mon Aug 12 23:41:48 2002
|
||||
@@ -21,7 +21,6 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
-#include <shadow.h>
|
||||
|
||||
#include <security/pam_appl.h>
|
||||
|
|
@ -1,42 +1,51 @@
|
|||
--- dovecot-example.conf.orig Thu Aug 29 07:59:26 2002
|
||||
+++ dovecot-example.conf Sun Sep 1 22:07:55 2002
|
||||
@@ -38,7 +38,7 @@
|
||||
##
|
||||
|
||||
# Executable location
|
||||
-#login_executable = /usr/lib/dovecot/imap-login
|
||||
+#login_executable = %%PREFIX%%/lib/dovecot/imap-login
|
||||
|
||||
# User to use for imap-login process
|
||||
#login_user = imapd
|
||||
@@ -46,7 +46,7 @@
|
||||
# Directory where imap-auth places authentication UNIX sockets which login
|
||||
# needs to be able to connect to. The sockets are created when running as
|
||||
# root, so you don't need to give imap-auth any access for it.
|
||||
-#login_dir = /var/run/dovecot/login
|
||||
+#login_dir = /var/dovecot/login
|
||||
|
||||
# chroot() imap-login process to the login_dir. Only reason not to do this
|
||||
# is if you wish to run the whole imapd without roots.
|
||||
--- dovecot-example.conf Thu Jan 2 10:33:53 2003
|
||||
+++ dovecot-example.conf.new Sat Jan 4 21:40:34 2003
|
||||
@@ -64,7 +64,7 @@
|
||||
##
|
||||
|
||||
# Executable location
|
||||
-#imap_executable = /usr/lib/dovecot/imap
|
||||
+#imap_executable = %%PREFIX%%/lib/dovecot/imap
|
||||
-#login_executable = /usr/libexec/dovecot/imap-login
|
||||
+login_executable = %%PREFIX%%/dovecot/imap-login
|
||||
|
||||
# Maximum number of running imap processes. When this limit is reached,
|
||||
# new users aren't allowed to log in.
|
||||
@@ -139,7 +139,7 @@
|
||||
# User to use for imap-login process
|
||||
#login_user = imapd
|
||||
@@ -76,7 +76,7 @@
|
||||
# Directory where imap-auth places authentication UNIX sockets which login
|
||||
# needs to be able to connect to. The sockets are created when running as
|
||||
# root, so you don't need to give imap-auth any access for it.
|
||||
-#login_dir = /var/run/dovecot/login
|
||||
+login_dir = /var/dovecot/login
|
||||
|
||||
# chroot imap-login process to the login_dir. Only reason not to do this
|
||||
# is if you wish to run the whole imapd without roots.
|
||||
@@ -111,7 +111,7 @@
|
||||
##
|
||||
|
||||
# Executable location
|
||||
-#imap_executable = /usr/libexec/dovecot/imap
|
||||
+imap_executable = %%PREFIX%%/dovecot/imap
|
||||
|
||||
# Set max. process size in megabytes. Most of the memory goes to mmap()ing
|
||||
# files, so it shouldn't harm much even if this limit is set pretty high.
|
||||
@@ -292,7 +292,7 @@
|
||||
auth_userinfo = pam
|
||||
|
||||
# Executable location
|
||||
-#auth_executable = /var/lib/dovecot/imap-auth
|
||||
+#auth_executable = %%PREFIX%%/lib/dovecot/imap-auth
|
||||
-#auth_executable = /usr/libexec/dovecot/imap-auth
|
||||
+auth_executable = %%PREFIX%%/dovecot/imap-auth
|
||||
|
||||
# User to use for the process. Only shadow and pam authentication requires
|
||||
# roots, so use something else if possible.
|
||||
@@ -162,7 +162,7 @@
|
||||
# Set max. process size in megabytes.
|
||||
#auth_process_size = 256
|
||||
@@ -303,7 +303,7 @@
|
||||
|
||||
# Directory where to chroot the process. Most authentication backends don't
|
||||
# work if this is set, and there's no point chrooting if auth_user is root.
|
||||
-#auth_chroot =
|
||||
+auth_chroot = /var/dovecot/auth
|
||||
|
||||
# Number of authentication processes to create
|
||||
#auth_count = 1
|
||||
@@ -319,7 +319,7 @@
|
||||
#auth_realms =
|
||||
#auth_userinfo = passwd-file /etc/passwd.imap
|
||||
#auth_user = imapauth
|
||||
|
|
|
@ -9,5 +9,7 @@ sbin/imap-master
|
|||
%%PORTDOCS%%share/doc/dovecot/nfs.txt
|
||||
%%PORTDOCS%%share/doc/dovecot/index.txt
|
||||
%%PORTDOCS%%share/doc/dovecot/multiaccess.txt
|
||||
%%PORTDOCS%%share/doc/dovecot/configuration.txt
|
||||
%%PORTDOCS%%share/doc/dovecot/mail-storages.txt
|
||||
%%PORTDOCS%%@dirrm share/doc/dovecot
|
||||
@dirrm lib/dovecot
|
||||
|
|
Loading…
Reference in a new issue