- Update to 1.1.

This commit is contained in:
Alberto Villa 2011-10-17 00:07:14 +00:00
parent d0072a3554
commit 213132b237
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=283644
6 changed files with 112 additions and 18 deletions

View file

@ -6,9 +6,9 @@
#
PORTNAME= choqok
PORTVERSION= 1.0
PORTVERSION= 1.1
CATEGORIES= www kde
MASTER_SITES= http://choqok.gnufolks.org/pkgs/
MASTER_SITES= SF/${PORTNAME}/Choqok/
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE micro-blogging client
@ -16,17 +16,18 @@ COMMENT= KDE micro-blogging client
LICENSE= GPLv3
LIB_DEPENDS= qjson.0:${PORTSDIR}/devel/qjson \
qoauth.1:${PORTSDIR}/net/qoauth \
kwebkit.1:${PORTSDIR}/www/kwebkitpart
qoauth.1:${PORTSDIR}/net/qoauth
#BUILD_DEPENDS+= ${KDE4_PREFIX}/lib/kde4/kwebkitpart.so:${PORTSDIR}/www/kwebkitpart
#RUN_DEPENDS+= ${KDE4_PREFIX}/lib/kde4/kwebkitpart.so:${PORTSDIR}/www/kwebkitpart
USE_GETTEXT= yes
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USE_QT_VER= 4
QT_COMPONENTS= gui imageformats_run network \
moc_build qmake_build rcc_build uic_build
USE_BZIP2= yes
USE_CMAKE= yes
USE_GETTEXT= yes
USE_KDE4= kdelibs kdeprefix automoc4
USE_QT_VER= 4
QT_COMPONENTS= gui network imageformats_run moc_build \
qmake_build rcc_build uic_build
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (choqok-1.0.tar.bz2) = 45d08a621f2e96fb235aba24c181970cb9ddd423a695cd6c4f9be55300764847
SIZE (choqok-1.0.tar.bz2) = 885498
SHA256 (choqok-1.1.tar.bz2) = f9b3016a3e7dba1c5f894e3c453292333c49ee535a14c013f1331b20be519ff2
SIZE (choqok-1.1.tar.bz2) = 917476

View file

@ -0,0 +1,33 @@
From: Andrey Esin <gmlastik@gmail.com>
Date: Thu, 07 Apr 2011 09:01:02 +0000
Subject: Prevent crash, when noone message line enabled in account options.
X-Git-Url: http://quickgit.kde.org/?p=choqok.git&amp;a=commitdiff&amp;h=09b83146c682a0d467cff1be4236660554bd9ca1
---
Prevent crash, when noone message line enabled in account options.
---
--- ./helperlibs/twitterapihelper/twitterapimicroblogwidget.cpp
+++ ./helperlibs/twitterapihelper/twitterapimicroblogwidget.cpp
@@ -138,12 +138,14 @@ TwitterApiSearchTimelineWidget* TwitterA
void TwitterApiMicroBlogWidget::slotCurrentTimelineChanged(int index)
{
- Choqok::UI::TimelineWidget *stw =
- qobject_cast<Choqok::UI::TimelineWidget *>(timelinesTabWidget()->widget(index));
- if(stw->isClosable())
- d->btnCloseSearch->setEnabled(true);
- else
- d->btnCloseSearch->setEnabled(false);
+ if ( index > -1 ) {
+ Choqok::UI::TimelineWidget *stw =
+ qobject_cast<Choqok::UI::TimelineWidget *>(timelinesTabWidget()->widget(index));
+ if(stw->isClosable())
+ d->btnCloseSearch->setEnabled(true);
+ else
+ d->btnCloseSearch->setEnabled(false);
+ }
}
void TwitterApiMicroBlogWidget::slotCloseCurrentSearch()

View file

@ -0,0 +1,22 @@
From: Andrey Esin <gmlastik@gmail.com>
Date: Mon, 02 May 2011 12:32:12 +0000
Subject: BUG:272220
X-Git-Url: http://quickgit.kde.org/?p=choqok.git&amp;a=commitdiff&amp;h=112d643271d27614bd7585e2f3f281a0edeac474
---
BUG:272220
Add ability to recognize nicks with underscore.
---
--- ./microblogs/laconica/laconicapostwidget.cpp
+++ ./microblogs/laconica/laconicapostwidget.cpp
@@ -40,7 +40,7 @@
#include <choqoktools.h>
const QRegExp LaconicaPostWidget::mGroupRegExp( "([\\s]|^)!([a-z0-9]+){1,64}", Qt::CaseInsensitive );
-const QRegExp LaconicaPostWidget::mLaconicaUserRegExp( "([\\s\\W]|^)@([a-z0-9]+){1,64}(?!(@))", Qt::CaseInsensitive );
+const QRegExp LaconicaPostWidget::mLaconicaUserRegExp( "([\\s\\W]|^)@([a-z0-9_]+){1,64}(?!(@))", Qt::CaseInsensitive );
const QRegExp LaconicaPostWidget::mLaconicaHashRegExp( "([\\s]|^)#([\\w_\\.\\-]+)", Qt::CaseInsensitive );
const QString subdomains = "(([a-z0-9-_]\\.)?)";

View file

@ -0,0 +1,21 @@
From: Mehrdad Momeny <mehrdad.momeny@gmail.com>
Date: Fri, 08 Apr 2011 07:52:33 +0000
Subject: BUG:270377 Choqok 1.1 always chrashes upon closing with a segmentation fault
X-Git-Url: http://quickgit.kde.org/?p=choqok.git&amp;a=commitdiff&amp;h=7e15e0aa07d0f906842fd81ec244e908c31fe146
---
BUG:270377 Choqok 1.1 always chrashes upon closing with a segmentation fault
---
--- ./libchoqok/pluginmanager.cpp
+++ ./libchoqok/pluginmanager.cpp
@@ -67,7 +67,7 @@ public:
Plugin *plugin = it.value();
loadedPlugins.remove(info);
plugin->disconnect(&instance, SLOT(slotPluginDestroyed(QObject*)));
- delete plugin;
+ plugin->deleteLater();;
}
}

View file

@ -1,6 +1,7 @@
bin/choqok
include/choqok/account.h
include/choqok/accountmanager.h
include/choqok/application.h
include/choqok/choqok_export.h
include/choqok/choqokappearancesettings.h
include/choqok/choqokbehaviorsettings.h
@ -54,10 +55,12 @@ lib/kde4/choqok_mobypicture.so
lib/kde4/choqok_nowlistening.so
lib/kde4/choqok_ocs.so
lib/kde4/choqok_posterous.so
lib/kde4/choqok_quickfilter.so
lib/kde4/choqok_searchaction.so
lib/kde4/choqok_three_ly.so
lib/kde4/choqok_tighturl.so
lib/kde4/choqok_tinyarro_ws.so
lib/kde4/choqok_translator.so
lib/kde4/choqok_twitgoo.so
lib/kde4/choqok_twitpic.so
lib/kde4/choqok_twitter.so
@ -78,6 +81,7 @@ lib/kde4/kcm_choqok_nowlistening.so
lib/kde4/kcm_choqok_pluginconfig.so
lib/kde4/kcm_choqok_posterous.so
lib/kde4/kcm_choqok_tinyarro_ws.so
lib/kde4/kcm_choqok_translator.so
lib/kde4/kcm_choqok_twitgoo.so
lib/kde4/kcm_choqok_twitpic.so
lib/kde4/kcm_choqok_untiny.so
@ -85,23 +89,25 @@ lib/kde4/kcm_choqok_yourls.so
lib/kde4/konqchoqokplugin.so
lib/libchoqok.so
lib/libchoqok.so.1
lib/libchoqok.so.1.0.0
lib/libchoqok.so.1.1.0
lib/libtwitterapihelper.so
lib/libtwitterapihelper.so.1
lib/libtwitterapihelper.so.1.0.0
lib/libtwitterapihelper.so.1.0.1
share/applications/kde4/choqok.desktop
share/apps/choqok/choqok.notifyrc
share/apps/choqok/choqokui.rc
share/apps/choqok/images/splash_screen.png
share/apps/choqok/languagecodes
share/apps/choqok_filter/filterui.rc
share/apps/choqok_nowlistening/nowlisteningui.rc
share/apps/choqok_quickfilter/quickfilterui.rc
share/apps/choqok_searchaction/searchactionui.rc
share/apps/cmake/modules/FindChoqok.cmake
share/apps/cmake/modules/FindQtOAuth.cmake
share/apps/khtml/kpartplugins/konqchoqok.desktop
share/apps/khtml/kpartplugins/konqchoqok.rc
share/apps/kwebkitpart/kpartplugins/konqchoqok.desktop
share/apps/kwebkitpart/kpartplugins/konqchoqok.rc
@comment share/apps/kwebkitpart/kpartplugins/konqchoqok.desktop
@comment share/apps/kwebkitpart/kpartplugins/konqchoqok.rc
share/config.kcfg/bit_ly_settings.kcfg
share/config.kcfg/choqokappearancesettings.kcfg
share/config.kcfg/choqokbehaviorsettings.kcfg
@ -111,6 +117,7 @@ share/config.kcfg/mobypicturesettings.kcfg
share/config.kcfg/nowlisteningsettings.kcfg
share/config.kcfg/posteroussettings.kcfg
share/config.kcfg/tinyarro_ws_settings.kcfg
share/config.kcfg/translatorsettings.kcfg
share/config.kcfg/twitgoosettings.kcfg
share/config.kcfg/twitpicsettings.kcfg
share/config.kcfg/untinysettings.kcfg
@ -124,8 +131,10 @@ share/doc/HTML/en/choqok/common
share/doc/HTML/en/choqok/index.cache.bz2
share/doc/HTML/en/choqok/index.docbook
share/icons/hicolor/128x128/apps/choqok.png
share/icons/hicolor/128x128/apps/choqok_offline.png
share/icons/hicolor/16x16/actions/retweet.png
share/icons/hicolor/16x16/apps/choqok.png
share/icons/hicolor/16x16/apps/choqok_offline.png
share/icons/hicolor/16x16/apps/flickr_uploader.png
share/icons/hicolor/16x16/apps/imageshack_uploader.png
share/icons/hicolor/16x16/apps/laconica_microblog.png
@ -136,6 +145,7 @@ share/icons/hicolor/16x16/apps/twitgoo_uploader.png
share/icons/hicolor/16x16/apps/twitpic_uploader.png
share/icons/hicolor/16x16/apps/twitter_microblog.png
share/icons/hicolor/22x22/apps/choqok.png
share/icons/hicolor/22x22/apps/choqok_offline.png
share/icons/hicolor/22x22/apps/flickr_uploader.png
share/icons/hicolor/22x22/apps/imageshack_uploader.png
share/icons/hicolor/22x22/apps/laconica_microblog.png
@ -146,6 +156,7 @@ share/icons/hicolor/22x22/apps/twitgoo_uploader.png
share/icons/hicolor/22x22/apps/twitpic_uploader.png
share/icons/hicolor/22x22/apps/twitter_microblog.png
share/icons/hicolor/32x32/apps/choqok.png
share/icons/hicolor/32x32/apps/choqok_offline.png
share/icons/hicolor/32x32/apps/flickr_uploader.png
share/icons/hicolor/32x32/apps/imageshack_uploader.png
share/icons/hicolor/32x32/apps/laconica_microblog.png
@ -156,6 +167,7 @@ share/icons/hicolor/32x32/apps/twitgoo_uploader.png
share/icons/hicolor/32x32/apps/twitpic_uploader.png
share/icons/hicolor/32x32/apps/twitter_microblog.png
share/icons/hicolor/48x48/apps/choqok.png
share/icons/hicolor/48x48/apps/choqok_offline.png
share/icons/hicolor/48x48/apps/flickr_uploader.png
share/icons/hicolor/48x48/apps/imageshack_uploader.png
share/icons/hicolor/48x48/apps/laconica_microblog.png
@ -165,6 +177,7 @@ share/icons/hicolor/48x48/apps/posterous_uploader.png
share/icons/hicolor/48x48/apps/twitgoo_uploader.png
share/icons/hicolor/48x48/apps/twitter_microblog.png
share/icons/hicolor/64x64/apps/choqok.png
share/icons/hicolor/64x64/apps/choqok_offline.png
share/icons/hicolor/64x64/apps/flickr_uploader.png
share/icons/hicolor/64x64/apps/imageshack_uploader.png
share/icons/hicolor/64x64/apps/mobypicture_uploader.png
@ -196,11 +209,14 @@ share/kde4/services/choqok_ocs.desktop
share/kde4/services/choqok_pluginconfig.desktop
share/kde4/services/choqok_posterous.desktop
share/kde4/services/choqok_posterous_config.desktop
share/kde4/services/choqok_quickfilter.desktop
share/kde4/services/choqok_searchaction.desktop
share/kde4/services/choqok_three_ly.desktop
share/kde4/services/choqok_tighturl.desktop
share/kde4/services/choqok_tinyarro_ws.desktop
share/kde4/services/choqok_tinyarro_ws_config.desktop
share/kde4/services/choqok_translator.desktop
share/kde4/services/choqok_translator_config.desktop
share/kde4/services/choqok_twitgoo.desktop
share/kde4/services/choqok_twitgoo_config.desktop
share/kde4/services/choqok_twitpic.desktop
@ -256,9 +272,10 @@ share/locale/uk/LC_MESSAGES/choqok.mo
share/locale/zh_CN/LC_MESSAGES/choqok.mo
share/locale/zh_TW/LC_MESSAGES/choqok.mo
@dirrm share/doc/HTML/en/choqok
@dirrmtry share/apps/kwebkitpart/kpartplugins
@dirrmtry share/apps/kwebkitpart
@comment @dirrmtry share/apps/kwebkitpart/kpartplugins
@comment @dirrmtry share/apps/kwebkitpart
@dirrm share/apps/choqok_searchaction
@dirrm share/apps/choqok_quickfilter
@dirrm share/apps/choqok_nowlistening
@dirrm share/apps/choqok_filter
@dirrm share/apps/choqok/images