Update to 1.3.6
This commit is contained in:
parent
28a0ed564b
commit
2137f528bf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=131502
5 changed files with 35 additions and 29 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libgdamm
|
||||
PORTVERSION= 1.3.0
|
||||
PORTREVISION= 6
|
||||
PORTVERSION= 1.3.6
|
||||
CATEGORIES= databases gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.3
|
||||
|
@ -16,15 +15,25 @@ DIST_SUBDIR= gnome2
|
|||
MAINTAINER= bland@FreeBSD.org
|
||||
COMMENT= C++ wrapper for libgda2 library
|
||||
|
||||
LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2
|
||||
LIB_DEPENDS= glibmm-2.4:${PORTSDIR}/devel/glibmm
|
||||
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_GCC= 3.4
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack libgda2
|
||||
USE_INC_LIBTOOL_VER= 13
|
||||
USE_INC_LIBTOOL_VER= 15
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ARGS= --enable-static
|
||||
|
||||
patch-autotools:
|
||||
@(cd ${PATCH_WRKSRC}; \
|
||||
for file in ${LIBTOOLFILES}; do \
|
||||
${CP} $$file $$file.tmp; \
|
||||
${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
|
||||
$$file.tmp > $$file; \
|
||||
${RM} $$file.tmp; \
|
||||
done);
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (gnome2/libgdamm-1.3.0.tar.bz2) = 3bda28b19399db546a52ec45c1470008
|
||||
SIZE (gnome2/libgdamm-1.3.0.tar.bz2) = 236546
|
||||
MD5 (gnome2/libgdamm-1.3.6.tar.bz2) = 8a44124b4249da02f287379edad4a1cb
|
||||
SIZE (gnome2/libgdamm-1.3.6.tar.bz2) = 260666
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- configure.orig Wed May 21 15:52:43 2003
|
||||
+++ configure Wed May 21 15:53:07 2003
|
||||
@@ -7854,6 +7854,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
|
@ -1,12 +0,0 @@
|
|||
--- libgda/libgdamm-2.0.pc.in.orig Fri Apr 19 18:12:17 2002
|
||||
+++ libgda/libgdamm-2.0.pc.in Wed Nov 5 09:49:04 2003
|
||||
@@ -5,7 +5,7 @@
|
||||
|
||||
Name: GTKmm
|
||||
Description: C++ wrapper for libgda
|
||||
-Requires: gtkmm-2.0 >= 1.3.1 libgda-2.0 >= 0.8.106
|
||||
+Requires: gtkmm-2.0 >= 1.3.1 libgda >= 0.8.106
|
||||
Version: @VERSION@
|
||||
-Libs: -L${libdir} -ldamm-1.3
|
||||
+Libs: -L${libdir} -lgdamm-1.3
|
||||
Cflags: -I${includedir}/libgdamm-2.0 -I${libdir}/libgdamm-2.0/include
|
|
@ -1,19 +1,38 @@
|
|||
include/libgdamm-2.0/libgdamm.h
|
||||
include/libgdamm-2.0/libgdamm/client.h
|
||||
include/libgdamm-2.0/libgdamm/command.h
|
||||
include/libgdamm-2.0/libgdamm/config.h
|
||||
include/libgdamm-2.0/libgdamm/connection.h
|
||||
include/libgdamm-2.0/libgdamm/datamodel.h
|
||||
include/libgdamm-2.0/libgdamm/datasourceinfo.h
|
||||
include/libgdamm-2.0/libgdamm/error.h
|
||||
include/libgdamm-2.0/libgdamm/fieldattributes.h
|
||||
include/libgdamm-2.0/libgdamm/init.h
|
||||
include/libgdamm-2.0/libgdamm/parameter.h
|
||||
include/libgdamm-2.0/libgdamm/parameterlist.h
|
||||
include/libgdamm-2.0/libgdamm/private/client_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/command_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/connection_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/datamodel_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/datasourceinfo_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/error_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/fieldattributes_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/parameter_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/parameterlist_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/providerinfo_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/row_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/serverprovider_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/transaction_p.h
|
||||
include/libgdamm-2.0/libgdamm/private/value_p.h
|
||||
include/libgdamm-2.0/libgdamm/providerinfo.h
|
||||
include/libgdamm-2.0/libgdamm/row.h
|
||||
include/libgdamm-2.0/libgdamm/serverprovider.h
|
||||
include/libgdamm-2.0/libgdamm/transaction.h
|
||||
include/libgdamm-2.0/libgdamm/value.h
|
||||
include/libgdamm-2.0/libgdamm/wrap_init.h
|
||||
lib/libgdamm-1.3.a
|
||||
lib/libgdamm-1.3.so
|
||||
lib/libgdamm-1.3.so.1
|
||||
lib/libgdamm-1.3.so.7
|
||||
lib/libgdamm-2.0/include/libgdammconfig.h
|
||||
lib/libgdamm-2.0/proc/m4/convert.m4
|
||||
lib/libgdamm-2.0/proc/m4/convert_libgdamm.m4
|
||||
|
|
Loading…
Reference in a new issue