Library providing a source-level compatibility layer to aid porting

programs that use OpenSSL to use the NSS instead.

WWW: http://rcritten.fedorapeople.org/nss_compat_ossl.html
This commit is contained in:
Baptiste Daroussin 2014-11-01 19:43:41 +00:00
parent dc71fc4640
commit 213ffde6a0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=372033
6 changed files with 54 additions and 0 deletions

View file

@ -347,6 +347,7 @@
SUBDIR += nmap
SUBDIR += nmapsi4
SUBDIR += nss
SUBDIR += nss_compat_ossl
SUBDIR += oath-toolkit
SUBDIR += obfsclient
SUBDIR += obfsproxy

View file

@ -0,0 +1,19 @@
# $FreeBSD$
PORTNAME= nss_compat_ossl
PORTVERSION= 0.9.6
MASTER_SITES= http://rcritten.fedorapeople.org/
CATEGORIES= security devel
MAINTAINER= bapt@FreeBSD.org
COMMENT= Source-level compatibility library for OpenSSL to NSS porting
GNU_CONFIGURE= yes
USES= pkgconfig libtool
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
BUILD_DEPENDS= ${LOCALBASE}/lib/nss/libssl3.so:${PORTSDIR}/security/nss
RUN_DEPENDS= ${LOCALBASE}/lib/nss/libssl3.so:${PORTSDIR}/security/nss
LIB_DEPENDS= libnspr4.so:${PORTSDIR}/devel/nspr
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (nss_compat_ossl-0.9.6.tar.gz) = f2528e9f4f9444503d046408f4b9bc4cf7ea3296644016fff6387a79b5e19af9
SIZE (nss_compat_ossl-0.9.6.tar.gz) = 340628

View file

@ -0,0 +1,23 @@
Index: src/ssl.c
===================================================================
--- src/ssl.c (revision 76)
+++ src/ssl.c (working copy)
@@ -1754,12 +1754,13 @@
if (SSL_OptionSet(s, SSL_HANDSHAKE_AS_SERVER, server) != SECSuccess)
goto error;
- if (SSL_OptionSet(s, SSL_ENABLE_SSL2, ssl2) != SECSuccess)
- goto error;
+ /* Don't fail if enabling SSL2 options doesn't succeed as it may
+ * be disabled in NSS. So just ignore the return value from
+ * SSL_OptionSet().
+ */
+ SSL_OptionSet(s, SSL_ENABLE_SSL2, ssl2);
+ SSL_OptionSet(s, SSL_V2_COMPATIBLE_HELLO, ssl2);
- if (SSL_OptionSet(s, SSL_V2_COMPATIBLE_HELLO, ssl2) != SECSuccess)
- goto error;
-
if (SSL_OptionSet(s, SSL_ENABLE_SSL3, ssl3) != SECSuccess)
goto error;

View file

@ -0,0 +1,4 @@
Library providing a source-level compatibility layer to aid porting
programs that use OpenSSL to use the NSS instead.
WWW: http://rcritten.fedorapeople.org/nss_compat_ossl.html

View file

@ -0,0 +1,5 @@
include/nss_compat_ossl/nss_compat_ossl.h
lib/libnss_compat_ossl.a
lib/libnss_compat_ossl.so
lib/libnss_compat_ossl.so.0
lib/libnss_compat_ossl.so.0.0.0