Add new port net-im/qTox:

Qt 5 based Tox client

WWW: https://wiki.tox.im/QTox

PR:		194010 (based on)
Submitted by:	yuri@rawbw.com
This commit is contained in:
Max Brazhnikov 2014-10-19 15:06:48 +00:00
parent 41cbf34c00
commit 2140fcf6ca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=371182
6 changed files with 70 additions and 0 deletions

View file

@ -126,6 +126,7 @@
SUBDIR += py-xmpppy
SUBDIR += py-xmpppy-irc
SUBDIR += py-xmpppy-yahoo
SUBDIR += qTox
SUBDIR += qq
SUBDIR += qwit
SUBDIR += qwit-devel

34
net-im/qTox/Makefile Normal file
View file

@ -0,0 +1,34 @@
# Created by: Yuri Victorovich <yuri@rawbw.com>
# $FreeBSD$
PORTNAME= qTox
PORTVERSION= 0.141018
CATEGORIES= net-im
MAINTAINER= yuri@rawbw.com
COMMENT= Qt 5 based Tox client
LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
LIB_DEPENDS= libopencv_highgui.so:${PORTSDIR}/graphics/opencv
RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= tux3
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= bf35c5e
USE_QT5= core gui network opengl xml widgets buildtools_build
USES= compiler:c++11-lib openal:soft qmake
PLIST_FILES= bin/qtox \
share/applications/qTox.desktop \
share/pixmaps/qtox.png
pre-configure:
${CP} ${WRKSRC}/img/icon.png ${WRKSRC}/img/qtox.png
${REINPLACE_CMD} '/Comment/s,=.*,=${COMMENT},' \
${WRKSRC}/qTox.desktop
.include <bsd.port.mk>

2
net-im/qTox/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (qTox-0.141018.tar.gz) = a05fd310551f3c3f09f23d463990d7727cf345f0f148f1ae359a17f1a0fa204d
SIZE (qTox-0.141018.tar.gz) = 2588328

View file

@ -0,0 +1,12 @@
--- src/widget/emoticonswidget.cpp
+++ src/widget/emoticonswidget.cpp
@@ -25,6 +25,8 @@
#include <QGridLayout>
#include <QMouseEvent>
+#include <math.h>
+
EmoticonsWidget::EmoticonsWidget(QWidget *parent) :
QMenu(parent)
{

View file

@ -0,0 +1,18 @@
--- qtox.pro.orig 2014-10-18 16:44:41 UTC
+++ qtox.pro
@@ -186,3 +186,15 @@
src/cameraworker.cpp \
src/widget/videosurface.cpp \
src/netvideosource.cpp
+
+unix {
+ target.path = $$PREFIX/bin
+
+ desktop.files = qTox.desktop
+ desktop.path = $$PREFIX/share/applications
+
+ icon.files = img/qtox.png
+ icon.path = $$PREFIX/share/pixmaps
+
+ INSTALLS = target desktop icon
+}

3
net-im/qTox/pkg-descr Normal file
View file

@ -0,0 +1,3 @@
qTox is a graphical user interface for Tox written using Qt 5.
WWW: https://wiki.tox.im/QTox