- Update to 1.7.1
PR: ports/174713 Submitted by: Jens Jahnke <jan0sch@gmx.net>
This commit is contained in:
parent
a85a720850
commit
21a1b5ad08
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=313074
5 changed files with 998 additions and 11473 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= jruby
|
||||
PORTVERSION= 1.6.6
|
||||
PORTVERSION= 1.7.1
|
||||
CATEGORIES= lang ruby java
|
||||
MASTER_SITES= http://jruby.org.s3.amazonaws.com/downloads/${PORTVERSION}/
|
||||
DISTNAME= ${PORTNAME}-bin-${PORTVERSION}
|
||||
|
@ -62,9 +62,6 @@ do-install:
|
|||
@cd ${WRKSRC}/lib \
|
||||
&& ${FIND} . -type d -exec ${MKDIR} ${JRUBY_HOME}/lib/{} \; \
|
||||
&& ${FIND} . -type f -exec ${INSTALL_DATA} {} ${JRUBY_HOME}/lib/{} \;
|
||||
@cd ${WRKSRC}/share \
|
||||
&& ${FIND} . -type d -exec ${MKDIR} ${JRUBY_HOME}/share/{} \; \
|
||||
&& ${FIND} . -type f -exec ${INSTALL_DATA} {} ${JRUBY_HOME}/share/{} \;
|
||||
|
||||
@${ECHO_MSG} " [ DONE ]"
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (jruby-bin-1.6.6.tar.gz) = 1ef255ec73b80474602029a61f84062876873065c0f3398c30bc04ddd14aa34f
|
||||
SIZE (jruby-bin-1.6.6.tar.gz) = 15452601
|
||||
SHA256 (jruby-bin-1.7.1.tar.gz) = 99cda09e0533752f83001c5bb76897d1edf4e58b96603d07e839719087c2a1bc
|
||||
SIZE (jruby-bin-1.7.1.tar.gz) = 17160215
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- ./bin/jruby.old 2008-04-23 11:36:44.368716680 +0800
|
||||
+++ ./bin/jruby 2008-04-23 11:40:04.632441243 +0800
|
||||
@@ -37,6 +37,9 @@
|
||||
JRUBY_HOME_1=`dirname "$PRG"` # the ./bin dir
|
||||
JRUBY_HOME=`dirname "$JRUBY_HOME_1"` # the . dir
|
||||
|
||||
+# Set JAVA_HOME to the value the port was built with
|
||||
+JAVA_HOME=%%JAVA_HOME%%
|
||||
+
|
||||
if [ -z "$JRUBY_OPTS" ] ; then
|
||||
JRUBY_OPTS=""
|
||||
fi
|
|
@ -1,24 +0,0 @@
|
|||
--- bin/jruby.orig 2010-12-04 01:58:22.000000000 +0900
|
||||
+++ bin/jruby 2010-12-30 06:00:45.000000000 +0900
|
||||
@@ -28,15 +28,14 @@
|
||||
while [ -h "$PRG" ] ; do
|
||||
ls=`ls -ld "$PRG"`
|
||||
link=`expr "$ls" : '.*-> \(.*\)$'`
|
||||
- if expr "$link" : '.*/.*' > /dev/null; then
|
||||
- if expr "$link" : '/' > /dev/null; then
|
||||
+ case "$link" in
|
||||
+ /*)
|
||||
PRG="$link"
|
||||
- else
|
||||
+ ;;
|
||||
+ *)
|
||||
PRG="`dirname ${PRG}`/${link}"
|
||||
- fi
|
||||
- else
|
||||
- PRG="`dirname $PRG`/$link"
|
||||
- fi
|
||||
+ ;;
|
||||
+ esac
|
||||
done
|
||||
|
||||
JRUBY_HOME_1=`dirname "$PRG"` # the ./bin dir
|
12426
lang/jruby/pkg-plist
12426
lang/jruby/pkg-plist
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue