editors/openoffice-*: Unbreak build on 15.0-CURRENT
Revert "editors/openoffice-*: Unbreak build on 15.0-CURRENT"
Undo the switch to llvm from ports.
This reverts commit f25b169ac8
.
Instead, pass --undefined-version to the linker to avoid the build
breakage on -CURRENT by the change to the default value for this
switch.
Tidy up LIB_DEPENDS.
This commit is contained in:
parent
1d72d71ec4
commit
21c8a01919
6 changed files with 48 additions and 24 deletions
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= apache-openoffice
|
||||
PORTVERSION= ${AOOVERSION}
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= editors java
|
||||
MASTER_SITES= https://dlcdn.apache.org/openoffice/${PORTVERSION}/source/ \
|
||||
https://archive.apache.org/dist/openoffice/${PORTVERSION}/source/ \
|
||||
|
@ -75,7 +75,7 @@ LIB_DEPENDS= \
|
|||
libnspr4.so:devel/nspr \
|
||||
libcurl.so:ftp/curl \
|
||||
libcairo.so:graphics/cairo \
|
||||
libpng.so:graphics/png \
|
||||
libpng16.so:graphics/png \
|
||||
libgraphite.so:graphics/silgraphite \
|
||||
libblas.so:math/blas \
|
||||
libCbcSolver.so:math/cbc \
|
||||
|
@ -114,7 +114,7 @@ USES= autoreconf bison compiler:c++11-lib cpe desktop-file-utils \
|
|||
gettext-runtime gl gmake gnome iconv jpeg perl5 pkgconfig \
|
||||
shared-mime-info ssl tar:bzip2 xorg
|
||||
USE_GL= gl glu
|
||||
USE_GNOME= gdkpixbuf2 gdkpixbuf2xlib gtk20 libxslt libidl glib20
|
||||
USE_GNOME= gdkpixbuf2 gdkpixbuf2xlib gtk20 libxslt glib20
|
||||
USE_JAVA= yes
|
||||
JAVA_BUILD= jdk
|
||||
JAVA_RUN= jdk
|
||||
|
@ -198,14 +198,6 @@ TARGET_ORDER_OVERRIDE= 710:gnome-post-icons
|
|||
WITH= SDK
|
||||
.endif
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1500005
|
||||
# linker error when compiling with llvm 17.0.6 on CURRENT
|
||||
USES+= llvm:max=16
|
||||
CHOSEN_COMPILER_TYPE= clang
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OPSYS} == FreeBSD && ( \
|
||||
|
|
|
@ -1,6 +1,14 @@
|
|||
--- solenv/gbuild/platform/freebsd.mk.orig 2021-04-02 12:58:22 UTC
|
||||
+++ solenv/gbuild/platform/freebsd.mk
|
||||
@@ -188,13 +188,13 @@ $(call gb_Helper_abbreviate_dirs,\
|
||||
@@ -137,6 +137,7 @@ gb_LinkTarget_LDFLAGS += \
|
||||
-Wl,-rpath-link,$(SYSBASE)/lib:$(SYSBASE)/usr/lib \
|
||||
-Wl,-z,combreloc \
|
||||
-Wl,-z,defs \
|
||||
+ -Wl,--undefined-version \
|
||||
$(subst -L../lib , ,$(SOLARLIB)) \
|
||||
${FBSD_GCC_RPATH} \
|
||||
\
|
||||
@@ -188,13 +189,13 @@ $(call gb_Helper_abbreviate_dirs,\
|
||||
mkdir -p $(dir $(1)) && \
|
||||
mkdir -p $(dir $(call gb_CObject_get_dep_target,$(2))) && \
|
||||
$(gb_CC) \
|
||||
|
@ -16,7 +24,7 @@
|
|||
endef
|
||||
|
||||
# convert parametters filesystem root to native notation
|
||||
@@ -212,13 +212,13 @@ $(call gb_Helper_abbreviate_dirs,\
|
||||
@@ -212,13 +213,13 @@ $(call gb_Helper_abbreviate_dirs,\
|
||||
mkdir -p $(dir $(1)) && \
|
||||
mkdir -p $(dir $(call gb_CxxObject_get_dep_target,$(2))) && \
|
||||
$(gb_CXX) \
|
||||
|
|
11
editors/openoffice-4/files/patch-solenv_inc_unxfbsd.mk
Normal file
11
editors/openoffice-4/files/patch-solenv_inc_unxfbsd.mk
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- solenv/inc/unxfbsd.mk.orig 2021-04-02 12:58:22 UTC
|
||||
+++ solenv/inc/unxfbsd.mk
|
||||
@@ -176,7 +176,7 @@ LINKFLAGSRUNPATH_NONE=
|
||||
LINKFLAGSRUNPATH_BOXT=-Wl,-z,origin -Wl,-rpath,\''$$ORIGIN'\'
|
||||
#LINKFLAGSRUNPATH_BOXT=-Wl,-z,origin -Wl,-rpath,\''$$ORIGIN/../../../basis-link/program'\'
|
||||
LINKFLAGSRUNPATH_NONE=
|
||||
-LINKFLAGS=-Wl,-z,combreloc $(LDFLAGS) $(LINKFLAGSDEFS) $(LINKFLAGS_SYSBASE)
|
||||
+LINKFLAGS=-Wl,-z,combreloc -Wl,--undefined-version $(LDFLAGS) $(LINKFLAGSDEFS) $(LINKFLAGS_SYSBASE)
|
||||
|
||||
# linker flags for linking applications
|
||||
LINKFLAGSAPPGUI= -Wl,-export-dynamic -Wl,--noinhibit-exec \
|
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= apache-openoffice
|
||||
PORTVERSION= ${AOOVERSION1}.${AOOVERSION2}.${TIMESTAMP}
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
PORTEPOCH= 4
|
||||
CATEGORIES= editors java
|
||||
MASTER_SITES= https://dist.apache.org/repos/dist/dev/openoffice/${AOOVERSION}-${AOORC}-${TIMESTAMP}/source/ \
|
||||
|
@ -78,7 +78,7 @@ LIB_DEPENDS= \
|
|||
libnspr4.so:devel/nspr \
|
||||
libcurl.so:ftp/curl \
|
||||
libcairo.so:graphics/cairo \
|
||||
libpng.so:graphics/png \
|
||||
libpng16.so:graphics/png \
|
||||
libgraphite.so:graphics/silgraphite \
|
||||
libblas.so:math/blas \
|
||||
libCbcSolver.so:math/cbc \
|
||||
|
@ -117,7 +117,7 @@ USES= autoreconf bison compiler:c++11-lib cpe desktop-file-utils \
|
|||
gettext-runtime gl gmake gnome iconv jpeg perl5 pkgconfig \
|
||||
python:3.9 shared-mime-info ssl tar:${TARTYPE} xorg
|
||||
USE_GL= gl glu
|
||||
USE_GNOME= gdkpixbuf2 gdkpixbuf2xlib gtk20 libxslt libidl glib20
|
||||
USE_GNOME= gdkpixbuf2 gdkpixbuf2xlib gtk20 libxslt glib20
|
||||
USE_JAVA= yes
|
||||
JAVA_BUILD= jdk
|
||||
JAVA_RUN= jdk
|
||||
|
@ -230,14 +230,6 @@ TARGET_ORDER_OVERRIDE= 710:gnome-post-icons
|
|||
WITH= SDK
|
||||
.endif
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1500005
|
||||
# linker error when compiling with llvm 17.0.6 on CURRENT
|
||||
USES+= llvm:max=16
|
||||
CHOSEN_COMPILER_TYPE= clang
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OPSYS} == FreeBSD && ( \
|
||||
|
|
|
@ -0,0 +1,10 @@
|
|||
--- solenv/gbuild/platform/freebsd.mk.orig 2019-09-17 22:55:21 UTC
|
||||
+++ solenv/gbuild/platform/freebsd.mk
|
||||
@@ -125,6 +125,7 @@ gb_LinkTarget_LDFLAGS += \
|
||||
-Wl,-rpath-link,$(SYSBASE)/lib:$(SYSBASE)/usr/lib \
|
||||
-Wl,-z,combreloc \
|
||||
-Wl,-z,defs \
|
||||
+ -Wl,--undefined-version \
|
||||
$(subst -L../lib , ,$(SOLARLIB)) \
|
||||
${FBSD_GCC_RPATH} \
|
||||
\
|
11
editors/openoffice-devel/files/patch-solenv_inc_unxfbsd.mk
Normal file
11
editors/openoffice-devel/files/patch-solenv_inc_unxfbsd.mk
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- solenv/inc/unxfbsd.mk.orig 2019-09-17 22:55:21 UTC
|
||||
+++ solenv/inc/unxfbsd.mk
|
||||
@@ -173,7 +173,7 @@ LINKFLAGSRUNPATH_NONE=
|
||||
LINKFLAGSRUNPATH_BOXT=-Wl,-z,origin -Wl,-rpath,\''$$ORIGIN'\'
|
||||
#LINKFLAGSRUNPATH_BOXT=-Wl,-z,origin -Wl,-rpath,\''$$ORIGIN/../../../basis-link/program'\'
|
||||
LINKFLAGSRUNPATH_NONE=
|
||||
-LINKFLAGS=-Wl,-z,combreloc $(LDFLAGS) $(LINKFLAGSDEFS) $(LINKFLAGS_SYSBASE)
|
||||
+LINKFLAGS=-Wl,-z,combreloc -Wl,--undefined-version $(LDFLAGS) $(LINKFLAGSDEFS) $(LINKFLAGS_SYSBASE)
|
||||
|
||||
# linker flags for linking applications
|
||||
LINKFLAGSAPPGUI= -Wl,-export-dynamic -Wl,--noinhibit-exec \
|
Loading…
Reference in a new issue