- Update MASTER_SITES and WWW: line
- Support CC/CFLAGS properly - Strip binary PR: 123866 Submitted by: Ports Fury
This commit is contained in:
parent
90132438eb
commit
21d58ada23
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=213507
4 changed files with 46 additions and 61 deletions
|
@ -7,22 +7,42 @@
|
|||
|
||||
PORTNAME= tRNAscan-SE
|
||||
PORTVERSION= 1.23
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= biology
|
||||
MASTER_SITES= ftp://ftp.genetics.wustl.edu/pub/eddy/software/
|
||||
MASTER_SITES= ftp://selab.janelia.org/pub/software/tRNAscan-SE/
|
||||
EXTRACT_SUFX= .tar.Z
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= An improved tool for transfer RNA detection
|
||||
|
||||
USE_PERL5= yes
|
||||
MAKE_ARGS= BINDIR="${PREFIX}/bin" \
|
||||
LIBDIR="${DATADIR}" \
|
||||
CC="${CC}" \
|
||||
CFLAGS="${CFLAGS}"
|
||||
|
||||
MAN1= tRNAscan-SE.1
|
||||
|
||||
USE_PERL5= yes
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|tRNAscanSE setpaths|tRNAscanSE|g ; \
|
||||
s|if tRNAscan-SE|if ./tRNAscan-SE|g' ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
.for f in covels-SE coves-SE eufindtRNA trnascan-1.4
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
|
||||
.endfor
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/tRNAscan-SE ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/tRNAscan-SE.man ${MANPREFIX}/man/man1/tRNAscan-SE.1
|
||||
@${MKDIR} ${DATADIR}
|
||||
.for f in TPCsignal Dsignal *.cm gcode.*
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
|
||||
.endfor
|
||||
|
||||
#
|
||||
# have to install before testing as path to data files is hardcoded
|
||||
#
|
||||
post-install:
|
||||
@ cd ${WRKSRC} && $(MAKE) testrun
|
||||
@ cd ${WRKSRC} && $(MAKE) testrun
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/Manual.ps ${DOCSDIR}
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
--- Makefile.orig Sat Oct 7 00:16:41 2000
|
||||
+++ Makefile Thu Dec 20 17:26:37 2001
|
||||
@@ -19,10 +19,11 @@
|
||||
## (this could be 'perl5' or otherwise on some systems)
|
||||
PERLBIN = perl
|
||||
|
||||
+prefix = ${PREFIX}
|
||||
## where you want things installed
|
||||
-BINDIR = $(HOME)/bin
|
||||
-LIBDIR = $(HOME)/lib/tRNAscan-SE
|
||||
-MANDIR = $(HOME)/man
|
||||
+BINDIR = $(prefix)/bin
|
||||
+LIBDIR = $(prefix)/share/tRNAscan-SE
|
||||
+MANDIR = $(prefix)/man
|
||||
|
||||
## NOTE !! If you later manually move the location of
|
||||
## binaries or data files in the BINDIR or LIBDIR directories,
|
||||
@@ -106,7 +107,7 @@
|
||||
|
||||
MPOBJ = mpviterbi.o mp-dbviterbi.o
|
||||
|
||||
-all: $(PROGS) tRNAscanSE setpaths
|
||||
+all: $(PROGS) tRNAscanSE
|
||||
|
||||
covels-SE: $(OBJ) scan_main.o
|
||||
$(CC) $(CFLAGS) $(RFLAGS) -o covels-SE scan_main.o $(OBJ) $(LIBS)
|
||||
@@ -178,7 +179,7 @@
|
||||
@echo ""
|
||||
@rm -f testrun.out
|
||||
@echo "tRNAscan-SE -d -y -o testrun.out Demo/F22B7.fa"
|
||||
- @if tRNAscan-SE -d -y -o testrun.out Demo/F22B7.fa; \
|
||||
+ @if ./tRNAscan-SE -d -y -o testrun.out Demo/F22B7.fa; \
|
||||
then echo ""; \
|
||||
else echo "tRNAscan-SE did NOT complete properly."; fi
|
||||
@if diff testrun.out testrun.ref; \
|
|
@ -7,4 +7,4 @@ the flow of information between them, performing a limited amount of
|
|||
post-processing, and outputting the results in one of several
|
||||
formats.
|
||||
|
||||
WWW: http://www.genetics.wustl.edu/eddy/software/
|
||||
WWW: http://selab.janelia.org/software.html
|
||||
|
|
|
@ -1,26 +1,26 @@
|
|||
bin/tRNAscan-SE
|
||||
bin/eufindtRNA
|
||||
bin/coves-SE
|
||||
bin/covels-SE
|
||||
bin/coves-SE
|
||||
bin/eufindtRNA
|
||||
bin/tRNAscan-SE
|
||||
bin/trnascan-1.4
|
||||
share/tRNAscan-SE/TPCsignal
|
||||
share/tRNAscan-SE/gcode.vertmito
|
||||
share/tRNAscan-SE/gcode.othmito
|
||||
share/tRNAscan-SE/gcode.invmito
|
||||
share/tRNAscan-SE/gcode.echdmito
|
||||
share/tRNAscan-SE/gcode.cilnuc
|
||||
share/tRNAscan-SE/TRNA2ns.cm
|
||||
share/tRNAscan-SE/TRNA2.cm
|
||||
share/tRNAscan-SE/TRNA2-eukns.cm
|
||||
share/tRNAscan-SE/TRNA2-euk.cm
|
||||
share/tRNAscan-SE/TRNA2-bactns.cm
|
||||
share/tRNAscan-SE/TRNA2-bact.cm
|
||||
share/tRNAscan-SE/TRNA2-archns.cm
|
||||
share/tRNAscan-SE/TRNA2-arch.cm
|
||||
share/tRNAscan-SE/PSELC.cm
|
||||
share/tRNAscan-SE/ESELC.cm
|
||||
share/tRNAscan-SE/Dsignal
|
||||
share/tRNAscan-SE/gcode.ystmito
|
||||
@dirrm share/tRNAscan-SE
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Manual.ps
|
||||
%%DATADIR%%/TPCsignal
|
||||
%%DATADIR%%/gcode.vertmito
|
||||
%%DATADIR%%/gcode.othmito
|
||||
%%DATADIR%%/gcode.invmito
|
||||
%%DATADIR%%/gcode.echdmito
|
||||
%%DATADIR%%/gcode.cilnuc
|
||||
%%DATADIR%%/TRNA2ns.cm
|
||||
%%DATADIR%%/TRNA2.cm
|
||||
%%DATADIR%%/TRNA2-eukns.cm
|
||||
%%DATADIR%%/TRNA2-euk.cm
|
||||
%%DATADIR%%/TRNA2-bactns.cm
|
||||
%%DATADIR%%/TRNA2-bact.cm
|
||||
%%DATADIR%%/TRNA2-archns.cm
|
||||
%%DATADIR%%/TRNA2-arch.cm
|
||||
%%DATADIR%%/PSELC.cm
|
||||
%%DATADIR%%/ESELC.cm
|
||||
%%DATADIR%%/Dsignal
|
||||
%%DATADIR%%/gcode.ystmito
|
||||
@dirrm %%DATADIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Reference in a new issue