graphics/art: update 1.21 → 1.21.1; Add CTL option

CTL enables the Color Transformation Language support.

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2024-02-04 00:58:00 -08:00
parent c5e68e0474
commit 21dcc8a1c6
3 changed files with 24 additions and 6 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= art
DISTVERSION= 1.21
DISTVERSION= 1.21.1
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/agriggio/art/downloads/
PKGNAMESUFFIX= -raw-image-editor
@ -38,8 +38,15 @@ EXTRACT_CMD= gtar
LDFLAGS+= -lpthread # otherwise build breaks on some systems: error: undefined symbol: pthread_create
OPTIONS_DEFINE= LTO
OPTIONS_DEFAULT= LTO
OPTIONS_DEFINE= CTL LTO
OPTIONS_DEFAULT= CTL LTO
CTL_DESC= Enable support for the ACES Color Transformation Language
CTL_CMAKE_BOOL= ENABLE_CTL
CTL_LIB_DEPENDS= libIlmCtl.so:graphics/ctl \
libImath.so:math/Imath \
libOpenEXR.so:graphics/openexr \
libpng16.so:graphics/png
LTO_CMAKE_BOOL= WITH_LTO

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1702060744
SHA256 (ART-1.21.tar.xz) = 099dd26ce16e4d3ad86fd6d71bb9b0555f2f332a2a2642afd5dab670a7deba6d
SIZE (ART-1.21.tar.xz) = 18220736
TIMESTAMP = 1707026608
SHA256 (ART-1.21.1.tar.xz) = 2c488e7894b04c27a69db554a6ed885ad27b10c79865de68fdec0f1f002d1e36
SIZE (ART-1.21.1.tar.xz) = 18192028

View File

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig 2024-02-04 08:11:18 UTC
+++ CMakeLists.txt
@@ -644,7 +644,7 @@ if(ENABLE_CTL)
endif()
if(ENABLE_CTL)
- find_path(CTL_INCLUDE_DIR NAMES "CtlInterpeter.h" PATH_SUFFIXES "CTL")
+ find_path(CTL_INCLUDE_DIR NAMES "CtlVersion.h" PATH_SUFFIXES "CTL")
pkg_check_modules(OPENEXR OpenEXR>=3)
#find_path(_openexr_half OpenEXR/half.h)
find_library(_ctl_lib IlmCtl)