Update to LAPACK 3.4.0.
PR: 163906 Submitted by: Eijiro Shibusawa <phd_kimberlite@yahoo.co.jp> Feature safe: yes
This commit is contained in:
parent
95a354ccdf
commit
225176ef6a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=288733
9 changed files with 1826 additions and 90 deletions
|
@ -6,28 +6,33 @@
|
|||
#
|
||||
|
||||
PORTNAME= lapack
|
||||
PORTVERSION= 3.3.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 3.4.0
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= ftp://ftp.netlib.org/lapack/ \
|
||||
http://netlib.org/lapack/ \
|
||||
http://scicomp.ewha.ac.kr/netlib/lapack/ \
|
||||
http://service-spi.web.cern.ch/service-spi/external/tarFiles/
|
||||
DISTFILES= lapack-${PORTVERSION}.tgz manpages-3.2.0.tgz
|
||||
MASTER_SITES= NL
|
||||
MASTER_SITE_SUBDIR= lapack
|
||||
EXTRACT_SUFX= .tgz
|
||||
DIST_SUBDIR= lapack
|
||||
|
||||
MAINTAINER= maho@FreeBSD.org
|
||||
COMMENT= A library of Fortran 77 subroutines for linear algebra
|
||||
|
||||
LICENSE= BSD
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
LIB_DEPENDS= blas.2:${PORTSDIR}/math/blas
|
||||
|
||||
USE_FORTRAN= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
OPTIONS= PROFILE "Build and install profiling libraries" Off
|
||||
OPTIONS= PROFILE "Build and install profiling libraries" Off \
|
||||
DOXYGEN "Install Doxygen to build manpages" Off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_DOXYGEN)
|
||||
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == "sparc64"
|
||||
FPIC= -fPIC
|
||||
.else
|
||||
|
@ -35,7 +40,6 @@ FPIC= -fpic
|
|||
.endif
|
||||
|
||||
MAKE_JOBS_SAFE= yes
|
||||
MANSRC=${WRKDIR}/lapack-3.2.0
|
||||
WRKSRC_SHARED=${WRKSRC}_shared
|
||||
FFLAGS_SHARED=${FPIC}
|
||||
.if defined(WITH_PROFILE)
|
||||
|
@ -54,14 +58,23 @@ PLIST_SUB+= PROFILE="@comment "
|
|||
|
||||
SVERSION=4
|
||||
BLAS?= -L${LOCALBASE}/lib -lblas
|
||||
RANLIB= ${LOCALBASE}/bin/ranlib
|
||||
AR= ${LOCALBASE}/bin/ar
|
||||
|
||||
.if !defined(WITH_DOXYGEN)
|
||||
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} manpages-3.2.0.tgz
|
||||
MANSRC= ${WRKDIR}/lapack-3.2.0/manpages/man/manl
|
||||
.include "${FILESDIR}/manpages"
|
||||
MANL= ${LAPACK_MAN}
|
||||
MANDIR= ${PREFIX}/man/manl
|
||||
.else
|
||||
.include "${FILESDIR}/manpages_doxygen"
|
||||
MANSRC= ${WRKSRC}/DOCS/man/man3
|
||||
MAN3= ${LAPACK_MAN}
|
||||
MANDIR= ${PREFIX}/man/man3
|
||||
.endif
|
||||
|
||||
pre-fetch:
|
||||
@${ECHO} "You can override F77 and FFLAGS on the command line."
|
||||
|
||||
.include "${FILESDIR}/manpages"
|
||||
|
||||
post-patch:
|
||||
@${MV} ${WRKSRC}/INSTALL/make.inc.gfortran ${WRKSRC}/make.inc
|
||||
${REINPLACE_CMD} -Ee \
|
||||
|
@ -98,6 +111,9 @@ do-build:
|
|||
@${ECHO_CMD} "Building profile lapack library"
|
||||
${MAKE} -C ${WRKSRC_PROFILE} ${.MAKEFLAGS} ${_MAKE_JOBS} ARCH="${AR}"
|
||||
.endif
|
||||
.if defined(WITH_DOXYGEN)
|
||||
${MAKE} -C ${WRKSRC} ${.MAKEFLAGS} ${_MAKE_JOBS} ARCH="${AR}" man
|
||||
.endif
|
||||
|
||||
post-build:
|
||||
.for lib in lapack tmglib
|
||||
|
@ -115,10 +131,7 @@ do-install:
|
|||
${INSTALL_DATA} ${WRKSRC_PROFILE}/lib${lib}.a ${PREFIX}/lib/lib${lib}_p.a
|
||||
.endif
|
||||
.endfor
|
||||
${INSTALL_MAN} ${MANSRC}/manpages/man/manl/[a-c]*.l ${PREFIX}/man/manl
|
||||
${INSTALL_MAN} ${MANSRC}/manpages/man/manl/[d-l]*.l ${PREFIX}/man/manl
|
||||
${INSTALL_MAN} ${MANSRC}/manpages/man/manl/[m-s]*.l ${PREFIX}/man/manl
|
||||
${INSTALL_MAN} ${MANSRC}/manpages/man/manl/[t-z]*.l ${PREFIX}/man/manl
|
||||
@(cd ${MANSRC} && ${INSTALL_MAN} ${LAPACK_MAN} ${MANDIR})
|
||||
|
||||
regression-test check test: build
|
||||
@${ECHO_CMD} "Testing static lapack library"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
SHA256 (lapack/lapack-3.3.0.tgz) = bc531761287156e17476395c42664a15373723f54a6f80f192cda47771ec1225
|
||||
SIZE (lapack/lapack-3.3.0.tgz) = 6064824
|
||||
SHA256 (lapack/lapack-3.4.0.tgz) = a7139ef97004d0e3c4c30f1c52d508fd7ae84b5fbaf0dd8e792c167dc306c3e9
|
||||
SIZE (lapack/lapack-3.4.0.tgz) = 6127787
|
||||
SHA256 (lapack/manpages-3.2.0.tgz) = cac234e597f2b9388bf3d3c0549b8a56bf3867c6c554d844bb839039973861f6
|
||||
SIZE (lapack/manpages-3.2.0.tgz) = 1016997
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
MANL= \
|
||||
LAPACK_MAN= \
|
||||
cbdsqr.l \
|
||||
cgbbrd.l \
|
||||
cgbcon.l \
|
||||
|
@ -296,7 +296,6 @@ cspsvx.l \
|
|||
csptrf.l \
|
||||
csptri.l \
|
||||
csptrs.l \
|
||||
csrot.l \
|
||||
csrscl.l \
|
||||
cstedc.l \
|
||||
cstegr.l \
|
||||
|
@ -1236,7 +1235,6 @@ zbcon.l \
|
|||
zbdsqr.l \
|
||||
zcgesv.l \
|
||||
zcposv.l \
|
||||
zdrot.l \
|
||||
zdrscl.l \
|
||||
zgbbrd.l \
|
||||
zgbcon.l \
|
||||
|
|
1694
math/lapack/files/manpages_doxygen
Normal file
1694
math/lapack/files/manpages_doxygen
Normal file
File diff suppressed because it is too large
Load diff
|
@ -1,11 +1,11 @@
|
|||
--- Makefile~ 2008-11-08 02:20:55.000000000 +0900
|
||||
+++ Makefile 2009-04-13 13:05:23.000000000 +0900
|
||||
--- Makefile~ 2011-11-18 23:04:06.000000000 +0900
|
||||
+++ Makefile 2011-11-18 23:04:27.000000000 +0900
|
||||
@@ -6,7 +6,11 @@
|
||||
|
||||
include make.inc
|
||||
|
||||
+.if defined(ENABLE_TESTING) && ${ENABLE_TESTING} == "YES"
|
||||
all: lapack_install lib lapack_testing blas_testing
|
||||
all: lapack_install lib blas_testing lapack_testing
|
||||
+.else
|
||||
+all: lapack_install lib
|
||||
+.endif
|
||||
|
|
|
@ -1,51 +1,92 @@
|
|||
--- SRC/Makefile.orig 2010-11-04 11:11:45.000000000 +0900
|
||||
+++ SRC/Makefile 2010-12-11 12:46:22.000000000 +0900
|
||||
@@ -123,7 +123,7 @@
|
||||
sormr3.o sormrq.o sormrz.o sormtr.o spbcon.o spbequ.o spbrfs.o \
|
||||
spbstf.o spbsv.o spbsvx.o \
|
||||
spbtf2.o spbtrf.o spbtrs.o spocon.o spoequ.o sporfs.o sposv.o \
|
||||
- sposvx.o spotf2.o spotrf.o spotri.o spstrf.o spstf2.o \
|
||||
+ sposvx.o spotf2.o spotri.o spstrf.o spstf2.o \
|
||||
sppcon.o sppequ.o \
|
||||
spprfs.o sppsv.o sppsvx.o spptrf.o spptri.o spptrs.o sptcon.o \
|
||||
spteqr.o sptrfs.o sptsv.o sptsvx.o spttrs.o sptts2.o srscl.o \
|
||||
@@ -164,7 +164,7 @@
|
||||
cgels.o cgelsd.o cgelss.o cgelsx.o cgelsy.o cgeql2.o cgeqlf.o cgeqp3.o \
|
||||
cgeqpf.o cgeqr2.o cgeqr2p.o cgeqrf.o cgeqrfp.o cgerfs.o \
|
||||
cgerq2.o cgerqf.o cgesc2.o cgesdd.o cgesv.o cgesvd.o \
|
||||
- cgesvx.o cgetc2.o cgetf2.o cgetrf.o cgetri.o cgetrs.o \
|
||||
+ cgesvx.o cgetc2.o cgetf2.o cgetri.o \
|
||||
cggbak.o cggbal.o cgges.o cggesx.o cggev.o cggevx.o cggglm.o \
|
||||
cgghrd.o cgglse.o cggqrf.o cggrqf.o \
|
||||
cggsvd.o cggsvp.o \
|
||||
@@ -194,7 +194,7 @@
|
||||
claswp.o clasyf.o clatbs.o clatdf.o clatps.o clatrd.o clatrs.o clatrz.o \
|
||||
clatzm.o clauu2.o clauum.o cpbcon.o cpbequ.o cpbrfs.o cpbstf.o cpbsv.o \
|
||||
cpbsvx.o cpbtf2.o cpbtrf.o cpbtrs.o cpocon.o cpoequ.o cporfs.o \
|
||||
- cposv.o cposvx.o cpotf2.o cpotrf.o cpotri.o cpotrs.o cpstrf.o cpstf2.o \
|
||||
+ cposv.o cposvx.o cpotf2.o cpotri.o cpstrf.o cpstf2.o \
|
||||
cppcon.o cppequ.o cpprfs.o cppsv.o cppsvx.o cpptrf.o cpptri.o cpptrs.o \
|
||||
cptcon.o cpteqr.o cptrfs.o cptsv.o cptsvx.o cpttrf.o cpttrs.o cptts2.o \
|
||||
crot.o cspcon.o cspmv.o cspr.o csprfs.o cspsv.o \
|
||||
@@ -371,9 +371,9 @@
|
||||
--- SRC/Makefile~ 2011-11-18 23:21:16.000000000 +0900
|
||||
+++ SRC/Makefile 2011-11-18 23:22:26.000000000 +0900
|
||||
@@ -154,7 +154,7 @@
|
||||
|
||||
all: ../$(LAPACKLIB)
|
||||
DSLASRC = spotrs.o sgetrs.o spotrf.o sgetrf.o
|
||||
|
||||
-ifdef USEXBLAS
|
||||
+.ifdef USEXBLAS
|
||||
ALLXOBJ=$(SXLASRC) $(DXLASRC) $(CXLASRC) $(ZXLASRC) $(ALLXAUX)
|
||||
SXLASRC = sgesvxx.o sgerfsx.o sla_gerfsx_extended.o sla_geamv.o \
|
||||
sla_gercond.o sla_gerpvgrw.o ssysvxx.o ssyrfsx.o \
|
||||
sla_syrfsx_extended.o sla_syamv.o sla_syrcond.o sla_syrpvgrw.o \
|
||||
@@ -162,7 +162,7 @@
|
||||
sla_porpvgrw.o sgbsvxx.o sgbrfsx.o sla_gbrfsx_extended.o \
|
||||
sla_gbamv.o sla_gbrcond.o sla_gbrpvgrw.o sla_lin_berr.o slarscl2.o \
|
||||
slascl2.o sla_wwaddw.o
|
||||
-endif
|
||||
+.endif
|
||||
|
||||
ALLOBJ=$(SLASRC) $(DLASRC) $(DSLASRC) $(CLASRC) $(ZLASRC) $(ZCLASRC) \
|
||||
$(SCLAUX) $(DZLAUX) $(ALLAUX)
|
||||
@@ -409,13 +409,13 @@
|
||||
$(CLASRC): $(FRC)
|
||||
$(DLASRC): $(FRC)
|
||||
$(ZLASRC): $(FRC)
|
||||
CLASRC = \
|
||||
cbdsqr.o cgbbrd.o cgbcon.o cgbequ.o cgbrfs.o cgbsv.o cgbsvx.o \
|
||||
@@ -226,7 +226,7 @@
|
||||
cgeqrt.o cgeqrt2.o cgeqrt3.o cgemqrt.o \
|
||||
ctpqrt.o ctpqrt2.o ctpmqrt.o ctprfb.o
|
||||
|
||||
-ifdef USEXBLAS
|
||||
+.ifdef USEXBLAS
|
||||
CXLASRC = cgesvxx.o cgerfsx.o cla_gerfsx_extended.o cla_geamv.o \
|
||||
cla_gercond_c.o cla_gercond_x.o cla_gerpvgrw.o \
|
||||
csysvxx.o csyrfsx.o cla_syrfsx_extended.o cla_syamv.o \
|
||||
@@ -238,7 +238,7 @@
|
||||
chesvxx.o cherfsx.o cla_herfsx_extended.o cla_heamv.o \
|
||||
cla_hercond_c.o cla_hercond_x.o cla_herpvgrw.o \
|
||||
cla_lin_berr.o clarscl2.o clascl2.o cla_wwaddw.o
|
||||
-endif
|
||||
+.endif
|
||||
|
||||
ZCLASRC = cpotrs.o cgetrs.o cpotrf.o cgetrf.o
|
||||
|
||||
@@ -302,7 +302,7 @@
|
||||
dgeqrt.o dgeqrt2.o dgeqrt3.o dgemqrt.o \
|
||||
dtpqrt.o dtpqrt2.o dtpmqrt.o dtprfb.o
|
||||
|
||||
-ifdef USEXBLAS
|
||||
+.ifdef USEXBLAS
|
||||
DXLASRC = dgesvxx.o dgerfsx.o dla_gerfsx_extended.o dla_geamv.o \
|
||||
dla_gercond.o dla_gerpvgrw.o dsysvxx.o dsyrfsx.o \
|
||||
dla_syrfsx_extended.o dla_syamv.o dla_syrcond.o dla_syrpvgrw.o \
|
||||
@@ -310,7 +310,7 @@
|
||||
dla_porpvgrw.o dgbsvxx.o dgbrfsx.o dla_gbrfsx_extended.o \
|
||||
dla_gbamv.o dla_gbrcond.o dla_gbrpvgrw.o dla_lin_berr.o dlarscl2.o \
|
||||
dlascl2.o dla_wwaddw.o
|
||||
-endif
|
||||
+.endif
|
||||
|
||||
ZLASRC = \
|
||||
zbdsqr.o zgbbrd.o zgbcon.o zgbequ.o zgbrfs.o zgbsv.o zgbsvx.o \
|
||||
@@ -379,7 +379,7 @@
|
||||
zgeqrt.o zgeqrt2.o zgeqrt3.o zgemqrt.o \
|
||||
ztpqrt.o ztpqrt2.o ztpmqrt.o ztprfb.o
|
||||
|
||||
-ifdef USEXBLAS
|
||||
+.ifdef USEXBLAS
|
||||
ZXLASRC = zgesvxx.o zgerfsx.o zla_gerfsx_extended.o zla_geamv.o \
|
||||
zla_gercond_c.o zla_gercond_x.o zla_gerpvgrw.o zsysvxx.o zsyrfsx.o \
|
||||
zla_syrfsx_extended.o zla_syamv.o zla_syrcond_c.o zla_syrcond_x.o \
|
||||
@@ -389,14 +389,14 @@
|
||||
zla_gbrpvgrw.o zhesvxx.o zherfsx.o zla_herfsx_extended.o \
|
||||
zla_heamv.o zla_hercond_c.o zla_hercond_x.o zla_herpvgrw.o \
|
||||
zla_lin_berr.o zlarscl2.o zlascl2.o zla_wwaddw.o
|
||||
-endif
|
||||
+.endif
|
||||
|
||||
ALLOBJ = $(SLASRC) $(DLASRC) $(DSLASRC) $(CLASRC) $(ZLASRC) $(ZCLASRC) \
|
||||
$(SCLAUX) $(DZLAUX) $(ALLAUX)
|
||||
|
||||
-ifdef USEXBLAS
|
||||
+.ifdef USEXBLAS
|
||||
ALLXOBJ = $(SXLASRC) $(DXLASRC) $(CXLASRC) $(ZXLASRC)
|
||||
-endif
|
||||
+.endif
|
||||
|
||||
all: ../$(LAPACKLIB)
|
||||
|
||||
@@ -433,12 +433,12 @@
|
||||
$(ZLASRC): $(FRC)
|
||||
$(ZCLASRC): $(FRC)
|
||||
$(DSLASRC): $(FRC)
|
||||
-ifdef USEXBLAS
|
||||
+.ifdef USEXBLAS
|
||||
$(ALLXAUX): $(FRC)
|
||||
$(SXLASRC): $(FRC)
|
||||
$(CXLASRC): $(FRC)
|
||||
$(DXLASRC): $(FRC)
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- TESTING/LIN/Makefile.orig 2010-06-18 18:48:07.000000000 -0400
|
||||
+++ TESTING/LIN/Makefile 2010-08-29 10:55:41.000000000 -0400
|
||||
--- TESTING/LIN/Makefile~ 2011-11-01 07:21:11.000000000 +0900
|
||||
+++ TESTING/LIN/Makefile 2011-11-18 23:32:05.000000000 +0900
|
||||
@@ -34,11 +34,6 @@
|
||||
#
|
||||
#######################################################################
|
||||
|
@ -81,11 +81,11 @@
|
|||
DSLINTST = dchkab.o \
|
||||
ddrvab.o ddrvac.o derrab.o derrac.o dget08.o \
|
||||
@@ -250,7 +245,7 @@
|
||||
../../$(TMGLIB) ../../$(LAPACKLIB) $(XBLASLIB) $(BLASLIB) -o xlintstc && mv xlintstc $@
|
||||
../../$(TMGLIB) ../../$(LAPACKLIB) $(XBLASLIB) $(BLASLIB) -o $@
|
||||
|
||||
../xlintstd : $(ALINTST) $(DLINTST) $(DZLNTST)
|
||||
xlintstd : $(ALINTST) $(DLINTST) $(DZLNTST) ../../$(LAPACKLIB)
|
||||
- $(LOADER) $(LOADOPTS) $^ \
|
||||
+ $(LOADER) $(LOADOPTS) $(ALINTST) $(DLINTST) $(DZLNTST) \
|
||||
../../$(TMGLIB) ../../$(LAPACKLIB) $(XBLASLIB) $(BLASLIB) -o xlintstd && mv xlintstd $@
|
||||
../../$(TMGLIB) ../../$(LAPACKLIB) $(XBLASLIB) $(BLASLIB) -o $@
|
||||
|
||||
../xlintstz : $(ALINTST) $(ZLINTST) $(DZLNTST)
|
||||
xlintstz : $(ALINTST) $(ZLINTST) $(DZLNTST) ../../$(LAPACKLIB)
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- TESTING/Makefile.orig 2010-08-29 10:57:23.000000000 -0400
|
||||
+++ TESTING/Makefile 2010-08-29 10:57:43.000000000 -0400
|
||||
--- TESTING/Makefile~ 2011-11-18 23:12:35.000000000 +0900
|
||||
+++ TESTING/Makefile 2011-11-18 23:12:48.000000000 +0900
|
||||
@@ -37,11 +37,6 @@
|
||||
|
||||
include ../make.inc
|
||||
|
|
|
@ -1,14 +1,6 @@
|
|||
--- INSTALL/make.inc.gfortran.orig 2009-04-16 14:10:16.000000000 -0400
|
||||
+++ INSTALL/make.inc.gfortran 2010-08-29 10:41:02.000000000 -0400
|
||||
@@ -8,7 +8,6 @@
|
||||
#
|
||||
# The machine (platform) identifier to append to the library names
|
||||
#
|
||||
-PLAT = _LINUX
|
||||
#
|
||||
# Modify the FORTRAN and OPTS definitions to refer to the
|
||||
# compiler and desired compiler options for your machine. NOOPT
|
||||
@@ -16,12 +15,12 @@
|
||||
--- INSTALL/make.inc.gfortran~ 2011-11-18 23:13:49.000000000 +0900
|
||||
+++ INSTALL/make.inc.gfortran 2011-11-18 23:15:52.000000000 +0900
|
||||
@@ -12,12 +12,12 @@
|
||||
# selected. Define LOADER and LOADOPTS to refer to the loader and
|
||||
# desired load options for your machine.
|
||||
#
|
||||
|
@ -26,7 +18,7 @@
|
|||
#
|
||||
# Timer for the SECOND and DSECND routines
|
||||
#
|
||||
@@ -40,9 +39,8 @@
|
||||
@@ -36,9 +36,8 @@
|
||||
# The archiver and the flag(s) to use when building archive (library)
|
||||
# If you system has no ranlib, set RANLIB = echo.
|
||||
#
|
||||
|
@ -37,15 +29,13 @@
|
|||
#
|
||||
# Location of the extended-precision BLAS (XBLAS) Fortran library
|
||||
# used for building and testing extended-precision routines. The
|
||||
@@ -57,8 +55,8 @@
|
||||
@@ -53,6 +52,6 @@
|
||||
# machine-specific, optimized BLAS library should be used whenever
|
||||
# possible.)
|
||||
#
|
||||
-BLASLIB = ../../blas$(PLAT).a
|
||||
-LAPACKLIB = lapack$(PLAT).a
|
||||
-TMGLIB = tmglib$(PLAT).a
|
||||
-BLASLIB = ../../librefblas.a
|
||||
-LAPACKLIB = liblapack.a
|
||||
-TMGLIB = libtmglib.a
|
||||
+BLASLIB = %%BLAS%%
|
||||
+LAPACKLIB = liblapack$(PLAT).a
|
||||
+TMGLIB = libtmglib$(PLAT).a
|
||||
EIGSRCLIB = eigsrc$(PLAT).a
|
||||
LINSRCLIB = linsrc$(PLAT).a
|
||||
|
|
Loading…
Reference in a new issue