mpop is a small, fast, and portable POP3 client. Its features include
header-based email filtering (filter junk mail before downloading it), delivery to mbox files, maildir folders, or a mail delivery agent, a very fast POP3 implementation, many authentication methods, and good support for TLS/SSL. WWW: http://mpop.sourceforge.net PR: ports/139887 Submitted by: Sylvio Cesar <scjamorim@bsd.com.br> Approved by: miwi, jadawin(mentors,implicit)
This commit is contained in:
parent
0afc0b5d32
commit
225601ddec
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=243313
6 changed files with 97 additions and 0 deletions
|
@ -286,6 +286,7 @@
|
|||
SUBDIR += mmr
|
||||
SUBDIR += movemail
|
||||
SUBDIR += moztraybiff
|
||||
SUBDIR += mpop
|
||||
SUBDIR += mreport
|
||||
SUBDIR += msgconvert
|
||||
SUBDIR += msmtp
|
||||
|
|
60
mail/mpop/Makefile
Normal file
60
mail/mpop/Makefile
Normal file
|
@ -0,0 +1,60 @@
|
|||
# New ports collection makefile for: mpop
|
||||
# Date created: 2009-10-24
|
||||
# Whom: Sylvio Cesar <scjamorim@bsd.com.br>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mpop
|
||||
PORTVERSION= 1.0.19
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= scjamorim@bsd.com.br
|
||||
COMMENT= MPOP is a small and fast POP3 client
|
||||
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
MAN1= mpop.1
|
||||
INFO= mpop
|
||||
|
||||
.if defined(WITH_GNUTLS)
|
||||
LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
|
||||
CONFIGURE_ARGS+= --with-ssl=gnutls
|
||||
.elif defined(WITH_OPENSSL)
|
||||
USE_OPENSSL= yes
|
||||
CONFIGURE_ARGS+= --with-ssl=openssl
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-ssl
|
||||
.endif
|
||||
|
||||
.if defined(WITH_GNUTLS) || defined(WITH_OPENSSL)
|
||||
RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
|
||||
.endif
|
||||
|
||||
.if defined(WITH_GSASL)
|
||||
LIB_DEPENDS+= gsasl.13:${PORTSDIR}/security/gsasl
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-gsasl
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_IDN)
|
||||
LIB_DEPENDS+= idn.16:${PORTSDIR}/dns/libidn
|
||||
CONFIGURE_ARGS+= --with-libidn
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-libidn
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_NLS)
|
||||
USE_GETTEXT= yes
|
||||
CONFIGURE_ARGS+= --enable-nls
|
||||
PLIST_SUB= NLS=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-nls
|
||||
PLIST_SUB= NLS="@comment "
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
3
mail/mpop/distinfo
Normal file
3
mail/mpop/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (mpop-1.0.19.tar.bz2) = 40a48d486121a15075faee944a7b8fb7
|
||||
SHA256 (mpop-1.0.19.tar.bz2) = 3151f3d0fb34f0f93bcd139ab87ec6c4ba23b3d0768a88c310fe0838c41b6d01
|
||||
SIZE (mpop-1.0.19.tar.bz2) = 839096
|
23
mail/mpop/files/patch-doc-mpop.1
Normal file
23
mail/mpop/files/patch-doc-mpop.1
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- doc/mpop.1.orig 2009-10-05 16:47:15.000000000 -0300
|
||||
+++ doc/mpop.1 2009-10-24 12:18:19.000000000 -0200
|
||||
@@ -333,6 +333,11 @@
|
||||
.br
|
||||
On Debian based systems, you can install the \fBca\-certificates\fP package and
|
||||
use the file \fB/etc/ssl/certs/ca\-certificates.crt\fP.
|
||||
++.br
|
||||
+On FreeBSD based systems, you can install the \fBsecurity/ca_root_nss\fP port and
|
||||
++use the file \fB/usr/local/share/certs/ca-root-nss.crt\fP. Please note that if
|
||||
++you are installing mpop from ports with OpenSSL or gnutls support,
|
||||
++the \fBsecurity/ca_root_nss\fP port will be installed automaticly.
|
||||
.br
|
||||
An empty argument disables this feature.
|
||||
.IP "tls_crl_file [\fIfile\fP]"
|
||||
@@ -457,7 +462,7 @@
|
||||
.br
|
||||
# Enable full TLS certificate checks.
|
||||
.br
|
||||
-tls_trust_file /etc/ssl/certs/ca\-certificates.crt
|
||||
+tls_trust_file /usr/local/share/certs/ca-root-nss.crt
|
||||
.br
|
||||
# Use the POP3-over-TLS variant instead of the STARTTLS variant.
|
||||
.br
|
7
mail/mpop/pkg-descr
Normal file
7
mail/mpop/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
mpop is a small, fast, and portable POP3 client. Its features include
|
||||
header-based email filtering (filter junk mail before downloading it),
|
||||
delivery to mbox files, maildir folders, or a mail delivery agent,
|
||||
a very fast POP3 implementation, many authentication methods,
|
||||
and good support for TLS/SSL.
|
||||
|
||||
WWW: http://mpop.sourceforge.net
|
3
mail/mpop/pkg-plist
Normal file
3
mail/mpop/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/mpop
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/mpop.mo
|
||||
%%NLS%%share/locale/es/LC_MESSAGES/mpop.mo
|
Loading…
Reference in a new issue