net-mgmt/netdata: Update port to 1.10.0

The local patch for PR#3276 at GH also is merged upstream.

Sponsored by:	Netzkommune GmbH
This commit is contained in:
Mahdi Mokhtari 2018-03-28 12:00:31 +00:00
parent 02ce0f0ee0
commit 225d8e46b5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=465801
4 changed files with 37 additions and 305 deletions

View file

@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= netdata
PORTVERSION= 1.9.0
PORTVERSION= 1.10.0
DISTVERSIONPREFIX=v
PORTREVISION= 1
CATEGORIES= net-mgmt
MAINTAINER= mmokhi@FreeBSD.org

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1513697463
SHA256 (firehol-netdata-v1.9.0_GH0.tar.gz) = 300289b39105167eae4616943c7c511d68a54bdd3541a845932e9f773cbf4213
SIZE (firehol-netdata-v1.9.0_GH0.tar.gz) = 2483847
TIMESTAMP = 1522238204
SHA256 (firehol-netdata-v1.10.0_GH0.tar.gz) = 645b1cb60a779132c816d1bad377574884992c214bbb0f7a483649878884dbab
SIZE (firehol-netdata-v1.10.0_GH0.tar.gz) = 2611773

View file

@ -1,295 +0,0 @@
--- installer/functions.sh.orig
+++ installer/functions.sh
@@ -161,6 +161,22 @@ pidof() {
# -----------------------------------------------------------------------------
+export SYSTEM_CPUS=1
+portable_find_processors() {
+ if [ -f "/proc/cpuinfo" ]
+ then
+ # linux
+ SYSTEM_CPUS=$(grep -c ^processor /proc/cpuinfo)
+ else
+ # freebsd
+ SYSTEM_CPUS=$(sysctl hw.ncpu 2>/dev/null | grep ^hw.ncpu | cut -d ' ' -f 2)
+ fi
+ [ -z "${SYSTEM_CPUS}" -o $(( SYSTEM_CPUS )) -lt 1 ] && SYSTEM_CPUS=1
+}
+portable_find_processors
+
+# -----------------------------------------------------------------------------
+
run_ok() {
printf >&2 "${TPUT_BGGREEN}${TPUT_WHITE}${TPUT_BOLD} OK ${TPUT_RESET} ${*} \n\n"
}
--- makeself/functions.sh.orig
+++ makeself/functions.sh
@@ -8,8 +8,6 @@
[ -z "${NETDATA_MAKESELF_PATH}" ] && export NETDATA_MAKESELF_PATH="$(dirname "${0}")/.."
[ "${NETDATA_MAKESELF_PATH:0:1}" != "/" ] && export NETDATA_MAKESELF_PATH="$(pwd)/${NETDATA_MAKESELF_PATH}"
[ -z "${NETDATA_SOURCE_PATH}" ] && export NETDATA_SOURCE_PATH="${NETDATA_MAKESELF_PATH}/.."
-[ -z "${PROCESSORS}" ] && export PROCESSORS=$(grep -c ^processor /proc/cpuinfo)
-[ -z "${PROCESSORS}" -o $((PROCESSORS)) -lt 1 ] && export PROCESSORS=1
export NULL=
# make sure the path does not end with /
@@ -21,14 +19,7 @@ fi
# find the parent directory
export NETDATA_INSTALL_PARENT="$(dirname "${NETDATA_INSTALL_PATH}")"
-
-# debug
-echo "ME=${0}"
-echo "NETDATA_INSTALL_PARENT=${NETDATA_INSTALL_PARENT}"
-echo "NETDATA_INSTALL_PATH=${NETDATA_INSTALL_PATH}"
-echo "NETDATA_MAKESELF_PATH=${NETDATA_MAKESELF_PATH}"
-echo "NETDATA_SOURCE_PATH=${NETDATA_SOURCE_PATH}"
-echo "PROCESSORS=${PROCESSORS}"
+# -----------------------------------------------------------------------------
# bash strict mode
set -euo pipefail
@@ -58,3 +49,13 @@ fetch() {
# load the functions of the netdata-installer.sh
. "${NETDATA_SOURCE_PATH}/installer/functions.sh"
+
+# -----------------------------------------------------------------------------
+
+# debug
+echo "ME=${0}"
+echo "NETDATA_INSTALL_PARENT=${NETDATA_INSTALL_PARENT}"
+echo "NETDATA_INSTALL_PATH=${NETDATA_INSTALL_PATH}"
+echo "NETDATA_MAKESELF_PATH=${NETDATA_MAKESELF_PATH}"
+echo "NETDATA_SOURCE_PATH=${NETDATA_SOURCE_PATH}"
+echo "PROCESSORS=${SYSTEM_CPUS}"
--- makeself/jobs/50-bash-4.4.install.sh.orig
+++ makeself/jobs/50-bash-4.4.install.sh
@@ -34,7 +34,7 @@ run ./configure \
run make clean
-run make -j${PROCESSORS}
+run make -j${SYSTEM_CPUS}
cat >examples/loadables/Makefile <<EOF
all:
--- makeself/jobs/50-curl-7.53.1.install.sh.orig
+++ makeself/jobs/50-curl-7.53.1.install.sh
@@ -24,7 +24,7 @@ run ./configure \
run sed -i -e "s/curl_LDFLAGS =/curl_LDFLAGS = -all-static/" src/Makefile
run make clean
-run make -j${PROCESSORS}
+run make -j${SYSTEM_CPUS}
run make install
if [ ${NETDATA_BUILD_WITH_DEBUG} -eq 0 ]
--- makeself/jobs/50-fping-4.0.install.sh.orig
+++ makeself/jobs/50-fping-4.0.install.sh
@@ -19,7 +19,7 @@ install:
EOF
run make clean
-run make -j${PROCESSORS}
+run make -j${SYSTEM_CPUS}
run make install
if [ ${NETDATA_BUILD_WITH_DEBUG} -eq 0 ]
--- netdata-installer.sh.orig
+++ netdata-installer.sh
@@ -63,9 +63,6 @@ umask 002
# Be nice on production environments
renice 19 $$ >/dev/null 2>/dev/null
-processors=$(grep -c ^processor /proc/cpuinfo)
-[ $(( processors )) -lt 1 ] && processors=1
-
# you can set CFLAGS before running installer
CFLAGS="${CFLAGS--O2}"
[ "z${CFLAGS}" = "z-O3" ] && CFLAGS="-O2"
@@ -495,7 +492,7 @@ progress "Cleanup compilation directory"
# -----------------------------------------------------------------------------
progress "Compile netdata"
-run make -j${processors} || exit 1
+run make -j${SYSTEM_CPUS} || exit 1
# -----------------------------------------------------------------------------
--- src/apps_plugin.c.orig
+++ src/apps_plugin.c
@@ -715,19 +715,35 @@ static inline int managed_log(struct pid_stat *p, uint32_t log, int status) {
p->log_thrown |= log;
switch(log) {
case PID_LOG_IO:
+ #ifdef __FreeBSD__
+ error("Cannot fetch process %d I/O info (command '%s')", p->pid, p->comm);
+ #else
error("Cannot process %s/proc/%d/io (command '%s')", netdata_configured_host_prefix, p->pid, p->comm);
+ #endif
break;
case PID_LOG_STATM:
+ #ifdef __FreeBSD__
+ error("Cannot fetch process %d memory info (command '%s')", p->pid, p->comm);
+ #else
error("Cannot process %s/proc/%d/statm (command '%s')", netdata_configured_host_prefix, p->pid, p->comm);
+ #endif
break;
case PID_LOG_CMDLINE:
+ #ifdef __FreeBSD__
+ error("Cannot fetch process %d command line (command '%s')", p->pid, p->comm);
+ #else
error("Cannot process %s/proc/%d/cmdline (command '%s')", netdata_configured_host_prefix, p->pid, p->comm);
+ #endif
break;
case PID_LOG_FDS:
+ #ifdef __FreeBSD__
+ error("Cannot fetch process %d files (command '%s')", p->pid, p->comm);
+ #else
error("Cannot process entries in %s/proc/%d/fd (command '%s')", netdata_configured_host_prefix, p->pid, p->comm);
+ #endif
break;
case PID_LOG_STAT:
@@ -955,7 +971,7 @@ static inline int read_proc_pid_stat(struct pid_stat *p, void *ptr) {
pid_incremental_rate(stat, p->utime, (kernel_uint_t)proc_info->ki_rusage.ru_utime.tv_sec * 100 + proc_info->ki_rusage.ru_utime.tv_usec / 10000);
pid_incremental_rate(stat, p->stime, (kernel_uint_t)proc_info->ki_rusage.ru_stime.tv_sec * 100 + proc_info->ki_rusage.ru_stime.tv_usec / 10000);
pid_incremental_rate(stat, p->cutime, (kernel_uint_t)proc_info->ki_rusage_ch.ru_utime.tv_sec * 100 + proc_info->ki_rusage_ch.ru_utime.tv_usec / 10000);
- pid_incremental_rate(stat, p->cstime, (kernel_uint_t)proc_info->ki_rusage_ch.ru_stime.tv_sec * 100 + proc_info->ki_rusage_ch.ru_utime.tv_usec / 10000);
+ pid_incremental_rate(stat, p->cstime, (kernel_uint_t)proc_info->ki_rusage_ch.ru_stime.tv_sec * 100 + proc_info->ki_rusage_ch.ru_stime.tv_usec / 10000);
p->num_threads = proc_info->ki_numthreads;
@@ -2006,8 +2022,8 @@ static int compar_pid(const void *pid1, const void *pid2) {
#endif
static inline int collect_data_for_pid(pid_t pid, void *ptr) {
- if(unlikely(pid < INIT_PID || pid > pid_max)) {
- error("Invalid pid %d read (expected %d to %d). Ignoring process.", pid, INIT_PID, pid_max);
+ if(unlikely(pid < 0 || pid > pid_max)) {
+ error("Invalid pid %d read (expected %d to %d). Ignoring process.", pid, 0, pid_max);
return 0;
}
@@ -2069,28 +2085,46 @@ static int collect_data_for_all_processes(void) {
#ifdef __FreeBSD__
int i, procnum;
- size_t procbase_size;
- static struct kinfo_proc *procbase;
- int mib[3];
+ static size_t procbase_size = 0;
+ static struct kinfo_proc *procbase = NULL;
- mib[0] = CTL_KERN;
- mib[1] = KERN_PROC;
- mib[2] = KERN_PROC_PROC;
- if (unlikely(sysctl(mib, 3, NULL, &procbase_size, NULL, 0))) {
+ size_t new_procbase_size;
+
+ int mib[3] = { CTL_KERN, KERN_PROC, KERN_PROC_PROC };
+ if (unlikely(sysctl(mib, 3, NULL, &new_procbase_size, NULL, 0))) {
error("sysctl error: Can't get processes data size");
return 0;
}
- procbase = reallocz(procbase, procbase_size);
- if (unlikely(sysctl(mib, 3, procbase, &procbase_size, NULL, 0))) {
+
+ // give it some air for processes that may be started
+ // during this little time.
+ new_procbase_size += 100 * sizeof(struct kinfo_proc);
+
+ // increase the buffer if needed
+ if(new_procbase_size > procbase_size) {
+ procbase_size = new_procbase_size;
+ procbase = reallocz(procbase, procbase_size);
+ }
+
+ // sysctl() gets from new_procbase_size the buffer size
+ // and also returns to it the amount of data filled in
+ new_procbase_size = procbase_size;
+
+ // get the processes from the system
+ if (unlikely(sysctl(mib, 3, procbase, &new_procbase_size, NULL, 0))) {
error("sysctl error: Can't get processes data");
return 0;
}
- procnum = procbase_size / sizeof(struct kinfo_proc);
+
+ // based on the amount of data filled in
+ // calculate the number of processes we got
+ procnum = new_procbase_size / sizeof(struct kinfo_proc);
+
#endif
if(all_pids_count) {
-#ifndef __FreeBSD__
+#if (ALL_PIDS_ARE_READ_INSTANTLY == 0)
size_t slc = 0;
#endif
for(p = root_of_pids; p ; p = p->next) {
@@ -2107,7 +2141,7 @@ static int collect_data_for_all_processes(void) {
#if (ALL_PIDS_ARE_READ_INSTANTLY == 0)
if(unlikely(slc != all_pids_count)) {
- error("Internal error: I was thinking I had %zu processes in my arrays, but it seems there are more.", all_pids_count);
+ error("Internal error: I was thinking I had %zu processes in my arrays, but it seems there are %zu.", all_pids_count, slc);
all_pids_count = slc;
}
@@ -2130,7 +2164,7 @@ static int collect_data_for_all_processes(void) {
}
#ifdef __FreeBSD__
- for (i = INIT_PID; i < procnum - INIT_PID; ++i) {
+ for (i = 0 ; i < procnum ; ++i) {
pid_t pid = procbase[i].ki_pid;
collect_data_for_pid(pid, &procbase[i]);
}
@@ -2258,21 +2292,17 @@ static void apply_apps_groups_targets_inheritance(void) {
if(unlikely(!p->sortlist && !p->children_count))
p->sortlist = sortlist++;
- // if this process does not have any children
- // and is not already merged
- // and has a parent
- // and its parent has children
- // and the target of this process and its parent is the same, or the parent does not have a target
- // and its parent is not init
- // then, mark them as merged.
if(unlikely(
- !p->children_count
- && !p->merged
- && p->parent
- && p->parent->children_count
+ !p->children_count // if this process does not have any children
+ && !p->merged // and is not already merged
+ && p->parent // and has a parent
+ && p->parent->children_count // and its parent has children
+ // and the target of this process and its parent is the same,
+ // or the parent does not have a target
&& (p->target == p->parent->target || !p->parent->target)
- && p->ppid != INIT_PID
+ && p->ppid != INIT_PID // and its parent is not init
)) {
+ // mark it as merged
p->parent->children_count--;
p->merged = 1;
@@ -2296,6 +2326,10 @@ static void apply_apps_groups_targets_inheritance(void) {
if(all_pids[INIT_PID])
all_pids[INIT_PID]->target = apps_groups_default_target;
+ // pid 0 goes always to default target
+ if(all_pids[0])
+ all_pids[0]->target = apps_groups_default_target;
+
// give a default target on all top level processes
if(unlikely(debug)) loops++;
for(p = root_of_pids; p ; p = p->next) {

View file

@ -8,6 +8,7 @@
@sample(netdata,netdata,0640) %%ETCDIR%%/charts.d/example.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/charts.d/exim.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/charts.d/hddtemp.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/charts.d/libreswan.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/charts.d/load_average.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/charts.d/mem_apps.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/charts.d/mysql.conf.sample
@ -24,13 +25,17 @@
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/backend.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/beanstalkd.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/bind_rndc.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/btrfs.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/ceph.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/couchdb.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/cpu.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/disks.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/elasticsearch.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/entropy.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/fping.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/fronius.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/haproxy.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/httpcheck.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/ipc.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/ipfs.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/ipmi.conf.sample
@ -45,6 +50,8 @@
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/net.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/netfilter.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/nginx.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/nginx_plus.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/portcheck.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/postgres.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/qos.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/ram.conf.sample
@ -52,6 +59,7 @@
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/retroshare.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/softnet.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/squid.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/stiebeleltron.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/swap.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/tcp_conn.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/health.d/tcp_listen.conf.sample
@ -81,6 +89,7 @@
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/apache.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/beanstalk.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/bind_rndc.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/ceph.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/chrony.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/couchdb.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/cpufreq.conf.sample
@ -95,6 +104,8 @@
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/go_expvar.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/haproxy.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/hddtemp.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/httpcheck.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/icecast.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/ipfs.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/isc_dhcpd.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/mdstat.conf.sample
@ -102,9 +113,12 @@
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/mongodb.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/mysql.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/nginx.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/nginx_plus.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/nsd.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/ntpd.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/ovpn_status_log.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/phpfpm.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/portcheck.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/postfix.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/postgres.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/powerdns.conf.sample
@ -114,8 +128,10 @@
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/samba.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/sensors.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/smartd_log.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/springboot.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/squid.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/tomcat.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/traefik.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/varnish.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/python.d/web_log.conf.sample
@sample(netdata,netdata,0640) %%ETCDIR%%/statsd.d/example.conf.sample
@ -129,6 +145,7 @@ libexec/netdata/charts.d/cpufreq.chart.sh
libexec/netdata/charts.d/example.chart.sh
libexec/netdata/charts.d/exim.chart.sh
libexec/netdata/charts.d/hddtemp.chart.sh
libexec/netdata/charts.d/libreswan.chart.sh
libexec/netdata/charts.d/load_average.chart.sh
libexec/netdata/charts.d/mem_apps.chart.sh
libexec/netdata/charts.d/mysql.chart.sh
@ -175,6 +192,7 @@ libexec/netdata/python.d/README.md
libexec/netdata/python.d/apache.chart.py
libexec/netdata/python.d/beanstalk.chart.py
libexec/netdata/python.d/bind_rndc.chart.py
libexec/netdata/python.d/ceph.chart.py
libexec/netdata/python.d/chrony.chart.py
libexec/netdata/python.d/couchdb.chart.py
libexec/netdata/python.d/cpufreq.chart.py
@ -190,6 +208,8 @@ libexec/netdata/python.d/freeradius.chart.py
libexec/netdata/python.d/go_expvar.chart.py
libexec/netdata/python.d/haproxy.chart.py
libexec/netdata/python.d/hddtemp.chart.py
libexec/netdata/python.d/httpcheck.chart.py
libexec/netdata/python.d/icecast.chart.py
libexec/netdata/python.d/ipfs.chart.py
libexec/netdata/python.d/isc_dhcpd.chart.py
libexec/netdata/python.d/mdstat.chart.py
@ -197,9 +217,12 @@ libexec/netdata/python.d/memcached.chart.py
libexec/netdata/python.d/mongodb.chart.py
libexec/netdata/python.d/mysql.chart.py
libexec/netdata/python.d/nginx.chart.py
libexec/netdata/python.d/nginx_plus.chart.py
libexec/netdata/python.d/nsd.chart.py
libexec/netdata/python.d/ntpd.chart.py
libexec/netdata/python.d/ovpn_status_log.chart.py
libexec/netdata/python.d/phpfpm.chart.py
libexec/netdata/python.d/portcheck.chart.py
libexec/netdata/python.d/postfix.chart.py
libexec/netdata/python.d/postgres.chart.py
libexec/netdata/python.d/powerdns.chart.py
@ -297,8 +320,10 @@ libexec/netdata/python.d/retroshare.chart.py
libexec/netdata/python.d/samba.chart.py
libexec/netdata/python.d/sensors.chart.py
libexec/netdata/python.d/smartd_log.chart.py
libexec/netdata/python.d/springboot.chart.py
libexec/netdata/python.d/squid.chart.py
libexec/netdata/python.d/tomcat.chart.py
libexec/netdata/python.d/traefik.chart.py
libexec/netdata/python.d/varnish.chart.py
libexec/netdata/python.d/web_log.chart.py
sbin/netdata
@ -311,7 +336,7 @@ sbin/netdata
%%DATADIR%%/web/css/bootstrap-slider-10.0.0.min.css
%%DATADIR%%/web/css/bootstrap-theme-3.3.7.min.css
%%DATADIR%%/web/css/bootstrap-toggle-2.2.2.min.css
%%DATADIR%%/web/css/c3-0.4.11.min.css
%%DATADIR%%/web/css/c3-0.4.18.min.css
%%DATADIR%%/web/css/morris-0.5.1.css
%%DATADIR%%/web/dashboard.css
%%DATADIR%%/web/dashboard.html
@ -357,10 +382,12 @@ sbin/netdata
%%DATADIR%%/web/lib/bootstrap-table-1.11.0.min.js
%%DATADIR%%/web/lib/bootstrap-table-export-1.11.0.min.js
%%DATADIR%%/web/lib/bootstrap-toggle-2.2.2.min.js
%%DATADIR%%/web/lib/c3-0.4.11.min.js
%%DATADIR%%/web/lib/d3-3.5.17.min.js
%%DATADIR%%/web/lib/dygraph-combined-dd74404.js
%%DATADIR%%/web/lib/dygraph-smooth-plotter-dd74404.js
%%DATADIR%%/web/lib/c3-0.4.18.min.js
%%DATADIR%%/web/lib/clipboard-polyfill-be05dad.js
%%DATADIR%%/web/lib/d3-4.12.2.min.js
%%DATADIR%%/web/lib/d3pie-0.2.1-netdata-3.js
%%DATADIR%%/web/lib/dygraph-c91c859.min.js
%%DATADIR%%/web/lib/dygraph-smooth-plotter-c91c859.js
%%DATADIR%%/web/lib/fontawesome-all-5.0.1.min.js
%%DATADIR%%/web/lib/gauge-1.3.2.min.js
%%DATADIR%%/web/lib/jquery-2.2.4.min.js
@ -380,6 +407,7 @@ sbin/netdata
%%DATADIR%%/web/old/index.js
%%DATADIR%%/web/old/netdata.js
%%DATADIR%%/web/old/theme.css
%%DATADIR%%/web/refresh-badges.js
%%DATADIR%%/web/registry.html
%%DATADIR%%/web/robots.txt
%%DATADIR%%/web/sitemap.xml