- update to 1.7.6 [1]

- add license (AL2)
- add some tabs
- drop support for python <2.6

PR:		166661 [1]
Submitted by:	Attila Nagy <bra at fsn dot hu> (maintainer)
This commit is contained in:
Ruslan Makhmatkhanov 2012-04-13 19:22:59 +00:00
parent 389ce1a6c0
commit 226735aa92
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=294784
4 changed files with 16 additions and 34 deletions

View file

@ -1,31 +1,29 @@
# New ports collection makefile for: pysvn
# Date created: 22 April 2008
# Whom: bra@fsn.hu
# Date created: 22 April 2008
# Whom: bra@fsn.hu
#
# $FreeBSD$
#
PORTNAME= pysvn
PORTVERSION= 1.7.5
PORTREVISION= 1
PORTVERSION= 1.7.6
CATEGORIES= devel
MASTER_SITES= http://pysvn.barrys-emacs.org/source_kits/
MAINTAINER= bra@fsn.hu
COMMENT= Python binding for Subversion
LIB_DEPENDS= svn_client-1:${PORTSDIR}/devel/subversion16
LICENSE= AL2
CONFLICTS_BUILD=subversion-1.7.[0-9]*
LIB_DEPENDS= svn_client-1:${PORTSDIR}/devel/subversion
# Python3 ready
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_NOEGGINFO=yes
PYDISTUTILS_CONFIGURE_TARGET=configure
PYDISTUTILS_CONFIGUREARGS=--apr-inc-dir=${LOCALBASE}/include/apr-1 \
--svn-root-dir=${LOCALBASE}
PYVERSION= ${PYTHON_VERSION:S/^python//}
USE_PYDISTUTILS= yes
PYDISTUTILS_NOEGGINFO= yes
PYDISTUTILS_CONFIGURE_TARGET= configure
PYDISTUTILS_CONFIGUREARGS= --apr-inc-dir=${LOCALBASE}/include/apr-1 \
--svn-root-dir=${LOCALBASE}
PLIST_SUB= PYTHONVER=${PYTHON_VERSION:S/./_/:S/python//}
PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PORTNAME}/__init__.py \
@ -34,12 +32,6 @@ PLIST_DIRS= %%PYTHON_SITELIBDIR%%/${PORTNAME}
WRKSRC= ${WRKDIR}/${DISTNAME}/Source
.include <bsd.port.pre.mk>
.if defined(PYTHON_VERSION) && ${PYVERSION:S/.//} < 26
pre-configure:
@cd ${WRKSRC} && ${PYTHON_CMD} setup.py backport
.endif
do-build:
@cd ${WRKSRC} && ${MAKE}
@ -53,4 +45,4 @@ do-install:
${WRKSRC}/${PORTNAME}/*.so \
${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (pysvn-1.7.5.tar.gz) = cb9664de62a85adba8471eda1894c3831d3400131feeea0e7b9cdd7c15d671ef
SIZE (pysvn-1.7.5.tar.gz) = 333366
SHA256 (pysvn-1.7.6.tar.gz) = 47252408a1b18add18634395108737eaca77d12fbb22e5f187280b9e074c8b73
SIZE (pysvn-1.7.6.tar.gz) = 331549

View file

@ -1,10 +0,0 @@
--- setup_configure.py.orig 2009-03-15 12:58:45.000000000 +0100
+++ setup_configure.py 2009-03-15 12:59:08.000000000 +0100
@@ -147,6 +147,7 @@
# add source dir
include_dir_list.append( '.' )
+ include_dir_list.reverse()
# get the python CFLAGS
py_cflags_python_list = distutils.sysconfig.get_config_var('CFLAGS').split()

View file

@ -9,6 +9,6 @@ from Subversion.
Using the API, you can check out a working copy, add, edit, and remove working
files, and check in, compare, or discard your changes. Repository properties
such as keyword expansion, end of line characters, and ignore lists can also
be examined and manipulated.
be examined and manipulated.
WWW: http://pysvn.tigris.org/
WWW: http://pysvn.tigris.org/