xen-tools: fix path of xenstore device
When xenstore is not running on the same domain as the toolstack the xenstore device is used in order to access it (like when running some tools from an unprivileged domain). Fix the path to point to the FreeBSD path (/dev/xen/xenstore). This is a backport of upstream commit 7ff99b. Sponsored by: Citrix Systems R&D Approved by: bapt MFH: 2016Q4 --This line, and hose below, will be ignored-- M sysutils/xen-tools/Makefile AM sysutils/xen-tools/files/0001-libs-xenstore-set-correct-FreeBSD-device.patch
This commit is contained in:
parent
7c286a6a74
commit
226bb1b594
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=428628
2 changed files with 35 additions and 2 deletions
|
@ -3,7 +3,7 @@
|
|||
PORTNAME= xen
|
||||
PKGNAMESUFFIX= -tools
|
||||
PORTVERSION= 4.7.1
|
||||
PORTREVISION= 0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= sysutils emulators
|
||||
MASTER_SITES= http://downloads.xenproject.org/release/xen/${PORTVERSION}/
|
||||
|
||||
|
@ -47,7 +47,8 @@ QEMU_ARGS= --disable-gtk \
|
|||
EXTRA_PATCHES= ${FILESDIR}/var_paths.patch:-p1 \
|
||||
${FILESDIR}/xsa198.patch:-p1 \
|
||||
${FILESDIR}/0001-libxl-fix-creation-of-pkgconf-install-dir.patch \
|
||||
${FILESDIR}/0001-tools-configure-fix-pkg-config-install-path-for-Free.patch
|
||||
${FILESDIR}/0001-tools-configure-fix-pkg-config-install-path-for-Free.patch \
|
||||
${FILESDIR}/0001-libs-xenstore-set-correct-FreeBSD-device.patch
|
||||
|
||||
CONFIGURE_ARGS+= --with-extra-qemuu-configure-args="${QEMU_ARGS}" \
|
||||
--with-system-seabios=${LOCALBASE}/share/seabios/bios.bin
|
||||
|
|
|
@ -0,0 +1,32 @@
|
|||
From 7ff99b232e0f91a5189f429498868bfccf8d7154 Mon Sep 17 00:00:00 2001
|
||||
From: Roger Pau Monne <roger.pau@citrix.com>
|
||||
Date: Mon, 12 Dec 2016 16:07:40 +0000
|
||||
Subject: [PATCH] libs/xenstore: set correct FreeBSD device
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
The path to the xenstore FreeBSD device is /dev/xen/xenstore.
|
||||
|
||||
Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
|
||||
Acked-by: Wei Liu <wei.liu2@citrix.com>
|
||||
---
|
||||
tools/xenstore/xs_lib.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/tools/xenstore/xs_lib.c b/tools/xenstore/xs_lib.c
|
||||
index 5ef3d6d..3e43f88 100644
|
||||
--- a/tools/xenstore/xs_lib.c
|
||||
+++ b/tools/xenstore/xs_lib.c
|
||||
@@ -85,6 +85,8 @@ const char *xs_domain_dev(void)
|
||||
return "/proc/xen/xenbus";
|
||||
#elif defined(__NetBSD__)
|
||||
return "/kern/xen/xenbus";
|
||||
+#elif defined(__FreeBSD__)
|
||||
+ return "/dev/xen/xenstore";
|
||||
#else
|
||||
return "/dev/xen/xenbus";
|
||||
#endif
|
||||
--
|
||||
2.10.1 (Apple Git-78)
|
||||
|
Loading…
Reference in a new issue