Remove expired port

2010-10-27 sysutils/sfdisk: All supported freebsd versions now have sade, sfdisk 0.2 is outdated
This commit is contained in:
Renato Botelho 2010-10-27 16:34:03 +00:00
parent 67bfdc309d
commit 22a8791225
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=263652
6 changed files with 1 additions and 63 deletions

1
MOVED
View file

@ -4646,3 +4646,4 @@ security/samba-vscan||2010-10-18|Removed
net-p2p/amule2|net-p2p/amule|2010-10-05|Split to -devel and non-devel ports
www/firefox3-devel|www/firefox|2010-10-24|Upstream development focuses on Firefox 4.0
editors/vim5||2010-10-26|Has expired: Outdated, superceded by editors/vim7 and has security issues
sysutils/sfdisk||2010-10-27|Has expired: All supported freebsd versions now have sade, sfdisk 0.2 is outdated

View file

@ -800,7 +800,6 @@
SUBDIR += service-config
SUBDIR += setcdboot
SUBDIR += setquota
SUBDIR += sfdisk
SUBDIR += sformat
SUBDIR += sg3_utils
SUBDIR += sge60

View file

@ -1,32 +0,0 @@
# New ports collection makefile for: sfdisk
# Date created: 22 April 2006
# Whom: spam@rm-rf.kiev.ua
#
# $FreeBSD$
#
PORTNAME= sfdisk
PORTVERSION= 0.2
CATEGORIES= sysutils
MASTER_SITES= http://src4.narod.ru/
MAINTAINER= spam@rm-rf.kiev.ua
COMMENT= Standalone sysinstall's fdisk
DEPRECATED= All supported freebsd versions now have sade, sfdisk 0.2 is outdated
EXPIRATION_DATE= 2010-10-27
USE_BZIP2= yes
PLIST_FILES= sbin/sfdisk
MAKEFILE= Makefile.bsd
NOT_FOR_ARCHS= ia64
.include <bsd.port.pre.mk>
.if ${MACHINE} == "pc98"
CFLAGS+= -DPC98
.endif
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
MD5 (sfdisk-0.2.tar.bz2) = 5f2914cd9f18387e6cf3f148b4df1125
SHA256 (sfdisk-0.2.tar.bz2) = fe77fe71736dd928aeb398c7760a17810906614100d2c31e65bf4ecc9fcd3a85
SIZE (sfdisk-0.2.tar.bz2) = 11316

View file

@ -1,26 +0,0 @@
--- main.c.orig 2006-04-23 09:38:25.000000000 +0200
+++ main.c 2009-07-26 17:00:09.000000000 +0200
@@ -49,7 +49,7 @@
Initialize(int argc, char *argv[])
{
sigset_t signalset;
- struct ttysize ts;
+ struct winsize ws;
char *diskname;
Fake = FALSE;
@@ -59,11 +59,11 @@
diskname = check_arg(argc, argv);
- if (ioctl(0, TIOCGSIZE, &ts) == -1) {
+ if (ioctl(0, TIOCGWINSZ, &ws) == -1) {
msgDebug("Unable to get terminal size - errno %d\n", errno);
- ts.ts_lines = 0;
+ ws.ws_row = 0;
}
- StatusLine = ts.ts_lines ? ts.ts_lines - 1: TTY_STATUS_LINE;
+ StatusLine = ws.ws_row ? ws.ws_row - 1: TTY_STATUS_LINE;
init_dialog();

View file

@ -1 +0,0 @@
This is standalone sysinstall's fdisk. Functionality is similar to original.