-Update to 0.23
-Change my email to mezz@FreeBSD.org Approved by: adamw (mentor)
This commit is contained in:
parent
b1770230b2
commit
22b98d2b4a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=110146
5 changed files with 84 additions and 18 deletions
|
@ -6,12 +6,12 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= straw
|
PORTNAME= straw
|
||||||
PORTVERSION= 0.22.1
|
PORTVERSION= 0.23
|
||||||
CATEGORIES= net gnome
|
CATEGORIES= net gnome
|
||||||
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
|
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
|
||||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||||
|
|
||||||
MAINTAINER= mezz7@cox.net
|
MAINTAINER= mezz@FreeBSD.org
|
||||||
COMMENT= A GNOME 2 desktop weblog aggregator written in Python
|
COMMENT= A GNOME 2 desktop weblog aggregator written in Python
|
||||||
|
|
||||||
USE_BZIP2= yes
|
USE_BZIP2= yes
|
||||||
|
@ -21,7 +21,7 @@ USE_REINPLACE= yes
|
||||||
USE_GNOME= libglade2 pygnome2
|
USE_GNOME= libglade2 pygnome2
|
||||||
USE_PYTHON= yes
|
USE_PYTHON= yes
|
||||||
USE_PYDISTUTILS= yes
|
USE_PYDISTUTILS= yes
|
||||||
PYDISTUTILS_INSTALLARGS= --prefix=${PREFIX} \
|
PYDISTUTILS_INSTALLARGS= -c -O1 --prefix=${PREFIX} \
|
||||||
--install-lib=${PREFIX}/share/gnome
|
--install-lib=${PREFIX}/share/gnome
|
||||||
|
|
||||||
.include <bsd.port.pre.mk>
|
.include <bsd.port.pre.mk>
|
||||||
|
@ -38,6 +38,10 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb
|
||||||
post-patch:
|
post-patch:
|
||||||
@${REINPLACE_CMD} -e 's|%%PYTHON_SITELIBDIR%%|${PYTHON_SITELIBDIR}|g' \
|
@${REINPLACE_CMD} -e 's|%%PYTHON_SITELIBDIR%%|${PYTHON_SITELIBDIR}|g' \
|
||||||
${WRKSRC}/src/straw
|
${WRKSRC}/src/straw
|
||||||
|
@${REINPLACE_CMD} -e 's|share/applications|share/gnome/applications|g' \
|
||||||
|
${WRKSRC}/tools/straw_distutils.py
|
||||||
|
@${REINPLACE_CMD} -e 's|Internet|Network|g' \
|
||||||
|
${WRKSRC}/straw.desktop.in
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
@${CAT} ${PKGMESSAGE}
|
@${CAT} ${PKGMESSAGE}
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
MD5 (straw-0.22.1.tar.bz2) = 977930b03ba049513f5d1bd981bc3b2f
|
MD5 (straw-0.23.tar.bz2) = 8dbdb3bbb7a20554a069bca11712d8c3
|
||||||
SIZE (straw-0.22.1.tar.bz2) = 139164
|
SIZE (straw-0.23.tar.bz2) = 158777
|
||||||
|
|
|
@ -1,15 +1,24 @@
|
||||||
--- setup.py.orig Fri Feb 20 17:53:55 2004
|
--- setup.py.orig Mon Apr 26 12:17:31 2004
|
||||||
+++ setup.py Fri Feb 20 17:54:20 2004
|
+++ setup.py Thu May 20 13:41:56 2004
|
||||||
@@ -79,9 +79,9 @@
|
@@ -97,8 +97,8 @@
|
||||||
'''Build list of data files to be installed'''
|
'''Build list of data files to be installed'''
|
||||||
images = glob.glob('images/*.png')
|
images = glob.glob('images/*.png')
|
||||||
files = [
|
files = [
|
||||||
- ('share/pixmaps', ['images/straw.png']),
|
- ('share/pixmaps', ['images/straw.png']),
|
||||||
- ('share/applications', ['straw.desktop']),
|
- ('share/straw', images + ['data/default_subscriptions.opml', 'glade/straw.glade'])]
|
||||||
- ('share/straw', images +
|
|
||||||
+ ('share/gnome/pixmaps', ['images/straw.png']),
|
+ ('share/gnome/pixmaps', ['images/straw.png']),
|
||||||
+ ('share/gnome/applications', ['straw.desktop']),
|
+ ('share/gnome/straw', images + ['data/default_subscriptions.opml', 'glade/straw.glade'])]
|
||||||
+ ('share/gnome/straw', images +
|
|
||||||
['data/default_subscriptions.opml', 'glade/straw.glade'])]
|
|
||||||
return files
|
return files
|
||||||
|
|
||||||
|
long_desc = '''\
|
||||||
|
@@ -121,9 +121,8 @@
|
||||||
|
config_files = [('gconf/schemas',['data/straw.schemas'],
|
||||||
|
'with-gconf-schema-file-dir')],
|
||||||
|
scripts = ['src/straw'],
|
||||||
|
- modules_check = modules_check,
|
||||||
|
packages = ['straw'],
|
||||||
|
package_dir = {'straw' : 'src/lib'},
|
||||||
|
- msg_sources = translation_files(),
|
||||||
|
+ msg_sources = ['glade/strings.c'] + glob.glob('src/lib/*.py'),
|
||||||
|
desktop_file = ['straw.desktop.in'])
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,15 @@
|
||||||
--- src/lib/Main.py.orig Tue Feb 17 13:35:41 2004
|
--- src/lib/Main.py.orig Mon Apr 26 12:17:31 2004
|
||||||
+++ src/lib/Main.py Tue Feb 17 13:36:26 2004
|
+++ src/lib/Main.py Sun May 2 15:30:14 2004
|
||||||
@@ -479,7 +479,7 @@
|
@@ -417,7 +417,7 @@
|
||||||
|
gtk.main()
|
||||||
|
|
||||||
|
def quit(self):
|
||||||
|
- gtk.mainquit()
|
||||||
|
+ gtk.main_quit()
|
||||||
|
self._itemstore.stop()
|
||||||
|
return
|
||||||
|
|
||||||
|
@@ -480,7 +480,7 @@
|
||||||
return os.environ["STRAW_DATA"]
|
return os.environ["STRAW_DATA"]
|
||||||
h, t = os.path.split(os.path.split(os.path.abspath(sys.argv[0]))[0])
|
h, t = os.path.split(os.path.split(os.path.abspath(sys.argv[0]))[0])
|
||||||
if t == 'bin':
|
if t == 'bin':
|
||||||
|
|
|
@ -10,94 +10,138 @@ share/gnome/applications/straw.desktop
|
||||||
share/gnome/pixmaps/straw.png
|
share/gnome/pixmaps/straw.png
|
||||||
share/gnome/straw/Config.py
|
share/gnome/straw/Config.py
|
||||||
share/gnome/straw/Config.pyc
|
share/gnome/straw/Config.pyc
|
||||||
|
share/gnome/straw/Config.pyo
|
||||||
share/gnome/straw/DashboardFrontend.py
|
share/gnome/straw/DashboardFrontend.py
|
||||||
share/gnome/straw/DashboardFrontend.pyc
|
share/gnome/straw/DashboardFrontend.pyc
|
||||||
|
share/gnome/straw/DashboardFrontend.pyo
|
||||||
share/gnome/straw/Event.py
|
share/gnome/straw/Event.py
|
||||||
share/gnome/straw/Event.pyc
|
share/gnome/straw/Event.pyc
|
||||||
|
share/gnome/straw/Event.pyo
|
||||||
share/gnome/straw/Feed.py
|
share/gnome/straw/Feed.py
|
||||||
share/gnome/straw/Feed.pyc
|
share/gnome/straw/Feed.pyc
|
||||||
|
share/gnome/straw/Feed.pyo
|
||||||
share/gnome/straw/FeedCategoryList.py
|
share/gnome/straw/FeedCategoryList.py
|
||||||
share/gnome/straw/FeedCategoryList.pyc
|
share/gnome/straw/FeedCategoryList.pyc
|
||||||
|
share/gnome/straw/FeedCategoryList.pyo
|
||||||
share/gnome/straw/FeedDataRouter.py
|
share/gnome/straw/FeedDataRouter.py
|
||||||
share/gnome/straw/FeedDataRouter.pyc
|
share/gnome/straw/FeedDataRouter.pyc
|
||||||
|
share/gnome/straw/FeedDataRouter.pyo
|
||||||
share/gnome/straw/FeedItems.py
|
share/gnome/straw/FeedItems.py
|
||||||
share/gnome/straw/FeedItems.pyc
|
share/gnome/straw/FeedItems.pyc
|
||||||
|
share/gnome/straw/FeedItems.pyo
|
||||||
share/gnome/straw/FeedList.py
|
share/gnome/straw/FeedList.py
|
||||||
share/gnome/straw/FeedList.pyc
|
share/gnome/straw/FeedList.pyc
|
||||||
|
share/gnome/straw/FeedList.pyo
|
||||||
share/gnome/straw/FeedPropertiesDialog.py
|
share/gnome/straw/FeedPropertiesDialog.py
|
||||||
share/gnome/straw/FeedPropertiesDialog.pyc
|
share/gnome/straw/FeedPropertiesDialog.pyc
|
||||||
|
share/gnome/straw/FeedPropertiesDialog.pyo
|
||||||
share/gnome/straw/FindDialog.py
|
share/gnome/straw/FindDialog.py
|
||||||
share/gnome/straw/FindDialog.pyc
|
share/gnome/straw/FindDialog.pyc
|
||||||
|
share/gnome/straw/FindDialog.pyo
|
||||||
share/gnome/straw/ImageCache.py
|
share/gnome/straw/ImageCache.py
|
||||||
share/gnome/straw/ImageCache.pyc
|
share/gnome/straw/ImageCache.pyc
|
||||||
|
share/gnome/straw/ImageCache.pyo
|
||||||
share/gnome/straw/ItemStore.py
|
share/gnome/straw/ItemStore.py
|
||||||
share/gnome/straw/ItemStore.pyc
|
share/gnome/straw/ItemStore.pyc
|
||||||
|
share/gnome/straw/ItemStore.pyo
|
||||||
share/gnome/straw/LookupManager.py
|
share/gnome/straw/LookupManager.py
|
||||||
share/gnome/straw/LookupManager.pyc
|
share/gnome/straw/LookupManager.pyc
|
||||||
|
share/gnome/straw/LookupManager.pyo
|
||||||
share/gnome/straw/Main.py
|
share/gnome/straw/Main.py
|
||||||
share/gnome/straw/Main.pyc
|
share/gnome/straw/Main.pyc
|
||||||
|
share/gnome/straw/Main.pyo
|
||||||
share/gnome/straw/MainWindow.py
|
share/gnome/straw/MainWindow.py
|
||||||
share/gnome/straw/MainWindow.pyc
|
share/gnome/straw/MainWindow.pyc
|
||||||
|
share/gnome/straw/MainWindow.pyo
|
||||||
share/gnome/straw/MessageManager.py
|
share/gnome/straw/MessageManager.py
|
||||||
share/gnome/straw/MessageManager.pyc
|
share/gnome/straw/MessageManager.pyc
|
||||||
|
share/gnome/straw/MessageManager.pyo
|
||||||
share/gnome/straw/NetworkConstants.py
|
share/gnome/straw/NetworkConstants.py
|
||||||
share/gnome/straw/NetworkConstants.pyc
|
share/gnome/straw/NetworkConstants.pyc
|
||||||
|
share/gnome/straw/NetworkConstants.pyo
|
||||||
share/gnome/straw/OPML.py
|
share/gnome/straw/OPML.py
|
||||||
share/gnome/straw/OPML.pyc
|
share/gnome/straw/OPML.pyc
|
||||||
|
share/gnome/straw/OPML.pyo
|
||||||
share/gnome/straw/OPMLExport.py
|
share/gnome/straw/OPMLExport.py
|
||||||
share/gnome/straw/OPMLExport.pyc
|
share/gnome/straw/OPMLExport.pyc
|
||||||
|
share/gnome/straw/OPMLExport.pyo
|
||||||
share/gnome/straw/OPMLImport.py
|
share/gnome/straw/OPMLImport.py
|
||||||
share/gnome/straw/OPMLImport.pyc
|
share/gnome/straw/OPMLImport.pyc
|
||||||
|
share/gnome/straw/OPMLImport.pyo
|
||||||
share/gnome/straw/ParsedSummary.py
|
share/gnome/straw/ParsedSummary.py
|
||||||
share/gnome/straw/ParsedSummary.pyc
|
share/gnome/straw/ParsedSummary.pyc
|
||||||
|
share/gnome/straw/ParsedSummary.pyo
|
||||||
share/gnome/straw/PollManager.py
|
share/gnome/straw/PollManager.py
|
||||||
share/gnome/straw/PollManager.pyc
|
share/gnome/straw/PollManager.pyc
|
||||||
|
share/gnome/straw/PollManager.pyo
|
||||||
share/gnome/straw/PreferencesDialog.py
|
share/gnome/straw/PreferencesDialog.py
|
||||||
share/gnome/straw/PreferencesDialog.pyc
|
share/gnome/straw/PreferencesDialog.pyc
|
||||||
|
share/gnome/straw/PreferencesDialog.pyo
|
||||||
share/gnome/straw/QueueDict.py
|
share/gnome/straw/QueueDict.py
|
||||||
share/gnome/straw/QueueDict.pyc
|
share/gnome/straw/QueueDict.pyc
|
||||||
|
share/gnome/straw/QueueDict.pyo
|
||||||
share/gnome/straw/StrawURLOpener.py
|
share/gnome/straw/StrawURLOpener.py
|
||||||
share/gnome/straw/StrawURLOpener.pyc
|
share/gnome/straw/StrawURLOpener.pyc
|
||||||
|
share/gnome/straw/StrawURLOpener.pyo
|
||||||
share/gnome/straw/SubscribeDialog.py
|
share/gnome/straw/SubscribeDialog.py
|
||||||
share/gnome/straw/SubscribeDialog.pyc
|
share/gnome/straw/SubscribeDialog.pyc
|
||||||
|
share/gnome/straw/SubscribeDialog.pyo
|
||||||
share/gnome/straw/SummaryItem.py
|
share/gnome/straw/SummaryItem.py
|
||||||
share/gnome/straw/SummaryItem.pyc
|
share/gnome/straw/SummaryItem.pyc
|
||||||
|
share/gnome/straw/SummaryItem.pyo
|
||||||
share/gnome/straw/SummaryParser.py
|
share/gnome/straw/SummaryParser.py
|
||||||
share/gnome/straw/SummaryParser.pyc
|
share/gnome/straw/SummaryParser.pyc
|
||||||
|
share/gnome/straw/SummaryParser.pyo
|
||||||
share/gnome/straw/URLFetch.py
|
share/gnome/straw/URLFetch.py
|
||||||
share/gnome/straw/URLFetch.pyc
|
share/gnome/straw/URLFetch.pyc
|
||||||
|
share/gnome/straw/URLFetch.pyo
|
||||||
share/gnome/straw/__init__.py
|
share/gnome/straw/__init__.py
|
||||||
share/gnome/straw/__init__.pyc
|
share/gnome/straw/__init__.pyc
|
||||||
|
share/gnome/straw/__init__.pyo
|
||||||
share/gnome/straw/dashboard.py
|
share/gnome/straw/dashboard.py
|
||||||
share/gnome/straw/dashboard.pyc
|
share/gnome/straw/dashboard.pyc
|
||||||
|
share/gnome/straw/dashboard.pyo
|
||||||
share/gnome/straw/default_subscriptions.opml
|
share/gnome/straw/default_subscriptions.opml
|
||||||
share/gnome/straw/error.py
|
share/gnome/straw/error.py
|
||||||
share/gnome/straw/error.pyc
|
share/gnome/straw/error.pyc
|
||||||
|
share/gnome/straw/error.pyo
|
||||||
share/gnome/straw/feedparser.py
|
share/gnome/straw/feedparser.py
|
||||||
share/gnome/straw/feedparser.pyc
|
share/gnome/straw/feedparser.pyc
|
||||||
|
share/gnome/straw/feedparser.pyo
|
||||||
share/gnome/straw/file_selector.py
|
share/gnome/straw/file_selector.py
|
||||||
share/gnome/straw/file_selector.pyc
|
share/gnome/straw/file_selector.pyc
|
||||||
|
share/gnome/straw/file_selector.pyo
|
||||||
share/gnome/straw/hig_alert.py
|
share/gnome/straw/hig_alert.py
|
||||||
share/gnome/straw/hig_alert.pyc
|
share/gnome/straw/hig_alert.pyc
|
||||||
|
share/gnome/straw/hig_alert.pyo
|
||||||
share/gnome/straw/httplib_async.py
|
share/gnome/straw/httplib_async.py
|
||||||
share/gnome/straw/httplib_async.pyc
|
share/gnome/straw/httplib_async.pyc
|
||||||
|
share/gnome/straw/httplib_async.pyo
|
||||||
share/gnome/straw/image-broken.png
|
share/gnome/straw/image-broken.png
|
||||||
share/gnome/straw/image-waiting.png
|
share/gnome/straw/image-waiting.png
|
||||||
share/gnome/straw/offline.png
|
share/gnome/straw/offline.png
|
||||||
share/gnome/straw/online.png
|
share/gnome/straw/online.png
|
||||||
share/gnome/straw/rssfinder.py
|
share/gnome/straw/rssfinder.py
|
||||||
share/gnome/straw/rssfinder.pyc
|
share/gnome/straw/rssfinder.pyc
|
||||||
|
share/gnome/straw/rssfinder.pyo
|
||||||
share/gnome/straw/straw.glade
|
share/gnome/straw/straw.glade
|
||||||
share/gnome/straw/straw.png
|
share/gnome/straw/straw.png
|
||||||
share/gnome/straw/utils.py
|
share/gnome/straw/utils.py
|
||||||
share/gnome/straw/utils.pyc
|
share/gnome/straw/utils.pyc
|
||||||
|
share/gnome/straw/utils.pyo
|
||||||
|
share/locale/cs/LC_MESSAGES/straw.mo
|
||||||
share/locale/de/LC_MESSAGES/straw.mo
|
share/locale/de/LC_MESSAGES/straw.mo
|
||||||
|
share/locale/en_GB/LC_MESSAGES/straw.mo
|
||||||
share/locale/es/LC_MESSAGES/straw.mo
|
share/locale/es/LC_MESSAGES/straw.mo
|
||||||
share/locale/fi/LC_MESSAGES/straw.mo
|
share/locale/fi/LC_MESSAGES/straw.mo
|
||||||
share/locale/fr/LC_MESSAGES/straw.mo
|
share/locale/fr/LC_MESSAGES/straw.mo
|
||||||
share/locale/nl/LC_MESSAGES/straw.mo
|
share/locale/nl/LC_MESSAGES/straw.mo
|
||||||
share/locale/no/LC_MESSAGES/straw.mo
|
share/locale/no/LC_MESSAGES/straw.mo
|
||||||
|
share/locale/pt_BR/LC_MESSAGES/straw.mo
|
||||||
share/locale/ru/LC_MESSAGES/straw.mo
|
share/locale/ru/LC_MESSAGES/straw.mo
|
||||||
|
share/locale/sr/LC_MESSAGES/straw.mo
|
||||||
|
share/locale/sr@Latn/LC_MESSAGES/straw.mo
|
||||||
|
share/locale/sv/LC_MESSAGES/straw.mo
|
||||||
@dirrm share/gnome/straw
|
@dirrm share/gnome/straw
|
||||||
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/straw/ui
|
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/straw/ui
|
||||||
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/straw/general
|
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/straw/general
|
||||||
|
|
Loading…
Reference in a new issue