emulators/cpmemu: Remove expired port

2024-03-18 emulators/cpmemu: BROKEN on all versions since last year
This commit is contained in:
Rene Ladan 2024-03-19 21:02:21 +01:00
parent c75ee5343b
commit 22d0c88307
10 changed files with 1 additions and 147 deletions

1
MOVED
View File

@ -3053,3 +3053,4 @@ net-im/telegram-purple||2024-03-17|Has expired: No longer works, migrate to net-
multimedia/gstreamer1-plugins-rtmp||2024-03-17|Support for legacy library librtmp has been removed in tree
lang/swi-pl|lang/swipl|2024-03-17|Port renamed on request
devel/rubygem-with_advisory_lock|devel/rubygem-with_advisory_lock61|2024-03-18|Port renamed to follow naming convention
emulators/cpmemu||2024-03-19|Has expired: BROKEN on all versions since last year

View File

@ -15,7 +15,6 @@
SUBDIR += cingb
SUBDIR += citra
SUBDIR += citra-qt5
SUBDIR += cpmemu
SUBDIR += cpmtools
SUBDIR += cpmtools2
SUBDIR += darcnes

View File

@ -1,28 +0,0 @@
PORTNAME= cpmemu
PORTVERSION= 0.2.1.1
CATEGORIES= emulators
MASTER_SITES= SUNSITE/system/emulators
DISTNAME= cpm-0.2.1
PATCH_SITES= SUNSITE/system/emulators
PATCHFILES= cpm-0.2.1-glibc-rjm.patch.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
COMMENT= Cpm emulator
DEPRECATED= BROKEN on all versions since last year
EXPIRATION_DATE= 2024-03-18
BROKEN= incorrect register `%esi' used with `w' suffix
ONLY_FOR_ARCHS= i386
USES= compiler
.include <bsd.port.pre.mk>
.if ${COMPILER_TYPE} == "clang"
USE_BINUTILS= yes
CPPFLAGS+= -no-integrated-as
.endif
.include <bsd.port.post.mk>

View File

@ -1,4 +0,0 @@
SHA256 (cpm-0.2.1.tar.gz) = ba98d4453d5444011fbfca127d6beed685b41ee9ede04b0f4799a30a7f588b2c
SIZE (cpm-0.2.1.tar.gz) = 103797
SHA256 (cpm-0.2.1-glibc-rjm.patch.gz) = 1b22d2de75706571fdedab0fda417c6571b46e6e113777df8a6112274660a682
SIZE (cpm-0.2.1-glibc-rjm.patch.gz) = 6348

View File

@ -1,53 +0,0 @@
--- Makefile.orig Mon Nov 15 06:49:52 1999
+++ Makefile Mon Nov 15 06:54:21 1999
@@ -2,26 +2,26 @@
# basic prefix for installation
-PREFIX = /usr/local
+PREFIX ?= /usr/local
# where to install `cpm' executable.
BINDIR = $(PREFIX)/bin
# where `cpm' looks for its files (cpm.sys and .com files).
-CPMLIBDIR = $(PREFIX)/lib/cpm
+CPMLIBDIR = $(PREFIX)/share/cpm
# You shouldn't need to edit below this line.
-CC = gcc
+CC ?= gcc
-CFLAGS = -O2 -pipe -ansi -Wall \
+CFLAGS += $(CPPFLAGS) -ansi -Wall \
-Wshadow -Wpointer-arith -Wcast-qual -Wcast-align \
-Waggregate-return -Wstrict-prototypes -Wmissing-prototypes \
-Wnested-externs -Wwrite-strings \
-DCPMLIBDIR=\"$(CPMLIBDIR)\"
-LDFLAGS = -s
+#LDFLAGS = -s
OBJS = single.o z80emu.o em.o io.o bios.o \
commands.o running.o main.o disneu.o disz80.o low.o
@@ -42,11 +42,14 @@
cpm: $(OBJS)
$(CC) $(LDFLAGS) -o cpm $(OBJS)
+format: format.o
+ $(CC) $(LDFLAGS) -o format format.o
+
clean:
rm -f *~ loads.s makeloads *.o $(TARGETS)
install: all
- install -m 511 cpm $(BINDIR)
- -mkdir $(CPMLIBDIR)
- chmod 755 $(CPMLIBDIR)
- install -m 444 z80-binaries/* $(CPMLIBDIR)
+ ${BSD_INSTALL_PROGRAM} cpm $(DESTDIR)$(BINDIR)/cpmemu
+ ${BSD_INSTALL_PROGRAM} format $(DESTDIR)$(BINDIR)/cpmformat
+ -mkdir $(DESTDIR)$(CPMLIBDIR)
+ ${BSD_INSTALL_DATA} z80-binaries/* $(DESTDIR)$(CPMLIBDIR)

View File

@ -1,11 +0,0 @@
--- bios.c.orig Mon Nov 15 06:33:54 1999
+++ bios.c Mon Nov 15 06:39:55 1999
@@ -227,7 +227,7 @@
case BIOS: /* System Reset (coldboot) */
case DIRBUF-20:
if (!silent_exit)
- printf("\nCp/M BIOS COLDBOOT takes you back to Linux\n");
+ printf("\nCp/M BIOS COLDBOOT takes you back to FreeBSD\n");
exit(0);
case BIOS+3: /* System Reset (warmboot) */
case DIRBUF-19:

View File

@ -1,11 +0,0 @@
--- io.c.orig Wed Jun 22 03:25:46 1994
+++ io.c Mon Nov 15 06:31:36 1999
@@ -13,7 +13,7 @@
/*****************************************************************************/
#include "cpmemu.h"
-#define HAVE_RAW_IO
+#undef HAVE_RAW_IO
/* magic for character I/O */
#include <unistd.h>

View File

@ -1,26 +0,0 @@
--- low.c.orig Wed Dec 11 22:44:43 2002
+++ low.c Wed Dec 11 22:44:56 2002
@@ -18,11 +18,10 @@
* space-invaders-type game working, I think it was. :-) -rjm
*/
+#include <sys/types.h>
#include "cpmemu.h"
#include <ctype.h>
#include <unistd.h>
-#include <sys/perm.h> /* needed for ioperm() -rjm */
-#include <sys/types.h>
#include <sys/time.h>
#include <signal.h>
#include <sys/mman.h>
@@ -88,10 +87,8 @@
/* get access to sound port */
cptr = NULL;
- if (ioperm(0x61, 1, 1)) {
hardware_access = 0; /* no access to speaker port */
return;
- }
/* install signal handler */
sa.sa_handler = tickerint;

View File

@ -1,7 +0,0 @@
A CPM emulator.
Type 'UNIX' at the CCP prompt to leave the emulator.
(Or ctrl-@, followed by 'q' any time the keyboard is polled)
WARNING! This software runs only on 386 compatible processors
and systems which allow nonaligned word/dword memory access.

View File

@ -1,6 +0,0 @@
bin/cpmemu
bin/cpmformat
share/cpm/cpm.sys
share/cpm/cd.com
share/cpm/link.com
share/cpm/xccp.com