Add libuta 0.3.36, a Graphical User Interface library for C++.

PR:		26250
Submitted by:	Oliver Lehmann <lehmann@ans-netz.de>
This commit is contained in:
Alexander Langer 2001-04-05 19:01:48 +00:00
parent dd3a111807
commit 22d8d01d04
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40907
47 changed files with 791 additions and 0 deletions

View file

@ -193,6 +193,7 @@
SUBDIR += libtool
SUBDIR += libunicode
SUBDIR += libusb
SUBDIR += libuta
SUBDIR += libxalloc
SUBDIR += lincvs
SUBDIR += linguist

25
devel/libuta/Makefile Normal file
View file

@ -0,0 +1,25 @@
# New ports collection makefile for: libuta
# Date created: 29 March 2001
# Whom: Oliver Lehmann <lehmann@ans-netz.de>
#
# $FreeBSD$
#
PORTNAME= libuta
PORTVERSION= 0.3.36
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= lehmann@ans-netz.de
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
ttf.4:${PORTSDIR}/print/freetype \
sigc.1:${PORTSDIR}/devel/libsigc++ \
SDL-1.1.3:${PORTSDIR}/devel/sdl-devel \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
USE_LIBTOOL= YES
CONFIGURE_ARGS= --prefix=${PREFIX}
.include <bsd.port.mk>

1
devel/libuta/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (libuta-0.3.36.tar.gz) = 7237fb067884745cde01f290f35932f4

View file

@ -0,0 +1,21 @@
--- configure.orig Thu Apr 5 17:21:15 2001
+++ configure Thu Apr 5 17:23:51 2001
@@ -7,6 +7,9 @@
# This configure script is free software; the Free Software Foundation
# gives unlimited permission to copy, distribute and modify it.
+LIBS="$LIBS -L/usr/local/lib"
+
+
# Defaults:
ac_help=
ac_default_prefix=/usr/local
@@ -4603,7 +4606,7 @@
no_sdl=yes
else
SDL_CFLAGS=`$SDL_CONFIG $sdlconf_args --cflags`
- SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs`
+ SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs | sed 's/-lXxf86vm -lXxf86dga -lXv //g'`
sdl_major_version=`$SDL_CONFIG $sdl_args --version | \
sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`

View file

@ -0,0 +1,11 @@
--- uta/color.h.orig Sat Mar 31 05:24:37 2001
+++ uta/color.h Sat Mar 31 05:26:10 2001
@@ -22,7 +22,7 @@
#define _COLOR_H
#include <iostream>
-#include <SDL/SDL_version.h>
+#include <SDL11/SDL_version.h>
namespace uta {
///

View file

@ -0,0 +1,11 @@
--- uta/event.h.orig Sat Mar 31 05:24:44 2001
+++ uta/event.h Sat Mar 31 05:26:20 2001
@@ -21,7 +21,7 @@
#ifndef _EVENT_H
#define _EVENT_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "keysym.h"
#include "point.h"

View file

@ -0,0 +1,11 @@
--- uta/keysym.h.orig Sat Mar 31 05:24:56 2001
+++ uta/keysym.h Sat Mar 31 05:26:32 2001
@@ -20,7 +20,7 @@
#ifndef KEYSYM_H
#define KEYSYM_H
-#include <SDL/SDL_keysym.h>
+#include <SDL11/SDL_keysym.h>
namespace uta {

View file

@ -0,0 +1,11 @@
--- uta/mutex.h.orig Sat Mar 31 05:25:05 2001
+++ uta/mutex.h Sat Mar 31 05:26:54 2001
@@ -22,7 +22,7 @@
#ifndef _MUTEX_H_
#define _MUTEX_H_
-#include <SDL/SDL_mutex.h>
+#include <SDL11/SDL_mutex.h>
namespace uta {

View file

@ -0,0 +1,11 @@
--- uta/rect.h.orig Sat Mar 31 05:25:30 2001
+++ uta/rect.h Sat Mar 31 05:27:27 2001
@@ -21,7 +21,7 @@
#ifndef _RECT_H
#define _RECT_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "point.h"

View file

@ -0,0 +1,14 @@
--- uta/sound.h.orig Sat Mar 31 05:25:38 2001
+++ uta/sound.h Sat Mar 31 05:27:39 2001
@@ -36,9 +36,9 @@
#endif
#ifdef HAVE_MIXER
-#include <SDL/SDL_mixer.h>
+#include <SDL11/SDL_mixer.h>
#else
-#include <SDL/SDL_types.h>
+#include <SDL11/SDL_types.h>
#endif
namespace uta {

View file

@ -0,0 +1,11 @@
--- uta/surface.h.orig Sat Mar 31 05:25:49 2001
+++ uta/surface.h Sat Mar 31 05:27:49 2001
@@ -22,7 +22,7 @@
#ifndef _SURFACE_H_
#define _SURFACE_H_
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "color.h"
#include "point.h"

View file

@ -0,0 +1,11 @@
--- uta/sge_blib.h.orig Sat Mar 31 05:44:18 2001
+++ uta/sge_blib.h Sat Mar 31 05:38:40 2001
@@ -18,7 +18,7 @@
#ifndef sge_blib_H
#define sge_blib_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_internal.h"

View file

@ -0,0 +1,11 @@
--- uta/sge_blib.cc.orig Sat Mar 31 05:40:36 2001
+++ uta/sge_blib.cc Sat Mar 31 05:40:51 2001
@@ -19,7 +19,7 @@
* This is written by Johan E. Thélin and is slightly modified by me.
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_draw.h"
#include "sge_blib.h"

View file

@ -0,0 +1,11 @@
--- uta/sge_draw.cc.orig Sat Mar 31 05:41:03 2001
+++ uta/sge_draw.cc Sat Mar 31 05:41:56 2001
@@ -20,7 +20,7 @@
* John Garrison's PowerPak
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include <math.h>
#include <string.h>
#include <stdarg.h>

View file

@ -0,0 +1,11 @@
--- uta/surface_io.cc.orig Sat Mar 31 05:41:28 2001
+++ uta/surface_io.cc Sat Mar 31 05:42:29 2001
@@ -79,7 +79,7 @@
#include <assert.h>
#include <png.h>
-#include <SDL/SDL_endian.h>
+#include <SDL11/SDL_endian.h>
namespace uta {

View file

@ -0,0 +1,11 @@
--- uta/timer.cc.orig Sat Mar 31 05:41:43 2001
+++ uta/timer.cc Sat Mar 31 05:42:38 2001
@@ -18,7 +18,7 @@
Boston, MA 02111-1307, SA.
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "timer.h"
#include <stl.h>

View file

@ -0,0 +1,11 @@
--- uta/pixelformat.h.orig Sat Mar 31 05:51:51 2001
+++ uta/pixelformat.h Sat Mar 31 05:52:22 2001
@@ -27,7 +27,7 @@
//just for typedefs ...
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include <string>
#include <stl.h>

View file

@ -0,0 +1,11 @@
--- uta/sge_draw.h.orig Sat Mar 31 05:52:07 2001
+++ uta/sge_draw.h Sat Mar 31 05:52:34 2001
@@ -18,7 +18,7 @@
#ifndef sge_draw_H
#define sge_draw_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_internal.h"

View file

@ -0,0 +1,62 @@
--- acinclude.m4.orig Tue Nov 21 11:10:07 2000
+++ acinclude.m4 Sat Mar 31 06:08:52 2001
@@ -606,8 +606,8 @@
CHECK_LIB_HEADER_VERSION(
SDL,
SDL_Init,
- SDL/SDL.h,
- SDL/SDL_version.h,
+ SDL11/SDL.h,
+ SDL11/SDL_version.h,
SDL_MAJOR_VERSION.SDL_MINOR_VERSION.SDL_PATCHLEVEL,
$1,
http://www.devolution.com/~slouken/SDL/SDL-0.10/src/SDL-$1.tar.gz)
@@ -618,7 +618,7 @@
[
TEST_SKIP(
[
- AC_CHECK_HEADER(SDL/SDL_mixer.h,
+ AC_CHECK_HEADER(SDL11/SDL_mixer.h,
[
AC_DEFINE(HAVE_MIXER))
AC_CHECK_LIB([
@@ -1027,13 +1027,13 @@
if test x$sdl_exec_prefix != x ; then
sdl_args="$sdl_args --exec-prefix=$sdl_exec_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_exec_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_exec_prefix/bin/sdl11-config
fi
fi
if test x$sdl_prefix != x ; then
sdl_args="$sdl_args --prefix=$sdl_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_prefix/bin/sdl11-config
fi
fi
@@ -1067,7 +1067,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
char*
my_strdup (char *str)
@@ -1141,7 +1141,7 @@
LIBS="$LIBS $SDL_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
], [ return 0; ],
[ echo "*** The test program compiled, but did not run. This usually means"
echo "*** that the run-time linker is not finding SDL or finding the wrong"
@@ -1292,4 +1292,4 @@
AC_SUBST(SIGC_CFLAGS)
AC_SUBST(SIGC_LIBS)
-])
+])

View file

@ -0,0 +1,11 @@
--- configure.in.orig Sat Mar 31 06:01:00 2001
+++ configure.in Sat Mar 31 06:01:12 2001
@@ -186,7 +186,7 @@
])
AM_CONDITIONAL(SMPEG_AVAILABLE, test x$have_smpeg = xyes)
-AC_CHECK_HEADER(SDL/SDL_mixer.h,AC_CHECK_LIB(SDL_mixer, Mix_SetPostMix, [
+AC_CHECK_HEADER(SDL11/SDL_mixer.h,AC_CHECK_LIB(SDL_mixer, Mix_SetPostMix, [
MIXLIBS=-lSDL_mixer
AC_DEFINE(HAVE_MIXER)
]))

View file

@ -0,0 +1,56 @@
--- aclocal.m4.orig Wed Mar 21 13:44:06 2001
+++ aclocal.m4 Sat Mar 31 06:09:47 2001
@@ -618,8 +618,8 @@
CHECK_LIB_HEADER_VERSION(
SDL,
SDL_Init,
- SDL/SDL.h,
- SDL/SDL_version.h,
+ SDL11/SDL.h,
+ SDL11/SDL_version.h,
SDL_MAJOR_VERSION.SDL_MINOR_VERSION.SDL_PATCHLEVEL,
$1,
http://www.devolution.com/~slouken/SDL/SDL-0.10/src/SDL-$1.tar.gz)
@@ -630,7 +630,7 @@
[
TEST_SKIP(
[
- AC_CHECK_HEADER(SDL/SDL_mixer.h,
+ AC_CHECK_HEADER(SDL11/SDL_mixer.h,
[
AC_DEFINE(HAVE_MIXER))
AC_CHECK_LIB([
@@ -1039,13 +1039,13 @@
if test x$sdl_exec_prefix != x ; then
sdl_args="$sdl_args --exec-prefix=$sdl_exec_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_exec_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_exec_prefix/bin/sdl11-config
fi
fi
if test x$sdl_prefix != x ; then
sdl_args="$sdl_args --prefix=$sdl_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_prefix/bin/sdl11-config
fi
fi
@@ -1079,7 +1079,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
char*
my_strdup (char *str)
@@ -1153,7 +1153,7 @@
LIBS="$LIBS $SDL_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
], [ return 0; ],
[ echo "*** The test program compiled, but did not run. This usually means"
echo "*** that the run-time linker is not finding SDL or finding the wrong"

1
devel/libuta/pkg-comment Normal file
View file

@ -0,0 +1 @@
A Graphical User Interface library for C++

6
devel/libuta/pkg-descr Normal file
View file

@ -0,0 +1,6 @@
libuta is a Graphical User Interface library for C++ that uses SDL
as its output layer. It allows application and game programmers to
put together portable graphical applications easily. libuta has a
range of already implemented widgets and uses libsigc++ as a signal
dispatching system. It also performs resource management and has a
sound system.

55
devel/libuta/pkg-plist Normal file
View file

@ -0,0 +1,55 @@
bin/uta-config
lib/libuta.so
lib/libuta-0.3.so.36
lib/libuta.a
include/uta/debug.h
include/uta/color.h
include/uta/point.h
include/uta/rect.h
include/uta/keysym.h
include/uta/event.h
include/uta/shared.h
include/uta/pixelformat.h
include/uta/painter.h
include/uta/progressdialog.h
include/uta/logo.h
include/uta/logo_data.h
include/uta/terminal.h
include/uta/directsurface.h
include/uta/mutex.h
include/uta/version.h
include/uta/uta.h
include/uta/timer.h
include/uta/dialogbox.h
include/uta/messagebox.h
include/uta/questionbox.h
include/uta/blitters.h
include/uta/mmx.h
include/uta/application.h
include/uta/button.h
include/uta/dialog.h
include/uta/focus.h
include/uta/font.h
include/uta/label.h
include/uta/lineedit.h
include/uta/listbox.h
include/uta/mixer.h
include/uta/mouse.h
include/uta/mouse_data.h
include/uta/movie.h
include/uta/multilineedit.h
include/uta/music.h
include/uta/pushbutton.h
include/uta/resources.h
include/uta/rootwindow.h
include/uta/sample.h
include/uta/screensurface.h
include/uta/slider.h
include/uta/sound.h
include/uta/soundmapper.h
include/uta/surface.h
include/uta/togglebutton.h
include/uta/widget.h
share/aclocal/uta.m4
@dirrm include/uta

25
devel/wftk/Makefile Normal file
View file

@ -0,0 +1,25 @@
# New ports collection makefile for: libuta
# Date created: 29 March 2001
# Whom: Oliver Lehmann <lehmann@ans-netz.de>
#
# $FreeBSD$
#
PORTNAME= libuta
PORTVERSION= 0.3.36
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= lehmann@ans-netz.de
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
ttf.4:${PORTSDIR}/print/freetype \
sigc.1:${PORTSDIR}/devel/libsigc++ \
SDL-1.1.3:${PORTSDIR}/devel/sdl-devel \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
USE_LIBTOOL= YES
CONFIGURE_ARGS= --prefix=${PREFIX}
.include <bsd.port.mk>

1
devel/wftk/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (libuta-0.3.36.tar.gz) = 7237fb067884745cde01f290f35932f4

21
devel/wftk/files/patch-aa Normal file
View file

@ -0,0 +1,21 @@
--- configure.orig Thu Apr 5 17:21:15 2001
+++ configure Thu Apr 5 17:23:51 2001
@@ -7,6 +7,9 @@
# This configure script is free software; the Free Software Foundation
# gives unlimited permission to copy, distribute and modify it.
+LIBS="$LIBS -L/usr/local/lib"
+
+
# Defaults:
ac_help=
ac_default_prefix=/usr/local
@@ -4603,7 +4606,7 @@
no_sdl=yes
else
SDL_CFLAGS=`$SDL_CONFIG $sdlconf_args --cflags`
- SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs`
+ SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs | sed 's/-lXxf86vm -lXxf86dga -lXv //g'`
sdl_major_version=`$SDL_CONFIG $sdl_args --version | \
sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`

11
devel/wftk/files/patch-ab Normal file
View file

@ -0,0 +1,11 @@
--- uta/color.h.orig Sat Mar 31 05:24:37 2001
+++ uta/color.h Sat Mar 31 05:26:10 2001
@@ -22,7 +22,7 @@
#define _COLOR_H
#include <iostream>
-#include <SDL/SDL_version.h>
+#include <SDL11/SDL_version.h>
namespace uta {
///

11
devel/wftk/files/patch-ac Normal file
View file

@ -0,0 +1,11 @@
--- uta/event.h.orig Sat Mar 31 05:24:44 2001
+++ uta/event.h Sat Mar 31 05:26:20 2001
@@ -21,7 +21,7 @@
#ifndef _EVENT_H
#define _EVENT_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "keysym.h"
#include "point.h"

11
devel/wftk/files/patch-ad Normal file
View file

@ -0,0 +1,11 @@
--- uta/keysym.h.orig Sat Mar 31 05:24:56 2001
+++ uta/keysym.h Sat Mar 31 05:26:32 2001
@@ -20,7 +20,7 @@
#ifndef KEYSYM_H
#define KEYSYM_H
-#include <SDL/SDL_keysym.h>
+#include <SDL11/SDL_keysym.h>
namespace uta {

11
devel/wftk/files/patch-ae Normal file
View file

@ -0,0 +1,11 @@
--- uta/mutex.h.orig Sat Mar 31 05:25:05 2001
+++ uta/mutex.h Sat Mar 31 05:26:54 2001
@@ -22,7 +22,7 @@
#ifndef _MUTEX_H_
#define _MUTEX_H_
-#include <SDL/SDL_mutex.h>
+#include <SDL11/SDL_mutex.h>
namespace uta {

11
devel/wftk/files/patch-af Normal file
View file

@ -0,0 +1,11 @@
--- uta/rect.h.orig Sat Mar 31 05:25:30 2001
+++ uta/rect.h Sat Mar 31 05:27:27 2001
@@ -21,7 +21,7 @@
#ifndef _RECT_H
#define _RECT_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "point.h"

14
devel/wftk/files/patch-ag Normal file
View file

@ -0,0 +1,14 @@
--- uta/sound.h.orig Sat Mar 31 05:25:38 2001
+++ uta/sound.h Sat Mar 31 05:27:39 2001
@@ -36,9 +36,9 @@
#endif
#ifdef HAVE_MIXER
-#include <SDL/SDL_mixer.h>
+#include <SDL11/SDL_mixer.h>
#else
-#include <SDL/SDL_types.h>
+#include <SDL11/SDL_types.h>
#endif
namespace uta {

11
devel/wftk/files/patch-ah Normal file
View file

@ -0,0 +1,11 @@
--- uta/surface.h.orig Sat Mar 31 05:25:49 2001
+++ uta/surface.h Sat Mar 31 05:27:49 2001
@@ -22,7 +22,7 @@
#ifndef _SURFACE_H_
#define _SURFACE_H_
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "color.h"
#include "point.h"

11
devel/wftk/files/patch-ai Normal file
View file

@ -0,0 +1,11 @@
--- uta/sge_blib.h.orig Sat Mar 31 05:44:18 2001
+++ uta/sge_blib.h Sat Mar 31 05:38:40 2001
@@ -18,7 +18,7 @@
#ifndef sge_blib_H
#define sge_blib_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_internal.h"

11
devel/wftk/files/patch-aj Normal file
View file

@ -0,0 +1,11 @@
--- uta/sge_blib.cc.orig Sat Mar 31 05:40:36 2001
+++ uta/sge_blib.cc Sat Mar 31 05:40:51 2001
@@ -19,7 +19,7 @@
* This is written by Johan E. Thélin and is slightly modified by me.
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_draw.h"
#include "sge_blib.h"

11
devel/wftk/files/patch-ak Normal file
View file

@ -0,0 +1,11 @@
--- uta/sge_draw.cc.orig Sat Mar 31 05:41:03 2001
+++ uta/sge_draw.cc Sat Mar 31 05:41:56 2001
@@ -20,7 +20,7 @@
* John Garrison's PowerPak
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include <math.h>
#include <string.h>
#include <stdarg.h>

11
devel/wftk/files/patch-al Normal file
View file

@ -0,0 +1,11 @@
--- uta/surface_io.cc.orig Sat Mar 31 05:41:28 2001
+++ uta/surface_io.cc Sat Mar 31 05:42:29 2001
@@ -79,7 +79,7 @@
#include <assert.h>
#include <png.h>
-#include <SDL/SDL_endian.h>
+#include <SDL11/SDL_endian.h>
namespace uta {

11
devel/wftk/files/patch-am Normal file
View file

@ -0,0 +1,11 @@
--- uta/timer.cc.orig Sat Mar 31 05:41:43 2001
+++ uta/timer.cc Sat Mar 31 05:42:38 2001
@@ -18,7 +18,7 @@
Boston, MA 02111-1307, SA.
*/
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "timer.h"
#include <stl.h>

11
devel/wftk/files/patch-an Normal file
View file

@ -0,0 +1,11 @@
--- uta/pixelformat.h.orig Sat Mar 31 05:51:51 2001
+++ uta/pixelformat.h Sat Mar 31 05:52:22 2001
@@ -27,7 +27,7 @@
//just for typedefs ...
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include <string>
#include <stl.h>

11
devel/wftk/files/patch-ao Normal file
View file

@ -0,0 +1,11 @@
--- uta/sge_draw.h.orig Sat Mar 31 05:52:07 2001
+++ uta/sge_draw.h Sat Mar 31 05:52:34 2001
@@ -18,7 +18,7 @@
#ifndef sge_draw_H
#define sge_draw_H
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
#include "sge_internal.h"

62
devel/wftk/files/patch-ap Normal file
View file

@ -0,0 +1,62 @@
--- acinclude.m4.orig Tue Nov 21 11:10:07 2000
+++ acinclude.m4 Sat Mar 31 06:08:52 2001
@@ -606,8 +606,8 @@
CHECK_LIB_HEADER_VERSION(
SDL,
SDL_Init,
- SDL/SDL.h,
- SDL/SDL_version.h,
+ SDL11/SDL.h,
+ SDL11/SDL_version.h,
SDL_MAJOR_VERSION.SDL_MINOR_VERSION.SDL_PATCHLEVEL,
$1,
http://www.devolution.com/~slouken/SDL/SDL-0.10/src/SDL-$1.tar.gz)
@@ -618,7 +618,7 @@
[
TEST_SKIP(
[
- AC_CHECK_HEADER(SDL/SDL_mixer.h,
+ AC_CHECK_HEADER(SDL11/SDL_mixer.h,
[
AC_DEFINE(HAVE_MIXER))
AC_CHECK_LIB([
@@ -1027,13 +1027,13 @@
if test x$sdl_exec_prefix != x ; then
sdl_args="$sdl_args --exec-prefix=$sdl_exec_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_exec_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_exec_prefix/bin/sdl11-config
fi
fi
if test x$sdl_prefix != x ; then
sdl_args="$sdl_args --prefix=$sdl_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_prefix/bin/sdl11-config
fi
fi
@@ -1067,7 +1067,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
char*
my_strdup (char *str)
@@ -1141,7 +1141,7 @@
LIBS="$LIBS $SDL_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
], [ return 0; ],
[ echo "*** The test program compiled, but did not run. This usually means"
echo "*** that the run-time linker is not finding SDL or finding the wrong"
@@ -1292,4 +1292,4 @@
AC_SUBST(SIGC_CFLAGS)
AC_SUBST(SIGC_LIBS)
-])
+])

11
devel/wftk/files/patch-aq Normal file
View file

@ -0,0 +1,11 @@
--- configure.in.orig Sat Mar 31 06:01:00 2001
+++ configure.in Sat Mar 31 06:01:12 2001
@@ -186,7 +186,7 @@
])
AM_CONDITIONAL(SMPEG_AVAILABLE, test x$have_smpeg = xyes)
-AC_CHECK_HEADER(SDL/SDL_mixer.h,AC_CHECK_LIB(SDL_mixer, Mix_SetPostMix, [
+AC_CHECK_HEADER(SDL11/SDL_mixer.h,AC_CHECK_LIB(SDL_mixer, Mix_SetPostMix, [
MIXLIBS=-lSDL_mixer
AC_DEFINE(HAVE_MIXER)
]))

56
devel/wftk/files/patch-ar Normal file
View file

@ -0,0 +1,56 @@
--- aclocal.m4.orig Wed Mar 21 13:44:06 2001
+++ aclocal.m4 Sat Mar 31 06:09:47 2001
@@ -618,8 +618,8 @@
CHECK_LIB_HEADER_VERSION(
SDL,
SDL_Init,
- SDL/SDL.h,
- SDL/SDL_version.h,
+ SDL11/SDL.h,
+ SDL11/SDL_version.h,
SDL_MAJOR_VERSION.SDL_MINOR_VERSION.SDL_PATCHLEVEL,
$1,
http://www.devolution.com/~slouken/SDL/SDL-0.10/src/SDL-$1.tar.gz)
@@ -630,7 +630,7 @@
[
TEST_SKIP(
[
- AC_CHECK_HEADER(SDL/SDL_mixer.h,
+ AC_CHECK_HEADER(SDL11/SDL_mixer.h,
[
AC_DEFINE(HAVE_MIXER))
AC_CHECK_LIB([
@@ -1039,13 +1039,13 @@
if test x$sdl_exec_prefix != x ; then
sdl_args="$sdl_args --exec-prefix=$sdl_exec_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_exec_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_exec_prefix/bin/sdl11-config
fi
fi
if test x$sdl_prefix != x ; then
sdl_args="$sdl_args --prefix=$sdl_prefix"
if test x${SDL_CONFIG+set} != xset ; then
- SDL_CONFIG=$sdl_prefix/bin/sdl-config
+ SDL_CONFIG=$sdl_prefix/bin/sdl11-config
fi
fi
@@ -1079,7 +1079,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
char*
my_strdup (char *str)
@@ -1153,7 +1153,7 @@
LIBS="$LIBS $SDL_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL11/SDL.h>
], [ return 0; ],
[ echo "*** The test program compiled, but did not run. This usually means"
echo "*** that the run-time linker is not finding SDL or finding the wrong"

1
devel/wftk/pkg-comment Normal file
View file

@ -0,0 +1 @@
A Graphical User Interface library for C++

6
devel/wftk/pkg-descr Normal file
View file

@ -0,0 +1,6 @@
libuta is a Graphical User Interface library for C++ that uses SDL
as its output layer. It allows application and game programmers to
put together portable graphical applications easily. libuta has a
range of already implemented widgets and uses libsigc++ as a signal
dispatching system. It also performs resource management and has a
sound system.

55
devel/wftk/pkg-plist Normal file
View file

@ -0,0 +1,55 @@
bin/uta-config
lib/libuta.so
lib/libuta-0.3.so.36
lib/libuta.a
include/uta/debug.h
include/uta/color.h
include/uta/point.h
include/uta/rect.h
include/uta/keysym.h
include/uta/event.h
include/uta/shared.h
include/uta/pixelformat.h
include/uta/painter.h
include/uta/progressdialog.h
include/uta/logo.h
include/uta/logo_data.h
include/uta/terminal.h
include/uta/directsurface.h
include/uta/mutex.h
include/uta/version.h
include/uta/uta.h
include/uta/timer.h
include/uta/dialogbox.h
include/uta/messagebox.h
include/uta/questionbox.h
include/uta/blitters.h
include/uta/mmx.h
include/uta/application.h
include/uta/button.h
include/uta/dialog.h
include/uta/focus.h
include/uta/font.h
include/uta/label.h
include/uta/lineedit.h
include/uta/listbox.h
include/uta/mixer.h
include/uta/mouse.h
include/uta/mouse_data.h
include/uta/movie.h
include/uta/multilineedit.h
include/uta/music.h
include/uta/pushbutton.h
include/uta/resources.h
include/uta/rootwindow.h
include/uta/sample.h
include/uta/screensurface.h
include/uta/slider.h
include/uta/sound.h
include/uta/soundmapper.h
include/uta/surface.h
include/uta/togglebutton.h
include/uta/widget.h
share/aclocal/uta.m4
@dirrm include/uta