update to 0.6.0.729

bump PORTEPOCH
This commit is contained in:
Oliver Lehmann 2009-05-06 04:46:11 +00:00
parent 8721736f29
commit 22fb2ca9e7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=233287
5 changed files with 54 additions and 44 deletions

View file

@ -6,12 +6,13 @@
#
PORTNAME= gigi
PORTVERSION= 0.7.0
PORTVERSION= 0.6.0.729
PORTEPOCH= 1
CATEGORIES= x11-toolkits
MASTER_SITES= SF
DISTNAME= GG-${PORTVERSION}
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= oliver
MAINTAINER= ports@FreeBSD.org
MAINTAINER= oliver@FreeBSD.org
COMMENT= OpenGL Graphic User Interface Library
LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
@ -20,23 +21,25 @@ LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
USE_SCONS= yes
SCONS_ARGS= prefix="" pkgconfigdir=""
USE_BZIP2= yes
USE_SDL= sdl
USE_LDCONFIG= yes
# Ensure local headers are found first, otherwise updating would fail.
CFLAGS+= -I.
OPTIONS= OGRE "Enable Ogre (3D engine) support" off
OPTIONS= OGRE "Enable Ogre (3D engine) support" on
SHLIB_VER= 0
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
GIGI_LIBS= GiGi GiGiSDL
WRKSRC= ${WRKDIR}/gigi/GG
.include <bsd.port.pre.mk>
.if defined(WITH_OGRE)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
BUILD_DEPENDS+= ${LOCALBASE}/lib/libOgreMain-1.6.2.so:${PORTSDIR}/graphics/ogre3d \
${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
RUN_DEPENDS+= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
RUN_DEPENDS+= ${LOCALBASE}/lib/libOgreMain-1.6.2.so:${PORTSDIR}/graphics/ogre3d \
${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
PLIST_SUB+= OGRE=""
GIGI_LIBS+= GiGiOgre
@ -49,26 +52,13 @@ PLIST_SUB+= OGRE="@comment "
BROKEN= Does not compile
.endif
post-patch:
${REINPLACE_CMD} -E 's|#include <boost/serialization/is_abstract.hpp>||g; \
s|BOOST_IS_ABSTRACT.*||g' \
${WRKSRC}/GG/BrowseInfoWnd.h \
${WRKSRC}/GG/Control.h
@rm -f ${WRKSRC}/GG/BrowseInfoWnd.h.bak ${WRKSRC}/GG/Control.h.bak
${REINPLACE_CMD} -E 's|system_error\(\) == EIO|code\(\) == boost::system::posix_error::io_error|g; \
s|filesystem/cerrno|system/system_error|g' \
${WRKSRC}/src/dialogs/FileDlg.cpp
# for graphics/ogre3d version 1.6.x
# ${REINPLACE_CMD} -E 's|CMPF_ALWAYS_PASS, 0)|CMPF_ALWAYS_PASS, 0, false)|g' \
# ${WRKSRC}/src/Ogre/OgreGUI.cpp
post-build:
@${REINPLACE_CMD} -Ee 's,^(prefix|(lib|include)dir)=,&${PREFIX},' \
${WRKSRC}/*.pc
do-install:
${MKDIR} ${PREFIX}/include/GG
${CP} -R ${WRKSRC}/GG/* ${PREFIX}/include/GG
cd ${WRKSRC}/GG && ${FIND} . -name "*.h" -depth | ${CPIO} -pdmv ${PREFIX}/include/GG
.for lib in ${GIGI_LIBS}
${INSTALL_PROGRAM} ${WRKSRC}/lib${lib}.so \
${PREFIX}/lib/lib${lib}.so.${SHLIB_VER}

View file

@ -1,3 +1,3 @@
MD5 (GG-0.7.0.tar.gz) = 360e7131fde11da55efbdd555eabf665
SHA256 (GG-0.7.0.tar.gz) = f4ef86c2b8344085217163b6310f9c2f868929a22e864eebb200786f42a0aa54
SIZE (GG-0.7.0.tar.gz) = 1730169
MD5 (gigi-0.6.0.729.tar.bz2) = ccce51b71f7be1cdf65677bcf2d3cf00
SHA256 (gigi-0.6.0.729.tar.bz2) = 9df2d9d768208fe59b637e4d5b5745988689a63d5d473b7924789e1f62750ed8
SIZE (gigi-0.6.0.729.tar.bz2) = 901294

View file

@ -1,20 +1,20 @@
--- ./SConstruct.orig Wed Aug 29 19:33:24 2007
+++ ./SConstruct Wed Sep 5 17:54:37 2007
@@ -45,6 +45,11 @@
options.Add('with_devil', 'Root directory of DevIL installation')
options.Add('with_devil_include', 'Specify exact include dir for DevIL headers')
options.Add('with_devil_libdir', 'Specify exact library dir for DevIL library')
--- SConstruct.orig 2009-04-09 16:43:28.000000000 +0200
+++ SConstruct 2009-04-09 16:56:22.000000000 +0200
@@ -82,6 +82,11 @@
options.Add('with_ois', 'Root directory of OIS installation (only applicable when build_ogre_ois_plugin=1)')
options.Add('with_ois_include', 'Specify exact include dir for OIS headers (only applicable when build_ogre_ois_plugin=1)')
options.Add('with_ois_libdir', 'Specify exact library dir for OIS library (only applicable when build_ogre_ois_plugin=1)')
+options.Add('CC', 'C compiler')
+options.Add('CXX', 'C++ compiler')
+options.Add('CCFLAGS', 'C compiler flags', Split(''))
+options.Add('CPPPATH', 'Compiler include path', Split(''))
+options.Add('LIBPATH', 'Linker library path', Split(''))
##################################################
# Drivers #
@@ -124,6 +129,10 @@
options.Update(env)
@@ -155,6 +160,10 @@
if os.environ.has_key('PKG_CONFIG_PATH'):
env['ENV']['PKG_CONFIG_PATH'] = os.environ['PKG_CONFIG_PATH']
+env['CCFLAGS'] = Split(env['CCFLAGS'])
+env['CPPPATH'] = Split(env['CPPPATH'])
@ -23,27 +23,26 @@
if env.has_key('use_distcc') and env['use_distcc']:
env['CC'] = 'distcc %s' % env['CC']
env['CXX'] = 'distcc %s' % env['CXX']
@@ -274,6 +283,15 @@
@@ -301,6 +310,15 @@
else:
print 'Configuring unknown system (assuming the system is POSIX-like) ...'
+ # pthreads
+ if str(Platform()) == 'posix':
+ if env['multithreaded']:
+ # pthreads
+ if str(Platform()) == 'posix':
+ if env['multithreaded']:
+ if conf.CheckCHeader('pthread.h') and conf.CheckLib('pthread', 'pthread_create', autoadd = 0):
+ env.Append(CCFLAGS = ['-pthread'])
+ env.Append(LINKFLAGS = ['-pthread'])
+ else:
+ Exit(1)
+
signals_namespace = 'signals'
if OptionValue('boost_signals_namespace', env):
signals_namespace = OptionValue('boost_signals_namespace', env)
env.Append(CPPDEFINES = [
@@ -288,15 +306,6 @@
]
@@ -318,15 +336,6 @@
if not conf.CheckBoost(boost_version_string, boost_libs, conf, not ms_linker):
Exit(1)
-
- # pthreads
- if str(Platform()) == 'posix':
- if env['multithreaded']:
@ -52,6 +51,7 @@
- env.Append(LINKFLAGS = ['-pthread'])
- else:
- Exit(1)
-
# GL and GLU
if str(Platform()) == 'win32':
env.Append(LIBS = [

View file

@ -0,0 +1,11 @@
--- src/Font.cpp.orig 2009-04-13 08:50:10.000000000 +0200
+++ src/Font.cpp 2009-04-13 08:51:06.000000000 +0200
@@ -1218,7 +1218,7 @@
boost::uint8_t* src = src_start + row * glyph_bitmap.pitch;
boost::uint16_t* dst = dst_start + (row + Value(y_offset)) * Value(BUF_WIDTH);
for (int col = 0; col < glyph_bitmap.width; ++col) {
-#ifdef __BIG_ENDIAN__
+#if (_BYTE_ORDER == _BIG_ENDIAN)
*dst++ = *src++ | (255 << 8); // big-endian uses different byte ordering
#else
*dst++ = (*src++ << 8) | 255; // alpha is the value from glyph_bitmap; luminance is always 100% white

View file

@ -1,8 +1,10 @@
include/GG/AdamGlue.h
include/GG/AlignmentFlags.h
include/GG/Base.h
include/GG/BrowseInfoWnd.h
include/GG/Button.h
include/GG/Clr.h
include/GG/Config.h
include/GG/Control.h
include/GG/Cursor.h
include/GG/DrawUtil.h
@ -14,11 +16,13 @@ include/GG/EventPump.h
include/GG/Exception.h
include/GG/Flags.h
include/GG/Font.h
include/GG/FontFwd.h
include/GG/GUI.h
include/GG/Layout.h
include/GG/ListBox.h
include/GG/Menu.h
include/GG/MultiEdit.h
include/GG/MultiEditFwd.h
include/GG/Ogre/OgreGUI.h
include/GG/PluginInterface.h
include/GG/PtRect.h
@ -38,11 +42,13 @@ include/GG/SignalsAndSlots.h
include/GG/Slider.h
include/GG/Spin.h
include/GG/StaticGraphic.h
include/GG/StrongTypedef.h
include/GG/StyleFactory.h
include/GG/TabWnd.h
include/GG/TextControl.h
include/GG/Texture.h
include/GG/Timer.h
include/GG/UnicodeCharsets.h
include/GG/Wnd.h
include/GG/WndEditor.h
include/GG/WndEvent.h
@ -50,10 +56,12 @@ include/GG/ZList.h
include/GG/dialogs/ColorDlg.h
include/GG/dialogs/FileDlg.h
include/GG/dialogs/ThreeButtonDlg.h
include/GG/gen_signals.py
include/GG/glext.h
include/GG/ltdl.h
include/GG/ltdl_config.h
include/GG/utf8/checked.h
include/GG/utf8/core.h
include/GG/utf8/unchecked.h
lib/libGiGi.so
lib/libGiGi.so.0
%%OGRE%%lib/libGiGiOgre.so
@ -66,4 +74,5 @@ libdata/pkgconfig/GiGiSDL.pc
@dirrm include/GG/dialogs
@dirrm include/GG/SDL
@dirrm include/GG/Ogre
@dirrm include/GG/utf8
@dirrm include/GG