- Update to 3.6.7
- Add new rc.d script PR: 96667 Submitted by: Andrew Pantyukhin <infofarmer___gmail.com> Approved by: maintainer
This commit is contained in:
parent
21661f7ed1
commit
230fa6ce6e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=161531
6 changed files with 27 additions and 93 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= ddclient
|
||||
PORTVERSION= 3.6.6
|
||||
PORTVERSION= 3.6.7
|
||||
CATEGORIES= dns
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -15,37 +15,30 @@ MAINTAINER= radek@raadradd.com
|
|||
COMMENT= Update dynamic DNS entries
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_PERL5= yes
|
||||
USE_PERL5_RUN= yes
|
||||
NO_BUILD= yes
|
||||
USE_RC_SUBR= yes
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
|
||||
PLIST_FILES= etc/ddclient.conf.sample \
|
||||
etc/rc.d/ddclient.sh \
|
||||
sbin/ddclient
|
||||
SUB_FILES= pkg-message
|
||||
PKGMESSAGE= ${WRKDIR}/pkg-message
|
||||
PLIST_FILES= etc/ddclient.conf.sample sbin/ddclient
|
||||
|
||||
PORTDOCS= COPYING COPYRIGHT Changelog README README.cisco \
|
||||
sample-etc_cron.d_ddclient sample-etc_dhclient-exit-hooks \
|
||||
sample-etc_dhcpc_dhcpcd-eth0.exe sample-etc_ppp_ip-up.local
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's|/etc/ddclient/|${PREFIX}/etc/ddclient/|g' ${WRKSRC}/README
|
||||
@${GREP} -lr '/usr' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g'
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
|
||||
-e 's|/usr.*perl|${PERL}|g' ${WRKSRC}/ddclient
|
||||
|
||||
do-install:
|
||||
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g; s|%%PERL%%|${PERL}|g' ${WRKSRC}/ddclient
|
||||
@${PERL} -pe 's|%%PREFIX%%|${PREFIX}|g; s|%%RC_SUBR%%|${RC_SUBR}|g' \
|
||||
< ${FILESDIR}/ddclient.sh > ${WRKDIR}/ddclient.sh
|
||||
@${INSTALL_DATA} ${WRKSRC}/sample-etc_ddclient.conf ${PREFIX}/etc/ddclient.conf.sample
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/ddclient ${PREFIX}/sbin
|
||||
@${INSTALL_SCRIPT} ${WRKDIR}/ddclient.sh ${PREFIX}/etc/rc.d/
|
||||
|
||||
post-install:
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/ddclient ${PREFIX}/sbin/
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for i in ${PORTDOCS}
|
||||
@${PERL} -pe 's|%%PREFIX%%|${PREFIX}|g' < ${WRKSRC}/$i > ${WRKDIR}/$i
|
||||
@${INSTALL_DATA} ${WRKDIR}/${i} ${DOCSDIR}
|
||||
.endfor
|
||||
@${INSTALL} -d ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
|
||||
.endif
|
||||
@${PERL} -pe 's|/usr/local|${PREFIX}|g' < ${PKGMESSAGE}
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (ddclient-3.6.6.tar.bz2) = 5fd0f82446fbed857c841a4deb83cdb9
|
||||
SHA256 (ddclient-3.6.6.tar.bz2) = 70ede28229ec944634ac67734e37d04c47e0df38b376a2478089c21b0005bb2d
|
||||
SIZE (ddclient-3.6.6.tar.bz2) = 34009
|
||||
MD5 (ddclient-3.6.7.tar.bz2) = b07a29a891dcf40b941b9bc5ef3ce598
|
||||
SHA256 (ddclient-3.6.7.tar.bz2) = d8b6a1b23cd8ef46ae3a5060e98f31f1f439c688e3fd3e16badf97e7763eba67
|
||||
SIZE (ddclient-3.6.7.tar.bz2) = 35040
|
||||
|
|
|
@ -2,26 +2,26 @@
|
|||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
# PROVIDE: ddclient
|
||||
# REQUIRE: LOGIN
|
||||
# KEYWORD: shutdown
|
||||
|
||||
#
|
||||
# Add the following line to /etc/rc.conf to enable ddclient:
|
||||
#
|
||||
#ddclient_enable="YES"
|
||||
# ddclient_enable="YES"
|
||||
#
|
||||
ddclient_enable=${ddclient_enable-"NO"}
|
||||
ddclient_flags=${ddclient_flags-"-daemon 300"}
|
||||
|
||||
. %%RC_SUBR%%
|
||||
|
||||
name="ddclient"
|
||||
rcvar=`set_rcvar`
|
||||
rcvar=${name}_enable
|
||||
|
||||
command="%%PREFIX%%/sbin/${name}"
|
||||
required_files="%%PREFIX%%/etc/${name}.conf"
|
||||
|
||||
load_rc_config ${name}
|
||||
|
||||
: ${ddclient_enable="NO"}
|
||||
: ${ddclient_flags="-daemon 300"}
|
||||
|
||||
run_rc_command "$1"
|
|
@ -1,50 +0,0 @@
|
|||
--- sample-etc_cron.d_ddclient.orig Sun Oct 24 03:48:56 2004
|
||||
+++ sample-etc_cron.d_ddclient Sun Oct 24 03:49:48 2004
|
||||
@@ -10,8 +10,8 @@
|
||||
######################################################################
|
||||
## force an update twice a month (only if you are not using daemon-mode)
|
||||
##
|
||||
-## 30 23 1,15 * * root /usr/sbin/ddclient -daemon=0 -syslog -quiet -force
|
||||
+## 30 23 1,15 * * root %%PREFIX%%/sbin/ddclient -daemon=0 -syslog -quiet -force
|
||||
######################################################################
|
||||
## retry failed updates every hour (only if you are not using daemon-mode)
|
||||
##
|
||||
-##0 * * * * root /usr/sbin/ddclient -daemon=0 -syslog -quiet retry
|
||||
+##0 * * * * root %%PREFIX%%/sbin/ddclient -daemon=0 -syslog -quiet retry
|
||||
--- sample-etc_dhclient-exit-hooks.orig Sun Oct 24 03:51:37 2004
|
||||
+++ sample-etc_dhclient-exit-hooks Sun Oct 24 03:52:20 2004
|
||||
@@ -2,10 +2,10 @@
|
||||
######################################################################
|
||||
## $Header: /cvsroot/ddclient/ddclient/sample-etc_dhclient-exit-hooks,v 1.1.1.1 2004/08/13 22:29:17 wimpunk Exp $
|
||||
######################################################################
|
||||
-# The /etc/dhclient-enter-hooks script is run by the ISC DHCP client's standard
|
||||
+# The /etc/dhclient-exit-hooks script is run by the ISC DHCP client's standard
|
||||
# update script whenever dhclient obtains or renews an address.
|
||||
|
||||
-PATH=/usr/sbin:${PATH}
|
||||
+PATH=%%PREFIX%%/sbin:${PATH}
|
||||
case "$new_ip_address" in
|
||||
10.*) ;;
|
||||
172.1[6-9].* | 172.2[0-9].* | 172.3[0-1].*) ;;
|
||||
--- sample-etc_dhcpc_dhcpcd-eth0.exe.orig Sun Oct 24 03:52:38 2004
|
||||
+++ sample-etc_dhcpc_dhcpcd-eth0.exe Sun Oct 24 03:52:58 2004
|
||||
@@ -2,7 +2,7 @@
|
||||
######################################################################
|
||||
## $Header: /cvsroot/ddclient/ddclient/sample-etc_dhcpc_dhcpcd-eth0.exe,v 1.1 2004/10/07 19:19:37 wimpunk Exp $
|
||||
######################################################################
|
||||
-PATH=/usr/sbin:${PATH}
|
||||
+PATH=%%PREFIX%%/sbin:${PATH}
|
||||
|
||||
## update the DNS server unless the IP address is a private address
|
||||
## that may be used as a internal LAN address. This may be true if
|
||||
--- sample-etc_ppp_ip-up.local.orig Sun Oct 24 03:53:15 2004
|
||||
+++ sample-etc_ppp_ip-up.local Sun Oct 24 03:54:06 2004
|
||||
@@ -16,7 +16,7 @@
|
||||
## in the environment as either PPP_LOCAL or IPLOCAL.
|
||||
##
|
||||
######################################################################
|
||||
-PATH=/usr/sbin:${PATH}
|
||||
+PATH=%%PREFIX%%/sbin:${PATH}
|
||||
IP=
|
||||
IP=${IP:-$PPP_LOCAL}
|
||||
IP=${IP:-$IPLOCAL}
|
|
@ -1,12 +1,5 @@
|
|||
--- ddclient.orig Sun Oct 24 03:45:24 2004
|
||||
+++ ddclient Sun Oct 24 03:47:57 2004
|
||||
@@ -1,5 +1,4 @@
|
||||
-#!/usr/bin/perl -w
|
||||
-#!/usr/local/bin/perl -w
|
||||
+#!%%PERL%% -w
|
||||
######################################################################
|
||||
# $Header: /cvsroot/ddclient/ddclient/ddclient,v 1.5 2004/10/17 21:31:31 wimpunk Exp $
|
||||
#
|
||||
--- ./ddclient.orig Sun Dec 18 18:03:42 2005
|
||||
+++ ./ddclient Tue May 2 18:38:16 2006
|
||||
@@ -21,8 +20,8 @@
|
||||
$program =~ s/d$//;
|
||||
my $now = time;
|
|
@ -1,10 +1,9 @@
|
|||
|
||||
***********************************************************
|
||||
Copy
|
||||
|
||||
/usr/local/etc/ddclient.conf.sample
|
||||
Copy
|
||||
%%PREFIX%%/etc/ddclient.conf.sample
|
||||
to
|
||||
/usr/local/etc/ddclient.conf
|
||||
%%PREFIX%%/etc/ddclient.conf
|
||||
|
||||
and edit it to fit your needs.
|
||||
|
||||
|
@ -14,4 +13,3 @@ following line to /etc/rc.conf
|
|||
ddclient_enable="YES"
|
||||
|
||||
***********************************************************
|
||||
|
Loading…
Reference in a new issue