emulators/yabause: Update version 0.9.11.1 => 0.9.13.1 and stage
PR: 191820 Submitted by: Ports Fury
This commit is contained in:
parent
0f281435fc
commit
231c809495
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=361669
8 changed files with 77 additions and 52 deletions
|
@ -2,52 +2,34 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= yabause
|
||||
PORTVERSION= 0.9.11.1
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 0.9.13.1
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:S/1.1/1/g}/
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Sega Saturn system emulator
|
||||
|
||||
LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
|
||||
LICENSE= GPLv2 # (or later)
|
||||
|
||||
USE_AUTOTOOLS= automake:env autoconf:env aclocal:env
|
||||
GNU_CONFIGURE= yes
|
||||
USES= gmake openal:soft
|
||||
USES= cmake openal:soft pkgconfig
|
||||
USE_XORG= xmu xrandr
|
||||
USE_GL= gl glu glut
|
||||
USE_GNOME= #
|
||||
USE_SDL= yes
|
||||
USE_SDL= sdl
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
MAN1= yabause.1
|
||||
|
||||
OPTIONS_DEFINE= QT4
|
||||
OPTIONS_SINGLE= GUI
|
||||
OPTIONS_SINGLE_GUI= GTK2 QT4
|
||||
OPTIONS_DEFAULT= QT4
|
||||
QT4_DESC= Build wit qt4 interface instead of gtk2 one
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.options.mk>
|
||||
GTK2_LIB_DEPENDS= libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
|
||||
GTK2_USE= gnome=gtk20
|
||||
GTK2_CMAKE_ON= -DYAB_PORTS:STRING=gtk
|
||||
QT4_USE= qt4=corelib,gui,opengl \
|
||||
qt4=moc_build,qmake_build,rcc_build,uic_build
|
||||
QT4_CMAKE_ON= -DYAB_PORTS:STRING=qt
|
||||
|
||||
.if ${PORT_OPTIONS:MQT4}
|
||||
USE_QT4= corelib gui opengl
|
||||
CONFIGURE_ARGS+= --with-port=qt
|
||||
.else
|
||||
USE_GNOME= gtk20
|
||||
CONFIGURE_ARGS+= --with-port=gtk
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s|%%ACLOCAL%%|${ACLOCAL}|g" -e "s|%%AUTOCONF%%|${AUTOCONF}|g" \
|
||||
-e "s|%%AUTOMAKE%%|${AUTOMAKE}|g" ${WRKSRC}/autogen.sh
|
||||
@${REINPLACE_CMD} -e "s|0.9.10|${PORTVERSION}|g" ${WRKSRC}/configure.in
|
||||
|
||||
pre-configure:
|
||||
@cd ${WRKSRC} && ${SH} autogen.sh
|
||||
|
||||
post-install:
|
||||
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (yabause-0.9.11.1.tar.gz) = 42538eb31232f8bdd2e6e19ad797d556e6e787b57ac0a2a21e0fe7c407b32bca
|
||||
SIZE (yabause-0.9.11.1.tar.gz) = 1882934
|
||||
SHA256 (yabause-0.9.13.1.tar.gz) = f76f9deca59ab91f8a463792611336962510868d3dc8bdd23e9215a26b7cc175
|
||||
SIZE (yabause-0.9.13.1.tar.gz) = 1634482
|
||||
|
|
|
@ -1,7 +0,0 @@
|
|||
--- autogen.sh.orig 2012-03-25 20:41:13.000000000 -0500
|
||||
+++ autogen.sh 2012-03-25 20:42:38.000000000 -0500
|
||||
@@ -1,2 +1,2 @@
|
||||
-aclocal && autoconf && automake --add-missing --copy
|
||||
-cd src/c68k && aclocal && autoconf && automake
|
||||
+%%ACLOCAL%% && %%AUTOCONF%% && %%AUTOMAKE%% --add-missing --copy
|
||||
+cd src/c68k && %%ACLOCAL%% && %%AUTOCONF%% && %%AUTOMAKE%%
|
24
emulators/yabause/files/patch-src__CMakeLists.txt
Normal file
24
emulators/yabause/files/patch-src__CMakeLists.txt
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- src/CMakeLists.txt.orig
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -88,6 +88,12 @@
|
||||
add_definitions(-DHAVE_BUILTIN_BSWAP16=1)
|
||||
endif()
|
||||
|
||||
+# __builtin_bswap32
|
||||
+check_function_exists(__builtin_bswap32 BSWAP32_OK)
|
||||
+if (BSWAP32_OK)
|
||||
+ add_definitions(-DHAVE_BUILTIN_BSWAP32=1)
|
||||
+endif()
|
||||
+
|
||||
# sys/time.h
|
||||
check_include_file("sys/time.h" SYSTIME_OK)
|
||||
if (SYSTIME_OK)
|
||||
@@ -527,7 +533,7 @@
|
||||
set(YAB_PORT_BUILT TRUE PARENT_SCOPE)
|
||||
endmacro(yab_port_success)
|
||||
|
||||
-set(YAB_MAN_DIR "share/man")
|
||||
+set(YAB_MAN_DIR "man")
|
||||
if (NOT $ENV{PKGMANDIR} STREQUAL "")
|
||||
set(YAB_MAN_DIR $ENV{PKGMANDIR})
|
||||
endif ()
|
13
emulators/yabause/files/patch-src__core.h
Normal file
13
emulators/yabause/files/patch-src__core.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/core.h.orig
|
||||
+++ src/core.h
|
||||
@@ -252,8 +252,10 @@
|
||||
# define BSWAP16(x) ((__builtin_bswap16((x) >> 16) << 16) | __builtin_bswap16((x)))
|
||||
# define BSWAP16L(x) (__builtin_bswap16((x)))
|
||||
#endif
|
||||
+#ifdef HAVE_BUILTIN_BSWAP32
|
||||
# define BSWAP32(x) (__builtin_bswap32((x)))
|
||||
#endif
|
||||
+#endif
|
||||
|
||||
#ifdef _MSC_VER
|
||||
# define BSWAP16(x) ((_byteswap_ushort((x) >> 16) << 16) | _byteswap_ushort((x)))
|
12
emulators/yabause/files/patch-src__qt__YabauseThread.cpp
Normal file
12
emulators/yabause/files/patch-src__qt__YabauseThread.cpp
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/qt/YabauseThread.cpp.orig
|
||||
+++ src/qt/YabauseThread.cpp
|
||||
@@ -18,6 +18,9 @@
|
||||
along with Yabause; if not, write to the Free Software
|
||||
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
||||
*/
|
||||
+
|
||||
+#include <time.h>
|
||||
+
|
||||
#include "YabauseThread.h"
|
||||
#include "Settings.h"
|
||||
#include "VolatileSettings.h"
|
|
@ -1,6 +1,4 @@
|
|||
Yabause is a Sega Saturn emulator. It currently runs on GNU/Linux, FreeBSD and
|
||||
is being ported to Microsoft Windows and Mac OS X. It is also ported to the
|
||||
Sega Dreamcast as a separate project. It is written in C using the SDL and
|
||||
Yabause is a Sega Saturn emulator. It is written in C using the SDL and
|
||||
OpenGL libraries with support for cdrom and iso files.
|
||||
|
||||
WWW: http://yabause.sourceforge.net/
|
||||
WWW: http://yabause.sourceforge.net/
|
||||
|
|
|
@ -1,12 +1,15 @@
|
|||
bin/yabause
|
||||
man/man1/yabause.1.gz
|
||||
share/applications/yabause.desktop
|
||||
share/pixmaps/yabause.png
|
||||
%%DATADIR%%/yts/de.yts
|
||||
%%DATADIR%%/yts/es.yts
|
||||
%%DATADIR%%/yts/fr.yts
|
||||
%%DATADIR%%/yts/it.yts
|
||||
%%DATADIR%%/yts/lt.yts
|
||||
%%DATADIR%%/yts/nl.yts
|
||||
%%DATADIR%%/yts/pt.yts
|
||||
%%DATADIR%%/yts/pt_BR.yts
|
||||
%%DATADIR%%/yts/sv.yts
|
||||
share/pixmaps/yabause.png
|
||||
@dirrmtry share/yabause/yts
|
||||
@dirrmtry share/yabause
|
||||
@dirrm %%DATADIR%%/yts
|
||||
@dirrm %%DATADIR%%
|
||||
|
|
Loading…
Reference in a new issue