www/py-django-smart-selects: Update to 1.6.0

* Remove LICENSE from ${FILESDIR} as the license file is already
  supplied with the sdist.

* devel/py-setuptools-scm is only required for build as it's also
  defined in setup.py.

* Prevent the installation of the test suite to avoid installation
  conflicts. [1]

Changelog:

https://github.com/jazzband/django-smart-selects/releases/tag/1.6.0

PR:		277000, 262759 [1]
Approved by:	maintainer timeout (3+ weeks)
This commit is contained in:
Kai Knoblich 2024-03-09 15:17:47 +01:00
parent 90d0d2fa5a
commit 2328d0f164
4 changed files with 22 additions and 37 deletions

View File

@ -1,6 +1,5 @@
PORTNAME= django-smart-selects
PORTVERSION= 1.5.9
PORTREVISION= 1
PORTVERSION= 1.6.0
CATEGORIES= www
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -10,12 +9,12 @@ COMMENT= Quickly filter or group "chained" models
WWW= https://github.com/jazzband/django-smart-selects
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${FILESDIR}/LICENSE
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools-scm>0:devel/py-setuptools-scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}django32>0:www/py-django32@${PY_FLAVOR}
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools-scm>0:devel/py-setuptools-scm@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=2.2:www/py-django32@${PY_FLAVOR}
USES= python:run
USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1618936160
SHA256 (django-smart-selects-1.5.9.tar.gz) = 2b87362c15c0e80ba10d71955b85a486a50bd00ac72bb9014b25e4a3715988c2
SIZE (django-smart-selects-1.5.9.tar.gz) = 25967
TIMESTAMP = 1707669089
SHA256 (django-smart-selects-1.6.0.tar.gz) = 67ce449bf456ddb6fc5434fa1a55f21194ef11a3b6871d7454f7f7c5a30bf493
SIZE (django-smart-selects-1.6.0.tar.gz) = 263290

View File

@ -1,28 +0,0 @@
Copyright (c) 2009, Patrick Lauber
All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:
* Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials provided
with the distribution.
* Neither the name of the author nor the names of other
contributors may be used to endorse or promote products derived
from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

View File

@ -0,0 +1,14 @@
Avoid the installation of the test suite in the top-level directory
of ${PYTHON_SITELIBDIR}.
--- setup.py.orig 2024-02-12 05:03:25 UTC
+++ setup.py
@@ -14,7 +14,7 @@ setup(
author="Patrick Lauber",
author_email="digi@treepy.com",
url="https://github.com/jazzband/django-smart-selects",
- packages=find_packages(),
+ packages=find_packages(exclude=['test_app*']),
include_package_data=True,
python_requires=">=3.6",
install_requires=["django>=2.2"],