No-one apparently cares enough to update this port
from the old, insecure version. Goodbye! :)
This commit is contained in:
parent
5b398407cb
commit
236b21797c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36984
17 changed files with 0 additions and 380 deletions
|
@ -16,7 +16,6 @@
|
|||
SUBDIR += arts++
|
||||
SUBDIR += ascend-radius
|
||||
SUBDIR += balance
|
||||
SUBDIR += bb
|
||||
SUBDIR += bind8
|
||||
SUBDIR += bind9
|
||||
SUBDIR += bing
|
||||
|
|
|
@ -1,57 +0,0 @@
|
|||
# New ports collection makefile for: bb
|
||||
# Date created: So 17 Nov 1996 16:59:23 MET
|
||||
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= bb
|
||||
PORTVERSION= 1.2a
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://maclawran.ca/~sean/bb-dnld/ \
|
||||
http://freefall.freebsd.org/~andreas/download/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
FORBIDDEN= "Remote buffer overflow in bbd"
|
||||
|
||||
# The FreeBSD Ports Team has permission to include this in our CDROM
|
||||
# from the author, but others who wish to do likewise will have to
|
||||
# contact Sean MacGuire <sean@iti.qc.ca>.
|
||||
|
||||
WRKSRC= ${WRKDIR}/bb
|
||||
|
||||
pre-configure:
|
||||
@${ECHO_MSG} "==================================================="
|
||||
@${ECHO_MSG} "You need to install a WWW Server to use this port"
|
||||
@${ECHO_MSG} "For example: - apache13 or "
|
||||
@${ECHO_MSG} " - apache13-modssl
|
||||
@${ECHO_MSG} "port."
|
||||
@${ECHO_MSG} "==================================================="
|
||||
|
||||
post-configure:
|
||||
( cd ${WRKSRC}/doc; ${SH} bbconfig freebsd )
|
||||
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
|
||||
|
||||
do-install:
|
||||
@cd ${WRKDIR} && find . -name "*.orig" | xargs ${RM}
|
||||
@cd ${WRKDIR}; tar --exclude 'src' -c -f - bb \
|
||||
| ( cd ${PREFIX}; tar xpf - )
|
||||
@${RM} -f ${PREFIX}/share/doc/apache/manual/bb
|
||||
@${MKDIR} ${PREFIX}/share/doc/apache/manual
|
||||
@${LN} -fs ${PREFIX}/bb/www ${PREFIX}/share/doc/apache/manual/bb
|
||||
@${LN} -fs bb.html ${PREFIX}/bb/www/index.html
|
||||
@${MKDIR} ${PREFIX}/share/apache/cgi-bin
|
||||
@${LN} -fs ${PREFIX}/bb/web/bb-ack.sh ${PREFIX}/share/apache/cgi-bin
|
||||
@${MV} -f ${PREFIX}/bb/doc/bbclient ${PREFIX}/bb/bin
|
||||
@${MV} -f ${PREFIX}/bb/doc/bbconfig ${PREFIX}/bb/bin
|
||||
@${MV} -f ${PREFIX}/bb/doc ${PREFIX}/share/doc/bb
|
||||
@${MKDIR} ${PREFIX}/share/bb/bbclients
|
||||
@${TOUCH} ${PREFIX}/share/bb/bbclients/.keep_me
|
||||
@${RM} ${PREFIX}/bb/KNOWN.BUGS
|
||||
@${RM} ${PREFIX}/bb/README
|
||||
@${RM} ${PREFIX}/bb/README.CHANGES
|
||||
@${RM} ${PREFIX}/bb/README.INSTALL
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1 +0,0 @@
|
|||
MD5 (bb-1.2a.tar.gz) = 59d36875647c2cfcd3bee93510732be1
|
|
@ -1,2 +0,0 @@
|
|||
all:
|
||||
( cd src && make all install )
|
|
@ -1,5 +0,0 @@
|
|||
#! /bin/sh
|
||||
|
||||
# $FreeBSD$
|
||||
|
||||
!!PREFIX!!/bb/runbb.sh &
|
|
@ -1,20 +0,0 @@
|
|||
--- src/Makefile.freebsd.orig Sun Jun 27 12:02:36 1999
|
||||
+++ src/Makefile.freebsd Sun Jun 27 12:03:08 1999
|
||||
@@ -1,6 +1,6 @@
|
||||
SHELL = /bin/sh
|
||||
-MAKE = make
|
||||
-CC = gcc
|
||||
+MAKE ?= make
|
||||
+CC ?= gcc
|
||||
|
||||
# FLAGS REQUIRED FOR PORTING
|
||||
# SUNOS 4.1.4, HPUX 10.0, and LINUX NEED NOTHING DEFINED
|
||||
@@ -13,7 +13,7 @@
|
||||
#LIBS = -ll -lnsl -lsocket # SOLARIS NEEDS THIS
|
||||
|
||||
# FREEBSD NEEDS SPECIAL ZOMBIE HANDLING
|
||||
-CFLAGS=-DZOMBIE -O
|
||||
+CFLAGS+=-DZOMBIE
|
||||
|
||||
all: bb bbd bbnet touchtime
|
||||
|
|
@ -1,20 +0,0 @@
|
|||
--- runbb.sh.orig Sun Jun 27 12:08:56 1999
|
||||
+++ runbb.sh Sun Jun 27 12:09:57 1999
|
||||
@@ -17,7 +17,7 @@
|
||||
# BBHOME IS THE ROOT DIRECTORY OF BIG BROTHER!!!
|
||||
# YOU MUST SET THE NEXT LINE TO WHERE BB LIVES
|
||||
|
||||
-BBHOME=""
|
||||
+BBHOME="!!PREFIX!!/bb"
|
||||
export BBHOME
|
||||
|
||||
if test "$BBHOME" = ""
|
||||
@@ -35,7 +35,7 @@
|
||||
|
||||
. $BBHOME/etc/bbdef.sh # GET STANDARD INCLUDES
|
||||
|
||||
-BBSLEEP=300 # HOW OFTEN TO UPDATE (IN SECONDS)
|
||||
+BBSLEEP=!!BBSLEEP!! # HOW OFTEN TO UPDATE (IN SECONDS)
|
||||
export BBSLEEP
|
||||
|
||||
|
|
@ -1,31 +0,0 @@
|
|||
--- etc/bb-hosts.orig Sun Jun 27 12:23:17 1999
|
||||
+++ etc/bb-hosts Sun Jun 27 12:25:25 1999
|
||||
@@ -3,16 +3,15 @@
|
||||
#
|
||||
# This file should be identical on both the display server and paging server
|
||||
# if they reside on different hosts
|
||||
-192.168.116.1 iti-s01.iti.qc.com # BBPAGER BBNET BBDISPLAY ftp smtp pop3 http://iti-s01/
|
||||
-192.168.117.1 ns.iti.qc.com # ftp smtp dns
|
||||
-group-compress <H3><I>Web Servers</I></H3>
|
||||
-192.168.117.2 ns2.iti.qc.com # ftp smtp noping
|
||||
-192.168.117.3 ns3.iti.qc.com # ftp smtp
|
||||
-192.168.117.4 ns4.iti.qc.com # ftp smtp
|
||||
-page modem Modem page
|
||||
-group <H3><I>Modem Banks</I></H3>
|
||||
-dialup modem-bank1 192.168.117.1 16
|
||||
-dialup modem-bank2 192.168.117.17 16
|
||||
-dialup modem-bank3 192.168.117.33 16
|
||||
-# Summaries are always displayed on the main page
|
||||
-summary canada.bc 192.168.116.1 http://www.iti.qc.com/iti/users/sean/bb/
|
||||
+127.0.0.1 !!HOSTNAME!! # BBPAGER BBNET BBDISPLAY dns ftp smtp pop3 http://!!HOSTNAME!!/
|
||||
+#group-compress <H3><I>Web Servers</I></H3>
|
||||
+#192.168.117.2 ns2.iti.qc.com # ftp smtp noping
|
||||
+#192.168.117.3 ns3.iti.qc.com # ftp smtp
|
||||
+#192.168.117.4 ns4.iti.qc.com # ftp smtp
|
||||
+#page modem Modem page
|
||||
+#group <H3><I>Modem Banks</I></H3>
|
||||
+#dialup modem-bank1 192.168.117.1 16
|
||||
+#dialup modem-bank2 192.168.117.17 16
|
||||
+#dialup modem-bank3 192.168.117.33 16
|
||||
+## Summaries are always displayed on the main page
|
||||
+#summary canada.bc 192.168.116.1 http://www.iti.qc.com/iti/users/sean/bb/
|
|
@ -1,12 +0,0 @@
|
|||
--- web/bb-ack.sh.orig Sun Jun 27 12:16:54 1999
|
||||
+++ web/bb-ack.sh Sun Jun 27 12:18:05 1999
|
||||
@@ -30,7 +30,8 @@
|
||||
# ************* NOTICE!!! ************
|
||||
# BBWEB MUST BE SET CORRECTLY FOR THIS TO WORK
|
||||
|
||||
-BBWEB="http://INSERT-WEB-HOST-HERE/bb/";
|
||||
+#BBWEB="http://INSERT-WEB-HOST-HERE/bb/";
|
||||
+BBWEB="http://!!WEBHOST!!/bb/";
|
||||
|
||||
|
||||
. $BBHOME/etc/bbdef.sh
|
|
@ -1,12 +0,0 @@
|
|||
--- web/bb-hist.sh.orig Sun Jun 27 12:17:15 1999
|
||||
+++ web/bb-hist.sh Sun Jun 27 12:18:22 1999
|
||||
@@ -13,7 +13,8 @@
|
||||
# ************* NOTICE!!! ************
|
||||
# BBWEB MUST BE SET CORRECTLY FOR THIS TO WORK
|
||||
#
|
||||
-BBWEB="http://INSERT-WEB-HOST-HERE/bb/"
|
||||
+#BBWEB="http://INSERT-WEB-HOST-HERE/bb/"
|
||||
+BBWEB="http://!!WEBHOST!!/bb/"
|
||||
export BBWEB
|
||||
|
||||
# BBHOME IS THE ROOT DIRECTORY OF BIG BROTHER!!!
|
|
@ -1,20 +0,0 @@
|
|||
--- doc/bbclient.orig Sun Jun 27 15:33:09 1999
|
||||
+++ doc/bbclient Sun Jun 27 15:35:28 1999
|
||||
@@ -95,13 +95,15 @@
|
||||
|
||||
cd ../..
|
||||
echo "*** Creating tar file for Big Brother on $CLIENT"
|
||||
-tar cvf bb-${CLIENT}.tar `cat /tmp/BBLIST`
|
||||
+# this might be better then polluting ../.. which would be ${PREFIX}
|
||||
+mkdir -p !!PREFIX!!/share/bb/bbclients
|
||||
+tar cvzf !!PREFIX!!/share/bb/bbclients/bb-${CLIENT}.tar.gz `cat /tmp/BBLIST`
|
||||
rm -f /tmp/BBLIST
|
||||
|
||||
echo "*** Done.
|
||||
|
||||
The Big Brother Client archive has been created. It's called:
|
||||
bb-${CLIENT}.tar
|
||||
-and lives in the directory above the bb directory.
|
||||
+and lives in the directory !!PREFIX!!/share/bb/bbclients
|
||||
|
||||
You can now install Big Brother on ${CLIENT}"
|
|
@ -1 +0,0 @@
|
|||
Monitoring and Notifocation for Systems and Networks
|
|
@ -1,23 +0,0 @@
|
|||
*** Web-based Monitoring & Notification for Systems and Networks ***
|
||||
|
||||
Big Brother is a combination of monitoring methods.
|
||||
Unlike SNMP where information is just collected and devices polled,
|
||||
Big Brother is designed in such a way that each local system broadcasts it's
|
||||
own information to a central location. Simultaneously, Big Brother also polls
|
||||
all networked systems from a central location. This creates a highly efficient
|
||||
and redundant method for proactive network monitoring.
|
||||
Features: Monitors:
|
||||
- Web-based status display - dns nntp ftp smtp and pop3 testing
|
||||
- Configurable warning and panic levels - connectivity via ping
|
||||
- Notification via Pager or email - http servers up and running
|
||||
- Support for grouping of machines - disk space usage
|
||||
- Support for modem monitoring - uptime and cpu usage
|
||||
- Selectable paging delays - essential processes are still running
|
||||
- Heterogeneous Network Support - messages and warnings
|
||||
Author: sean@maclawran.ca
|
||||
License: http://maclawran.ca/cgi-bin/newbb.pl
|
||||
Demo: http://maclawran.ca/~sean/bb-dnld/new-demo.html
|
||||
Mailing list: MajorDomo@taex001.tamu.edu / in body: subscribe bb
|
||||
Mailing list archive: http://www.fusioni.com/~bb/
|
||||
|
||||
WWW: http://maclawran.ca/~sean/bb-dnld/index.html
|
|
@ -1,18 +0,0 @@
|
|||
|
||||
================================================================
|
||||
==== Configuration Notes: ===
|
||||
================================================================
|
||||
|
||||
a) your hosts 'full qualified domain name' and IP-address
|
||||
b) 'watched' hosts 'full qualified domain name' and IP-address
|
||||
go here -> /usr/local/bb/etc/bb-hosts
|
||||
c) configure -> /usr/local/bb/etc/bbdef.sh
|
||||
d) configure -> /usr/local/bb/etc/bbinc.sh
|
||||
e) You need to have a running WWW server (apache)
|
||||
f) You need kermit or qpage for pager functionality
|
||||
After that, you can startup the big brother service by typing
|
||||
/usr/local/bb/runbb.sh &
|
||||
and watching your systems status by viewing this URL with
|
||||
Netscape or another WWW browser
|
||||
http://localhost/bb
|
||||
|
127
net/bb/pkg-plist
127
net/bb/pkg-plist
|
@ -1,127 +0,0 @@
|
|||
bb/LICENSE
|
||||
bb/Makefile
|
||||
bb/bin/bb
|
||||
bb/bin/bb-display.sh
|
||||
bb/bin/bb-doack.sh
|
||||
bb/bin/bb-local.sh
|
||||
bb/bin/bb-network.sh
|
||||
bb/bin/bb-page.sh
|
||||
bb/bin/bb-page1.sh
|
||||
bb/bin/bbclient
|
||||
bb/bin/bbconfig
|
||||
bb/bin/bbd
|
||||
bb/bin/bbnet
|
||||
bb/bin/bbrun
|
||||
bb/bin/sendmsg
|
||||
bb/bin/touchtime
|
||||
bb/etc/bb-dftab.INFO
|
||||
bb/etc/bb-hosts
|
||||
bb/etc/bbchkcfg.sh
|
||||
bb/etc/bbchkhosts.sh
|
||||
bb/etc/bbdef.sh
|
||||
bb/etc/bbinc.sh
|
||||
bb/etc/bbsys.aix
|
||||
bb/etc/bbsys.bsdi
|
||||
bb/etc/bbsys.debian
|
||||
bb/etc/bbsys.dgux
|
||||
bb/etc/bbsys.dynix
|
||||
bb/etc/bbsys.freebsd
|
||||
bb/etc/bbsys.hpux
|
||||
bb/etc/bbsys.hpux9
|
||||
bb/etc/bbsys.irix
|
||||
bb/etc/bbsys.linux
|
||||
bb/etc/bbsys.local
|
||||
bb/etc/bbsys.netbsd
|
||||
bb/etc/bbsys.osf
|
||||
bb/etc/bbsys.redhat
|
||||
bb/etc/bbsys.sco
|
||||
bb/etc/bbsys.sco3
|
||||
bb/etc/bbsys.sh
|
||||
bb/etc/bbsys.solaris
|
||||
bb/etc/bbsys.sunos
|
||||
bb/etc/bbsys.ultrix
|
||||
bb/etc/bbsys.unixware
|
||||
bb/etc/bbwarnrules.cfg
|
||||
bb/etc/bbwarnsetup.cfg
|
||||
bb/etc/numeric-k6.scr
|
||||
bb/etc/numeric.scr
|
||||
bb/etc/security.INFO
|
||||
bb/etc/sms.scr
|
||||
bb/ext/.helloworld
|
||||
bb/runbb.sh
|
||||
bb/tmp/.helloworld
|
||||
bb/web/bb-ack.sh
|
||||
bb/web/bb-hist.sh
|
||||
bb/web/footer
|
||||
bb/web/header
|
||||
bb/web/mkbb.bkg
|
||||
bb/web/mkbb.cols
|
||||
bb/web/mkbb.comp
|
||||
bb/web/mkbb.page
|
||||
bb/web/mkbb.sh
|
||||
bb/web/mkbb2.sh
|
||||
bb/www/acks/.helloworld
|
||||
bb/www/bb-faq.html
|
||||
bb/www/bb-help.html
|
||||
bb/www/bb-info.html
|
||||
bb/www/bb-man.html
|
||||
bb/www/bb-page.html
|
||||
bb/www/gifs/bb-diag.gif
|
||||
bb/www/gifs/bb.gif
|
||||
bb/www/gifs/bb2.gif
|
||||
bb/www/gifs/bbbut.gif
|
||||
bb/www/gifs/bkg-clear.gif
|
||||
bb/www/gifs/bkg-green.gif
|
||||
bb/www/gifs/bkg-purple.gif
|
||||
bb/www/gifs/bkg-red.gif
|
||||
bb/www/gifs/bkg-yellow.gif
|
||||
bb/www/gifs/blue.gif
|
||||
bb/www/gifs/buthelp.gif
|
||||
bb/www/gifs/buthist.gif
|
||||
bb/www/gifs/butinfo.gif
|
||||
bb/www/gifs/butpage.gif
|
||||
bb/www/gifs/butview.gif
|
||||
bb/www/gifs/clear.gif
|
||||
bb/www/gifs/green.gif
|
||||
bb/www/gifs/nb-bbbut.gif
|
||||
bb/www/gifs/nb-red.gif
|
||||
bb/www/gifs/nb-yellow.gif
|
||||
bb/www/gifs/purple.gif
|
||||
bb/www/gifs/red.gif
|
||||
bb/www/gifs/yellow.gif
|
||||
bb/www/hist/.helloworld
|
||||
bb/www/html/.helloworld
|
||||
@exec ln -fs bb.html %D/bb/www/index.html
|
||||
@unexec rm %D/bb/www/index.html
|
||||
bb/www/logs/later
|
||||
bb/www/notes/footer
|
||||
bb/www/notes/iti-s01
|
||||
bb/www/notes/iti-s01.html
|
||||
bb/www/notes/iti-s01.iti.qc.ca
|
||||
bb/www/notes/iti-s01.iti.qc.ca.html
|
||||
bb/www/notes/router-000.htm
|
||||
share/apache/cgi-bin/bb-ack.sh
|
||||
share/bb/bbclients/.keep_me
|
||||
share/doc/bb/FAQ
|
||||
share/doc/bb/README
|
||||
share/doc/bb/README.SMS
|
||||
share/doc/bb/STRUCTURE
|
||||
@exec rm -f %D/share/doc/apache/manual/bb
|
||||
@exec ln -fs %D/bb/www %D/share/doc/apache/manual/bb
|
||||
@unexec rm %D/share/doc/apache/manual/bb
|
||||
@dirrm bb/bin
|
||||
@dirrm bb/etc
|
||||
@dirrm bb/ext
|
||||
@dirrm bb/web
|
||||
@dirrm bb/www/acks
|
||||
@dirrm bb/www/gifs
|
||||
@dirrm bb/www/hist
|
||||
@dirrm bb/www/html
|
||||
@dirrm bb/www/logs
|
||||
@dirrm bb/www/notes
|
||||
@dirrm bb/www
|
||||
@dirrm bb/tmp
|
||||
@dirrm bb
|
||||
@dirrm share/bb/bbclients
|
||||
@dirrm share/bb
|
||||
@dirrm share/doc/bb
|
21
net/bb/scripts/configure
vendored
21
net/bb/scripts/configure
vendored
|
@ -1,21 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# $FreeBSD$
|
||||
|
||||
cd $WRKSRC || exit 1
|
||||
|
||||
# some tuneable global defines
|
||||
WEBHOST=`hostname`
|
||||
SLEEPVAL=300
|
||||
|
||||
# globally set BBHOME here
|
||||
perl -pi -e "s=!!PREFIX!!=$PREFIX=" ${WRKSRC}/runbb.sh
|
||||
# globally adjust sleepvalue
|
||||
perl -pi -e "s=!!BBSLEEP!!=$SLEEPVAL=" ${WRKSRC}/runbb.sh
|
||||
# set paths for bbclient tar archives
|
||||
perl -pi -e "s=!!PREFIX!!=$PREFIX=g" ${WRKSRC}/doc/bbclient
|
||||
# set webhost
|
||||
perl -pi -e "s=!!WEBHOST!!=$WEBHOST=g" ${WRKSRC}/web/bb-ack.sh
|
||||
perl -pi -e "s=!!WEBHOST!!=$WEBHOST=g" ${WRKSRC}/web/bb-hist.sh
|
||||
# set hostname
|
||||
perl -pi -e "s=!!HOSTNAME!!=$HOSTNAME=g" ${WRKSRC}/etc/bb-hosts
|
|
@ -1,9 +0,0 @@
|
|||
#! /bin/sh
|
||||
|
||||
# $FreeBSD$
|
||||
|
||||
sed -e "s=!!PREFIX!!=${PREFIX}=" \
|
||||
< ${FILESDIR}/bb.sh \
|
||||
> ${PREFIX}/etc/rc.d/bb.sh
|
||||
|
||||
chmod 554 ${PREFIX}/etc/rc.d/bb.sh
|
Loading…
Reference in a new issue