- Remove redundant version select
- Allow use of wx 2.8 - Correct build of usrpm
This commit is contained in:
parent
36a8c76ffe
commit
2394288545
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=206035
5 changed files with 6 additions and 23 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= gnuradio
|
||||
PORTVERSION= 3.1.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= comms astro hamradio
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= gnuradio
|
||||
|
@ -27,7 +28,7 @@ RUN_DEPENDS= ${PYNUMERIC} \
|
|||
${PYTHON_SITELIBDIR}/ephem.so:${PORTSDIR}/astro/pyephem
|
||||
|
||||
USE_PYTHON= 2.4+
|
||||
USE_WX= 2.6
|
||||
USE_WX= 2.6+
|
||||
WX_COMPS= wx wx:build wx:run python:build python:run
|
||||
USE_PERL5= yes
|
||||
USE_AUTOTOOLS= autoconf:261 libtool:15
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- gr-wxgui/src/python/stdgui.py.orig 2007-11-05 19:54:57.000000000 -0500
|
||||
+++ gr-wxgui/src/python/stdgui.py 2008-01-03 13:20:37.000000000 -0500
|
||||
@@ -21,6 +21,8 @@
|
||||
|
||||
'''A simple wx gui for GNU Radio applications'''
|
||||
|
||||
+import wxversion
|
||||
+wxversion.select('2.6')
|
||||
import wx
|
||||
import sys
|
||||
from gnuradio import gr
|
|
@ -1,10 +0,0 @@
|
|||
--- usrp/host/swig/Makefile.in.orig 2007-11-05 20:04:16.000000000 -0500
|
||||
+++ usrp/host/swig/Makefile.in 2008-01-03 13:19:58.000000000 -0500
|
||||
@@ -455,7 +455,6 @@
|
||||
usrp_prims.py
|
||||
|
||||
ourpython_PYTHON = \
|
||||
- __init__.py \
|
||||
usrp_fpga_regs.py \
|
||||
usrp_prims.py
|
||||
|
|
@ -1,2 +1,2 @@
|
|||
import wxversion
|
||||
wxversion.select('2.6')
|
||||
wxversion.ensureMinimal('2.6')
|
||||
|
|
|
@ -1308,6 +1308,9 @@ share/usrp/rev4/usrp_sounder.rbf
|
|||
%%PYTHON_SITELIBDIR%%/gnuradio/wxgui/waterfallsink2.py
|
||||
%%PYTHON_SITELIBDIR%%/gnuradio/wxgui/waterfallsink2.pyc
|
||||
%%PYTHON_SITELIBDIR%%/gnuradio/wxgui/waterfallsink2.pyo
|
||||
%%PYTHON_SITELIBDIR%%/usrpm/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/usrpm/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/usrpm/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/usrpm/usrp_dbid.py
|
||||
%%PYTHON_SITELIBDIR%%/usrpm/usrp_dbid.pyc
|
||||
%%PYTHON_SITELIBDIR%%/usrpm/usrp_dbid.pyo
|
||||
|
|
Loading…
Reference in a new issue