cad/opencascade: upgrade to 7.7.0
Release notes at <https://www.opencascade.com/open-cascade-technology-7-7-0-released/>. Differential Revision: https://reviews.freebsd.org/D36884
This commit is contained in:
parent
8580a3f0a3
commit
23b7d54e92
9 changed files with 1098 additions and 568 deletions
|
@ -1,6 +1,5 @@
|
|||
PORTNAME= opencascade
|
||||
PORTVERSION= 7.6.0
|
||||
PORTREVISION= 10
|
||||
DISTVERSION= 7.7.0
|
||||
CATEGORIES= cad science
|
||||
MASTER_SITES= LOCAL/thierry
|
||||
|
||||
|
@ -19,6 +18,7 @@ BUILD_DEPENDS= rapidjson>0:devel/rapidjson \
|
|||
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
|
||||
libfreetype.so:print/freetype2 \
|
||||
libexpat.so:textproc/expat2 \
|
||||
libdraco.so:archivers/draco \
|
||||
libpng16.so:graphics/png \
|
||||
libvtksys-${VTK_VER}.so:math/vtk${VTK_VER:R}
|
||||
RUN_DEPENDS= bash:shells/bash
|
||||
|
@ -59,7 +59,10 @@ CMAKE_ARGS+= -DINSTALL_DIR=${OCCROOT} \
|
|||
-DUSE_FREETYPE:BOOL=ON \
|
||||
-DUSE_TBB:BOOL=OFF \
|
||||
-DUSE_RAPIDJSON:BOOL=ON \
|
||||
-DUSE_DRACO:BOOL=ON \
|
||||
-DUSE_VTK:BOOL=ON \
|
||||
-D3RDPARTY_DRACO_LIBRARY_DIR:PATH=${LOCALBASE}/lib \
|
||||
-D3RDPARTY_DRACO_INCLUDE_DIR:PATH=${LOCALBASE}/include/draco \
|
||||
-D3RDPARTY_VTK_INCLUDE_DIR:PATH=${LOCALBASE}/include/vtk-${VTK_VER}
|
||||
CONFIGURE_ENV+= DESTDIR=${STAGEDIR}
|
||||
|
||||
|
@ -80,7 +83,7 @@ CONFLICTS_INSTALL= opencascade740 # OpenCAS/bin/DRAWEXE
|
|||
LOCCROOT= OpenCAS
|
||||
OCCROOT= ${PREFIX}/${LOCCROOT}
|
||||
PLIST_SUB= OCCROOT="${LOCCROOT}" BITS=${BITS} CC=${CHOSEN_COMPILER_TYPE} \
|
||||
VE=${PORTVERSION:R:R} VER=${PORTVERSION}
|
||||
VE=${PORTVERSION:R} VER=${DISTVERSION:C/-beta//}
|
||||
|
||||
FFMPEG_CMAKE_ON= -DUSE_FFMPEG:BOOL=ON
|
||||
FFMPEG_CMAKE_OFF= -DUSE_FFMPEG:BOOL=OFF
|
||||
|
@ -118,7 +121,7 @@ VIS_LIB_DEPENDS= libftgl.so:graphics/ftgl \
|
|||
VIS_USE= GL=glesv2
|
||||
|
||||
DOXYGEN_IMPLIES= DOCS
|
||||
DOXYGEN_USE= TEX=latex:build
|
||||
DOXYGEN_USE= TEX=latex:build
|
||||
DOXYGEN_BUILD_DEPENDS= bash:shells/bash \
|
||||
doxygen:devel/doxygen \
|
||||
dot:graphics/graphviz \
|
||||
|
@ -158,7 +161,7 @@ post-build-DOXYGEN-on:
|
|||
(cd ${WRKSRC} && ./gendoc -overview)
|
||||
|
||||
post-install:
|
||||
${MV} ${STAGEDIR}${OCCROOT}/bin/DRAWEXE-${PORTVERSION} ${STAGEDIR}${PREFIX}/bin/DRAWEXE
|
||||
${MV} ${STAGEDIR}${OCCROOT}/bin/DRAWEXE-${DISTVERSION:C/-beta//} ${STAGEDIR}${PREFIX}/bin/DRAWEXE
|
||||
(cd ${STAGEDIR}${PREFIX}/bin && \
|
||||
${LN} -sf DRAWEXE ${STAGEDIR}${OCCROOT}/bin/DRAWEXE)
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1635964606
|
||||
SHA256 (opencascade-7.6.0.tgz) = 8dd81ee7b37f38bf930e0c067aa10f027310f3ab896f2925b32a2a2c5e273401
|
||||
SIZE (opencascade-7.6.0.tgz) = 230101903
|
||||
TIMESTAMP = 1668069465
|
||||
SHA256 (opencascade-7.7.0.tgz) = 40e8e0e78b56dd407192b4cabf55dd0bdd1fa9c0a292d263b12f7e21733cb07e
|
||||
SIZE (opencascade-7.7.0.tgz) = 247268442
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2021-10-30 11:13:37 UTC
|
||||
--- CMakeLists.txt.orig 2022-09-30 11:53:39 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -963,7 +963,7 @@ if (${DRAWEXE_INDEX} GREATER -1)
|
||||
@@ -1005,7 +1005,7 @@ if (${DRAWEXE_INDEX} GREATER -1)
|
||||
PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_WRITE GROUP_EXECUTE WORLD_READ WORLD_WRITE WORLD_EXECUTE)
|
||||
else()
|
||||
install (FILES "${CMAKE_SOURCE_DIR}/adm/templates/draw.${SCRIPT_EXT}" DESTINATION "${INSTALL_DIR_SCRIPT}"
|
||||
|
@ -9,7 +9,7 @@
|
|||
endif()
|
||||
|
||||
# copy draw script to CMake binary folder
|
||||
@@ -979,7 +979,7 @@ else()
|
||||
@@ -1021,7 +1021,7 @@ endif()
|
||||
endif()
|
||||
|
||||
# change custom.bat/sh
|
||||
|
@ -18,18 +18,12 @@
|
|||
file (READ "${INSTALL_DIR}/${INSTALL_DIR_SCRIPT}/custom.${SCRIPT_EXT}" CUSTOM_CONTENT)
|
||||
|
||||
set (CUSTOM_CONTENT "${CUSTOM_CONTENT} ${ADDITIONAL_CUSTOM_CONTENT}")
|
||||
@@ -1229,7 +1229,13 @@ foreach (OCCT_CONFIGURATION ${CMAKE_CONFIGURATION_TYPE
|
||||
@@ -1265,7 +1265,7 @@ install (CODE "string (TOLOWER \"\${CMAKE_INSTALL_CONF
|
||||
endforeach()
|
||||
# install OpenCASCADE config file with compile definitions and C/C++ flags ONLY for current configuration
|
||||
install (CODE "string (TOLOWER \"\${CMAKE_INSTALL_CONFIG_NAME}\" CMAKE_INSTALL_CONFIG_NAME_LOWER)")
|
||||
-install (CODE "configure_file(\"${CMAKE_BINARY_DIR}/OpenCASCADECompileDefinitionsAndFlags-\${CMAKE_INSTALL_CONFIG_NAME_LOWER}.cmake\" \"${INSTALL_DIR}/${INSTALL_DIR_CMAKE}/OpenCASCADECompileDefinitionsAndFlags-\${CMAKE_INSTALL_CONFIG_NAME_LOWER}.cmake\" COPYONLY)")
|
||||
+install(CODE "
|
||||
+ configure_file(
|
||||
+ \"${CMAKE_BINARY_DIR}/OpenCASCADECompileDefinitionsAndFlags-\${CMAKE_INSTALL_CONFIG_NAME_LOWER}.cmake\"
|
||||
+ \"\$ENV{DESTDIR}/${INSTALL_DIR_CMAKE}/OpenCASCADECompileDefinitionsAndFlags-\${CMAKE_INSTALL_CONFIG_NAME_LOWER}.cmake\"
|
||||
+ COPYONLY)
|
||||
+")
|
||||
+
|
||||
-install (CODE "file(INSTALL FILES \"${CMAKE_BINARY_DIR}/OpenCASCADECompileDefinitionsAndFlags-\${CMAKE_INSTALL_CONFIG_NAME_LOWER}.cmake\" DESTINATION \"${INSTALL_DIR}/${INSTALL_DIR_CMAKE}/\" TYPE FILE)")
|
||||
+install (CODE "file(INSTALL FILES \"${CMAKE_BINARY_DIR}/OpenCASCADECompileDefinitionsAndFlags-\${CMAKE_INSTALL_CONFIG_NAME_LOWER}.cmake\" DESTINATION \"${INSTALL_DIR_CMAKE}/\" TYPE FILE)")
|
||||
|
||||
foreach (OCCT_MODULE ${OCCT_MODULES})
|
||||
if (BUILD_MODULE_${OCCT_MODULE})
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- adm/cmake/occt_macros.cmake.orig 2021-10-30 11:13:37 UTC
|
||||
--- adm/cmake/occt_macros.cmake.orig 2022-09-30 11:53:39 UTC
|
||||
+++ adm/cmake/occt_macros.cmake
|
||||
@@ -47,7 +47,7 @@ macro (OCCT_MAKE_OS_WITH_BITNESS)
|
||||
elseif(APPLE)
|
||||
|
@ -18,12 +18,12 @@
|
|||
|
||||
string(TIMESTAMP CURRENT_TIME "%H:%M:%S")
|
||||
message (STATUS "Info: \(${CURRENT_TIME}\) Checking headers in inc folder...")
|
||||
@@ -592,12 +592,12 @@ macro (OCCT_UPDATE_TARGET_FILE)
|
||||
"cmake_policy(PUSH)
|
||||
cmake_policy(SET CMP0007 NEW)
|
||||
string (TOLOWER \"\${CMAKE_INSTALL_CONFIG_NAME}\" CMAKE_INSTALL_CONFIG_NAME_LOWERCASE)
|
||||
@@ -590,12 +590,12 @@ macro (OCCT_UPDATE_TARGET_FILE)
|
||||
|
||||
install (CODE
|
||||
"string (TOLOWER \"\${CMAKE_INSTALL_CONFIG_NAME}\" CMAKE_INSTALL_CONFIG_NAME_LOWERCASE)
|
||||
- file (GLOB ALL_OCCT_TARGET_FILES \"${INSTALL_DIR}/${INSTALL_DIR_CMAKE}/OpenCASCADE*Targets-\${CMAKE_INSTALL_CONFIG_NAME_LOWERCASE}.cmake\")
|
||||
+ file (GLOB ALL_OCCT_TARGET_FILES \"$ENV{DESTDIR}${INSTALL_DIR_CMAKE}/OpenCASCADE*Targets-\${CMAKE_INSTALL_CONFIG_NAME_LOWERCASE}.cmake\")
|
||||
+ file (GLOB ALL_OCCT_TARGET_FILES \"$ENV{DESTDIR}/${INSTALL_DIR_CMAKE}/OpenCASCADE*Targets-\${CMAKE_INSTALL_CONFIG_NAME_LOWERCASE}.cmake\")
|
||||
foreach(TARGET_FILENAME \${ALL_OCCT_TARGET_FILES})
|
||||
file (STRINGS \"\${TARGET_FILENAME}\" TARGET_FILE_CONTENT)
|
||||
file (REMOVE \"\${TARGET_FILENAME}\")
|
||||
|
@ -32,4 +32,4 @@
|
|||
+ string (REGEX REPLACE \"[\\\\]?[\\\$]{OCCT_INSTALL_BIN_LETTER}\" \"${OCCT_INSTALL_BIN_LETTER}\" line \"\${line}\")
|
||||
file (APPEND \"\${TARGET_FILENAME}\" \"\${line}\\n\")
|
||||
endforeach()
|
||||
endforeach()
|
||||
endforeach()")
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
--- inc/Standard_Time.hxx.orig 2017-08-30 13:28:31 UTC
|
||||
+++ inc/Standard_Time.hxx
|
||||
@@ -26,11 +26,11 @@
|
||||
// ------------------------------------------------------------------
|
||||
// IsEqual : Returns Standard_True if two time values are equal
|
||||
// ------------------------------------------------------------------
|
||||
-inline Standard_Boolean IsEqual (const Standard_Time theOne,
|
||||
- const Standard_Time theTwo)
|
||||
-{
|
||||
- return theOne == theTwo;
|
||||
-}
|
||||
+//inline Standard_Boolean IsEqual (const Standard_Time theOne,
|
||||
+// const Standard_Time theTwo)
|
||||
+//{
|
||||
+// return theOne == theTwo;
|
||||
+//}
|
||||
|
||||
#endif
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
--- src/STEPConstruct/STEPConstruct_AP203Context.cxx.orig 2017-08-30 13:28:30 UTC
|
||||
--- src/STEPConstruct/STEPConstruct_AP203Context.cxx.orig 2022-09-30 11:53:57 UTC
|
||||
+++ src/STEPConstruct/STEPConstruct_AP203Context.cxx
|
||||
@@ -123,7 +123,15 @@ Handle(StepBasic_DateAndTime) STEPConstr
|
||||
@@ -121,7 +121,15 @@ Handle(StepBasic_DateAndTime) STEPConstruct_AP203Conte
|
||||
long shift = 0;
|
||||
_get_timezone (&shift);
|
||||
#else
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- src/Standard/Standard_CString.cxx.orig 2021-10-30 11:13:58 UTC
|
||||
--- src/Standard/Standard_CString.cxx.orig 2022-09-30 11:54:05 UTC
|
||||
+++ src/Standard/Standard_CString.cxx
|
||||
@@ -82,7 +82,7 @@ Standard_Integer HashCodes (const Standard_CString the
|
||||
@@ -80,7 +80,7 @@ Standard_Integer HashCodes (const Standard_CString the
|
||||
// strtod, strtol, strtoll functions. For other system with locale-depended
|
||||
// implementations problems may appear if "C" locale is not set explicitly.
|
||||
#if !defined(__ANDROID__) && !defined(__QNX__) && !defined(__MINGW32__)
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
--- src/Standard/Standard_Time.hxx.orig 2017-08-30 13:28:31 UTC
|
||||
+++ src/Standard/Standard_Time.hxx
|
||||
@@ -26,11 +26,11 @@
|
||||
// ------------------------------------------------------------------
|
||||
// IsEqual : Returns Standard_True if two time values are equal
|
||||
// ------------------------------------------------------------------
|
||||
-inline Standard_Boolean IsEqual (const Standard_Time theOne,
|
||||
- const Standard_Time theTwo)
|
||||
-{
|
||||
- return theOne == theTwo;
|
||||
-}
|
||||
+//inline Standard_Boolean IsEqual (const Standard_Time theOne,
|
||||
+// const Standard_Time theTwo)
|
||||
+//{
|
||||
+// return theOne == theTwo;
|
||||
+//}
|
||||
|
||||
#endif
|
||||
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue