- Add FUSE option to compile ntfsmount with FUSE support [1].
- Add local patch to make FUSE support compile on FreeBSD [1]. - Force --enable-gnome-vfs when WITH_GNOMEVFS2 is set. Asked by: Sergei Mozhaisky <technix@mediana.net.ua> [1]
This commit is contained in:
parent
9bcbf96887
commit
241f1cec6c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=149164
3 changed files with 33 additions and 4 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= ntfsprogs
|
||||
PORTVERSION= 1.12.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= linux-ntfs
|
||||
|
@ -24,7 +25,8 @@ USE_AUTOTOOLS= libtool:13:inc
|
|||
CONFIGURE_ARGS= --program-transform-name=""
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
OPTIONS= GNOMEVFS2 "Install GnomeVFS 2.0 libntfs interface" off
|
||||
OPTIONS= GNOMEVFS2 "Install GnomeVFS 2.0 libntfs interface" off \
|
||||
FUSE "Compile with Fuse interface" off
|
||||
|
||||
MAN8= libntfs-gnomevfs.8 \
|
||||
mkntfs.8 \
|
||||
|
@ -46,11 +48,22 @@ MLINKS= mkntfs.8 mkfs.ntfs.8
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_GNOMEVFS2)
|
||||
CONFIGURE_ARGS+=--enable-gnome-vfs
|
||||
USE_GNOME= gnomevfs2
|
||||
PLIST_SUB= GNOMEVFS2=""
|
||||
PLIST_SUB+= GNOMEVFS2=""
|
||||
.else
|
||||
CONFIGURE_ARGS= --disable-gnome-vfs
|
||||
PLIST_SUB= GNOMEVFS2="@comment "
|
||||
CONFIGURE_ARGS+=--disable-gnome-vfs
|
||||
PLIST_SUB+= GNOMEVFS2="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_FUSE)
|
||||
CONFIGURE_ARGS+=--enable-fuse-module
|
||||
PLIST_SUB+= FUSE=""
|
||||
LIB_DEPENDS+= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
|
||||
MLINKS+= ntfsmount.8 mount.ntfs-fuse.8
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-fuse-module
|
||||
PLIST_SUB+= FUSE="@comment "
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
|
|
14
sysutils/ntfsprogs/files/patch-ntfsprogs_ntfsmount.c
Normal file
14
sysutils/ntfsprogs/files/patch-ntfsprogs_ntfsmount.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- ntfsprogs/ntfsmount.c.orig Wed Nov 23 12:33:56 2005
|
||||
+++ ntfsprogs/ntfsmount.c Wed Nov 23 12:32:15 2005
|
||||
@@ -228,7 +228,11 @@
|
||||
size = 0;
|
||||
sfs->f_ffree = size;
|
||||
/* Maximum length of filenames. */
|
||||
+#ifdef __FreeBSD__
|
||||
+ sfs->f_namemax = NTFS_MAX_NAME_LEN;
|
||||
+#else
|
||||
sfs->f_namelen = NTFS_MAX_NAME_LEN;
|
||||
+#endif
|
||||
return 0;
|
||||
}
|
||||
|
|
@ -3,6 +3,7 @@ bin/ntfscluster
|
|||
bin/ntfsfix
|
||||
bin/ntfsinfo
|
||||
bin/ntfsls
|
||||
%%FUSE%%bin/ntfsmount
|
||||
include/ntfs/attrib.h
|
||||
include/ntfs/attrlist.h
|
||||
include/ntfs/bitmap.h
|
||||
|
@ -39,6 +40,7 @@ lib/libntfs.so
|
|||
lib/libntfs.so.8
|
||||
sbin/mkntfs
|
||||
sbin/mkfs.ntfs
|
||||
%%FUSE%%sbin/mount.ntfs-fuse
|
||||
sbin/ntfsclone
|
||||
sbin/ntfscp
|
||||
sbin/ntfslabel
|
||||
|
|
Loading…
Reference in a new issue