Update to 5.18.2.
This commit is contained in:
parent
93aa588ded
commit
244b858cf8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=339451
4 changed files with 7 additions and 38 deletions
|
@ -3,7 +3,6 @@
|
|||
|
||||
PORTNAME= perl
|
||||
PORTVERSION= ${PERL_VERSION}
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= lang devel perl5
|
||||
MASTER_SITES= CPAN \
|
||||
${MASTER_SITE_LOCAL:S/$/:local/} \
|
||||
|
@ -56,7 +55,7 @@ PERL_MALLOC_CONFIGURE_OFF= -Dusemymalloc=n
|
|||
|
||||
PORTSCOUT= limitw:1,even
|
||||
|
||||
PERL_VERSION= 5.18.1
|
||||
PERL_VERSION= 5.18.2
|
||||
PERL_VER= ${PERL_VERSION:C/\.[0-9]+$//}
|
||||
PERL_ARCH= mach
|
||||
SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
SHA256 (perl/perl-5.18.1.tar.bz2) = bf46c732c68fb160ea276b4b0cda26971646a206e31951abb8623a60f0ee5249
|
||||
SIZE (perl/perl-5.18.1.tar.bz2) = 14059628
|
||||
SHA256 (perl/perl-5.18.2.tar.bz2) = 06a0cd490be36d829606aa41d8c9c4c72ae70542f8d4f23ec554335b3d9e2746
|
||||
SIZE (perl/perl-5.18.2.tar.bz2) = 14058513
|
||||
SHA256 (perl/BSDPAN-20111107.tar.bz2) = 2f03218a592dc65ebfdc3c6b9394d91dcf4c53aa5290a08458b837baad5a21f9
|
||||
SIZE (perl/BSDPAN-20111107.tar.bz2) = 8448
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
From 4d106cc5d8fd328d39b1db3c57572dd3dec915b5 Mon Sep 17 00:00:00 2001
|
||||
From: Nicholas Clark <nick@ccl4.org>
|
||||
Date: Thu, 22 Aug 2013 11:48:29 +0200
|
||||
Subject: [PATCH] For SDBM_File, stop EU::MM from generating its default
|
||||
subdirs rule.
|
||||
|
||||
The default subdirs rule creates a race condition with the rule that
|
||||
Makefile.PL explicitly adds to generate libsdbm.a, which can cause parallel
|
||||
makes to fail.
|
||||
---
|
||||
ext/SDBM_File/Makefile.PL | 6 ++++++
|
||||
pod/perldelta.pod | 11 ++++++++++-
|
||||
2 files changed, 16 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git ext/SDBM_File/Makefile.PL ext/SDBM_File/Makefile.PL
|
||||
index fa16a79..b96b80b 100644
|
||||
--- ext/SDBM_File/Makefile.PL
|
||||
+++ ext/SDBM_File/Makefile.PL
|
||||
@@ -23,6 +23,12 @@ WriteMakefile(
|
||||
PERL_MALLOC_OK => 1,
|
||||
);
|
||||
|
||||
+# We don't want the default subdir rule, as it creates a race condition with the
|
||||
+# rule we add below.
|
||||
+sub MY::subdir_x {
|
||||
+ return '';
|
||||
+}
|
||||
+
|
||||
sub MY::postamble {
|
||||
if ($^O =~ /MSWin32/ && !defined($ENV{SYSTEMROOT})) {
|
||||
if ($Config{'make'} =~ /dmake/i) {
|
||||
--
|
||||
1.8.2.1
|
||||
|
|
@ -1056,6 +1056,7 @@ lib/perl5/%%PERL_VER%%/pod/perl5162delta.pod
|
|||
lib/perl5/%%PERL_VER%%/pod/perl5163delta.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perl5180delta.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perl5181delta.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perl5182delta.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perl561delta.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perl56delta.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perl581delta.pod
|
||||
|
@ -1172,6 +1173,7 @@ lib/perl5/%%PERL_VER%%/pod/perlrecharclass.pod
|
|||
lib/perl5/%%PERL_VER%%/pod/perlref.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perlreftut.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perlreguts.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perlrepository.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perlrequick.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perlreref.pod
|
||||
lib/perl5/%%PERL_VER%%/pod/perlretut.pod
|
||||
|
@ -2145,6 +2147,7 @@ man/man1/perl5162delta.1.gz
|
|||
man/man1/perl5163delta.1.gz
|
||||
man/man1/perl5180delta.1.gz
|
||||
man/man1/perl5181delta.1.gz
|
||||
man/man1/perl5182delta.1.gz
|
||||
man/man1/perl561delta.1.gz
|
||||
man/man1/perl56delta.1.gz
|
||||
man/man1/perl581delta.1.gz
|
||||
|
@ -2263,6 +2266,7 @@ man/man1/perlrecharclass.1.gz
|
|||
man/man1/perlref.1.gz
|
||||
man/man1/perlreftut.1.gz
|
||||
man/man1/perlreguts.1.gz
|
||||
man/man1/perlrepository.1.gz
|
||||
man/man1/perlrequick.1.gz
|
||||
man/man1/perlreref.1.gz
|
||||
man/man1/perlretut.1.gz
|
||||
|
|
Loading…
Reference in a new issue