Add uf-view 1.4.2, a gTK+ viewer for the User Friendly and several

other popular comics.

PR:		27071
Submitted by:	Jonathan McGee <mcgee@mcgee.student.umd.edu>
This commit is contained in:
Maxim Sobolev 2001-05-30 20:19:32 +00:00
parent 6a9be81a73
commit 246dffc587
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=43328
8 changed files with 107 additions and 0 deletions

View file

@ -159,6 +159,7 @@
SUBDIR += tkrunit
SUBDIR += ttyrec
SUBDIR += tvguide
SUBDIR += uf-view
SUBDIR += uk-phone
SUBDIR += uk-postcodes
SUBDIR += unclutter

29
misc/uf-view/Makefile Normal file
View file

@ -0,0 +1,29 @@
# New ports collection makefile for: uf-view
# Date created: 5 December 1994
# Whom: Jonathan McGee <mcgee@mcgee.student.umd.edu>
#
# $FreeBSD$
#
PORTNAME= uf-view
PORTVERSION= 1.4.2
CATEGORIES= misc
MASTER_SITES= http://hadess.net/files/
MAINTAINER= mcgee@wam.umd.edu
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>

1
misc/uf-view/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (uf-view-1.4.2.tar.gz) = 36917754a13b06b0bbe183b7cab3a443

View file

@ -0,0 +1,14 @@
$FreeBSD$
--- Makefile.in 2001/05/30 20:07:13 1.1
+++ Makefile.in 2001/05/30 20:07:31
@@ -120,7 +120,7 @@
uf_view_SOURCES = uf-gui.c uf-gui.h uf-view.c uf-view.h
-uf_view_LDADD = -lgnomevfs $(GNOME_LIBDIR) $(GNOMEUI_LIBS) $(INTLLIBS)
+uf_view_LDADD = -lgnomevfs $(GNOME_LIBDIR) $(GNOMEUI_LIBS) $(INTLLIBS) $(PTHREAD_LIB)
EXTRA_DIST = uf-view.desktop $(foo_DATA) uf-view.spec.in
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4

View file

@ -0,0 +1,49 @@
$FreeBSD$
--- uf-view.c.orig Sun May 13 21:13:07 2001
+++ uf-view.c Wed May 30 22:57:40 2001
@@ -98,7 +98,7 @@
if (url != NULL)
{
gchar foo[100] = "/tmp/ufXXXXXX";
- mktemp(foo);
+ mkstemp(foo);
appbar_send_msg(_("Fetching %s"), url);
@@ -206,6 +206,7 @@
const gchar *authors[] = {
("Bastien Nocera <hadess@hadess.net>"),
("Robert Brady <rwb197@ecs.soton.ac.uk>"),
+ ("Drew Ogle <daliegri@wam.umd.edu>"),
NULL,
};
@@ -239,7 +240,7 @@
void on_today_button_clicked(GtkWidget * button, gpointer user_data)
{
struct tm *time_struct;
- glong curtime;
+ time_t curtime;
gint month, year, day;
curtime = time(0);
@@ -383,7 +384,7 @@
gchar foo[100] = "/tmp/ufXXXXXX";
/* Initialise */
- mktemp(foo);
+ mkstemp(foo);
if (date_error(year, month, day, 1997, 9, 17) == TRUE) {
show_error(_("User Friendly did not exist at that time.\nPlease choose a later date."));
@@ -466,7 +467,7 @@
gchar foo[100] = "/tmp/ufXXXXXX";
/* Initialise */
- mktemp(foo);
+ mkstemp(foo);
if (date_error(year, month, day, 2000, 3, 17) == TRUE) {
show_error(_("This Penny Arcade's stuff's too old.\nPlease choose a later date."));

1
misc/uf-view/pkg-comment Normal file
View file

@ -0,0 +1 @@
A gTK+ viewer for the User Friendly and several other popular comics

6
misc/uf-view/pkg-descr Normal file
View file

@ -0,0 +1,6 @@
uf-view is a Gnome viewer for the UserFriendly comic.
It also supports MegaTokyo, Penny Arcade, Calvin and Hobbes and
Dilbert. This port also includes a patch by Drew Ogle to view
the comic goats.
WWW: http://hadess.net/uf-view.shtml

6
misc/uf-view/pkg-plist Normal file
View file

@ -0,0 +1,6 @@
bin/uf-view
share/gnome/apps/Utilities/uf-view.desktop
share/gnome/pixmaps/uf-view/gnome-uf-view.png
share/gnome/pixmaps/uf-view/uf-logo.png
share/locale/sv/LC_MESSAGES/uf-view.mo
@dirrm share/gnome/pixmaps/uf-view