Some minor fixes in Japanese support.
PR: ports/20026 Submitted by: IWASHITA Yoji <shuna@pop16.odn.ne.jp> (Maintainer)
This commit is contained in:
parent
d1c4366634
commit
24916051a2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30821
7 changed files with 46 additions and 4 deletions
|
@ -41,7 +41,6 @@ ALL_TARGET= all
|
|||
CONFIGURE_ARGS= --with-slang --enable-locales-fix --with-included-gettext \
|
||||
--enable-flock --disable-fcntl \
|
||||
--sysconfdir=${PREFIX}/etc \
|
||||
--with-sharedir=${PREFIX}/share/mutt \
|
||||
--with-docdir=${PREFIX}/share/doc/mutt \
|
||||
--enable-pop --enable-imap
|
||||
|
||||
|
|
26
japanese/mutt-devel/files/patch-ac
Normal file
26
japanese/mutt-devel/files/patch-ac
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- handler.c.orig Wed Jul 19 13:37:07 2000
|
||||
+++ handler.c Wed Jul 19 13:42:28 2000
|
||||
@@ -187,7 +187,11 @@
|
||||
if(ch != EOF)
|
||||
{
|
||||
mutt_decoder_push_one (dec, ch);
|
||||
+#ifdef KANJI
|
||||
+ if (ch == '\n' || l++ == 1024)
|
||||
+#else
|
||||
if (l++ == 1024)
|
||||
+#endif
|
||||
{
|
||||
mutt_decoder_pop_to_state (dec, s);
|
||||
l = 0;
|
||||
@@ -270,7 +274,11 @@
|
||||
else
|
||||
mutt_decoder_push_one (dec, ch);
|
||||
|
||||
+#ifdef KANJI
|
||||
+ if (ch == '\n' || (l += 3) >= 1024)
|
||||
+#else
|
||||
if ((l += 3) >= 1024)
|
||||
+#endif
|
||||
{
|
||||
mutt_decoder_pop_to_state (dec, s);
|
||||
l = 0;
|
10
japanese/mutt-devel/files/patch-ad
Normal file
10
japanese/mutt-devel/files/patch-ad
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- Makefile.am.orig Wed Jul 19 14:29:18 2000
|
||||
+++ Makefile.am Wed Jul 19 14:31:11 2000
|
||||
@@ -122,7 +122,6 @@
|
||||
fi
|
||||
|
||||
install-data-local: Muttrc
|
||||
- $(srcdir)/mkinstalldirs $(DESTDIR)$(sharedir)
|
||||
$(srcdir)/mkinstalldirs $(DESTDIR)$(sysconfdir)
|
||||
-if [ -f $(DESTDIR)$(sharedir)/Muttrc ] ; then \
|
||||
mv $(DESTDIR)$(sharedir)/Muttrc $(DESTDIR)$(sysconfdir) ; \
|
|
@ -44,7 +44,6 @@ share/doc/mutt/manual_ja.sgml
|
|||
share/doc/mutt/manual_ja.tex
|
||||
share/doc/mutt/manual_ja.txt
|
||||
@dirrm share/doc/mutt
|
||||
@dirrm share/mutt
|
||||
share/locale/cs/LC_MESSAGES/mutt.mo
|
||||
share/locale/da/LC_MESSAGES/mutt.mo
|
||||
share/locale/de/LC_MESSAGES/mutt.mo
|
||||
|
|
|
@ -41,7 +41,6 @@ ALL_TARGET= all
|
|||
CONFIGURE_ARGS= --with-slang --enable-locales-fix --with-included-gettext \
|
||||
--enable-flock --disable-fcntl \
|
||||
--sysconfdir=${PREFIX}/etc \
|
||||
--with-sharedir=${PREFIX}/share/mutt \
|
||||
--with-docdir=${PREFIX}/share/doc/mutt \
|
||||
--enable-pop --enable-imap
|
||||
|
||||
|
|
10
japanese/mutt/files/patch-ad
Normal file
10
japanese/mutt/files/patch-ad
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- Makefile.am.orig Wed Jul 19 14:29:18 2000
|
||||
+++ Makefile.am Wed Jul 19 14:31:11 2000
|
||||
@@ -122,7 +122,6 @@
|
||||
fi
|
||||
|
||||
install-data-local: Muttrc
|
||||
- $(srcdir)/mkinstalldirs $(DESTDIR)$(sharedir)
|
||||
$(srcdir)/mkinstalldirs $(DESTDIR)$(sysconfdir)
|
||||
-if [ -f $(DESTDIR)$(sharedir)/Muttrc ] ; then \
|
||||
mv $(DESTDIR)$(sharedir)/Muttrc $(DESTDIR)$(sysconfdir) ; \
|
|
@ -44,7 +44,6 @@ share/doc/mutt/manual_ja.sgml
|
|||
share/doc/mutt/manual_ja.tex
|
||||
share/doc/mutt/manual_ja.txt
|
||||
@dirrm share/doc/mutt
|
||||
@dirrm share/mutt
|
||||
share/locale/cs/LC_MESSAGES/mutt.mo
|
||||
share/locale/da/LC_MESSAGES/mutt.mo
|
||||
share/locale/de/LC_MESSAGES/mutt.mo
|
||||
|
|
Loading…
Reference in a new issue