Update to 5.92b, and depend on print/teTeX.
Approved by: linimon (mentor)
This commit is contained in:
parent
6e9c19227b
commit
24aebae479
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=109023
10 changed files with 260 additions and 270 deletions
|
@ -6,86 +6,74 @@
|
|||
#
|
||||
|
||||
PORTNAME= dvipsk
|
||||
PORTVERSION= 5.78a
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 5.92b
|
||||
CATEGORIES= japanese print
|
||||
MASTER_SITES= ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/dvips/ \
|
||||
ftp://ftp.center.osaka-u.ac.jp/CTAN/dviware/dvipsk/ \
|
||||
ftp://ftp.riken.go.jp/pub/CTAN/dviware/dvipsk/ \
|
||||
ftp://ftp.u-aizu.ac.jp/pub/tex/CTAN/dviware/dvipsk/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
|
||||
${PORTNAME}-jpatch-p1.4d.tar.gz
|
||||
MASTER_SITES= ftp://sunsite.informatik.rwth-aachen.de/pub/comp/tex/teTeX/2.0/distrib/ \
|
||||
${MASTER_SITE_TEX_CTAN} \
|
||||
ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/dvips/:1
|
||||
MASTER_SITE_SUBDIR= systems/unix/teTeX/2.0/distrib/
|
||||
PKGNAMEPREFIX= ja-
|
||||
PKGNAMESUFFIX= -tetex
|
||||
DISTFILES= tetex-src-${VER_TETEX}${EXTRACT_SUFX} \
|
||||
dvipsk-jpatch-p${VER_JPATCH}${EXTRACT_SUFX}:1
|
||||
DIST_SUBDIR= teTeX
|
||||
|
||||
MAINTAINER= hrs@FreeBSD.org
|
||||
COMMENT= A DVI to PostScript translator + Japanese patch
|
||||
|
||||
RUN_DEPENDS= MakeTeXPK:${PORTSDIR}/japanese/ptex-base
|
||||
BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
|
||||
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
|
||||
wwwcore.1:${PORTSDIR}/www/libwww \
|
||||
t1.5:${PORTSDIR}/devel/t1lib
|
||||
RUN_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
|
||||
|
||||
MANUAL_PACKAGE_BUILD= incompatible with other versions of dvipsk-*
|
||||
|
||||
DIST_SUBDIR= ptex
|
||||
USE_GMAKE= yes
|
||||
WRKSRC= ${WRKDIR}/tetex-src-${VER_TETEX}
|
||||
PLIST_SUB= TEXMFDIR=${TEXMFDIR} MKTEXLSR=${MKTEXLSR}
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= ac_cv_path_install="${INSTALL} -c -o ${BINOWN} -g ${BINGRP}"
|
||||
SCRIPTS_ENV= MV=${MV} SED=${SED}
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX} \
|
||||
--disable-multiplatform \
|
||||
--without-texinfo --without-dialog \
|
||||
--with-system-ncurses --with-system-zlib \
|
||||
--with-system-wwwlib --with-libwww-libdir=${LIBWWW_PREFIX}/lib \
|
||||
--with-libwww-include=${LIBWWW_PREFIX}/include/w3c-libwww \
|
||||
--with-system-pnglib --with-pnglib-libdir=${LIBPNG_PREFIX}/lib \
|
||||
--with-pnglib-include=${LIBPNG_PREFIX}/include \
|
||||
--with-system-t1lib --with-t1lib-libdir=${LIBT1_PREFIX}/lib \
|
||||
--with-t1lib-include=${LIBT1_PREFIX}/include
|
||||
PKGINSTALL= ${WRKDIR}/pkg-install.sh
|
||||
PKGDEINSTALL= ${WRKDIR}/pkg-install.sh
|
||||
CONFLICTS= ja-ptex-base* dvips* ja-dvipsk-vflib-*
|
||||
|
||||
MAN1= dvips.1 afm2tfm.1
|
||||
INFO= dvips
|
||||
|
||||
TEXMF= ${PREFIX}/share/texmf
|
||||
DVIPSDIR= ${TEXMF}/dvips
|
||||
TEXDIR= ${TEXMF}/tex
|
||||
BINARIES= dvips afm2tfm
|
||||
BASE_FILES= config.ps cmfonts.map cyrfonts.map eufonts.map lafonts.map
|
||||
CONTRIB_DIRS= afm-extra bbfig configs psfig volker
|
||||
CONTRIB_FILES= MakeTeXPK.pl PSTricks colorsep.pro config.proto crop.lpr \
|
||||
timesmat.sty whichinpath afm-extra/*.ed bbfig/bb* \
|
||||
configs/*[^g] psfig/README psfig/lprep* volker/*
|
||||
PLAIN_MACROS= psfig/psfig.tex psfntmac/ps_plain.tex
|
||||
LATEX209_MACROS=latex209/*.sty psfntmac/ps_lfonts.tex pspic/*
|
||||
DOCS= ../README.jpatch dvipsk/README \
|
||||
dvipsk/dvips.texi dvipsk/dvips.help
|
||||
VER_TETEX= 2.0.2
|
||||
VER_JPATCH= 1.6
|
||||
MKTEXLSR?= ${LOCALBASE}/bin/mktexlsr
|
||||
TEXMFDIR?= share/texmf
|
||||
LIBPNG_PREFIX?= ${LOCALBASE}
|
||||
LIBWWW_PREFIX?= ${LOCALBASE}
|
||||
LIBT1_PREFIX?= ${LOCALBASE}
|
||||
DVIPSKCNF= ${PREFIX}/${TEXMFDIR}/dvips/config/config.ps
|
||||
|
||||
pre-patch:
|
||||
@${PATCH} -p -s -d ${WRKSRC} < ${WRKDIR}/dvipsk.patch
|
||||
do-patch:
|
||||
cd ${WRKSRC}/texk &&\
|
||||
${PATCH} -p0 < ${WRKDIR}/dvipsk-${PORTVERSION}-p${VER_JPATCH}.patch
|
||||
${SED} -e 's,%%TEXMFCNF%%,${TEXMFCNF},g;s,%%DVIPSKCNF%%,${DVIPSKCNF},g;s,%%MKTEXLSR%%,${MKTEXLSR},g' \
|
||||
< ${FILESDIR}/pkg-install.in > ${PKGINSTALL}
|
||||
${CHMOD} 0755 ${PKGINSTALL}
|
||||
|
||||
post-build:
|
||||
@(\
|
||||
cd ${WRKSRC}/dvipsk/contrib ; \
|
||||
../squeeze < colorsep.lpro > colorsep.pro \
|
||||
)
|
||||
do-build:
|
||||
cd ${WRKSRC}/texk/dvipsk &&\
|
||||
${MAKE_ENV} ${MAKE} ${ALL_TARGET}
|
||||
|
||||
do-install:
|
||||
cd ${WRKSRC}/texk/dvipsk &&\
|
||||
${MAKE_ENV} ${MAKE} ${INSTALL_TARGET}
|
||||
${INSTALL_DATA} ${FILESDIR}/kanji.map ${PREFIX}/${TEXMFDIR}/dvips/config
|
||||
${INSTALL_DATA} ${FILESDIR}/config.ps ${PREFIX}/${TEXMFDIR}/dvips/config/config.ps.ptex-tetex
|
||||
|
||||
post-install:
|
||||
@for i in ${BINARIES} ; do \
|
||||
strip ${PREFIX}/bin/$$i ; \
|
||||
done
|
||||
@for i in ${CONTRIB_DIRS} ; do \
|
||||
${MKDIR} ${DVIPSDIR}/contrib/$$i ; \
|
||||
done
|
||||
@${MKDIR} ${TEXDIR}/latex209/dvips
|
||||
@(\
|
||||
cd ${WRKSRC}/dvipsk ; \
|
||||
for i in ${BASE_FILES} ; do \
|
||||
${INSTALL_DATA} $$i ${DVIPSDIR}/base ; \
|
||||
done ; \
|
||||
cd ${WRKSRC}/dvipsk/contrib ; \
|
||||
for i in ${CONTRIB_FILES} ; do \
|
||||
${INSTALL_DATA} $$i ${DVIPSDIR}/contrib/$$i ; \
|
||||
done ; \
|
||||
for i in ${PLAIN_MACROS} ; do \
|
||||
${INSTALL_DATA} $$i ${TEXDIR}/plain/dvips ; \
|
||||
done ; \
|
||||
for i in ${LATEX209_MACROS} ; do \
|
||||
${INSTALL_DATA} $$i ${TEXDIR}/latex209/dvips ; \
|
||||
done \
|
||||
)
|
||||
# rebuild tex ls-R file
|
||||
mktexlsr
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/dvips
|
||||
@for i in ${DOCS} ; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/share/doc/dvips ; \
|
||||
done
|
||||
@${LN} -fs ${DVIPSDIR}/contrib ${PREFIX}/share/doc/dvips/contrib
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
MD5 (ptex/dvipsk-5.78a.tar.gz) = 7731c81a2614f62ff892b296d257c4d0
|
||||
SIZE (ptex/dvipsk-5.78a.tar.gz) = 1503994
|
||||
MD5 (ptex/dvipsk-jpatch-p1.4d.tar.gz) = e9f29bb7128da7b0b5810cc4558392b4
|
||||
SIZE (ptex/dvipsk-jpatch-p1.4d.tar.gz) = 19900
|
||||
MD5 (teTeX/tetex-src-2.0.2.tar.gz) = a16f6bba227d55e79aeee46fbbd82d28
|
||||
SIZE (teTeX/tetex-src-2.0.2.tar.gz) = 11745933
|
||||
MD5 (teTeX/dvipsk-jpatch-p1.6.tar.gz) = a072a2196015caa15834522728a91a78
|
||||
SIZE (teTeX/dvipsk-jpatch-p1.6.tar.gz) = 28637
|
||||
|
|
130
japanese/dvipsk/files/config.ps
Normal file
130
japanese/dvipsk/files/config.ps
Normal file
|
@ -0,0 +1,130 @@
|
|||
% teTeX's config.ps. Thomas Esser, 1998, public domain.
|
||||
% $FreeBSD$
|
||||
|
||||
% Memory available. Download the three-line PostScript file:
|
||||
% %! Hey, we're PostScript
|
||||
% /Times-Roman findfont 30 scalefont setfont 144 432 moveto
|
||||
% vmstatus exch sub 40 string cvs show pop showpage
|
||||
% to determine this number. (It will be the only thing printed.)
|
||||
m 3500000
|
||||
|
||||
% Execution of external programs is disabled by default. Set
|
||||
% to z0 if you want backticks in \special commands enabled.
|
||||
z1
|
||||
|
||||
% How to print, maybe with lp instead lpr, etc. If commented-out, output
|
||||
% will go into a file by default.
|
||||
%o |lpr
|
||||
|
||||
% Default resolution of this device, in dots per inch.
|
||||
D 600
|
||||
X 600
|
||||
Y 600
|
||||
|
||||
% Metafont mode. (This is completely different from the -M
|
||||
% command-line option, which controls whether mktexpk is invoked.)
|
||||
% See ../../metafont/misc/modes.mf for a list of mode names. This mode
|
||||
% and the D number above must agree, or mktexpk will get confused.
|
||||
M ljfour
|
||||
|
||||
% Also look for this list of resolutions.
|
||||
R 300 600
|
||||
|
||||
% Correct printer offset. You can use testpage.tex from the LaTeX
|
||||
% distribution to find these numbers.
|
||||
O 0pt,0pt
|
||||
|
||||
% With a high resolution and a RISC cpu, better to compress the bitmaps.
|
||||
% PS files are much more compact, but can sometimes cause trouble.
|
||||
Z
|
||||
|
||||
% Partially download Type 1 fonts by default. Only reason not to do
|
||||
% this is if you encounter bugs. (Please report them to
|
||||
% @email{tex-k@@mail.tug.org} if you do.)
|
||||
j
|
||||
|
||||
% This shows how to add your own map file.
|
||||
% Remove the comment and adjust the name:
|
||||
% p +myfonts.map
|
||||
p +kanji.map
|
||||
|
||||
@ A4size 210mm 297mm
|
||||
@+ %%PaperSize: A4
|
||||
|
||||
@ letterSize 8.5in 11in
|
||||
|
||||
@ letter 8.5in 11in
|
||||
@+ %%BeginPaperSize: Letter
|
||||
@+ letter
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ legal 8.5in 14in
|
||||
@+ ! %%DocumentPaperSizes: Legal
|
||||
@+ %%BeginPaperSize: Legal
|
||||
@+ legal
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ ledger 17in 11in
|
||||
@+ ! %%DocumentPaperSizes: Ledger
|
||||
@+ %%BeginPaperSize: Ledger
|
||||
@+ ledger
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ tabloid 11in 17in
|
||||
@+ ! %%DocumentPaperSizes: Tabloid
|
||||
@+ %%BeginPaperSize: Tabloid
|
||||
@+ 11x17
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ a6 105mm 148mm
|
||||
@+ ! %%DocumentPaperSizes: a6
|
||||
@+ %%BeginPaperSize: a6
|
||||
@+ a6
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ a5 148mm 210mm
|
||||
@+ ! %%DocumentPaperSizes: a5
|
||||
@+ %%BeginPaperSize: a5
|
||||
@+ a5
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ a4 210mm 297mm
|
||||
@+ ! %%DocumentPaperSizes: a4
|
||||
@+ %%BeginPaperSize: a4
|
||||
@+ a4
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ a3 297mm 420mm
|
||||
@+ ! %%DocumentPaperSizes: a3
|
||||
@+ %%BeginPaperSize: a3
|
||||
@+ a3
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ b6 128mm 182mm
|
||||
@+ ! %%DocumentPaperSizes: b6
|
||||
@+ %%BeginPaperSize: b6
|
||||
@+ b6
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ b5 182mm 257mm
|
||||
@+ ! %%DocumentPaperSizes: b5
|
||||
@+ %%BeginPaperSize: b5
|
||||
@+ b5
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ b4 257mm 364mm
|
||||
@+ ! %%DocumentPaperSizes: b4
|
||||
@+ %%BeginPaperSize: b4
|
||||
@+ b4
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ b3 364mm 515mm
|
||||
@+ ! %%DocumentPaperSizes: b3
|
||||
@+ %%BeginPaperSize: b3
|
||||
@+ b3
|
||||
@+ %%EndPaperSize
|
||||
|
||||
@ unknown 0in 0in
|
||||
@+ statusdict /setpageparams known { hsize vsize 0 1 statusdict begin {
|
||||
@+ setpageparams } stopped end } { true } ifelse { statusdict /setpage known
|
||||
@+ { hsize vsize 1 statusdict begin { setpage } stopped pop end } if } if
|
18
japanese/dvipsk/files/kanji.map
Normal file
18
japanese/dvipsk/files/kanji.map
Normal file
|
@ -0,0 +1,18 @@
|
|||
%% $FreeBSD$
|
||||
%%
|
||||
rml Ryumin-Light-H
|
||||
rmlv Ryumin-Light-V
|
||||
gbm GothicBBB-Medium-H
|
||||
gbmv GothicBBB-Medium-V
|
||||
ryumin-l Ryumin-Light-H
|
||||
ryumin-l-v Ryumin-Light-V
|
||||
gtbbb-m GothicBBB-Medium-H
|
||||
gtbbb-m-v GothicBBB-Medium-V
|
||||
futomin-b FutoMinA101-Bold-H
|
||||
futomin-b-v FutoMinA101-Bold-V
|
||||
futogo-b FutoGoB101-Bold-H
|
||||
futogo-b-v FutoGoB101-Bold-V
|
||||
jun101-l Jun101-Light-H
|
||||
jun101-l-v Jun101-Light-V
|
||||
unimin Ryumin-Light-UniJIS-UCS2-H
|
||||
unigoth GothicBBB-Medium-UniJIS-UCS2-H
|
|
@ -1,24 +0,0 @@
|
|||
--- Makefile.in.orig Thu Mar 12 06:37:45 1998
|
||||
+++ Makefile.in Sun Jun 28 11:41:59 1998
|
||||
@@ -34,7 +34,7 @@
|
||||
(cd $$d && $(MAKE) $(makeargs) $@) || break; else true; fi; done
|
||||
|
||||
install install-data install-exec:
|
||||
- for d in kpathsea $(programs); do if test -d $$d; then \
|
||||
+ for d in $(programs); do if test -d $$d; then \
|
||||
(cd $$d && $(MAKE) $(installargs) $@) || break; else true; fi; done
|
||||
|
||||
# Other standard targets for everything.
|
||||
--- dvipsk/Makefile.in.orig Tue Mar 3 23:47:43 1998
|
||||
+++ dvipsk/Makefile.in Wed Jul 1 15:41:44 1998
|
||||
@@ -103,8 +103,8 @@
|
||||
$(INSTALL_DATA) $(srcdir)/dvips.1 $(mandir)/dvips.$(manext)
|
||||
$(INSTALL_DATA) $(srcdir)/afm2tfm.1 $(mandir)/afm2tfm.$(manext)
|
||||
# TeX macros.
|
||||
- cd $(srcdir)/tex && for m in *.tex; do \
|
||||
- $(INSTALL_DATA) $$m $(dvips_plain_macrodir)/$$m; done
|
||||
+# cd $(srcdir)/tex && for m in *.tex; do \
|
||||
+# $(INSTALL_DATA) $$m $(dvips_plain_macrodir)/$$m; done
|
||||
$(POSTINSTALL)
|
||||
if $(SHELL) -c 'install-info --version' >/dev/null 2>&1; then \
|
||||
install-info --info-dir=$(infodir) $(infodir)/$(program).info; \
|
|
@ -1,26 +0,0 @@
|
|||
--- dvipsk/config.ps.orig Tue Jan 22 03:32:55 2002
|
||||
+++ dvipsk/config.ps Tue Jan 22 04:03:44 2002
|
||||
@@ -4,9 +4,9 @@
|
||||
*
|
||||
m 470000
|
||||
*
|
||||
-* And send output by default to the printer.
|
||||
+* Run as a filter by default.
|
||||
*
|
||||
-* o !lpr
|
||||
+f
|
||||
*
|
||||
* Additional .map files
|
||||
*
|
||||
@@ -14,6 +14,11 @@
|
||||
* p +lafonts.map
|
||||
* p +cyrfonts.map
|
||||
* p +eufonts.map
|
||||
+*
|
||||
+* These two lines are added to obtain good-looking PDF files.
|
||||
+* (Refer [ports-jp 12248])
|
||||
+p +psfonts.cmz
|
||||
+p +psfonts.amz
|
||||
*
|
||||
* Default resolution.
|
||||
*
|
40
japanese/dvipsk/files/pkg-install.in
Normal file
40
japanese/dvipsk/files/pkg-install.in
Normal file
|
@ -0,0 +1,40 @@
|
|||
# $FreeBSD$
|
||||
|
||||
GREP=/usr/bin/grep
|
||||
SED=/usr/bin/sed
|
||||
SUFFIX=ptex-tetex
|
||||
|
||||
case $2 in
|
||||
POST-INSTALL)
|
||||
if [ ! -f %%DVIPSKCNF%% ]; then
|
||||
cp %%DVIPSKCNF%%.${SUFFIX} %%DVIPSKCNF%%
|
||||
echo "Notice: installing %%DVIPSKCNF%%.${SUFFIX} -> %%DVIPSKCNF%%."
|
||||
%%MKTEXLSR%%
|
||||
elif ${SED} q < %%DVIPSKCNF%% | ${GREP} "public domain" > /dev/null 2>&1; then
|
||||
cp %%DVIPSKCNF%%.${SUFFIX} %%DVIPSKCNF%%
|
||||
echo "Notice: installing %%DVIPSKCNF%%.${SUFFIX} -> %%DVIPSKCNF%%."
|
||||
%%MKTEXLSR%%
|
||||
else
|
||||
echo "Notice: %%DVIPSKCNF%% is not installed."
|
||||
echo " Merge from %%DVIPSKCNF%%.${SUFFIX} manually."
|
||||
fi
|
||||
;;
|
||||
DEINSTALL)
|
||||
if [ -f %%DVIPSKCNF%% ]; then
|
||||
if ${SED} q < %%DVIPSKCNF%% | ${GREP} "public domain" > /dev/null 2>&1; then
|
||||
if [ -f %%DVIPSKCNF%%.tetex ]; then
|
||||
cp %%DVIPSKCNF%%.tetex %%DVIPSKCNF%%
|
||||
echo "Notice: installing %%DVIPSKCNF%%.tetex -> %%DVIPSKCNF%%."
|
||||
%%MKTEXLSR%%
|
||||
else
|
||||
rm -f %%DVIPSKCNF%%
|
||||
echo "Notice: %%DVIPSKCNF%% is removed."
|
||||
%%MKTEXLSR%%
|
||||
fi
|
||||
else
|
||||
echo "Notice: %%DVIPSKCNF%% is NOT removed."
|
||||
echo " Remove manually."
|
||||
fi
|
||||
fi
|
||||
;;
|
||||
esac
|
|
@ -1,14 +0,0 @@
|
|||
******************************************************************************
|
||||
This program requires some japanese virtual fonts. For that purpose,
|
||||
you can install `ja-makejvf-fkr-1.0' or `ja-vftool-1.2' package.
|
||||
|
||||
Configuration file is /usr/local/share/texmf/dvips/base/config.ps
|
||||
In this configuration, it is possible to do convert them to
|
||||
PDF file through ghostscript, then read by Adobe Acrobat to perform
|
||||
`cut and paste' of English fonts. If you don't like this behavior
|
||||
(i.e. You want to embed bitmap information of english fonts; cut and
|
||||
paste becomes impossible), delete or comment following two lines:
|
||||
p +psfonts.cmz
|
||||
p +psfonts.amz
|
||||
|
||||
******************************************************************************
|
|
@ -1,122 +1,13 @@
|
|||
bin/dvips
|
||||
@comment $FreeBSD$
|
||||
bin/afm2tfm
|
||||
@unexec install-info --delete %D/info/dvips.info %D/info/dir
|
||||
info/dvips.info
|
||||
info/dvips.info-1
|
||||
info/dvips.info-2
|
||||
info/dvips.info-3
|
||||
info/dvips.info-4
|
||||
@exec install-info %D/info/dvips.info %D/info/dir
|
||||
share/texmf/dvips/base/color.pro
|
||||
share/texmf/dvips/base/crop.pro
|
||||
share/texmf/dvips/base/finclude.pro
|
||||
share/texmf/dvips/base/hps.pro
|
||||
share/texmf/dvips/base/special.pro
|
||||
share/texmf/dvips/base/tex.pro
|
||||
share/texmf/dvips/base/texc.pro
|
||||
share/texmf/dvips/base/texps.pro
|
||||
share/texmf/dvips/base/8a.enc
|
||||
share/texmf/dvips/base/8r.enc
|
||||
share/texmf/dvips/base/EC.enc
|
||||
share/texmf/dvips/base/ad.enc
|
||||
share/texmf/dvips/base/asex.enc
|
||||
share/texmf/dvips/base/asexp.enc
|
||||
share/texmf/dvips/base/cork.enc
|
||||
share/texmf/dvips/base/dc.enc
|
||||
share/texmf/dvips/base/dvips.enc
|
||||
share/texmf/dvips/base/extex.enc
|
||||
share/texmf/dvips/base/funky.enc
|
||||
share/texmf/dvips/base/texmext.enc
|
||||
share/texmf/dvips/base/texmital.enc
|
||||
share/texmf/dvips/base/texmsym.enc
|
||||
share/texmf/dvips/base/xl2.enc
|
||||
share/texmf/dvips/base/xt2.enc
|
||||
share/texmf/dvips/base/cmfonts.map
|
||||
share/texmf/dvips/base/cyrfonts.map
|
||||
share/texmf/dvips/base/eufonts.map
|
||||
share/texmf/dvips/base/lafonts.map
|
||||
share/texmf/dvips/base/psfonts.map
|
||||
share/texmf/dvips/base/config.ps
|
||||
share/texmf/dvips/contrib/MakeTeXPK.pl
|
||||
share/texmf/dvips/contrib/PSTricks
|
||||
share/texmf/dvips/contrib/colorsep.pro
|
||||
share/texmf/dvips/contrib/config.proto
|
||||
share/texmf/dvips/contrib/crop.lpr
|
||||
share/texmf/dvips/contrib/timesmat.sty
|
||||
share/texmf/dvips/contrib/whichinpath
|
||||
share/texmf/dvips/contrib/afm-extra/ptmr.ed
|
||||
share/texmf/dvips/contrib/afm-extra/ptmro.ed
|
||||
share/texmf/dvips/contrib/bbfig/bb.ps
|
||||
share/texmf/dvips/contrib/bbfig/bbfig
|
||||
share/texmf/dvips/contrib/bbfig/bbfig.1
|
||||
share/texmf/dvips/contrib/configs/2a4.ps
|
||||
share/texmf/dvips/contrib/configs/config.fax
|
||||
share/texmf/dvips/contrib/configs/config.lino
|
||||
share/texmf/dvips/contrib/configs/config.lj2p
|
||||
share/texmf/dvips/contrib/configs/config.post3x3
|
||||
share/texmf/dvips/contrib/configs/config.rokicki
|
||||
share/texmf/dvips/contrib/configs/loop.ps
|
||||
share/texmf/dvips/contrib/configs/mkdvipspapers
|
||||
share/texmf/dvips/contrib/configs/papersize.level2
|
||||
share/texmf/dvips/contrib/configs/papersize.simple
|
||||
share/texmf/dvips/contrib/configs/prepipe.ps
|
||||
share/texmf/dvips/contrib/configs/showpage.ps
|
||||
share/texmf/dvips/contrib/psfig/README
|
||||
share/texmf/dvips/contrib/psfig/lprep68.pro
|
||||
share/texmf/dvips/contrib/psfig/lprep68.ps
|
||||
share/texmf/dvips/contrib/psfig/lprep70.pro
|
||||
share/texmf/dvips/contrib/psfig/lprep70.ps
|
||||
share/texmf/dvips/contrib/volker/README
|
||||
share/texmf/dvips/contrib/volker/a3.cfg
|
||||
share/texmf/dvips/contrib/volker/duplong.cfg
|
||||
share/texmf/dvips/contrib/volker/dupshort.cfg
|
||||
share/texmf/dvips/contrib/volker/inv.cfg
|
||||
share/texmf/dvips/contrib/volker/scr100.cfg
|
||||
share/texmf/dvips/contrib/volker/scr100-0.cfg
|
||||
share/texmf/dvips/contrib/volker/scr110.cfg
|
||||
share/texmf/dvips/contrib/volker/scr120.cfg
|
||||
share/texmf/dvips/contrib/volker/scr130.cfg
|
||||
share/texmf/dvips/contrib/volker/scr140.cfg
|
||||
share/texmf/dvips/contrib/volker/scr150.cfg
|
||||
share/texmf/dvips/contrib/volker/scr70.cfg
|
||||
share/texmf/dvips/contrib/volker/scr80.cfg
|
||||
share/texmf/dvips/contrib/volker/scr85.cfg
|
||||
share/texmf/dvips/contrib/volker/scr90.cfg
|
||||
share/texmf/dvips/contrib/volker/simplex.cfg
|
||||
share/texmf/tex/plain/dvips/psfig.tex
|
||||
share/texmf/tex/plain/dvips/ps_plain.tex
|
||||
share/texmf/tex/latex209/dvips/avantgarde.sty
|
||||
share/texmf/tex/latex209/dvips/blackdvi.sty
|
||||
share/texmf/tex/latex209/dvips/bookman.sty
|
||||
share/texmf/tex/latex209/dvips/chancery.sty
|
||||
share/texmf/tex/latex209/dvips/colordvi.sty
|
||||
share/texmf/tex/latex209/dvips/epsf.sty
|
||||
share/texmf/tex/latex209/dvips/lucida.sty
|
||||
share/texmf/tex/latex209/dvips/ncs.sty
|
||||
share/texmf/tex/latex209/dvips/palatino.sty
|
||||
share/texmf/tex/latex209/dvips/psfonts.sty
|
||||
share/texmf/tex/latex209/dvips/psgreek.sty
|
||||
share/texmf/tex/latex209/dvips/rotate.sty
|
||||
share/texmf/tex/latex209/dvips/times.sty
|
||||
share/texmf/tex/latex209/dvips/ps_lfonts.tex
|
||||
share/texmf/tex/latex209/dvips/pspic.readme
|
||||
share/texmf/tex/latex209/dvips/pspic.sty
|
||||
share/doc/dvips/README
|
||||
share/doc/dvips/README.jpatch
|
||||
share/doc/dvips/dvips.texi
|
||||
share/doc/dvips/dvips.help
|
||||
@exec ln -fs %D/share/texmf/dvips/contrib %D/share/doc/dvips/contrib
|
||||
@unexec rm %D/share/doc/dvips/contrib
|
||||
@dirrm share/texmf/dvips/base
|
||||
@dirrm share/texmf/dvips/contrib/afm-extra
|
||||
@dirrm share/texmf/dvips/contrib/bbfig
|
||||
@dirrm share/texmf/dvips/contrib/configs
|
||||
@dirrm share/texmf/dvips/contrib/psfig
|
||||
@dirrm share/texmf/dvips/contrib/volker
|
||||
@dirrm share/texmf/dvips/contrib
|
||||
@dirrm share/texmf/dvips
|
||||
@dirrm share/texmf/tex/latex209/dvips
|
||||
@dirrm share/texmf/tex/latex209
|
||||
@dirrm share/doc/dvips
|
||||
@exec mktexlsr
|
||||
@unexec mktexlsr
|
||||
bin/dvips
|
||||
%%TEXMFDIR%%/dvips/base/tex.pro
|
||||
%%TEXMFDIR%%/dvips/base/texps.pro
|
||||
%%TEXMFDIR%%/dvips/base/texc.pro
|
||||
%%TEXMFDIR%%/dvips/base/special.pro
|
||||
%%TEXMFDIR%%/dvips/base/finclude.pro
|
||||
%%TEXMFDIR%%/dvips/base/color.pro
|
||||
%%TEXMFDIR%%/dvips/base/crop.pro
|
||||
%%TEXMFDIR%%/dvips/base/hps.pro
|
||||
%%TEXMFDIR%%/dvips/config/kanji.map
|
||||
%%TEXMFDIR%%/dvips/config/config.ps.ptex-tetex
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
chgdirs=". kpathsea dvipsk"
|
||||
|
||||
cd ${WRKSRC}
|
||||
|
||||
for dir in ${chgdirs}; do
|
||||
${MV} -f ${dir}/Makefile ${dir}/Makefile.bak
|
||||
${SED} \
|
||||
-e 's@^prefix[ ]*=.*$@prefix=${PREFIX}@' \
|
||||
-e 's@^texmf[ ]*=.*$@texmf=${PREFIX}/share/texmf@' \
|
||||
< ${dir}/Makefile.bak > ${dir}/Makefile
|
||||
done
|
Loading…
Reference in a new issue