The Python keyring lib provides an easy way to access the system keyring
service from Python. It can be used in any application that needs safe password storage. It supports OSX, KDE, Gnome and Windows's native password storing services. Besides this, it is shipped with kinds of Python implemented keyring for the left environments. WWW: http://pypi.python.org/pypi/keyring PR: ports/138513 Submitted by: Douglas Thrift
This commit is contained in:
parent
7e194b6bbc
commit
24b4f66f4d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=240891
6 changed files with 93 additions and 0 deletions
|
@ -663,6 +663,7 @@
|
|||
SUBDIR += py-gnupg
|
||||
SUBDIR += py-gnutls
|
||||
SUBDIR += py-hashlib
|
||||
SUBDIR += py-keyring
|
||||
SUBDIR += py-m2crypto
|
||||
SUBDIR += py-mcrypt
|
||||
SUBDIR += py-mhash
|
||||
|
|
56
security/py-keyring/Makefile
Normal file
56
security/py-keyring/Makefile
Normal file
|
@ -0,0 +1,56 @@
|
|||
# New ports collection makefile for: py-keyring
|
||||
# Date created: 2 September 2009
|
||||
# Whom: Douglas Thrift
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= keyring
|
||||
PORTVERSION= 0.1
|
||||
CATEGORIES= security python
|
||||
MASTER_SITES= CHEESESHOP \
|
||||
http://code.douglasthrift.net/files/${PORTNAME}/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= douglas@douglasthrift.net
|
||||
COMMENT= Store and access your passwords safely
|
||||
|
||||
LATEST_LINK= py-${PORTNAME}
|
||||
|
||||
USE_KDE4= #
|
||||
USE_PYTHON= 2.6+
|
||||
USE_PYDISTUTILS= yes
|
||||
|
||||
OPTIONS= GNOME_KEYRING "GNOME Keyring backend" Off \
|
||||
KDE_KWALLET "KDE KWallet backend" Off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_GNOME_KEYRING)
|
||||
LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
|
||||
PLIST_SUB+= GNOME_KEYRING=""
|
||||
.else
|
||||
PLIST_SUB+= GNOME_KEYRING="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_KDE_KWALLET)
|
||||
PLIST_SUB+= KDE_KWALLET=""
|
||||
USE_KDE4+= kdelibs
|
||||
.else
|
||||
PLIST_SUB+= KDE_KWALLET="@comment "
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
.if !defined(WITH_GNOME_KEYRING)
|
||||
@${REINPLACE_CMD} -e 's|exts\.append(gnome_keychain_module)|#&|' \
|
||||
${WRKSRC}/extensions.py
|
||||
.endif
|
||||
.if defined(WITH_KDE_KWALLET)
|
||||
@${REINPLACE_CMD} -e 's|kde4-config|${KDE4_PREFIX}/bin/kde4-config|' \
|
||||
${WRKSRC}/extensions.py
|
||||
.else
|
||||
@${REINPLACE_CMD} -e 's|exts\.append(kde_kwallet_module)|#&|' \
|
||||
${WRKSRC}/extensions.py
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
security/py-keyring/distinfo
Normal file
3
security/py-keyring/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (keyring-0.1.tar.gz) = e593725919ed00a631c4348d08c77f56
|
||||
SHA256 (keyring-0.1.tar.gz) = c5e19bfd138034a8d3193a5c5314493e51a90a0c4bb78db87c0a0451aa7327a8
|
||||
SIZE (keyring-0.1.tar.gz) = 14468
|
14
security/py-keyring/files/patch-extensions.py
Normal file
14
security/py-keyring/files/patch-extensions.py
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- extensions.py.orig 2009-08-21 09:34:01.000000000 -0700
|
||||
+++ extensions.py 2009-09-03 15:43:41.224189815 -0700
|
||||
@@ -42,9 +42,9 @@
|
||||
|
||||
keywords.setdefault('libraries', []).append('kdeui')
|
||||
libs = commands.getoutput("kde4-config --path lib").split(':')
|
||||
- if len(libs) == 0:
|
||||
- libs = commands.getoutput("kde-config --path lib").split(':')
|
||||
keywords.setdefault('library_dirs', []).extend(libs)
|
||||
+ includes = commands.getoutput("kde4-config --install include").split(':')
|
||||
+ keywords.setdefault('include_dirs', []).extend(includes)
|
||||
return keywords
|
||||
|
||||
def get_extensions():
|
7
security/py-keyring/pkg-descr
Normal file
7
security/py-keyring/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
The Python keyring lib provides an easy way to access the system keyring
|
||||
service from Python. It can be used in any application that needs safe password
|
||||
storage. It supports OSX, KDE, Gnome and Windows's native password storing
|
||||
services. Besides this, it is shipped with kinds of Python implemented keyring
|
||||
for the left environments.
|
||||
|
||||
WWW: http://pypi.python.org/pypi/keyring
|
12
security/py-keyring/pkg-plist
Normal file
12
security/py-keyring/pkg-plist
Normal file
|
@ -0,0 +1,12 @@
|
|||
%%GNOME_KEYRING%%%%PYTHON_SITELIBDIR%%/gnome_keyring.so
|
||||
%%KDE_KWALLET%%%%PYTHON_SITELIBDIR%%/kde_kwallet.so
|
||||
%%PYTHON_SITELIBDIR%%/keyring/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/keyring/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/keyring/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/keyring/backend.py
|
||||
%%PYTHON_SITELIBDIR%%/keyring/backend.pyc
|
||||
%%PYTHON_SITELIBDIR%%/keyring/backend.pyo
|
||||
%%PYTHON_SITELIBDIR%%/keyring/core.py
|
||||
%%PYTHON_SITELIBDIR%%/keyring/core.pyc
|
||||
%%PYTHON_SITELIBDIR%%/keyring/core.pyo
|
||||
@dirrm %%PYTHON_SITELIBDIR%%/keyring
|
Loading…
Reference in a new issue