Update to 2.6.0. Port changes:
- add LICENSE (GPLv2) - convert to new options framework - make NLS optional - add EXPOBLEND option to pull in runtime dependencies for the ExpoBlening plugin (a lot of ports that get pulled in by graphics/hugin, so turn it OFF by default) - add options for the new digikam libraries - add KSANE option for scanning - remove no longer needed patches - update WWW Submitted by: Jason E. Hale <bsdkaffee at gmail.com> via area51 commit
This commit is contained in:
parent
9976929279
commit
24f173c2f7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=298859
8 changed files with 1311 additions and 1217 deletions
|
@ -6,61 +6,111 @@
|
|||
#
|
||||
|
||||
PORTNAME= kipi-plugins
|
||||
PORTVERSION= 1.9.0
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 2.6.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= graphics kde
|
||||
MASTER_SITES= SF/kipi/${PORTNAME}/${PORTVERSION}
|
||||
MASTER_SITES= SF/digikam/digikam/${PORTVERSION}
|
||||
DISTNAME= digikam-${PORTVERSION}
|
||||
|
||||
MAINTAINER= kris@pcbsd.org
|
||||
MAINTAINER= kde@FreeBSD.org
|
||||
COMMENT= KDE4 kipi graphics plugins
|
||||
|
||||
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
|
||||
kipi.8:${PORTSDIR}/graphics/libkipi-kde4 \
|
||||
kexiv2.10:${PORTSDIR}/graphics/libkexiv2-kde4 \
|
||||
kdcraw.20:${PORTSDIR}/graphics/libkdcraw-kde4 \
|
||||
ksane.0:${PORTSDIR}/graphics/libksane \
|
||||
qjson.0:${PORTSDIR}/devel/qjson
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
|
||||
qjson:${PORTSDIR}/devel/qjson
|
||||
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
|
||||
|
||||
LATEST_LINK= ${PORTNAME}-kde4
|
||||
|
||||
OPTIONS_DEFINE= NLS EXPOBLEND GPOD KGEOMAP KSANE KVKONTAKTE MEDIAWIKI OPENCV PIMLIBS
|
||||
OPTIONS_DEFAULT= KGEOMAP KSANE OPENCV PIMLIBS
|
||||
|
||||
EXPOBLEND_DESC= Add runtime deps for ExpoBlending plugin
|
||||
GPOD_DESC= Enable Ipod Export plugin
|
||||
KGEOMAP_DESC= Enable GPSSync (geolocalize pictures) plugin
|
||||
KSANE_DESC= Enable Scanning plugin
|
||||
KVKONTAKTE_DESC= Enable VKontakte (VK) plugin
|
||||
MEDIAWIKI_DESC= Enable MediaWiki plugin
|
||||
OPENCV_DESC= Enable Red Eye Removal plugin
|
||||
PIMLIBS_DESC= Enable Calendar plugins
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_CMAKE= yes
|
||||
USE_GETTEXT= yes
|
||||
USE_GL= glu
|
||||
USE_KDE4= automoc4 kdehier kdeprefix kdelibs
|
||||
USE_QT4= gui dbus network svg xml opengl \
|
||||
qmake_build moc_build rcc_build uic_build
|
||||
USE_KDE4= automoc4 kdehier kdeprefix kdelibs libkdcraw libkexiv2 libkipi
|
||||
USE_QT4= qmake_build moc_build rcc_build uic_build
|
||||
USE_LDCONFIG= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
OPTIONS= GPOD "Enable Ipod Export plugin" ON \
|
||||
OPENCV "Enable Red Eye Removal plugin" ON \
|
||||
PIMLIBS "Enable Calendar plugin" ON
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/extra/${PORTNAME}
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if defined(WITH_GPOD)
|
||||
LIB_DEPENDS+= gpod.7:${PORTSDIR}/audio/libgpod
|
||||
.if ${PORT_OPTIONS:MNLS}
|
||||
USE_GETTEXT= yes
|
||||
PLIST_SUB+= NLS=""
|
||||
.else
|
||||
CMAKE_ARGS+= -DWITH_NLS:BOOL=OFF
|
||||
PLIST_SUB+= NLS="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MEXPOBLEND}
|
||||
RUN_DEPENDS+= align_image_stack:${PORTSDIR}/graphics/hugin
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MGPOD}
|
||||
LIB_DEPENDS+= gpod:${PORTSDIR}/audio/libgpod
|
||||
PLIST_SUB+= GPOD=""
|
||||
.else
|
||||
CMAKE_ARGS+= -DWITH_GLIB2:BOOL=OFF \
|
||||
-DWITH_GObject:BOOL=OFF \
|
||||
-DWITH_Gdk:BOOL=OFF \
|
||||
-DWITH_Gpod:BOOL=OFF
|
||||
-DWITH_Ipod:BOOL=OFF
|
||||
PLIST_SUB+= GPOD="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_OPENCV)
|
||||
LIB_DEPENDS+= opencv_legacy.2:${PORTSDIR}/graphics/opencv
|
||||
.if ${PORT_OPTIONS:MKGEOMAP}
|
||||
LIB_DEPENDS+= kgeomap:${PORTSDIR}/astro/libkgeomap
|
||||
PLIST_SUB+= KGEOMAP=""
|
||||
.else
|
||||
CMAKE_ARGS+= -DWITH_KGeoMap:BOOL=OFF
|
||||
PLIST_SUB+= KGEOMAP="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MKSANE}
|
||||
USE_KDE4+= libksane
|
||||
PLIST_SUB+= KSANE=""
|
||||
.else
|
||||
CMAKE_ARGS+= -DWITH_KSane:BOOL=OFF
|
||||
PLIST_SUB+= KSANE="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MKVKONTAKTE}
|
||||
LIB_DEPENDS+= kvkontakte:${PORTSDIR}/net/libkvkontakte
|
||||
PLIST_SUB+= KVKONTAKTE=""
|
||||
.else
|
||||
CMAKE_ARGS+= -DWITH_LibKVkontakte:BOOL=OFF
|
||||
PLIST_SUB+= KVKONTAKTE="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MMEDIAWIKI}
|
||||
LIB_DEPENDS+= mediawiki:${PORTSDIR}/net/libmediawiki
|
||||
PLIST_SUB+= MEDIAWIKI=""
|
||||
.else
|
||||
CMAKE_ARGS+= -DWITH_Mediawiki:BOOL=OFF
|
||||
PLIST_SUB+= MEDIAWIKI="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MOPENCV}
|
||||
LIB_DEPENDS+= opencv_legacy:${PORTSDIR}/graphics/opencv
|
||||
PLIST_SUB+= OPENCV=""
|
||||
.else
|
||||
CMAKE_ARGS+= -DWITH_OpenCV:BOOL=OFF
|
||||
PLIST_SUB+= OPENCV="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PIMLIBS)
|
||||
.if ${PORT_OPTIONS:MPIMLIBS}
|
||||
USE_KDE4+= pimlibs
|
||||
PLIST_SUB+= PIMLIBS=""
|
||||
.else
|
||||
|
@ -68,4 +118,9 @@ CMAKE_ARGS+= -DWITH_KdepimLibs:BOOL=OFF
|
|||
PLIST_SUB+= PIMLIBS="@comment "
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${LN} -s ../../doc ${WRKSRC}/doc
|
||||
${LN} -s ../../po ${WRKSRC}/po
|
||||
${RM} ${WRKSRC}/po/*/digikam.po ${WRKSRC}/po/*/libkgeomap.po
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (kipi-plugins-1.9.0.tar.bz2) = d52466586725492788514c1b8d7bbea02f95c9deb744a0814d221c99c34e934c
|
||||
SIZE (kipi-plugins-1.9.0.tar.bz2) = 5775775
|
||||
SHA256 (digikam-2.6.0.tar.bz2) = 411ceaa3a489d9c9a5566d43c167927a07fb08fb4f613b0dbf1dec65b95736df
|
||||
SIZE (digikam-2.6.0.tar.bz2) = 55362029
|
||||
|
|
|
@ -1,20 +1,18 @@
|
|||
--- ./CMakeLists.txt.orig 2010-02-01 01:25:54.000000000 +1000
|
||||
+++ ./CMakeLists.txt 2010-02-02 23:40:06.822411786 +1000
|
||||
@@ -133,7 +133,7 @@
|
||||
IF(NOT WIN32)
|
||||
FIND_PACKAGE(PkgConfig)
|
||||
# Check KDcraw version.
|
||||
- PKG_CHECK_MODULES(Kdcraw libkdcraw>=1.1.0)
|
||||
+ PKG_CHECK_MODULES(Kdcraw libkdcraw-kde4>=1.1.0)
|
||||
IF(Kdcraw_FOUND)
|
||||
SET(KDCRAW_FOR_KIPIPLUGINS TRUE)
|
||||
ELSE(Kdcraw_FOUND)
|
||||
@@ -146,7 +146,7 @@
|
||||
# Check KExiv2 version installed to compile fine.
|
||||
IF(NOT WIN32)
|
||||
FIND_PACKAGE(PkgConfig)
|
||||
- PKG_CHECK_MODULES(Kexiv2 libkexiv2>=1.1.0)
|
||||
+ PKG_CHECK_MODULES(Kexiv2 libkexiv2-kde4>=1.1.0)
|
||||
IF(Kexiv2_FOUND)
|
||||
SET(KEXIV2_FOR_KIPIPLUGINS TRUE)
|
||||
ELSE(Kexiv2_FOUND)
|
||||
--- ./CMakeLists.txt.orig 2012-01-02 19:31:43.000000000 -0500
|
||||
+++ ./CMakeLists.txt 2012-05-13 07:55:34.000000000 -0400
|
||||
@@ -366,6 +366,15 @@
|
||||
ADD_DEFINITIONS(-DAREA_CODE_LOADING=${AREA_CODE_LOADING})
|
||||
ADD_DEFINITIONS(-DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS)
|
||||
|
||||
+ OPTION(WITH_NLS "NLS Support" ON)
|
||||
+ IF(WITH_NLS)
|
||||
+ FIND_PACKAGE(Msgfmt REQUIRED)
|
||||
+ FIND_PACKAGE(Gettext REQUIRED)
|
||||
+ ADD_SUBDIRECTORY(po)
|
||||
+ ENDIF(WITH_NLS)
|
||||
+
|
||||
+ ADD_SUBDIRECTORY(doc/kipi-plugins)
|
||||
+
|
||||
# kipi host test program to check plugins
|
||||
|
||||
ADD_SUBDIRECTORY(tests)
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- ./cmake/modules/FindGpod.cmake.orig 2009-03-17 04:52:18.000000000 -0400
|
||||
+++ ./cmake/modules/FindGpod.cmake 2009-06-08 04:36:50.000000000 -0400
|
||||
@@ -24,7 +24,7 @@
|
||||
|
||||
set(GPOD_DEFINITIONS ${PC_GPOD_CFLAGS_OTHER})
|
||||
|
||||
- exec_program(${PKGCONFIG_EXECUTABLE} ARGS --atleast-version=0.7.0 libgpod-1.0 OUTPUT_VARIABLE _pkgconfigDevNull RETURN_VALUE GPOD_VERSION_OKAY)
|
||||
+ exec_program(${PKG_CONFIG_EXECUTABLE} ARGS --atleast-version=0.7.0 libgpod-1.0 OUTPUT_VARIABLE _pkgconfigDevNull RETURN_VALUE GPOD_VERSION_OKAY)
|
||||
|
||||
endif( NOT WIN32 )
|
||||
|
|
@ -1,13 +1,14 @@
|
|||
--- ./expoblending/manager/actionthread.cpp.orig 2010-02-01 01:17:40.000000000 +1000
|
||||
+++ ./expoblending/manager/actionthread.cpp 2010-02-03 01:12:30.759423612 +1000
|
||||
@@ -53,6 +53,10 @@
|
||||
#include "kpwriteimage.h"
|
||||
#include "pluginsversion.h"
|
||||
--- ./expoblending/manager/actionthread.cpp.orig 2012-01-02 19:31:39.000000000 -0500
|
||||
+++ ./expoblending/manager/actionthread.cpp 2012-05-13 07:52:49.000000000 -0400
|
||||
@@ -32,6 +32,11 @@
|
||||
#define log2f(x) (logf(x)*1.4426950408889634f)
|
||||
#endif
|
||||
|
||||
+#if defined(__FreeBSD__)
|
||||
+#define log2f(x) (logf((x)) / logf(2))
|
||||
+#include <sys/param.h>
|
||||
+#if __FreeBSD_version < 802502 || (__FreeBSD_version >= 900000 && __FreeBSD_version < 900027)
|
||||
+#define log2f(x) (logf(x) / logf(2))
|
||||
+#endif
|
||||
+
|
||||
namespace KIPIExpoBlendingPlugin
|
||||
{
|
||||
// Qt includes
|
||||
|
||||
#include <QMutex>
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
--- ./ipodexport/CMakeLists.txt.orig 2009-08-20 21:07:19.000000000 -0400
|
||||
+++ ./ipodexport/CMakeLists.txt 2009-08-20 21:11:16.000000000 -0400
|
||||
@@ -19,7 +19,11 @@
|
||||
${GDK_LIBRARIES}
|
||||
${KIPI_LIBRARIES}
|
||||
${KDE4_KIO_LIBRARY}
|
||||
+ ${KDE4_KIO_LIBS}
|
||||
+ ${KDE4_KDECORE_LIBS}
|
||||
kipiplugins
|
||||
+ ${QT_QTCORE_LIBRARY}
|
||||
+ ${QT_QTGUI_LIBRARY}
|
||||
)
|
||||
|
||||
INSTALL(TARGETS kipiplugin_ipodexport DESTINATION ${PLUGIN_INSTALL_DIR})
|
|
@ -4,4 +4,4 @@ image plugins among graphic applications.
|
|||
|
||||
This is a set of plugins using Kipi for KDE 4.2 and higher.
|
||||
|
||||
WWW: http://www.kipi-plugins.org/
|
||||
WWW: https://projects.kde.org/projects/extragear/graphics/kipi-plugins
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue